SpecView User Manual for Version 3

© 1995 - 2015 SpecView

Disclaimer

SpecView software communicates with industrial instrumentation and displays and stores the information it receives. It is always possible that the data being displayed, stored or adjusted is not as expected. ERRORS IN THE DATABASE OR ELSEWHERE MEAN THAT YOU COULD BE READING OR ADJUSTING SOMETHING OTHER THAN THAT WHICH YOU EXPECT!
Safety devices must ALWAYS be used so that safe operation of equipment is assured even if incorrect data is read by or sent from SpecView.
SpecView itself MUST NOT BE USED IN ANY WAY AS A SAFETY DEVICE!

SpecView will not be responsible for any loss or damage caused by incorrect use or operation, even if caused by errors in programs supplied by SpecView Corporation.

Warranties & Trademarks

This document is for information only and is subject to change without prior notice.
SpecView is a registered trademark of SpecView Corporation
Windows is a trademark of Microsoft Corporation.
All other products and brand names are trademarks of their respective companies.

Copyright 1995-2014 by SpecView Corporation. All Rights Reserved.
This document was produced using HelpAndManual.
# Table of Contents

## Part I Introduction

1. Introduction to SpecView ................................................................. 14
2. Minimum Requirements for running SpecView ............................. 16
3. How to use the Help/Manual .......................................................... 18
4. Licensing in SpecView ..................................................................... 19
   - Dongles ......................................................................................... 19
   - Soft Dongles ................................................................................ 20
   - Evaluation Version ....................................................................... 24
   - Upgrading SpecView ..................................................................... 25
   - Update Expiry ............................................................................... 29
   - Runtime-Only Dongle ................................................................. 30
   - Version 3 Option not on Dongle .................................................. 31
   - End User License Agreement ....................................................... 32

## Part II What's New In Version 3

1. Videos ............................................................................................. 37
2. Installation ....................................................................................... 38
3. Trend Charts ................................................................................... 39
4. Edit Mode ......................................................................................... 42
5. Variables List .................................................................................. 44
6. Quick List ......................................................................................... 50
7. Position Dynamics .......................................................................... 51
8. Color Dynamics ............................................................................... 54
9. Import Project ................................................................................ 56
10. Runtime .......................................................................................... 57
11. Startup Sequence .......................................................................... 59
12. Preferences ..................................................................................... 62
13. Passwords - start at level 1 ............................................................ 63
14. Touch Screen Support .................................................................... 64
15. Additional Features ....................................................................... 65
16. 32bit and 64bit SpecView .............................................................. 67
17. Backward Compatibility ................................................................. 67
18. Update Policies .............................................................................. 68
19. Bug Reporting Procedure .............................................................. 69

## Part III ReleaseNotes

1. Build 3.0.042 ................................................................................. 72
2. Build 3.0.043 ................................................................................. 72

© 1995 - 2015 SpecView
# SpecView User Manual for Version 3

## Part IV  Installation and Starting SpecView

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 Installation</td>
<td>75</td>
</tr>
<tr>
<td>Installing SpecView</td>
<td>75</td>
</tr>
<tr>
<td>Installation Warnings and Errors</td>
<td>79</td>
</tr>
<tr>
<td>Updating SpecView from a previous version</td>
<td>80</td>
</tr>
<tr>
<td>Migrate Configurations</td>
<td>83</td>
</tr>
<tr>
<td>32bit and 64bit SpecView</td>
<td>84</td>
</tr>
<tr>
<td>2 Starting SpecView</td>
<td>84</td>
</tr>
<tr>
<td>Archive and Restore</td>
<td>87</td>
</tr>
<tr>
<td>Restore - Overwrite Project Warning</td>
<td>90</td>
</tr>
<tr>
<td>SpecView Command Line Options</td>
<td>91</td>
</tr>
<tr>
<td>3 Instrument Definition/Detection</td>
<td>92</td>
</tr>
<tr>
<td>Automatic Instrument Detection</td>
<td>93</td>
</tr>
<tr>
<td>TCP/IP Auto Detection</td>
<td>96</td>
</tr>
<tr>
<td>Manually Defining Instruments</td>
<td>99</td>
</tr>
<tr>
<td>COM Port Settings</td>
<td>100</td>
</tr>
<tr>
<td>Test Comms For Update</td>
<td>101</td>
</tr>
<tr>
<td>Add/Rename Instruments</td>
<td>102</td>
</tr>
<tr>
<td>For Instruments using the Modbus Protocol</td>
<td>104</td>
</tr>
<tr>
<td>Using a BarCode Scanner with SpecView</td>
<td>106</td>
</tr>
<tr>
<td>Honeywell HC900</td>
<td>109</td>
</tr>
<tr>
<td>HC900 HCDesigner import of Modbus maps</td>
<td>109</td>
</tr>
<tr>
<td>HC900 HCDesigner import: The steps required to do it</td>
<td>110</td>
</tr>
<tr>
<td>HC900 HCDesigner import: Including a Tag Number as part of the name.</td>
<td>114</td>
</tr>
<tr>
<td>HC900 HCDesigner import: Custom Loops</td>
<td>115</td>
</tr>
<tr>
<td>HC900 HCDesigner import: Notes on Updating an HC900</td>
<td>116</td>
</tr>
<tr>
<td>HC900 Redundant Controller</td>
<td>117</td>
</tr>
<tr>
<td>HC900 SPP Block running profile and descriptor</td>
<td>120</td>
</tr>
</tbody>
</table>

## Part V  Migrate V2 Configuration to a V3 Project

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 Migration Advanced</td>
<td>125</td>
</tr>
<tr>
<td>2 Migration Manually</td>
<td>125</td>
</tr>
<tr>
<td>3 Migration Warnings and Errors</td>
<td>125</td>
</tr>
</tbody>
</table>

## Part VI  Using SpecView in Runtime Mode

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 Values on the GDW</td>
<td>129</td>
</tr>
<tr>
<td>2 Data Entry</td>
<td>131</td>
</tr>
<tr>
<td>3 Data Entry - Numeric</td>
<td>132</td>
</tr>
<tr>
<td>4 Data Entry - Boolean</td>
<td>133</td>
</tr>
<tr>
<td>5 Data Entry - Enumeration</td>
<td>133</td>
</tr>
<tr>
<td>6 Data Entry - Text Strings</td>
<td>134</td>
</tr>
<tr>
<td>7 Data Entry - Date and Time</td>
<td>135</td>
</tr>
<tr>
<td>8 Parameter List</td>
<td>136</td>
</tr>
<tr>
<td>9 Quick List</td>
<td>138</td>
</tr>
<tr>
<td>10 Trend Charts</td>
<td>139</td>
</tr>
<tr>
<td>11 Touch Screen Support</td>
<td>139</td>
</tr>
</tbody>
</table>

© 1995 - 2015 SpecView
12 Runtime Menu Bar ................................................................. 140
   File Menu (Runtime) ............................................................ 141
   Logging Menu ................................................................. 144
   History Menu ................................................................. 144
   Recipe Menu ................................................................. 145
   View Menu ................................................................. 145
   Password Menu (Runtime) ............................................. 146
   Remotes Menu .......................................................... 146
   Options Menu .............................................................. 147
   Zoom Menu ................................................................. 148
   Window Menu (Runtime) .................................................. 149
   Help Menu (Runtime) ..................................................... 149

Part VII Editing a SpecView Project ........................................ 153
1 Menu Bar and Toolbar in Edit Mode ........................................ 154
   File Menu (Edit Mode) ...................................................... 155
   Edit Menu ................................................................. 158
   Draw menu ................................................................. 160
   Object Menu .............................................................. 162
   View Menu ................................................................. 166
   Password Menu (Edit Mode) ........................................... 169
   Setup Menu ................................................................. 169
   Online Features Menu ................................................... 172
   Window Menu (Edit Mode) .............................................. 173
   Help Menu (Edit Mode) ................................................... 174

2 Editing GDWs - Graphical Display Windows ......................... 176
   GDWs - Graphical Display Windows ................................... 176
   Extruder Graphic ........................................................... 177
   Variables List .................................................................. 178
      Variables List - SpecView Variables .............................. 184
      Variables List - Properties .......................................... 190
      Variables List - Internal Data Menu ............................... 199
      Variables List - Groups .............................................. 201
      Variables List - Find/Replace ...................................... 202
   Templates List ............................................................. 203
   Instrument Views .......................................................... 206
   SpecView.FastCount Variable ........................................ 206
   Adding Numeric Values to a GDW ..................................... 208
   Alarms ........................................................................... 210
   Dynamic Attributes Box .................................................. 211
   Color Dynamics ........................................................... 213
   Position Dynamics ........................................................ 215
   Insert New Object .......................................................... 217
   Edit Links ....................................................................... 218
   Quick List Setup ........................................................... 220

3 Drawing Basics ................................................................ 221
   Selecting, Grouping, Moving and Saving Objects .................. 223
   Shape Properties .......................................................... 225
   Objects in front / behind others ...................................... 225
   Quick Copying of Drawing Objects .................................... 226
   Select Tool ..................................................................... 226
   Line Drawing Tool ........................................................ 226
### Glossary of Key Terms used in SpecView

<table>
<thead>
<tr>
<th>Term</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alarms</td>
<td>274</td>
</tr>
<tr>
<td>Boolean</td>
<td>275</td>
</tr>
<tr>
<td>Communications Ports &quot;Com Port&quot;</td>
<td>277</td>
</tr>
<tr>
<td>Communications Protocol</td>
<td>278</td>
</tr>
<tr>
<td>Configuration</td>
<td>278</td>
</tr>
<tr>
<td>Data Logging</td>
<td>279</td>
</tr>
<tr>
<td>Decimal Places</td>
<td>279</td>
</tr>
<tr>
<td>Dongle</td>
<td>281</td>
</tr>
<tr>
<td>Driver</td>
<td>282</td>
</tr>
<tr>
<td>Dynamic Attributes</td>
<td>284</td>
</tr>
<tr>
<td>Edit Mode</td>
<td>284</td>
</tr>
<tr>
<td>GDO - Graphical Display Object</td>
<td>286</td>
</tr>
<tr>
<td>GDW - Graphical Display Window</td>
<td>286</td>
</tr>
<tr>
<td>Group</td>
<td>286</td>
</tr>
<tr>
<td>Instrument</td>
<td>287</td>
</tr>
<tr>
<td>Instrument View</td>
<td>287</td>
</tr>
<tr>
<td>Log Report</td>
<td>288</td>
</tr>
<tr>
<td>Multiport Option</td>
<td>289</td>
</tr>
<tr>
<td>Multi-Select</td>
<td>289</td>
</tr>
<tr>
<td>Project</td>
<td>290</td>
</tr>
<tr>
<td>Radio Buttons</td>
<td>290</td>
</tr>
<tr>
<td>Read Only Variable</td>
<td>290</td>
</tr>
<tr>
<td>Recipe</td>
<td>291</td>
</tr>
<tr>
<td>Running SpecView as an Administrator</td>
<td>292</td>
</tr>
<tr>
<td>Runtime Mode</td>
<td>292</td>
</tr>
<tr>
<td>SETTINGS.INI</td>
<td>292</td>
</tr>
<tr>
<td>Strategy Controller</td>
<td>293</td>
</tr>
<tr>
<td>SV3.INI</td>
<td>293</td>
</tr>
<tr>
<td>Toggle</td>
<td>293</td>
</tr>
<tr>
<td>Tooltips</td>
<td>294</td>
</tr>
<tr>
<td>Variable</td>
<td>294</td>
</tr>
</tbody>
</table>
Part VIII  Trend Charts  298

1  Trend Chart Conversion ................................................................. 302
2  Trend Chart Runtime Mode ............................................................ 303
3  Trend Chart Runtime - Export Range to CSV ................................. 306
4  Trend Chart Properties - Pens ....................................................... 307
5  Trend Chart Properties - Chart ..................................................... 312
6  Trend Chart Properties - Pen Scales ............................................. 315
7  Trend Chart Properties - Time Axis & Gridlines ............................ 317
8  Trend Chart Properties - Cursors ............................................... 318
9  Trend Chart Properties - Chart Notes ............................................. 321
   Automatic Chart Notes ................................................................. 323
10 Trend Chart Properties - Values .................................................. 325
11 Trend Chart Properties - Print & Batch ......................................... 327
12 Trend Chart Properties - Colors .................................................. 328
13 Trend Chart Properties - Buttons & View ..................................... 328
14 Trend Chart Gridlines ................................................................. 329
15 Trend Chart - CSV Export ........................................................... 330

Part IX  Instrument Connectivity  333

1  Instrument Installation and Wiring ............................................... 333
2  Instrument Settings ................................................................. 335
3  RS422/EIA422 ........................................................................... 335
4  RS485/EIA485 ............................................................................ 335
5  Ethernet and TCP/IP ................................................................. 336
6  Communications Protocol .......................................................... 336
7  Increasing Speed of Instrument Communications ........................ 337
8  Multiport Option ....................................................................... 339
9  OPC Client Support - Overview .................................................. 340
   OPC Browser ............................................................................. 341
   Supported OPC Servers ............................................................. 343
   OPC - Frequently Asked Questions (FAQs) ................................ 346
   OPC - PC Specification/Performance ........................................ 347
10 DDE (Dynamic Data Exchange) - Overview ................................ 349
   DDE Application Name ................................................................. 349
   DDE Topic Name ......................................................................... 350
   DDE Status Topic ........................................................................ 350
   SpecView DDE Restrictions ...................................................... 350
   Getting data from SpecView DDE ............................................. 350

© 1995 - 2015 SpecView
Part X Data Logging

1 Data Logging - Variables ............................................................................... 357
2 Data Logging - Disk Space Requirements .................................................. 359
3 Data Logging - Rate ....................................................................................... 360
4 Log Reports ..................................................................................................... 362
5 Log Report Setup ............................................................................................ 363
6 Log Reports from the Remote ........................................................................ 365
7 Log Report Format .......................................................................................... 366
8 Log Reports - Specifying decimal places ...................................................... 369
9 Data Logging - Alarms ...................................................................................... 370
10 Data Logging - Events .................................................................................... 373
11 Data Logging - Chart Notes .......................................................................... 374
12 Historical Replay Option ............................................................................... 375
13 Historical Replay - Control Panel ................................................................. 375
14 Historical Replay - Start Time ....................................................................... 376
15 Historical Replay - Find Batch Number ...................................................... 377
16 Historical Replay - Rate ................................................................................ 379
17 Historical Replay - Options ......................................................................... 379
18 Batch Tags ....................................................................................................... 380

Part XI Recipes

1 Selecting Variables to be Included in Recipe ............................................... 389
2 Recipes - Using ............................................................................................... 390
3 Recipe Warning ............................................................................................... 393
4 Recipe Names .................................................................................................. 394
5 Recipe Description .......................................................................................... 394
6 Recipe Hide this box ....................................................................................... 395
7 Recipe Save & Save As .................................................................................. 395
8 Recipe Import/Export ..................................................................................... 396
9 Recipe Send ...................................................................................................... 398
10 Recipe Send To .............................................................................................. 398
11 Source and Target Instruments .................................................................... 399
12 Recipe Send To: Warning .............................................................................. 400
13 Recipe Send To: Problems ............................................................................ 401
14 Setting the recipe download order .................................................................. 402
15 Recipe on Remote .......................................................................................... 403
### Part XVI Troubleshooting

1. Troubleshooting Instrument Communication ...................................................... 490
2. Cannot Open COM Port ....................................................................................... 493
3. HyperTerminal ..................................................................................................... 495
4. Telnet .................................................................................................................... 496
5. Reporting Bugs ................................................................................................... 496
6. Generating Dump Files ....................................................................................... 497
7. Technical Support ............................................................................................... 498
   - USA Contact Numbers .................................................................................... 499
   - UK Contact Numbers ...................................................................................... 499
   - Europe Contact Numbers ............................................................................... 499
   - Internet Support .............................................................................................. 499

### Part XVII Quick Start Guide

1. Quick Start - Overview ....................................................................................... 504
2. Quick Start - Starting SpecView ......................................................................... 506
3. Quick Start - Manual Project ............................................................................. 508
4. Quick Start - For Instruments using the Modbus Protocol ................................ 513
5. Quick Start - Automatically detect instruments and display instrument views .................................................................................. 514
6. Quick Start - Add a variable to the GDW ......................................................... 517
7. Quick Start - Draw a trend chart ....................................................................... 521
8. Quick Start - Define a second GDW .................................................................. 524
9. Quick Start - Add buttons to switch between GDW's ....................................... 525
10. Quick Start - Add a Bar chart .......................................................................... 527
11. Quick Start - See how it works in Runtime mode ............................................ 529

### Part XVIII User Guide

1. Setting up a Project ............................................................................................. 533
Part XIX  Frequently Asked Questions (FAQ)  554

1  FAQ - Installation/Update/Upgrade.............................................................. 555
2  FAQ - Instrument...................................................................................... 556
3  FAQ - SpecView Runtime........................................................................ 557
4  FAQ - SpecView Edit Mode....................................................................... 559

Index  565
Top Level Intro

This page is printed before a new top-level chapter starts
1 Introduction

Introduction:
Introduction to SpecView
Minimum Requirements for running SpecView
How to use the Help/Manual

Licensing in SpecView:
Dongles
Soft Dongles
Evaluation Version
Upgrading SpecView

1.1 Introduction to SpecView

SpecView is SCADA software. SCADA stands for Supervisory Control And Data Acquisition. SpecView is used as industrial control system software to monitor and control industrial processes.

Industrial processes include manufacturing, production, power generation, fabrication, refining, etc. These processes may run in continuous or batch modes.

SpecView makes it easy to use a PC with control and monitoring instrumentation, allowing you to setup:
- Data Logging
- Graphical User Interface tools (GUI/HMI)
- Recipe System
- Batch Tags
- Trending
- Passwords

SpecView has the following dongle options:
- Multiport - Allows SpecView to be connected to potentially 1000’s of different instruments, or increase the data rate on large systems
- Historical Replay - ‘Video’ review of logged data
- Strategy Controller - Automation of SpecView
- DDE - Add your own complex functionality
- Remote Users - Use SpecView from 'down the hall' to 'around the world'
- OPC - Connect to any OPC Server
- ActiveX - Use graphical objects to speed up screen design or use complex controls to perform specific tasks
- Runtime-only - No access to Edit Mode - great for turnkey systems
- Non-standard Driver - Some SpecView drivers are a chargeable option
- Mini version - Restricted to two Instrument Views - which could be 2 simple measurement instruments or may be a single programmable controller with separate Instrument Views for the programmer module and the controller module. A multi-loop controller can have many Instrument Views, one for each loop. The full version of SpecView is not limited to the number of Instrument Views or the number of parameters/variables.
If SpecView is run without a dongle (copy protection key) then it can be run in either Demo mode or Remote mode.
When used in Demo mode there is a 10 minute limit on communications in each Runtime session. This timer is reset each time the user enters Edit Mode and returns to Runtime Mode. It is not necessary to restart either SpecView or the computer. No save functions are disabled.

Licensing in SpecView

SpecView may be downloaded from the SpecView web site: http://www.specview.com
However, it is important to check the 'Free Updates until' date on the dongle. This can be seen in from the About SpecView menu command on the Help menu.

It is possible to add options to SpecView by upgrading the dongle. This can be done remotely - there is no need to send the dongle to SpecView.
For more details on these options see the 'What To Buy' page of our website.

There are now both 32bit and 64bit versions of SpecView. In general, it is recommended to run the 32-bit version. There is little, if any, performance advantage using the 64-bit version. Some options such as OPC servers and ActiveX controls may not run in the 64-bit version and drivers for some older instruments may not be available.
Minimum Requirements for running SpecView
Updating SpecView from a previous version
Upgrading SpecView to add additional options to a dongle

1.2 Minimum Requirements for running SpecView

The Minimum Hardware Requirements for Running SpecView
Intel Pentium processor or equivalent AMD
1GB RAM (2GB or more recommended, as Windows takes most of this minimum)
100MB hard disk space to install SpecView
additional disk space for data logging (varies depending on how much and how often you log data)
Instrument connection: RS232 / RS485 / RS422 / Ethernet / OPC
USB or Parallel port for the dongle. Soft Dongles also available on request.

**Ideal System:**
- Intel Core i5 (or Celeron or AMD equivalent) 2.6Ghz
- 2GB RAM
- 500GB hard disk + enough space for Data Logging

Essentially, any computer that runs MS Word and MS Excel quickly will be OK for SpecView.
Normal SpecView activity does not put a great load on computer performance, however for heavily loaded systems with lots of comms, many screens and complex Strategy Controller, it is recommended to get the fastest PC possible.

The amount of disk space used by SpecView's log files varies accounting to the number of variables being logged & the logging rate.

**Touch Screen Compatibility**
SpecView is partly compatible with Touch-Screens for use during Runtime Mode, as the main data-input boxes have on-screen buttons or an on-screen keyboard with buttons. For foreign languages, it is not possible to enter accented or complex characters using the on-screen buttons.

However, projects cannot be edited using just a Touch-Screen. A keyboard is needed (either on-screen or physical).
Similarly, there are some Runtime features which need a keyboard, such as searching for batches in Historical Replay.
Also, for doing Log Report Setup during Runtime mode it is easier to use a standard keyboard & mouse.

**The Minimum Software Requirements for Running SpecView**
SpecView is a 32 bit Windows application that will run on Windows 95/98/NT/2000/Me/XP/

When using Windows XP Service Pack 2 you may see the Windows Security Alert below because part of SpecView's Remote option attempts to analyse the computer's network during startup.
1.3 How to use the Help/Manual

Clicking on a Help button within SpecView will go to the relevant topic in the Help file.

The whole text can be reviewed and printed if necessary by going to the Manuals folder on the CD where a PDF file of the manual is located.

The Manual and the Help are identical to each other. The Help allows clicking on links (indicated by words which are underlined) to jump to another topic, whereas, the printed manual has page references.

In the Help, the Forward and Back buttons will navigate through previous pages that have been viewed, and the Index and Search tabs can be used to find specific topics.

Please email any comments/suggestions on improvements to: support@specview.com

There are a few changes to SpecView's terminology in SpecView Version 3:
- Configuration Mode is now known as Edit Mode
- A Configuration is now known as a Project
See What's New In Version 3

There is a Glossary of terms for reference.
1.4 Licensing in SpecView

Licensing in SpecView

The use of SpecView is under the terms of the End User License Agreement (EULA). Users must agree to these terms to use SpecView. The complete EULA may be read here (link to license).

SpecView is supplied with either a USB hardware key ('dongle') or a software key.

- **USB Dongles**
- **Soft Dongles**
- **Evaluation Version**
- **Upgrading SpecView to add additional options to a dongle**

1.4.1 Dongles

SpecView can use either a **hardware dongle**

![Hardware Dongle Image]

or **soft dongle** as a copy protection/license key. They tell SpecView which options have been purchased. They also contain the details of the **Free Updates Period**.

**Hardware dongles can be mistaken for a USB memory stick and therefore should be securely attached to the computer!**

Software dongles impose some additional user restrictions and are only supplied where hardware keys cannot be used. Software dongles require periodic re-authorization.

SpecView 32 may be downloaded at any time (and free of charge) from the SpecView web site: [http://www.specview.com](http://www.specview.com)

When used without a **dongle** SpecView can run in either **Remote Mode** or **Demo Mode**. In **Demo Mode** there is the following functionality/restrictions:
Each Runtime session is restricted to a 10 minute limit. This timer is started each time the user
goes online either by going into Runtime mode or by using the Online Features menu in Edit mode.
Going offline will reset this timer. It is not necessary to restart either SpecView or the computer.

- The Strategy Controller is restricted to 2 events.
- Historical Replay is limited to replaying the last 4 hours of data.
- Recipe is restricted to a maximum of 5 items in a recipe.
- The Multiport option is not available, so instrument communications can only be done through a
  single port.
- Remote connections are available.
- DDE server is enabled.
- OPC client is enabled.
- All drivers are available.
- All SpecView's language options are available. The language that SpecView will run in is based on
  the current Regional Settings as set via the Windows Control Panel.
- ActiveX is enabled.
- Otherwise all the functions within the standard software are available, including the save functions.

Once a dongle has been purchased it is possible to upgrade it to add software options to SpecView.
This can be done remotely - there is no need to send the dongle to SpecView.

Remote computers used with SpecView's Remote option do not require a dongle to be connected to
them. The dongle connected to the local computer will need to have been purchased for the required
number of simultaneous remote users.

Each dongle is considered to be a license to use the software. There is no concept of a 'Site License'
within SpecView.

There is a Troubleshooting program for the hardware dongle should there be a problem.

Both hardware & soft dongles can be supplied in Evaluation Mode which will have an expiry date defined
in them, after which time SpecView will only operate in Demo Mode. This expiry can be reset or
removed by upgrading your dongle.

1.4.2 Soft Dongles

Soft dongles are a new innovation which works in the same way as a hardware dongle, and dongle
upgrades are done in a similar way.

Currently soft dongles will only be supplied in rare cases where a hardware dongle cannot be used. This
restriction will be lifted when the technology to uninstall and reinstall on another PC is available.

Installing the soft dongle is a two part process. First, a code needs to be generated on the PC that
SpecView is going to be run on. This code needs to be E-Mailed to SpecView support.
Upon receipt, SpecView support will generate the appropriate code and email a special file back, which
then needs to be installed.
1 Procedure

With SpecView already installed, but not running, run the FIELDEXUTIL.EXE that will be in the main SV3 folder (by default this will be C:\SV3).

Click the ‘Software Key’ tab and ensure that ‘New’ is selected, as shown here:

Click the [Get Locking Code] button to generate the special code that needs to be emailed to SpecView support:
There are two ways to copy this code into an Email:

1. Copy the code to the clipboard using the 'Copy To Clipboard' icon, then 'Paste' it into the email.
2. Or save the code to a file using the 'Save locking code to a file' icon, then attach this file to the email.

Once the code has been emailed to SpecView support (support@specview.com), the FieldExUtil can be closed until the corresponding code has been emailed back by SpecView support.
This code will be in the form of a .LIC file.

Save this .LIC file onto the computer that will be running SpecView – this must be the same computer that generated the locking code above.

Ensure SpecView is not running, then run the FIELDEXUTIL.EXE that will be in the main SV3 folder.
Click the [Software Key] tab and ensure that ‘New’ is selected, as shown here:
Click the ‘Load license code from a file’ icon and locate the .LIC file sent by SpecView support. This will load the LIC file codes into the lower window.

Click the [Update License] button to install the License file on the PC.

If the codes match, then the Soft-dongle has been installed:
Hard and soft dongles each have advantages and disadvantages. Each may be upgraded in situ without having to return anything to SpecView.

**Hardware Dongles:**

**Pros**
- Easy to move from one computer to another – no un-install required
- May be physically attached to PC by security cable

**Cons**
- Physical key may get damaged
- May be lost or stolen (sometimes mistaken for memory stick)
- Uses USB port

**Soft Dongles:**

**Pros**
- No physical dongle to damage or lose
- Does not use a USB port

**Cons**
- A soft dongle MUST be installed by the user login that will be using it
- The user must obtain codes from SpecView to install it
- Cannot be moved to another PC without un-installing and contacting SpecView to purchase new installation codes
- Must purchase a new or replacement license if the computer is changed or damaged.

**Replacement**

If a hardware dongle is lost or stolen SpecView MAY, at its discretion, sell a replacement dongle. This will only be considered if the user can provide SpecView with the original serial number.

Soft dongles are keyed to a particular computer. If a component is changed, such as a hard disc, the user will have to contact SpecView for a new installation code. If there is a catastrophic failure such that the computer cannot be restored with any of the original components SpecView MAY, at its discretion, issue a replacement installation code. The charge for this will be the same as a replacement hardware dongle.

NOTE: All SpecView software dongle installations are required to be re-registered with SpecView from time to time. If an internet connection is available this can be done automatically. If not, the user has to contact SpecView for an updated code.

**1.4.3 Evaluation Version**

Both [hardware](#) & [soft dongles](#) can have an expiry date defined in them.
The expiry date can be seen on the 'Dongle Information' box, which is displayed using Help- >Registration Info

After the evaluation period SpecView will not be able to receive values from instruments.

This expiry date can be reset or removed by upgrading the dongle.

1.4.4 Upgrading SpecView

SpecView is copy protected using a dongle which is attached to the printer port of your computer. It contains all the options purchased with your copy. The user can add additional options. This is a two step process:
1. Your copy of SpecView generates a code that you give to SpecView, by phone, fax or email
2. SpecView gives you two or more codes that you enter
Start by clicking on the Help menu command and then on About SpecView.
Dongle Information

When you are ready to contact your SpecView distributor click Enable Further Options to begin the upgrade process.
Upgrade: Step 1

Click Step 1: Read code you will give to SpecView and click Generate the code now to get the Step1 code.

Be ready to write down the code.

Be careful not to accidentally generate another Step1 code because the Step2 codes you will be
Write down this code and give it to your SpecView representative. Click **OK** and then **Exit**.

**Upgrade Stage 2: Enter codes**
Open the Dongle Information box (Help menu; Registration Info)
Click Enable Further Options
Click Step 2: Enter Codes you have been given by SpecView
Enter the codes from SpecView in the box shown below, clicking the Use Code button after each.
NOTE: Codes may be in upper or lower case and spaces are not required, although spaces make reading it back easier.

After the last code has been entered this box appears:

It is necessary to exit SpecView & run it again for the new options to be recognized.

Licensing in SpecView

Updating SpecView software to the latest version

1.4.5 Update Expiry

New purchases of SpecView Version 3 (and upgrades to add Version 3 to an existing dongle) include 13 months of "Free Updates" (Users may download and install the latest version available).
When the free updates period expires a one year or five year extension must be purchased in order to update to the latest version.

Please contact your SpecView representative for prices for these update extensions.

However, the dongle will continue to work with the existing version of SpecView, it will only give an error if a SpecView is updated to a newer version.

1.4.6 Runtime-Only Dongle

SpecView offers 'RunTime Only' licenses that prevent the user from entering edit mode and making changes to the project.
These licenses are useful:

- When there are several copies of SpecView in the facility and one full copy is used for all project editing and the edited project is transferred to the 'Runtime' computers. This is typically done to reduce costs.
- For OEMs or systems integrators who develop projects for their customers and do not want them to be able to make any changes or see the details of how the project was developed.

Be aware that ALL changes, including passwords, MUST be done with a full version of SpecView. If the project is edited with the dongle removed (in Edit mode) it will be corrupted and not be allowed to run.

1.4.7 Version 3 Option not on Dongle

New dongles that have been purchased in recent years have included the Version 3 option. But for older dongles please contact your SpecView Representative for upgrade pricing.
1.4.8 End User License Agreement

Licence Agreement

BY CONTINUING TO USE THIS SOFTWARE, YOU ARE CONSENTING TO BE BOUND BY THIS AGREEMENT. IF YOU DO NOT AGREE TO ALL OF THE TERMS OF THIS AGREEMENT, IMMEDIATELY RETURN THE PRODUCT WITH A COPY OF YOUR RECEIPT TO YOUR SUPPLIER FOR A FULL REFUND OF MONIES PAID, IF ANY.

I GRANT
SpecView Corp ("SpecView") hereby grants to the end user person or entity ("Licensee") a non-exclusive license to use the accompanying software product(s), in machine executable object code form (the "Software") subject to the terms and conditions set forth below. LICENSEE MAY use the Software on any single computer; use the Software on a second computer so long as the primary user of each copy is the same person and more than one copy is not running simultaneously on a second computer; and copy the Software for archival purposes, provided any copy must contain all of the original Software's proprietary notices. LICENSEE MAY NOT permit other individuals to use the Software except under the terms listed above; modify, translate, reverse engineer, decompile, disassemble (except to the extent applicable laws specifically prohibit such restriction), or create derivative works based on the Software; copy the Software (except as specified above); export, directly or indirectly, the Software to any person or entity outside the United States except as provided in paragraph 6 below; rent, lease, transfer or otherwise transfer rights to the Software; or remove any proprietary notices or labels on the Software.

II LIMITED MEDIA WARRANTY
SpecView warrants that, for a period of thirty (30) days from the date of delivery to Licensee as evidenced by a copy of Licensee's receipt, the media, if any, on which the Software is furnished shall be free from defects in materials and workmanship under normal use. THE SOLE RESPONSIBILITY AND LIABILITY OF SPECVIEW, AND LICENSEE'S EXCLUSIVE REMEDY UNDER THIS LIMITED WARRANTY WILL BE REPLACEMENT OF THE DEFECTIVE MEDIA.

DISCLAIMER OF WARRANTIES. Except for the express limited media warranty stated above, Licensee expressly acknowledges and agrees that use of the Software is at Licensees sole risk. THE SOFTWARE IS PROVIDED "AS IS" AND WITHOUT WARRANTY OF ANY KIND. SPECVIEW AND ITS LICENSORS AND SUPPLIERS MAKE NO WARRANTIES OR CONDITIONS, EXPRESS OR IMPLIED, INCLUDING WITHOUT LIMITATION THE IMPLIED WARRANTIES OR CONDITIONS OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, AND NONINFRINGEMENT, REGARDING THE SOFTWARE. NEITHER SPECVIEW NOR ITS LICENSORS OR SUPPLIERS WARRANT, GUARANTEE OR MAKE ANY REPRESENTATIONS REGARDING THE USE OR THE RESULTS OF THE USE OF THE SOFTWARE IN TERMS OF ITS CORRECTNESS, ACCURACY, RELIABILITY, OR CURRENTNESS OR THAT THE OPERATION OF THE SOFTWARE WILL BE
UNINTERRUPTED OR ERROR FREE. THE ENTIRE RISK AS TO THE RESULTS AND PERFORMANCE OF THE SOFTWARE IS ASSUMED BY LICENSEE, INCLUDING WITHOUT LIMITATION ANY RISK OF THE INTRODUCTION OF COMPUTER VIRUSES AND ANY RISK ARISING OUT OF ANY CONTENT TRANSMITTED OR RECEIVED IN CONNECTION WITH THE USE OF THE SOFTWARE. THE EXCLUSION OF IMPLIED WARRANTIES IS NOT PERMITTED BY SOME STATES OR OTHER JURISDICTIONS AND THEREFORE THE ABOVE EXCLUSION MAY NOT APPLY TO LICENSEE. THIS WARRANTY GIVES LICENSEE SPECIFIC RIGHTS AND LICENSEE MAY ALSO HAVE OTHER RIGHTS WHICH MAY VARY FROM STATE TO STATE AND JURISDICTION TO JURISDICTION.

III LIMITATION OF LIABILITY
SpecView's liability to Licensee or any third party arising out of or related to this Agreement however caused and on any theory of liability, whether in contract, tort (including negligence), or otherwise will not exceed the fee, if any, paid by Licensee for the Software. The Software is not specifically developed or licensed for use in any nuclear, aviation, mass transit, or medical application or any other inherently dangerous applications. NEITHER SPECVIEW NOR ITS LICENSORS OR SUPPLIERS SHALL BE LIABLE FOR ANY CLAIMS OR DAMAGES ARISING FROM SUCH USE OF THE SOFTWARE. IN NO EVENT WILL SPECVIEW OR ITS LICENSORS OR SUPPLIERS BE LIABLE TO LICENSEE OR ANY THIRD PARTY FOR ANY INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES (INCLUDING DAMAGES FOR COST OF OBTAINING SUBSTITUTE GOODS, LOSS OF BUSINESS PROFITS, BUSINESS INTERRUPTION, LOSS OF DATA AND EQUIPMENT, AND OTHER SUCH DAMAGE OR LOSS), HOWEVER CAUSED (INCLUDING WITHOUT LIMITATION ANY LOSS CAUSED BY THE INTRODUCTION OF COMPUTER VIRUSES OR CONTENT TRANSMITTED OR RECEIVED IN CONNECTION WITH THE USE OF THE SOFTWARE) AND ON ANY THEORY OF LIABILITY, WHETHER BASED IN TORT (INCLUDING NEGLIGENCE), CONTRACT, OR OTHERWISE, EVEN IF SPECVIEW, OR ITS LICENSORS, SUPPLIERS OR AUTHORIZED DEALERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. LICENSEE ACKNOWLEDGES THAT THE LICENSE FEE, IF ANY, REFLECTS THIS ALLOCATION OF RISK. BECAUSE SOME STATES OR OTHER JURISDICTIONS DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES, THE ABOVE LIMITATIONS OR EXCLUSIONS MAY NOT APPLY TO LICENSEE.

IV TITLE
Title, ownership rights, and intellectual property rights in and to the Software shall remain in SpecView and/or its licensors and suppliers. The Software is protected by the copyright laws of the United States and international copyright treaties. Title, ownership rights, and intellectual property rights in and to the content accessed through the Software is the property of the applicable content owner and may be protected by applicable copyright or other law. This Agreement gives Licensee no rights to such content. Except as expressly provided herein, all right, title and interest in and to the Software remains with SpecView and its licensors and suppliers.

V TERMINATION
The Agreement, including all of Licensee's right to use the Software, will terminate automatically and immediately if Licensee fails to comply with the limitations described above. Upon termination, Licensee must immediately stop using the Software and Licensee must return to SpecView or destroy all copies of the Software.

VI EXPORT LAW ASSURANCES
Licensee agrees not to export the Software outside of the United States except as permitted by the laws and regulations of the United States. If Licensee has rightfully obtained the Software outside of the United States, Licensee agrees not to re-export the Software except as permitted by the laws and regulations of the United States and the laws and regulations of the jurisdiction in which Licensee
obtained the Software.

VII GOVERNMENT RESTRICTED RIGHTS LEGEND

If Licensee is acquiring the Software on behalf of any part of the United States Government, the following provisions apply. The Software and accompanying documentation are deemed to be "commercial computer software" and "commercial computer software documentation", respectively, pursuant to DFAR Section 227.7202 and FAR 12.212(b), as applicable. Any use, modification, reproduction, release, performance, display or disclosure of the Software and/or the accompanying documentation by the U.S. Government or any of its agencies shall be governed solely by the terms of this Agreement and shall be prohibited except to the extent expressly permitted by the terms of this Agreement.

VIII MISCELLANEOUS

This Agreement represents the complete agreement between Licensee and SpecView concerning the subject matter hereof and supersedes all prior agreements and representations between them. It may be amended only by a writing executed by both parties. THE ACCEPTANCE OF ANY PURCHASE ORDER PLACED BY LICENSEE IS EXPRESSLY MADE CONDITIONAL ON LICENSEE'S ASSENT TO THE TERMS SET FORTH HEREIN, AND NOT THOSE CONTAINED IN LICENSEE'S PURCHASE ORDER. If any provision of this Agreement is held to be unenforceable for any reason, such provision shall be reformed only to the extent necessary to make it enforceable. This Agreement cannot be amended, modified, or waived, unless the change is written and signed by an authorized SpecView representative. This Agreement is governed by the laws of the State of California, without reference to its conflict of law principles. Should Licensee have any questions concerning this Agreement, please contact in writing:

SpecView Corp,
13409 53rd Ave NW
Gig Harbor
WA 98332
USA

SpecView Ltd,
P.O. Box 52
Uckfield
East Sussex
TN22 1ZT
U.K.
Top Level Intro

This page is printed before a new top-level chapter starts
2 What's New In Version 3

There are a number of new features in Version 3:

- Installation
- Trend Charts
- Edit Mode
- Variables List & Templates List
- Quick List
- Position Dynamics for Animation
- Color Dynamics
- Import Project
- Runtime
- Startup Sequence
- Preferences
- Passwords - Start at level 1
- Touch Screen Support
- Additional Features
- 32bit and 64bit SpecView
- Backward Compatibility
- Update Policies costs and prices
- Bug Reporting Procedure

The 'XXX' for missing values has been replaced by specifics: N/R (No Response), NPV (Not Present Value), NCA (Not Currently Available), T/O (Timeout)

Acknowledges Alarms button/strategy action

This section of SpecView's Help does not cover features and functionality which has not changed from SpecView Version 2.5.

If this computer is connected to the Internet, then there are videos on YouTube here:
- What's new in Version 3
- Trend Charts
- Variables List
- Position Dynamics

There are a few changes to terminology in Version 3:
- Configuration Mode is now known as Edit Mode
- A Configuration is now known as a Project

Note that Version 3 will not work with the old style parallel (25 pin) dongles. It will only work with USB and Soft dongles, please contact your SpecView representative if you have a parallel dongle for dongle exchange pricing.

There are videos available on these features.
2.1 Videos

If the computer is on the Internet then the links below will access the videos that have been uploaded to YouTube.

When SpecView is installed from CD then the videos will also be installed in Videos subfolder of the SV3 installation folder.

1000 Installation
1010 Starting a V2 Configuration in V3
1100 Introduction
1200 Splash Screen
1300 Auto detection
1500 New manual project / Template list
1700 Adding Instruments
2000 Test Comms for Update
2200 Merging Projects
2500 Edit Mode
2700 Variables List
2800 Drag/Drop/Auto arrange
3000 Screen layout; Layers and grouping
3200 Drawing
3500 Copying
3700 Barchart
4000 Trend Chart Menu
  1. 4050 Chart Setup
  2. 4100 Pens Tab
  3. 4150 Chart Tab
  4. 4200 Chart Scales Tab
  5. 4250 Chart Time Axis Tab
  6. 4300 Chart Cursors
  7. 4350 Chart Notes
  8. 4400 Chart Notes - Auto
  9. 4500 Chart Print/Batch Tab - Batch Tags
  10. 4550 Chart Print/Batch Tab - Non-Scrolling Chart Batch Tags
  11. 4600 Chart Print/Batch Tab - Printing
4500 Active-X
4700 Buttons
4800 Colour Dynamics
5000 Position Dynamics
5200 Passwords
5500 On-Line features
6000 Quick List
6200 Cloning
6400 Recipe
6800 Set up / Swap COM ports
7000 Strategy Controller
7500 Log Reports
8000 History
8500 Batch Reports
9000 Remote Users
9500 Global
These videos will be added to as they are completed, if there is a particular one that would be useful then please contact SpecView Technical Support.

2.2 Installation

SpecView Version 3 is now installed into C:\SV3\ by default, instead of C:\SV32\.

It is necessary to have Version 3 enabled on the SpecView dongle. Recently purchased dongles will already have this enabled, see Update Policies.

The M9934 message is for information only - When the update-subscription expires the software will continue to work, but it will not be possible to update the software to a newer version without purchasing an update renewal from a SpecView representative.
For the errors E9903 or E9902 please contact your SpecView representative to purchase an update renewal.

### 2.3 Trend Charts

SpecView's Trend Charts have been completely redesigned and given a new look in Version 3. This means there are many new options available. However, the basic setup of a chart is unchanged from older versions of SpecView.

Charts from previous versions of SpecView can be converted.

If the new features are not required, then the option of simple setup is available.

The most significant changes to the functionality of Trend Charts are:

- **Back-fill** of historical data when the screen (GDW) is opened. This is independent from Historical Replay.
  
  *Note: The data points for back-fill are from logged data, so the resolution of the points is in accordance with the data logging rate.*

- **Scrollbar** using the scrollbar thumb to view up to 10 chart widths of previous data:

  ![Drag the scrollbar to review up to 10 screens of history](image)

- **Chart Notes** to mark significant points on a chart.
**Zoom** - Drag an area of the chart to expand X and Y axes. The popup-menu includes options to export data in zoomed area to a CSV file. The number of intermediate values is specified on the Chart tab.

- Multiple **scales** on the left or right of the chart, for some or all of the pens, with optional value pointers.

- Popup menu - Trend charts now have a popup menu that can be accessed from Runtime Mode using either the left or right mouse buttons, for compatibility with touch-screens which don't have a 'right' mouse button. In **Edit Mode** the popup menu is only available using the right mouse button. This is because the left button is used to select the Trend Chart for moving and resizing.

The new **Trend Chart Properties** box is accessed by either choosing **Setup Chart** from the popup menu or clicking the **Setup** button (if it is enabled) from Runtime Mode. The **Setup** button is enabled from the **Buttons & View** tab.

A number of variables can be dragged & dropped from the Variables List. For ease of setup there is automatic color assignment and scaling.

Settings can be saved for future use by clicking the **Save settings as default for new charts** button.

A quick way to assign variables for the pens is to multiselect a number of variables from the **Variables**
List and drag & drop them into the pens box on the Pens tab.

Pens are assigned default colors according to whether the chart background is a light or a dark color. To change the color and settings of a specific pen select it in the pens box and click the Edit button to open the Pen Properties box, with the following tabs:

**Pens & Pen Properties**
- Thickness setting for each pen
- Decimal point setting for each pen
- Preset tolerance band. Example: draws ±10° lines relative to working SP to check for deviation
- Pen trace can blink and/or change color on alarm
- Automatic or fixed scaling with logarithmic option
- Optional pointers for each pen on scales
- Y-Axis auto scaling

**Chart**
- Smooth Scroll – the chart scrolls to the left or downwards*; the latest value will be always shown at the right or bottom* of the chart (* depends on horizontal or vertical chart)
- Jump Scroll (like SpecView Version 2) – when the last segment is full, the chart will jump one segment
- No Scroll – the chart will keep expanding the time axis to fit all the data. This means the chart will show all the data, which is useful if the duration of the batch process is unknown
- More time span selections with scroll back management settings
- Vertical scrolling chart option for compatibility with paper chart recorders

**Pen Scales**
- Scales for any pens, left or right

**Time Axis & Gridlines**
- Secondary elapsed time display, which is useful for batch processes

**Cursors**
- Cursors are visually clearer and have more features

**Chart Notes**
- Chart notes to mark significant points on a chart. Chart Notes can also be setup to be added automatically

**Values**
- The pen values along the top of the chart can have additional information and be formatted in different ways.

**Print & Batch**
- Chart print and screen print options
- Page print to printer or JPG
- File name selection – fixed or from SpecView variable
- Display the chart with a dark background for clarity on the screen, but when printing use a white background to save ink

**Colors**
- Automatic pen color assignment

**Buttons & View**
Flexibility of items displayed in the top right corner of the Trend Chart

2.4 Edit Mode

Edit Mode allows changes to be made to a project without stopping communication with the instruments or interrupting data logging. This is useful for making changes to a running system without losing any data.

Instruments can start communicating and logging data as soon as they are put out onto the GDW.

The features that continue to receive live values while in Edit Mode are selected using the Online Features menu:

All features are fully functional.

Individual features can be disabled. For example, while setting the start and end location of animated objects, Position Dynamics must be disabled.

Selecting Objects:
To multi-select objects on the screen hold the SHIFT key or the CTRL key when clicking.
Moving Objects:
Cursor keys can be used to nudge objects, or multiple selected objects or groups of objects on a screen (GDW) by one pixel, this is very useful when aligning objects by eye.

Dragging an object on the screen using the mouse, or using SHIFT-cursor keys on the keyboard, will make the object jump by one grid increment, whichever grid size is active at the time. The position of the object relative to the grid will be preserved.

To align an object with the grid use Object->Align->Realign To Grid.
To nudge an object by one pixel regardless of the grid, use the cursor keys on the keyboard (without the SHIFT key).

Copying and Pasting of Objects:
Objects on a screen (GDW) can be copied & pasted or cut & pasted without losing their associations with parameters or variables or Dynamic/Color Attributes, but in Edit Mode will only work if enabled from the Online Features menu.

Copy and paste can be done using the Edit menu, or by using CTRL-C CTRL-V to copy & paste or CTRL-X CTRL-V to cut and paste.

To make a clone of an object on the screen hold both the SHIFT and CTRL keys when clicking. Clones of objects will retain their associations with parameters/variables and Dynamic/Color Attributes.

These are used to display the outline of the portion of the screen that would be seen if the GDW were displayed onto a screen of that resolution.
This is particularly useful when creating a GDW for Remote access from a lower resolution screen to ensure that the items on a GDW are positioned appropriately.

The maximum dimensions of the grid shown in SpecView's Edit mode is: 3837 x 2117.

Grid Size and Grid Lines:
The Grid Size menu item on the View menu allows 3 grid settings to be specified. The defaults are: 5, 10 and 20 pixels.
The dashed grid-lines are drawn at 10 times the actual grid-size, so a grid of 5 will have dashed lines every 50 pixels, etc.

The Toggle Grid Lines menu item (Ctrl-G) on the View menu, cycles round the 3 grid-size settings. The forth setting is zero to disable the grid.

There are subtle differences to operation in Edit Mode. For example, single clicking a button will select it, double clicking a button will open the Button Attributes box and right-clicking pops up a menu to allow the specified action to be performed.

Auto save & recovery of screens (GDWs) will save changes for later recovery in the event of failure. In this case, a list of saved items will be displayed so the items to be recovered can be selected:
Note: When editing a project, if a button or menu item isn’t enabled then a possible reason is that Online Features are enabled. For example, in the Variables List’s Variable Properties box the Delete button will be disabled (grayed out) if Online Features are enabled.

2.5 Variables List

There is now a separate list for new instruments, which are now known as instrument Templates.

The Show New button has been replaced by the T on the toolbar. Or an alternative way to access it is via the New menu on the Variables List.

There are now multiple options for sorting instruments and variables within the Variables List.

There are a number of columns which can be selected showing Values (V), Logging (L), Alarms (A), Short-List (S) and Read-Only (R).

Live values will be shown in the Values (V) column, if enabled on the Online Features menu. This will not put a heavy load on comms because only those values visible will be requested.

New User Variable types:

- **Enum** (Enumerated type) - to express multiple states, such as: Stopped/Running/Paused. The syntax for defining the value is, for example: 1=Stopped;2=Running;3=Paused
- **Countup Timer** - to record durations.

New SpecView Variable:

- **Date&Time** This is the current Date and Time combined, which is useful for Strategy Events.
Choosing **Options->Flat List** displays parameters from multiple instruments, so that all similar parameters from each instrument are shown together.

Instruments may be grouped together under a logical machine name. This is done using **Options->Groups** to create a logical name and going to the instrument's **Properties** and assigning it to a group.

Variables can now be dragged and dropped onto the screen (GDW).

Multi-select of variables can be sequential, using the SHIFT key, or random, using the CTRL key. When using the CTRL key, variables are put on the screen in the order selected.
When a number of variables are multi-selected and dragged out onto the screen they are automatically in **Spread Mode** to assist when dragging out a number of variables for a table. This is indicated by the large black square 'handles' around them. The 'handles' can be dragged to adjust the spacing, instead of just enlarging the font.

Any group of items can be put into **Spread Mode** by right clicking on the group and choosing *Spread Mode* from the popup menu.

Subsequent dragging will use the previous spacing, or use the **Reset Spacing** menu item from the **Multi-Select** sub-menu.
Drag and drop can also be used to assign a variable in a box, such as, the Strategy Controller Setup box.

Here the Flat List option has been chosen from the Options menu, so that all the similar parameters from each instrument are shown together. After multi-selecting the parameters, drag onto the GDW which automatically arranges them and, if enabled on the Online Features menu, then the live values will be shown immediately.
For Modbus instruments the Modbus address of a parameter will be displayed in a tooltip.

A summary of variables is shown in a tooltip when hovering the mouse over the bottom edge of the Variables List.
Other new Variables List features include:

- Tooltips are displayed by hovering the mouse over items such as: User Variables, Instrument Parameters and column headings.
- Easy re-naming with Options->Find and Options->Replace so that instrument names, parameter names, and addresses can be found and changed.
- Simplified User Variable creation and renaming, which is more intelligent by recognizing any number in a name and incrementing for the next one.
- Show/Hide columns for Logging (L), Alarms (A), Short List (S) and Read-Only (R) attributes.
- New Read-Only attribute may be applied to Read/Write variables on screen (GDW) to prevent accidental changes to the value.
- The scroll-wheel on the mouse operates the scroll bar on the Variables List.
- Simplified instrument addressing with separate fields for Address, Decimal Point position and Address Offset.
- The menu items that were on the Setup->Database sub-menu are now on the Internal Data tab on the Variables List.
2.6 Quick List

In SpecView Version 2.5 there is the Short List. This is an abbreviated list of an instrument's parameters displayed in the Parameter List box. Typically the Short List contains just the most important parameters for an instrument in order to keep it simple. However, only one Parameter List box can be displayed at any one time, and those parameters can only be from a single instrument.

The Quick List is a method of marking particularly important parameters/variables from ALL instruments and User Variables in the Variables List, such that their values can be easily accessed and modified from Runtime Mode.

See: Quick List in Runtime Mode
and Setting up a Quick List in Edit Mode

There is a new Button Attribute and Strategy Controller Action to invoke the Quick List.
2.7 Position Dynamics

Position Dynamics allows objects on the screen to be positioned according to the value of a variable, this is useful for animation of an object.

Such as: an object moving, or a button disappearing, etc.
For example: the progress of a product along a conveyor belt, as shown here:

To setup Position Dynamics, for example: a carton on a conveyor belt, follow these steps:
• From **Edit Mode** put the object on the screen (in this example, a bitmap of a carton) and select it.

• Using the **Online Features** menu check that **Position Dynamics** is disabled, or choose **Disable All**. This is because if live values are being received then the value could change causing the object to move while setting up **Position Dynamics**.

• Either choose ‘Position Dynamics’ from the **Edit menu** or right-click and choose ‘Position Dynamics’ from the popup menu.

Note: If this menu item is not enabled go to the ‘Online Features’ menu and either uncheck the ‘Position Dynamics’ menu item, or choose ‘Disable All’. This is because if **Position Dynamics** could be setup while ‘Online’ then the value could change causing the object to move.

• Drag and drop the variable, from the **Variables List**, this will be used to determine the position of the object.
If the object is not in the first position then move it there by dragging, and click the ‘Add Way Point’ button and enter the value for the first position into the Value cell. This will mean that when the variable has this value the object will be positioned at this location.

Move the object to the next position required for the next waypoint and click ‘Add Way Point’ and enter the Value in the cell for that position, etc.

When all way points have been entered it is possible to verify them by clicking on each Way Point in the list in turn and see the position of the highlight change. When finished, click OK.

Note: The ‘Add Way Point’ button will not be enabled until a variable has been assigned.
2.8 Color Dynamics

Color Dynamics have been improved in 3 ways:

1. It is now possible to multi-select variables on a screen and apply the same Color Dynamics rule to each of them at once. For example, this can be used to highlight the current segment on a Recipe screen by multi-selecting the variables for that segment and making their color change when that segment is running.

Note: Copying and Pasting of objects on a screen (GDW) will preserve their Position Dynamics settings.

Note: If the value for the first waypoint is 0 and the second waypoint is 10 then SpecView will automatically fill in the intermediate points for values in between.
2. Additionally it is possible to multi-select variables on a screen and by using the **Use Value** checkbox apply the rule according to the value.

For example, it is possible to specify that all Boolean variables on a screen are shown in a specific color when they are 'On'.

The **Use Value** checkbox allows this to be done with a single Color Dynamics rule avoiding the need to create a separate Color Dynamics rule for each variable.

In this case it is important to multi-select variables that are of the same type (Number, Boolean, etc.)
3. Copying and Pasting of objects on a screen (GDW) will preserve their Color Dynamics settings.

2.9 Import Project

This allows one project to be imported into another, possibly creating duplicates in the process. The unwanted duplicates can be subsequently deleted.

This is useful so that, for example, if there is a project with one furnace defined, with its associated Strategy, then a project with any number of furnaces can be created by repeatedly importing the single furnace project the required number of times.

Or, maybe an elaborate screen layout from another project needs to be added to an existing project.

To import a project open one of the projects in Edit Mode. From the File menu choose Import Project and browse to the project's CONFIG.CF3
A prefix or suffix can be added so that the duplicates are uniquely named.

The import process will automatically make a backup of the project.

The resultant project will be a project containing everything from both projects: Variables, Screens (GDWs) and Strategy. However, no log files from the imported project will be included.

### 2.10 Runtime

Data entry boxes are now resizeable. Their size and position is remembered, which is particularly helpful when using a Touch Screen, as larger buttons are easier to use. Since the boxes retain their previous positions, multiple data entry is smoother.
There are new data types - Enum, Countup Timer and High Precision Number.

Status: Running

Variables and parameters can now be made Read-Only from the Variables List to avoid values being inadvertently changed.
Preferences

The Preferences box, which is accessed from the File menu, has some additions that effect Runtime:
- Logging tab - DP Override for decimal places
- Language tab - to set the language for SpecView's menus and boxes
- Display tab - Window positions to remember the positions of GDWs and whether to allow minimizing of windows

Trend Charts

In Runtime Mode the most important features of Trend Charts are:
- Scroll back - to view previous data - this is independent of Historical Replay.
- Chart Notes - to add notes to the pen traces.
- Chart Cursors - to see exact values and times together with the difference in value and the elapsed time.

Quick List

The Quick List is a method of viewing particularly important parameters/variables from ALL instruments and User Variables in the Variables List, such that their values can be easily accessed and modified.

2.11 Startup Sequence

The language to be used by SpecView is selectable at startup. The Do not show checkbox is checked by default as normally one language is used throughout.

To reset the Do not show checkboxes choose Preferences from the File menu and click the Settings tab.

SpecView starts-up much quicker than previous versions. Especially opening projects containing ActiveX controls.
SpecView's splash-screen has been simplified to make it more straightforward for the user, so that the more complex \texttt{Configurations Found} box is not the first box seen at start-up. The \texttt{Configurations Found} box is called \texttt{Projects} and can be accessed by clicking the \texttt{Select/Create Project} button.

Holding the \texttt{SHIFT} key down while clicking the \texttt{Start} button will go directly into \texttt{Edit Mode} with Live Features Offline (this is the same as SpecView Version 2.5).

Whereas, holding the \texttt{CTRL} key down while clicking the \texttt{Start} button will go directly into Edit Mode with all \texttt{Online Features} enabled.

This also applies to the \texttt{Go Online} button on the \texttt{Projects} box.

The splash-screen graphic can be an animated graphic (GIF) file.

Projects can be grouped together under a folder structure. This means project folders within a sub-folder will be listed in the Projects box and can be expanded by clicking the '+'.

This helps to keep projects organized in logical groups in the project list.

When doing a Restore, the folder to be used can be specified.

The Demo projects are now in their own folder.

To group projects together use Windows Explorer to create a new empty folder with the name of the group and move the related projects into that folder. When SpecView next runs they will be shown in their groups.
Auto Detection

As instruments are auto-detected there is now a prompt for the instrument’s name to allow instruments to be given meaningful names from the outset, rather than having to remember to go into the Variables List and rename them. This is important because if Online Features are enabled, logging will commence immediately the instrument is defined and the data will be logged under an incorrect name.

The Test Comms for Update button can be used to auto-detect instruments and add them to an existing project.
2.12 Preferences

The Preferences box now has multi-layered tabs and some additional features.

The **Auto Backup** tab specifies the backup interval (default 5 mins).

The **Display** tab has settings for **Remembering Window Positions**. This is to display screens (GDWs) at specific coordinates, which can be useful when using multiple monitors.

The **Logging** tab has a setting for the number of decimal places to be logged. This will affect all logged parameters.

The **Language** tab allows the language that SpecView is running in to be changed. This will not take effect until SpecView is exited and restarted.
2.13 Passwords - start at level 1

The Password system has the concept of a level that doesn't require a password. This means that users will be able to do limited actions without having to login.
2.14 Touch Screen Support

Touch screen support in Runtime Mode has been enhanced. However, touch-screens are not supported in Edit Mode.

Data entry boxes are now resizeable. Their size and position is remembered, which is particularly helpful when using a Touch Screen, as larger buttons are easier to use.

For more details see Passwords GDW Setup
Trend charts now have a popup menu that can be accessed from Runtime Mode using either the left or right mouse buttons, for compatibility with touch-screens which don't have a 'right' mouse button. In Edit Mode the popup menu is only available using the right mouse button. This because the left button selects the Trend Chart for moving and resizing.

On the Button & View tab on the Trend Chart Properties box there is the option to have the Setup button shown in the top-left corner of the Trend Chart. The Setup button is useful for touch screen users to be able to quickly and easily access the Trend Chart Properties box. The alternative method of opening this box is by choosing Setup Chart from the popup menu.

...
To assist in designing screens (GDWs) intended for use on screens of a different size the **Screen Size Guide** menu item on the **View** menu allows the actual screen size (in pixels) to be specified.

The **Show Screen Size Guide** menu item is used to display the guide.

There are other menu items to specify the color of the guide, etc.

- XXX has been replaced by specifics: N/R (No Response), NPV (Not Present Value), NCA (Not Currently Available), T/O (Timeout)

- Acknowledge Alarms button/strategy action

- The menu items on the **Setup->Database** sub-menu have moved to the **Internal Data** menu on the **Variables List**
• New **Math** functions:
  
  `<Number / Integer / Enum / Time>`
  
  ADD / SUBTRACT / MULTIPLY
  
  `<Number / Integer / Enum / Time>`
  
  put result in `<BOOL>`

  If the result of the math is 0, then bool will be off, if the result is non-zero, then bool will be on.

  This allows an Enumerated Alarm to be 'translated' into On/Off.

  *Note: The other Math types will all result in Bool being set to Off.*

### 2.16 32bit and 64bit SpecView

There are now both 32bit and 64bit versions of SpecView: **SV3.exe** and **SV3_64.exe**

There are benefits and limitations of both, for more details see [32-bit and 64-bit SpecView](#).

### 2.17 Backward Compatibility

**Compatibility between Version 2.5 and Version 3**
Existing SpecView dongles will work with Version 3, please refer to update policies.

A project created in Version 2.5 can be used in Version 3. An archive (SVA file) will be automatically created when it is opened in Edit Mode as a backup.

Trend charts will appear as before. However, changing the setup of the Trend Chart will automatically display this box:

Projects created in Version 3 will not work with SpecView Version 2.5.

Note: There is a way to make a Version 3 project work with Version 2.5, but please contact SpecView for details.

2.18 Update Policies

SpecView purchased prior to 1st Jan 2005
SpecView dongles created prior to this date can run builds of SpecView Version 2 (& 2.5) up to and including Build 845.
Users can upgrade to Version 3 as described below.
Or to run Version 2.5 Build 846 and above requires a Version 2 update. The cost includes the cost of changing from a parallel to a USB dongle, if required. Order Code: SV32-Upgrade/V2
NOTE: There are no plans for any further releases of SpecView Version 2.5.

SpecView purchased between 1st Jan 2005 and 31st Dec 2007
The price to upgrade to Version 3 includes the cost of changing from a parallel to a USB dongle, if required.

Order Code: **SV32-Upgrade/V3**

NOTE: The V3 upgrade will include 2 years of updates of Version 3, from the date of the first use of Version 3.

**SpecView purchased after 1st January 2008**

All copies of SpecView Version 2 (& 2.5) supplied after 1st January 2008, are "Version 3 ready”.

To check if your copy has Version 3, click the Help menu and then Registration Info.

Users will be able to download free updates for two years after the first use of Version 3.

**Dongle Exchange**

Users who wish to continue to use their existing version of SpecView but need to switch from a parallel dongle to a USB dongle can purchase a dongle exchange. Order Code: **SV32-Swap**

**Version 3 Update Subscription**

SpecView Version3 (full releases, not the Beta test pre-releases) will set the **Free Updates until** date to 1 or 2 years from the date it is first run. This is because SpecView Version 3 includes a free-update-subscription for 1 year for dongles purchased in 2008/2009/2010, or 2 years for dongles purchased in 2011/2012/2013.

When the update-subscription expires the software will continue to work, but it will not be possible to update the software to a newer version without purchasing an update renewal from a SpecView representative.

Please contact your SpecView representative for prices.

### 2.19 Bug Reporting Procedure

To report an issue with this release of SpecView please email bug reports to **V3bugs@specview.com** detailing:

<table>
<thead>
<tr>
<th>Name:</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Company Name:</td>
<td></td>
</tr>
<tr>
<td>Email:</td>
<td></td>
</tr>
<tr>
<td>SpecView Version &amp; Build number:</td>
<td></td>
</tr>
<tr>
<td>SpecView Dongle Serial Number:</td>
<td></td>
</tr>
<tr>
<td>Microsoft Windows Version:</td>
<td></td>
</tr>
<tr>
<td>Using SpecView 32bit or 64bit:</td>
<td></td>
</tr>
<tr>
<td>Error Message:</td>
<td>Was an error message displayed and if so what was it?</td>
</tr>
<tr>
<td>Reproducable:</td>
<td>Does the problem reoccur?</td>
</tr>
<tr>
<td>Configuration/Project Name:</td>
<td></td>
</tr>
<tr>
<td>Instruments:</td>
<td>Please give manufacturer, model(s), COM port(s) and address(es).</td>
</tr>
<tr>
<td>-------------</td>
<td>---------------------------------------------------------------</td>
</tr>
<tr>
<td>Runtime/Edit Mode:</td>
<td>Did the problem occur in Runtime or Edit Mode?</td>
</tr>
<tr>
<td>Crash:</td>
<td>Did it crash? If so, when &amp; what was the module and version that it crashed in?</td>
</tr>
<tr>
<td>Comments:</td>
<td>Please give full details of the problem, ideally with screenshots.</td>
</tr>
<tr>
<td>Priority:</td>
<td>High/Medium/Low</td>
</tr>
</tbody>
</table>

If a more serious problem occurs, such as a crash or hang, then please generate a dump file and send it to us.
Top Level Intro

This page is printed before a new top-level chapter starts
3 Release Notes

Details of the changes in each build:

Build 3.0.042 - 12th May 2015

Build 3.0.043 - 28th May 2015

3.1 Build 3.0.042

Release date: 12th May 2015

Fixes and improvements:

- Variables List: More precise positioning of variables that are dragged and dropped
- Trend Charts: Batch handling & JPG files
- Historical Replay by Batch number will now go to the correct GDW
- Timezones: Improved interpretation of logged data from other timezones
- Changes to what is displayed when a value isn't available over comms:
  - N/R - No Response (Meaning: Timeout)
  - NCA - Not Currently Available Value (Meaning: If the Segment Type is Time then the Target Setpoint may be NCA)
  - NYA - Not Yet Available Value (Meaning: If the value has been requested, but it hasn't arrived for the first time yet)
- Webvalues on the File-Preferences Web Server tab
- Support for the Watlow F4T

3.2 Build 3.0.043

Release date: 28th May 2015

Fixes and improvements:

- Variables List:
  - Speed improvements
  - The Parameter Attribute 'Apply to all similar items' when changing things in the 'L','A','S','R' columns is now OFF by default to avoid unintended setting of other parameters
  - Enhancements to multi-drag/drop 'vertical' to 'horizontal' flipping while using the 'Spread handles', including a better indication of when the flip might happen
  - When doing a multi-drag/drop while the 'grid' is disabled and then choosing 'Reset Spacing' could cause a lockup
• GDWs:
  o The 'Screen Size Guide' font color could be changed, but this was not being saved
  o Edit->Replace while 'Online with Live values' did not refresh the screen correctly to reflect the new variable associations
  o 'Remember Window Positions' used to require a dongle to be connected in order to work

• Trend Charts:
  o When using variables to define 'Pen Scales', this could revert to 'Auto-scaling' on occasion
  o Pen Scales from variables were not correctly using the backup fixed values in the case of the variables being unavailable over comms
  o Adding a Pen to a trend chart would also add similar items to Logging if the 'Apply to all similar items' checkbox in the Parameter properties has been enabled

• Historical Replay:
  o Bar charts did not operate in Historical Replay if they were not positioned near other items on the screen

• SpecView Networking:
  o SpecView Remote could occasionally crash just after loading a Project

• Project Import:
  o Importing one project into another would not correctly interpret unique addresses for non-Modbus instruments in the projects

• Drivers:
  o Generic Modbus: Used to have a Primary Parameter at Reg 0, and if this register was unreadable, the whole block would be shut down over TCP/IP
  o Honeywell HC900: Import of HCDesigner files left out information that allowed 'Labels' in SPS blocks to work correctly
  o Eurotherm 3500: New parameters added
  o Watlow StandardBus: Autodetecting these controllers would sometimes crash if scanning was stopped by the user before the scan was completed
Top Level Intro

This page is printed before a new top-level chapter starts
4 Installation and Starting SpecView

Ideally first physically connect the instrument(s) to the computer, although this can be done later if necessary.

Installation
Starting SpecView
Instrument Definition/Detection

4.1 Installation

Then install the SpecView software:

Installing SpecView
Updating SpecView from a previous version
Migrate Configurations
32bit and 64bit SpecView

4.1.1 Installing SpecView

If there are any doubts about the suitability of the computer for installation of SpecView, or if you are using Windows XP, please check the Minimum Requirements for Installing SpecView.

Firstly, it is necessary to have Administrator privileges on this computer before installing SpecView.

To install SpecView choose one of the following methods:

CD
If you have SpecView on a CD then load the CD into the drive. It should then automatically run Setup from the CD.
If the CD does not auto-run then choose ‘Computer’ from the Start Menu
Open the CD drive and double-click the icon.

**NOTE:** It is strongly recommended to install into the default location C:\SV3
However, running the Setup program again to install the same release will offer Repair/Modify/Remove:
(Modify is used to add or remove sub-options, such as drivers or demo projects. Repair can be used if an installed file has been accidentally deleted).
If the setup being run is a newer version (by build number), then the installer will run as an "Update Install", where the installer updates anything that's new in this build. However, it will not alter which sub-components are installed, it just updates whatever was installed originally to the new build code (including drivers, help files, etc.).

This type of install would be done if SpecView had previously been installed from SV3_SETUP_30041.EXE and a newer version, such as SV3_SETUP_30042.EXE was subsequently run.

Migrate_Configs would not be run automatically.

Download

Downloading SpecView from http://www.specview.com can be done either by downloading with or without the demo projects.

Demo Projects

There are a number of fully functional example projects pre-prepared for many of the instruments that we support. These projects can be easily installed, and may be modified to meet your exact requirements.

When installing from a CD, by default all the Demo Projects are installed. Run SpecView then at the first screen (Projects), select the one(s) that are required. Each Project is stored in its own sub-folder within the installation folder (which is by default C:\SV3). The sub-folder can be copied using Windows Explorer, therefore it is easy to make a backup of a project by making a copy of it, or by
using SpecView's Archive/Restore facility. These projects can, if required, be modified from Edit Mode.

When downloading the SpecView setup program from the SpecView website choose the one that contains the Demo projects or not as required.

Additional Demo projects may also be available for download from the SpecView website. In this case the downloaded file(s) will be .SVA file(s), which is a SpecView Archive. To use one of these downloaded .SVA files, install and run SpecView, then at the Projects screen, press the Restore button. Find the .SVA file you have downloaded and restore the project into SpecView. Once restored, these projects can, if required, be modified from Edit Mode. However modifications will only affect the restored Project folder, not the downloaded .SVA file, therefore the .SVA file can be considered as a backup which can be restored again if necessary.

You may see these Installation Warnings and Errors. If you have any difficulty during installation please contact your SpecView representative.

**Quick Start**
Starting SpecView

### 4.1.1 Installation Warnings and Errors

The M9934 message is for information only - When the update-subscription expires the software will continue to work, but it will not be possible to update the software to a newer version without purchasing an update renewal from a SpecView representative.
4.1.2 Updating SpecView from a previous version

The latest version of SpecView can be downloaded from our website http://www.specview.com

It is always advisable to have good reliable backups of the computer before updating any software.

Firstly, it is necessary to have Administrator privileges on this computer before installing/updating SpecView.

**Updating SpecView Version 2 or 2.5 to Version 3**

Before updating it may be necessary to purchase a Version 3 upgrade. To check if this is necessary use the About SpecView menu command on the Help menu. If Version 3 is listed then this dongle will work with Version 3. Also check that the free-updates expiry hasn't lapsed.
Otherwise these errors may be displayed:

**SV3 - InstallShield Wizard**

E9903: The InstallShield Wizard has detected that your dongle does not have the Version 3 Bit enabled and so you cannot run Version 3 with this dongle. Please contact SpecView for upgrade details.

© 1995 - 2015 SpecView
Install SpecView Version 3 into a separate folder - not into the same folder as Version 2/2.5 (which was by default: C:\SV32). We recommend installing into C:\SV3.

Existing SpecView Configurations (now called Projects) will continue to work in SpecView Version 3.

There is a Migration tool that will help with this process.

Once this is complete run SpecView Version 3 and it will be listed in the 'Projects Found' box.

When SpecView Version 3 is first run it will set the the Free Updates until date on the dongle to a date in the future.

**Trend Charts V2 to V3**

When a Version 2/2.5 trend chart is used with Version 3 it will not be automatically updated to incorporate the new features of Version 3 Trend Charts.

This needs to be done manually for each trend chart in the project.

For further information: Trend Chart Conversion

**Backward Compatibility**

A Project cannot however be copied from SpecView Version 3 back into SpecView Version 2.5 as there will have been significant changes to the format of the files and also with regard to Trend Charts.

For more information see What's New in Version 3

**Updating SpecView Version 3 to a newer build of Version 3**

Before updating it may be necessary to purchase an Update Subscription for the dongle. Check the Free Updates until date on the dongle. This can be seen from the About SpecView menu command on the Help menu.

To purchase an Update Subscription for the dongle contact a SpecView supplier/distributor or SpecView directly.

If an update subscription has been purchased, download the new SpecView Setup program to update existing installations. Install it in the same directory to overwrite and update the older SpecView files - this will not affect any projects or screens already defined. As always, it is highly recommended to make an Archive of the current project and data before installing the new version.

To update SpecView to a more recent version run SpecView's Setup program to start the InstallShield Wizard:
This will update the same components of SpecView as were installed initially. In order to add components (such as additional drivers) either run the original setup program and choose 'Modify' from the 'Modify/Repair/Remove' box. Or use the Windows Control Panel - Programs and Features, and right-click on 'SpecView' in the list and choose 'Change'.

4.1.3 Migrate Configurations

After installing SpecView Version 3 copy the existing Configuration(s), now called Projects, from Version 2/2.5 into Version 3 using the Migration tool to assist with this process. Or run the Migrate Configs tool manually if the installation was done previously.

Alternatively manually copy the Configuration's sub-folder from C:\SV32\ into C:\SV3\, or preferably, make an Archive of it in Version 2/2.5 and Restore it into Version 3.

Also, for existing SpecView users see What's New In Version 3
When SpecView's Setup program is run to install SpecView there are 3 ways it can be run:

1) Clean Install - When there is NO previous version installed, or if the last version was deliberately uninstalled. Migrate_Configs would be run in this case.

2) Modify/Repair/Remove - If re-running the SAME Setup as before (by build number), 'Modify' is used to add or remove sub-options, such as drivers or demo projects. 'Repair' can be used if an installed file has been accidentally deleted. Migrate_Configs is NOT run.

3) Update Install - If the setup being run is a newer version (by build number), where the installer updates anything that's new in this build. However, it will not alter which sub-components are installed, it just updates whatever was installed originally to the new build code (including drivers, help files, etc.). Migrate_Configs is NOT run.

There is a command line option (/z2) to SpecView's Setup program that will force Migrate Configs to be run. 
Note: This MUST be a lower case z and cannot be used with other command line options.

4.1.4 32bit and 64bit SpecView

There are both 32-bit and 64-bit versions of SpecView: SV3.exe and SV3_64.exe

If your computer is running a 32-bit version of Windows then use the 32-bit version of SpecView.

Or, if your computer is running a 64-bit version of Windows then use the 64-bit version of SpecView. However, the exception to this is if you are on a 64-bit system but intending to use 32-bit ActiveX controls or a 32-bit OPC Server with SpecView, then use the 32-bit version of SpecView.

The 64-bit version is slightly faster than the 32-bit.

SpecView Projects can be used in either version, with the exception of projects containing ActiveX controls, as mentioned above.

64-bit DMP files are preferable for debugging purposes when reporting bugs.

Note: OPC and ActiveX-Control restrictions should be noted i.e. it is not allowed to use projects built in 32-bit and 64-bit and vice-versa.

4.2 Starting SpecView

Double-Click the SpecView Icon to start the program, or run from 'All Programs' on the Start menu.
If you do not have a SpecView copy protection key (called a dongle) connected then it will only Demo or Remote will offered:

Click the Demo button, SpecView will be fully functional in Demo mode but a timer limits communication with the instruments to ten minutes. This timer is reset each time Runtime Mode is entered.

When SpecView starts up it displays a splash screen containing the logo and the Copyright.

Either click Start to go directly to Runtime, or click the Select/Create Project button to display the
Projects box (shown below).
Holding the SHIFT-key down while clicking **Start** will go into **Edit Mode (Online)**. Holding the CTRL-key down goes into **Edit Mode (offline)**.

The **Refresh** button on this box allows for the list to be refreshed to take into account any new projects that might have been manually created after SpecView has been started.

The **Archive/Restore** buttons allow you to **Archive or Restore** entire projects.

If you have an existing Project, which may be a demo project installed as part of SpecView, or previously **Restored**, which you intend to run, then select it and click the **Go Online** button, and continue from **Runtime Mode - Using SpecView**.
Note that it is possible to do a shortcut directly into **Edit Mode (online)** by holding the SHIFT-key while clicking the **Go Online** button. Holding the CTRL-key down goes into **Edit Mode (offline)**.

Alternatively, clicking either **Test Comms for New Project** or **New Manual Project** will display the Input Required box:

Enter a name for the project. SpecView will create a sub-folder with this name in the SpecView folder (which is normally C:\SV3), the name you enter should follow the **Windows file naming rules** and should not be too long.

Remember this name. This folder will be where all your log files and project files will be stored. Log Reports will also be stored here unless another folder is specified.

Then continue from **Instrument Definition/Detection**.
4.2.1 Archive and Restore

To access the Archive and Restore buttons click 'Select/Create Project' on the Splash Screen when SpecView starts:

The Archive and Restore buttons allow you to Archive or Restore entire projects. This can be used for backup purposes, for sending projects from one computer to another, or for technical support purposes. Please see the Warning below.

Archive
SpecView creates a file known as a SpecView Archive, which has a filename extension of .SVA.

To create an Archive, exit from SpecView and run it again, then at the Projects Found screen, select the name of the project to be archived and click the Archive button.

The default place (disk and folder) to create the Archive is specified in Preferences - Runtime. Use the Browse button to specify a different location. If removable media (for example a memory stick) is specified (E:\) and the project is too large to fit onto it, then the Archive process will automatically prompt for the additional media. Please ensure that you have a media ready for use.

The checkboxes have the following operation:
- Include log files - This will include the log files into the Archive (.SVA) file. Uncheck this if you just want to archive the project without also backing up the log files. However, if the log files are being written to another folder (which is specified by, for example: 'Path=C:\MyLogFiles\' in Settings.ini) then these will NOT be archived even if the Include log files checkbox is checked.
- Exclude files older than (days) - This will exclude log files which are older than the number of days specified. Therefore entering 7 would exclude log files from the Archive that were more than a week old.
- Include Subfolders - This will include the contents of any subfolders within the project's folder.
- Include SpecView backups - This will include the backups that SpecView automatically makes of the CONFIG files when these files have been changed while in Edit mode. These backups are named: CONFIG.CF!, CONFIG.CF!1, CONFIG.CF!2, etc. And: CONFIG.CD!, CONFIG.CD!1, CONFIG.CD!2, etc.

Restore
To Restore a SpecView Archive (.SVA) file, start SpecView, then at the Projects Found screen click the Restore button.
Use the **Browse** button to locate the .SVA file to be restored. If the file is on removable media then the Restore process will automatically prompt for them.

**NOTE:** If the project to be restored contains ActiveX controls then it is necessary to be running **SpecView as an Administrator** so that the **ActiveX controls** can be registered correctly.

The **Include Subfolders** checkbox will include the contents of any subfolders within the project's folder.

**NOTE:** For archives which are on **removable media** the restore process will request the last disk of the set to be inserted first, then it will ask for the disks to be inserted in sequence. This is because certain information is written to the last disk during the Archive process, which must be read at the beginning of the Restore process. If the Archive only uses a single disk then ensure it is inserted and just click **OK**.
Once restored, a Project can, if required, be modified from Edit Mode. However modifications will only affect the restored Project folder, not the archived .SVA file, therefore the .SVA file can be considered as a backup.

**WARNING:**

If an Archive of a Project is to be copied onto another computer, in order for changes to be made to it & then to be subsequently Restored back onto the original computer, then **CAUTION** must be observed to avoid losing logged data, this is detailed in Restore - Overwrite Project Warning.

### 4.2.2 Restore - Overwrite Project Warning
If an Archive of a Project is to be copied onto another computer, in order for changes to be made to it & then to be subsequently Restored back onto the original computer, then **CAUTION** must be observed to avoid losing logged data:

There are a number of checks that are performed by SpecView before the Restore is allowed, such as:
- If the **log files** have the same name then they cannot have different sizes or date/times
- The variables are checked to make sure that there are no data type differences e.g. float and text for the same unique id would be rejected
- Instrument types are the same e.g. not allowed to overwrite a MM8TC with a MM4RO, etc.
- A Restore is only allowed to a project if there is at least one defined instrument of the same type, for example, at least one MM8TC

If you get this error then it means that the Archive file contains Log files which conflict with the ones in the existing project. To resolve this Restore the project without the 'Include log files' checked. Or alternatively Restore specifying a new name for the project.

### 4.2.3 SpecView Command Line Options

The following command line options are available:

- **-r <connection name>**
  The connection description is the name listed in the 'Connect To' box. This will cause SpecView to run up in **Remote** mode and go online to the **connection name** specified.

  It can be setup so that SpecView Remote will **start automatically** when the computer is started. Or configure a button on a GDW which will run another copy of SpecView in Remote mode. (By using the button action **Run External Program** and specifying, for example: `C:\SV3\SV3.EXE -r FactoryZone1`) In this case the Remote copy of SpecView will start up minimized by default, if this is a problem then see [here](#).

- **<file name>.sva**
  This will cause SpecView to run up and go to the **Restore** dialog with the .sva file specified.

- **<file name>.gdw**
This will cause SpecView to run up and go online to the project in which the GDW is located.

Launching SpecView by clicking on a .GDW file in Windows Explorer can cause the error:
   You cannot use GDW 'file name goes here' from this location,
   press Yes for details on how to resolve this problem.
if there is more than one installation of SpecView on this PC. This is because the Windows Add/Remove
programs in the Control Panel can only keep track of one installation.

If there is more than one SpecView installed (either by specifically installing into another folder, or by
copying SpecView's installation folder to another location) then it is possible that the GDW which is
being clicked on is not in a project sub-folder of the folder where the Windows registry currently believes
SpecView is installed.

To find all the locations that SpecView is installed, use the Windows search facility to search for all files
named SV3.EXE.

\textit{NOTE: When SpecView is being started by any of these three means, the startup
boxes will be displayed but will automatically be actioned by SpecView as it goes
through its startup sequence. Therefore it is not necessary to click on these boxes.}

### 4.3 Instrument Definition/Detection

Conventional supervisory systems require you to define each of the instrument's parameters (or
variables) that you want to access from your computer. Some instruments have hundreds of
parameters. In larger systems this can mean tens of thousands of tags and defining these from scratch
could take weeks.

SpecView has a built in database containing information on a very wide range of different instruments
and their associated parameters (also known as tags).

Special configuration tools are used by SpecView's engineers to define the database. These are
available, for some drivers only, to qualified users and only then in certain circumstances. It is not
possible to add variables to pre-defined instruments from within SpecView. The configuration tools are
required to do this. For further information on the above please contact your SpecView representative.

The following sections describe in more detail how to setup SpecView to communicate with the
instrument(s) either that you have currently connected by \textit{Auto Instrument Detection} or which you intend
to connect by \textit{Manually Defining Instruments}. However, if you have already successfully done this then
go to \textit{Runtime Mode - Using SpecView}.

The Honeywell HC900 is a special case because the HC Designer files can be imported.
4.3.1 Automatic Instrument Detection

What does ‘Automatic Instrument Detection’ mean?

Many instruments have an instrument identity code that SpecView requests. When the instrument responds SpecView uses its built-in database to create an Instrument View (or faceplate representation) with button(s) that give access to all the parameters on that instrument.

Some instruments, such as multi-loop controllers, have a very large number of parameters, in that case the parameters are split into parts, for example into the 'programmer' and the 'loops' (or 'channels'). So one controller can have many Instrument Views within SpecView.

Note that Auto Instrument Detection is inappropriate in the following cases:
- If there is a type of instrument connected that cannot be auto detected, for example, Red Lion, Dupline and Omron
  In this case please read Manually Defining Instruments
- If there are additional instrument(s) connected which need to be added to an existing Project
  In this case please read Test Comms for Update

For Auto Instrument Detection click the Test Comms for New Project button, to detect the instruments automatically.

The Input Required box is displayed.

![Input Required dialog box](image)

Enter a name for the project. SpecView will create a sub-folder with this name in the SpecView folder (which is normally C: \SV3), the name should follow the Windows file naming rules and should not be too long.

Remember this name. This sub-folder will be where all the log files and project files will be stored. Log Reports will also be stored here unless another folder is specified for the report.

When the name for the project has been entered, click OK, the Ports and Protocols box will be displayed.
Baud Rate

If the BAUD rate is known then set it appropriately.
If it is left as ‘Auto’ SpecView will first test different BAUD rates (9600 BAUD, then 19,200 BAUD etc.) for each address for the selected protocol.
If there is any uncertainty as to the BAUD rate used by the instrument then leave it set to the default shown.

Either select the protocol required for the COM port or use TCP/IP Auto Detection which is available for some types of instrument.

Auto Build GDW View (checkbox)

When this box is checked an Instrument View is created automatically for each instrument found.
Do NOT use this feature if:
- There are more instruments connected than can fit on one screen
- There is an intention to rename the instruments in the project.
Instead:
- Let SpecView detect the instruments
- After scanning all ports click Stop which will go into Edit Mode

- Open the Variables List tool
- Rename each instrument if necessary, and add Instrument Views to the GDW(s) as required
Once the above has been set then click to automatically detect instruments.

If the **Prompt For Instrument Name As Found** box is checked then this box will be displayed:

![Prompt For Instrument Name As Found](image)

This allows instruments to be given names as they are detected and the number of decimal places for the parameters of that instrument defined. The instruments can also be assigned to groups, for example, a number of controllers may make up a furnace, so grouping them together under the furnace name makes a logical group.

Once there is an Instrument View (or faceplate representation) displayed on the GDW for each of the instruments which are connected. These are some examples:

![Instrument Views](image)

Then stop the automatic scanning by clicking the **Stop** button. Or if there are instruments on other COM ports then click the **Skip to Next Port** button to continue scanning on the next COM port.

![Scan Confirmation](image)

To scan for additional instruments of different types that are connected click 'Cancel' to re-scan:
There is also auto detection for TCP/IP.

If there are any problems then first check the wiring and instrument setup.

Once the instruments are detected then the next stage is to setup the screen(s) with Trend Charts, Bar charts, Buttons, Bitmaps and other graphics.

4.3.2 TCP/IP Auto Detection

TCP/IP Auto Detection for instruments connected via TCP/IP works only with Instruments supporting Modbus/TCP, either natively or via an Ethernet Bridge.

Native instruments are:
- ModMux MMTCP-xxx range
- Honeywell HC900
- Honeywell TrendView Recorder
- Eurotherm Chessell 5000 recorder

Ethernet Bridges allow any Modbus RTU device to be communicated with by Modbus TCP/IP. Some examples of these Bridges are:
- ModMux TCPCONV
- Lantronix CoBox
- Honeywell Ethernet bridge

The Modbus protocol specifies a 'Slave Address', for RS422/485 devices, this is the address of the instrument over comms. For Modbus/TCP, the slave address is still relevant in the following cases:

For native instruments, there is only one slave address per IP Address because there is only one instrument. In this case the 'Slave Address' is usually 1.

For Bridge connected instruments, there can be up to 255 discrete Modbus Slaves connected through the one IP addressed bridge, so the Slave Address has the usual meaning.

In SpecView’s Auto detect setup we can specify a start and end IP Address. SpecView will start at the beginning IP Address and scan Slave addresses 1 to 255 on that IP address before moving to the next IP address.

In the case where each IP address is a native Modbus/TCP instrument this scanning can be unnecessary, as there is only ever one Slave Address to be found. In this case the Skip to Next IP button can be used in a similar way to the existing Skip to Next Port button.

It is useful to think of each IP Address as a separate COM port. Where it is clear that there is only one instrument attached to a port then looking for 254 more instruments is not required.
Firstly, if all the instruments to be auto detected are accessible via TCP/IP then set the Protocol for all the COM ports to <None>.

**Protocol:**
Select the relevant protocol for one of the instruments to be detected.

**Port:**
The 'port' field should be left as 502 unless there is a specific reason to change it. Port 502 is the standard Modbus TCP/IP port.

**Timeout:**
Due to limitations inside the Modbus TCP/IP protocol and the Internet in general, scanning for Slave Addresses on a single IP Address can take a long time. The 'Timeout' field is used to control this. For a LAN, the default of 5 seconds is suggested, meaning that one slave address per 5 seconds is tested. For testing across the Internet, a higher value is recommended, such as 25 seconds.

**Begin: and End:**
This allows you to specify a range of IP addresses; this allows all the addresses in the range to be scanned for instruments, or if indeed the precise address is not known.
The Ending IP Address is set to the same as the start address by default, this allows for quick scanning of a single IP addressed native instrument or a string on a single bridge.

The Honeywell HC900 Auto detect is pre-set as there can only be one Slave Address on any given IP Address, so it will always skip to the next IP Address (if any) when an HC900 is found.

Click

Then for each instrument found this box is displayed:

![New Instrument Name for MMTCPSTC TCP/IP Addr:1](image)

This allows the name for each instrument to be assigned (or use the default names), specify the decimal places and if required assign to a group.

Once the instrument view(s) have been displayed on the GDW (which may be behind the Ports and Protocols box) then click Stop. The following dialog will be displayed:

![SpecView -](image)

To finish scanning for instruments click OK. To scan for more instruments click Cancel.

Once this process is complete Auto detect cannot be used to add further TCP/IP instruments to this project. It is necessary to either add additional instruments manually. Or if the auto detect scanning is required (to confirm the exact address for the instrument(s)), then create a new project and auto detect them.

Then using the Variables List tool select the name of the instrument you have just detected and then click Properties. The address field will show the exact address to use to manually
add that instrument to a pre-existing project.

4.3.3 Manually Defining Instruments

Instruments will need to be defined manually if they:
1. Are not physically connected to the computer for auto detection
2. Are a special instrument that cannot be auto detected, for example, Red Lion, Dupline and Omron
3. Modular instruments where SpecView isn't able to automatically detect all the modules in the instrument

After starting SpecView click Select/Create Project, then click New Manual Project on the Projects box. This will go directly into Edit Mode.

Then see Templates List for the steps to define a new instrument.

For more information on Modbus instruments read Modbus instrument addressing

If this is the first occurrence of an instrument being assigned to this COM port then the Port Settings box will be displayed. Typically, just clicking OK on this box will be sufficient, unless the instrument is using non-standard settings, in which case please read Port Settings.

Some instruments in SpecView are made up of more than one Instrument View. This is done when an instrument has a large number of parameters. In this case the parameters for the instrument are split into logical groups, for example, Programmer & Controller, which are assigned the same instrument address. Each logical group has its own Instrument View.

Typically when an instrument is AutoDetected all the required Instrument Views for it are detected & automatically added to both the screen & the Variables List. However, for some modular instruments it isn't possible for SpecView to automatically detect all the modules in the instrument, so they will need to be added manually, as described above. If in doubt at this stage please contact a SpecView representative.

This is now configured as if the instrument was connected and the instruments had been automatically detected by clicking the Test Comms for New Project button.

Now add the Instrument View or individual numeric values to the GDW

Precautions Deleting and Creating Instruments
When an Instrument is defined in SpecView it is given a unique identity code (Unique ID) When any variable from that Instrument is used, SpecView identifies it by the Unique ID, NOT by name.

**NOTE: If an Instrument is deleted IT IS GONE FOREVER. All variables from that Instrument on GDW's, in Logging, on Trends will no longer be updated.**

Defining another instrument with the same name is NOT regarded by SpecView as the same Instrument, Be Careful.

Adding Instruments to the Database
Special configuration tools are used by SpecView's engineers to define the database. These are
available, for some drivers only, to qualified users and only then in certain circumstances. It is not possible to add variables to pre-defined instruments from within SpecView. The configuration tools are required to do this.

SpecView has a generic driver for the Modbus protocol which can be used to communicate with Modbus instruments which SpecView doesn't as yet support. This can also be used for Modbus PLCs.

For further information on the above please contact a SpecView representative.

Now go straight to Edit Mode.

4.3.4 COM Port Settings

When an instrument is being manually defined it is assigned to a COM port, Baud rate and data bits/parity/stop bits.

To change these settings afterwards:
- During Edit mode using the Setup COM Ports menu command on the Setup menu.
- Or during Runtime mode using the Setup COM Ports menu command on the Options menu, shown below:

![COM Port Setup](image)

**Baud Rate**
If the BAUD rate is known then set it appropriately.
If there is any uncertainty as to the BAUD rate used by the instrument then leave it set to the default
shown.

**Parity**
The Driver settings will be the factory defaults for the selected protocol.
If your instrument is set to other than factory defaults, specify the Data bits, Parity and Stop Bits you need.
For further details click the Variables List tool, select the instrument's name and click Properties, then click Address Help.

This box also allows Driver Commands to be set. In this example ‘T=5’ means that the timeout for reading a value over comms is set to 5 tenths of a second, ‘R=1’ means that it will retry once.
There are many other Driver Commands, such as setting DEBUG levels, but these are best discussed with a SpecView Representative.

### 4.3.5 Test Comms For Update

To auto-detect additional instruments to add to an existing project use Test Comms for Update.

This will find any additional instrumentation that has been connected since the original project was created and add the instrument definitions to the Variables List.

It searches for all instruments connected then compares this information with what is already defined in the project and will warn of any conflicts, such as where instrument types have changed at a given address.
4.3.6 Add/Rename Instruments

This box is used to add a new Instrument View to a GDW OR To change the name, and/or COM port, and/or address of an instrument

To add a new a new Instrument View to a GDW:

See Templates List for the steps to define a new instrument.

Open the Variables List by clicking on the toolbar, then
• Double-Click an instrument name in the Variables List OR
• Single Click an instrument name and click Properties OR
• Right Click an instrument name in the Variables List

NOTE: The names of existing Instrument Views will NOT be changed. To get an Instrument View with the new name, click Add to GDW and delete the existing Instrument View on the GDW by selecting it and pressing the Delete key. Do NOT click the Delete button on the 'Add/Rename Instrument' box.
Decimal Places
Some protocols (examples include Modbus, Red Lion and Yokogawa Green Series) do not provide the computer with information about decimal places. Therefore when SpecView auto-detects instruments it will assume NO decimal places for Modbus and Red Lion, and ONE decimal place for Yokogawa Green series.

Some instrument values are known by SpecView to require a decimal place and this will be added automatically. Other instrument values MAY need one or more decimal places depending on how the instrument is configured. These values take their decimal place requirements from the Decimal Places field on this box.

When you start SpecView, if the reading is ten or a hundred times too big/small (for example, 123.4 instead of 1234), then you will need to change the Decimal Places.

To change the decimal places for a specific variable on a GDW use the Dynamic Attributes menu command.

Name (of Instrument)
Names can be any length and include spaces and special characters (# : ; * etc.)

*NOTE: Do not make them too long. That will make list boxes very wide.*

Port
Select the communications port (COM1 to COM9) that this instrument is (to be) connected to. However, if the instrument(s) are connected to a COM port which has a number above 9 then it will be necessary to set MaxPorts.

Address
Type in the address for this instrument. Click Address Help if you are not sure.

Add to GDW
Click this button to add an Instrument View to the GDW. Any changes to Name, Address or COM Port are also saved.

Help for Instrument / Address
Help for your instrument(s) may be included if provided by the instrument manufacturer. Address Help will detail how to define the address SpecView uses to communicate with this instrument.

Rename Only
Saves any changes made to Name, Address or COM Port without adding a new Instrument View to the GDW.

Delete Instrument

*NOTE: Please read Precautions Deleting Creating Instruments under Manually Defining Instruments before deleting instruments*

Clicking this button will delete the Instrument.

To continue with Editing go to Editing Projects
If you have the project the way you want it go to Runtime Mode - Using SpecView
4.3.7 **For Instruments using the Modbus Protocol**

If the instrument you are using uses the Modbus protocol then you will need to know how the instrument is configured.

**For instruments using Serial Comms:**

When setting up the instrument itself:
- If there is a choice between Modbus or J-Bus protocol then choose J-BUS
- If there is a choice for Data Bits choose 8 (EIGHT)
- If there is a choice for Parity choose NONE
- If there is a choice for Stop Bits choose 1 (ONE)

Then in SpecView use the 'Add/Rename Instrument' box to reflect the instrument's own settings:

On the 'Parity' drop-down, ideally leave it as 'Driver' to use the driver defaults of '8N1', otherwise choose accordingly:
The meanings are listed below:

<table>
<thead>
<tr>
<th>Data bits</th>
<th>Parity</th>
<th>Stop Bits</th>
</tr>
</thead>
<tbody>
<tr>
<td>7E1</td>
<td>7</td>
<td>Even</td>
</tr>
<tr>
<td>7E2</td>
<td>7</td>
<td>Even</td>
</tr>
<tr>
<td>7N1</td>
<td>7</td>
<td>None</td>
</tr>
<tr>
<td>7O1</td>
<td>7</td>
<td>Odd</td>
</tr>
<tr>
<td>7O2</td>
<td>7</td>
<td>Odd</td>
</tr>
<tr>
<td>8E1</td>
<td>8</td>
<td>Even</td>
</tr>
<tr>
<td>8E2</td>
<td>8</td>
<td>Even</td>
</tr>
<tr>
<td>8N1</td>
<td>8</td>
<td>None</td>
</tr>
<tr>
<td>8N2</td>
<td>8</td>
<td>None</td>
</tr>
<tr>
<td>8O1</td>
<td>8</td>
<td>Odd</td>
</tr>
<tr>
<td>8O2</td>
<td>8</td>
<td>Odd</td>
</tr>
</tbody>
</table>

To define a Modbus instrument in SpecView:

**Slave Address:**
The two-digit address of the instrument in decimal.

**Decimal places:**
The number of decimal places for user defined items 0 / 1 / 2 / 3 SpecView will put a decimal place in the position indicated by this setting. The setting affects those variables where the number of decimals required is based on an instrument setting such as the range that has been selected. Some items, such as Output Power are fixed at a given number of decimal places and are not affected by this setting.

SpecView's Instrument Auto-Detection may assume 0 decimal places when detecting instruments. This might result in values being 10 or 100 times too large on displays.

**Offset:**
Some instrument companies (of, for example, multi-loop controllers) use an address structure so that a particular loop can be accessed with the appropriate address offset. This feature is also used with SpecView's 'Generic Modbus' instrument views. The addresses for each instance of the instrument are the same, offset by a fixed number. See Generic Modbus for more details. Also, where this feature is required for a specific instrument, refer to the help for that instrument.
Extra:
Leave this field blank unless otherwise directed by your SpecView representative.

For Instruments using Modbus TCP/IP

To specify a Modbus TCP instrument choose 'TCP/IP' from the COM port drop-down list and enter the IP address or hostname into the box:

Port:
The port is by default 502, only change this if absolutely necessary.

For Slave Address, Decimal Places, Offset and Extra see above.

Also ensure the instrument variables are using the correct scaling.

4.3.8 Using a BarCode Scanner with SpecView

A BarCode scanner is another way of entering alphanumeric data into a computer. A common question which is asked is: "Can SpecView do something such as download a recipe, start the process, check process parameters etc?"

All of these are possible providing the sequence of events can be broken down to simple 'If – Then'
Consider the example of downloading a recipe based on a barcode. If there are only a limited set of possible BarCodes, then having an event for each possible BarCode is reasonable. The Strategy Controller would be set up as:

Event: BarCode = ABCDEFGH  Action: Recipe: Download Specific Recipe: 'Blue Widgets'

However, it is probable that there are a far too many combinations to do a direct mapping; therefore a part of the BarCode can be extracted using SpecView's Math Function to get the relevant characters.

Using the Math Function 'divide' operator on a text variable works as a 'Mid' function, so the characters from the 'x'th position onward are taken, until the end of the text (where the first character is 0).

For example, the fourth character of the barcode might identify the recipe to be used for this process.

Therefore, to extract 'D' from 'ABCDEFGH' use divide by 3 giving 'DEFGH' and subtract 1 to give 'D'.

The Strategy Controller is now simplified to:

Event: BarCode = D  Action: Recipe: Download Specific Recipe: 'Blue Widgets'

How do I use a BarCode Scanner with SpecView?

There are two ways to communicate with a BarCode scanner from SpecView:

1. **By connecting the BarCode scanner interface to a Serial port:**
   SpecView will read from the Serial port and the sequence of characters is then seen in SpecView as a Text Variable.

2. **In series with a keyboard, sometimes called a 'keyboard wedge':**
   This method allows the BarCode Scanner to act exactly like a keyboard. The user must make sure that SpecView is ready to accept keyboard entry. This can be done by touching the variable or it can be linked to a button.

For example, the operator touches a button marked 'Ready to Start'. This turns on a SpecView Boolean which is watched by the Strategy Controller. The actions:

- **GDW Control: Swap to another GDW**
- **Parameters: Alter Value Interactively**

set SpecView ready to receive keyboard or BarCode input.

**Method 1** above is generally preferred as it can be used with no operator action. For method 1 the BarCode scanner interface reads from the Serial port until a <CR> is received, and then passes that into SpecView as a Text Variable SpecView does not transmit anything; it just accepts characters from the Serial port and stores them into the Text variable when a <CR> is received. The Strategy controller can be set to watch for any change in the text and then execute the required actions.

**Setting up SpecView with a serial port BarCode scanner**

To use a BarCode scanner the 'Generic BarCode' Driver must be enabled on the dongle.
From Edit Mode open the Templates List and find 'Generic BarCode' and create a 'Generic BarCode Scanner'. Enter the correct COM port that it is connected to. However, any address can be used, such as '0'.

The reason the address is not significant is because it is only possible to connect a single BarCode scanner to a given COM port. If further instruments are required then SpecView's Multiport option will need to be enabled on the dongle.

The 'BarCode' parameter of that instrument will display the last sequence of characters sent from the COM port with a <CR> after it.

There is NO specific action for a bad-read within SpecView. Some scanners will return the text 'BAD READ' but SpecView will assume that any text terminated with a <CR> is valid.

The case of a timeout will need to be handled appropriately, as there might be an issue with timeout when the text goes back to N/R.

Consider these two different scenarios (A and B below):

A) If the BarCodes are guaranteed to be different each time, because they represent a serial number. Then it would be best if the last BarCode received were shown on the screen without going to N/R after a timeout period.

Therefore, it is necessary to use a high value for the timeout, such as T=10000 (using 'Setup COM Port' from the Options menu) and TTL=10000 (Time To Live) to keep the last value on the screen. Also put the 'raw' value on the screen and use Edit->Dynamic Attributes to change the Scan Rate of the value on the screen to Ultra-High (or at least faster than the barcode is likely to change):
If the BarCodes could repeat themselves and be the same twice in a row (such as when there are two of the same product at a supermarket checkout). Then keeping the BarCode on the screen for a long time means that the operator cannot tell the difference between the first item and the second.

In this case the value of T should be short enough so that the values go to N/R between readings, either because they are being counted, or because an event is being triggered (such as a recipe download) on every BarCode scanned.

In the case of (B), the Strategy Controller could be used to capture the last known value of the BarCode and store it in a SpecView Text User Variable, in order to retain it on the screen for the operator's reference.

### 4.3.9 Honeywell HC900

There are some features specific to the Honeywell HC900:

- Honeywell HC900 HCDesigner Import
- Honeywell HC900 Redundant Controller
- Honeywell HC900 SPP Block’s current running profile and descriptor

#### 4.3.9.1 HC900 HCDesigner import of Modbus maps

SpecView can import the modbus map file from HCDesigner to define all the blocks and tags from the HC900 into the SpecView Variables list.

There are two types of HCDesigner Modbus Maps for the HC900: 'Fixed Modbus Map' and 'Custom Modbus Map'. SpecView can import both types.

If using a Fixed Modbus Map, then the Control Loops 1-32 are will be imported in full and represented in SpecView by a 'Loop' Instrument View. This also applies to the SPP blocks 1-8.

For a Custom Map which is based on a Fixed Map then, again, Control Loops 1-32 are imported in full...
(as are SPPs 1-8).

For additional Control Loops, the necessary parameters need to be placed in a custom Modbus map partition in HCDesigner. To retain full use of the SpecView Instrument View features it is necessary to include the parameters needed to support the PID interface to the HC900. You may use ‘Select All’ when adding parameters for Modbus addresses to the partition. This adds all of the PID parameters to the map. You may also use the Loops Template (Vista_PID.ptf) provided with HCDesigner but need to also include the 'LSP1' parameter for the local set point. See section below on importing custom loops from HC Designer.

If all parameters listed for the Loop are not included, then the loop will still have the Instrument View associated with it, but those parameters not included will simply not work on the Instrument View.

For additional custom SPP blocks (numbered 9 and above), only the minimal SpecView Instrument View, which just has a single Parameter button is used. Clicking on this Parameter button allows access to all the parameters of the given block.

This minimal Instrument View is also used for all other HC900 parts (not Loops and SPPs 1-8).

The steps required to do it
Including a Tag Number as part of the name and help on naming conventions between HCDesigner & SpecView
Importing Custom Loops
Notes on updating an HC900 using this import facility

4.3.9.2 HC900 HCDesigner import: The steps required to do it

It is possible to add either a new HC900 instrument into SpecView, or update an existing HC900 instrument (if, for example, changes have been made to the HCDesigner file). See later in this section for important details about what can be updated.

SpecView can import both types of Modbus Maps ('Fixed Modbus Map' and 'Custom Modbus Map') from HCDesigner.

The following screen shots were taken from HCDesigner V 4.2, later versions may have slight differences.

To Export the Fixed modbus map:

In HCDesigner, go to File->Export Report, then click on the 'FBDs' button to drop down a small menu. Choose 'All Modbus Registers' from this menu:
To Export the Custom modbus map:

In HCDesigner, go to File->Export Report, then click on the 'FBDs' button to drop down a small menu. Choose 'All Modbus Partitions' from this menu:

Choose a specific partition if just those blocks are being added to an existing project, or if one part of a project is being updated, SpecView can import either.

How to import the modbus map:

If the HC900 is being auto-detected using:

and if an HC900 is found, then the box shown below will be displayed to request the file name of the HCDesigner Modbus Map for each HC900 that is auto-detected:
For manually adding an HC900 or updating one in an existing SpecView Project, then this is done from Edit mode in the existing project.

To do this, use the HC900 menu on the menubar in SpecView – if this menu is not present, then the HC900 protocol option is not enabled in the dongle, please contact a SpecView representative for this option.

Choose 'Import HCDesigner File', the following box will be shown:
Choose 'Add as new HC900' to add this file to SpecView as a totally new Instrument, or Choose 'Update existing HC900' if this file is an update to an HC900 previously imported. (See section below on importing)

Type in, or Browse for, the name of the file to import

Select an optional Prefix for the instruments in the 'Prefix Section'. Using a prefix can help if there is more than one HC900, either now or in the future.
- **Use Name in file** will use the Controller name given in the HCDesigner file for this HC900 configuration as the prefix for all the SpecView instruments. For example, this could give the names: FURNACE1-PIDZONE1 or FURNACE1-Variables.
- **None** will add no prefix to the instruments, resulting in names like PIDZONE1 or Variables.
- **Use** will use the prefix supplied. For example, if the prefix was 'F1', then all the instruments will have that prefix (a hyphen will be added automatically): F1-PIDZONE1 or F1-Variables.

Choose the Byte Format for the instrument using the options given, this cannot be changed later.

The available Byte Formats are:
- FP_B (Big Endian: 4,3,2,1)
- FP_LB (Little Endian Byte Swap: 2,1,4,3)

**Note that SpecView does not currently support the byte formats:**
- FP_BB (Big Endian Byte Swap: 3,4,1,2)
- FP_L (Little Endian: 1,2,3,4)

For more information on byte ordering please refer to the Help in HCDesigner.

If the **Create Instrument Views on screen** box is checked, then the SpecView standard Instrument Views will be created after Import for all new blocks.

The **Include Variable/Tag Number as part of name** checkbox determines whether or not to add the Tag Number to the beginning of the name in SpecView’s Variables List. See: Including a Tag Number as
part of the name.

Note that SpecView uses the Short Name by default on Trend Charts, which is why it is important to know how the Short Name has been determined.

Press the OK button to start the import process. This could take a few minutes.

If there are any problems with the import or the update, then email an Archive of the project, plus the Modbus Map file that was used to SpecView.

4.3.9.3 HC900 HCDesigner import: Including a Tag Number as part of the name

The 'Include Variable/Tag Number as part of name' checkbox determines whether or not to add the Tag number to the beginning of the name in SpecView.

This checkbox is on by default, but there are situations when it is better to leave it unchecked. An example of this is when some Tags refer to a 'logical entity' in the HC900 and other Tags to another 'logical entity'.

For instance:

- Tag 15: SP for Furnace 1
- Tag 16: OP for Furnace 1
- Tag 17: SP for Furnace 2
- Tag 18: OP for Furnace 2

In a case like this, it is possible to use Search and replace to replace all 'Furnace 1' with 'Furnace 2', provided that the Tag number is not part of the name. With the Tag number as part of the name, the search/replace fails because it will try to replace:

  #15 SP for Furnace 1

with

  #15 SP for Furnace 2

but this does not exist, as the tag is actually called

  #17 SP for Furnace 2

Therefore, leaving out the Tag number helps in this situation.

Note about naming conventions in HCDesigner and in SpecView:

In HC Designer, a Tag has a Tag Name and (optionally) a Tag Description. These map to the name and short name in SpecView respectively.

Since the Tag Description may not be present (because it is optional), if it is missing from HCDesigner, then SpecView uses the Tag Name as the Tag Description to fill in SpecView's short name. If 'Include Tag Number' is checked, then the name has the tag number added, and the short name does not.

Some examples:

With 'Include Tag Number' checked, tag number 12 defined as:

  HCDesigner Tag Name = 'Level', HCDesigner Description = 'TankLev'

this appears in SpecView as:

  Name:  '#12 Level'  Short Name: 'TankLev'
With 'Include tag number' unchecked gives:
   Name: 'Level' Short Name: 'TankLev'

If the Tag Description is blank in the HCDesigner, then this gives:
With Tag Number:
   Name: '#12 Level' ShortName: 'Level'
Without Tag Number:
   Name: 'Level' ShortName: 'Level'

In addition, if any name is duplicated in the HCDesigner file, then these duplicates have the Tag Number appended to them for the 2nd and subsequent occurrences, to make sure that the names are unique inside SpecView.
For example, consider these 3 Tags in HCDesigner:
Tag 24: TagName='F1Temp' Description: 'Temp'
Tag 25: TagName='F2Temp' Description: 'Temp'
Tag 26: TagName='F3Temp' Description: 'Temp'

In SpecView, if 'Include Tag Number' was checked, then these will appear as:
   Name: '#24 F1Temp' ShortName: 'Temp'
   Name: '#25 F2Temp' ShortName: 'Temp(25)'
   Name: '#26 F3Temp' ShortName: 'Temp(26)'

or, if 'Include Tag Number' was unchecked:
   Name: 'F1Temp' ShortName: 'Temp'
   Name: 'F2Temp' ShortName: 'Temp(25)'
   Name: 'F3Temp' ShortName: 'Temp(26)'

Note that SpecView uses the Short Name by default on Trend Charts, which is why it is important to know how the Short Name has been determined.

4.3.9.4 HC900 HCDesigner import: Custom Loops

For additional Control Loops, these need to be placed in a custom partition in HCDesigner.

To obtain full use of the SpecView Instrument View features it is necessary to include the parameters needed to support the PID interface of the HC900. The "Select All" button can be used when adding parameters for Modbus addresses to the partition. This adds all of the PID parameters to the map.

Alternatively use the Loops Template (Vista_PID.ptf) provided with HCDesigner but it is necessary to also include the 'LSP1' parameter for Local Set Point. This would provide the minimum list of parameters needed for control via SpecView (see screenshot below):
Please refer to the Help in HCDesigner for details & other notes on how to access the screen above.

4.3.9.5 HC900 HCDesigner import: Notes on Updating an HC900

- It is strongly advised that a backup (Archive) of the project is made before attempting to update – although this process has been tested, changes in the future to HCDesigner might mean that the update routine spoils the existing instrument definitions within SpecView.

- This import facility cannot be used to update an HC900 inside SpecView that was not initially created by this import facility – so, for example, a Specview project auto-detected in SpecView 2.5 build 831 (or older), or an HC900 created manually cannot subsequently be updated by this routine.

- When 'Update' is selected, a check is made on the HC900 elements already defined in the SpecView project and if there is only one, then the IP address of the HC900 becomes un-editable. If there is more than one HC900, then the address is prompted for to indicate which HC900 is to be updated. If there is any doubt then cancel and check carefully in the Variables list to see which HC900 needs to be updated.
• Updating from a **Fixed Modbus Map** to a **Custom Modbus Map** (or vice versa) is allowed, but the update routine may create duplicate instruments, especially variables and Tags as these are defined differently in the two types of Map. If variables and/or Tags have already been used on screens from the Fixed Modbus Map file, then keep using those, otherwise start with the new ones for all future tags and variables used on screens inside Specview.

• If ‘Create Instrument Views on screen’ is checked, then any newly defined instruments in the new Modbus Map file will be added to the current screen.

• If instruments or parameters have been renamed during the import, those changes may not be reflected in the labels that may have been placed on any screens, although the actual variables will have the new names. Therefore it may be necessary to edit some labels on screens, or re-create the instrument views if an instrument has been renamed.

• After import, a summary screen is shown detailing the changes. If this summary indicated items that really should not be altered, then proceed with caution!

• If an instrument is added where the name specified already exists, then the name will have '_2' (or '_3', '_4', etc.) automatically added making, for example Furnace1-PID_2.

• If variables or tags are added to an existing project, then they will appear at the end of the variables or signal tags list in V2.5 of SpecView. i.e. they will be out of the usual numerical sequence.

• Newly added blocks (e.g. more loops) will appear at the end of the Variables List.

**4.3.9.6 HC900 Redundant Controller**

The Honeywell HC900 Redundant Controller has the model number C70R

There are two modes of failure that the Honeywell C70R is designed to protect against:
1) Failure of the CPU, which results in a switch from one CPU to another, keeping the same IP address throughout – i.e. communication is switched from one E1 port to the other E1
2) Failure of the External Network Infrastructure, which can cause a switch from the E1 port to the E2 port.

SpecView can be setup to handle both scenarios, but some care needs to be taken to ensure that the desired behaviour occurs – for instance, in case (1) above, although the IP address remains constant while the CPU switches from the Lead to the Reserve, the External Network Switch may take some time to notice this change, and during this time, SpecView may see an effect very similar to an External Network Failure.

**To set it up follow these steps:**
- Run SpecView and select the project and go into Edit mode
- Open the Templates List
- Scroll down to “IP Fail To” in the list and click the ‘+’ sign next to it
- Double-click the item called “IP Address Fail To”
- Enter a suitable name, choose “TCP/IP” for the port
- Enter an address that is the Primary IP Address, then the letter “B” and then the Secondary IP Address. For example, to fail over from 192.168.1.254 to the second address of 10.10.0.10 then enter the address: 192.168.1.254B10.10.0.10
For the Fail-over to work, the parameter inside this “IP Fail To” instrument must be placed on an open screen – to do this:
- Find the new instrument just added in the Variables List
- Click the “+” sign to open its list of parameters.
- Double-click the “Active IP Address” parameter and place it somewhere on a screen that will be opened at Runtime. This parameter will also show which IP address is being used.
- Note: It is useful to also put the SpecView variables: SpecView.GoodComms, SpecView.CommsErrors, SpecView.CommsErrorCode, SpecView.CommsErrorDescription & SpecView.CommsErrorItem onto the screen in order to be able to monitor comms.
This will enable the Fail-over mechanism inside the Modbus driver with some default values:
- The Active IP address parameter must be on an open screen at some point before the failure happens, see below for how to make this more reliable.
- Once failed over, the connection will remain with the secondary, unless that too fails, where it will switch back to the primary IP address.
- If a CPU failover happens, then there is a chance that SpecView will switch to the secondary IP address as well, because of Network Switch activity – see the details below for further info on this.
- If a ‘write’ was in progress at the time of the failover, then it cannot be guaranteed that the ‘write’ actually succeeded – if this is important, see below for more details:

How it works:
The Default Scenario:
When SpecView is communicating to the C70R, if SpecView sees a break in communications, then SpecView will attempt to re-establish the connection a number of times (Connect Retries). When this amount of connect retries is exhausted, SpecView will flip to the Secondary IP address specified and try to resume communications. SpecView will then remain talking to the Secondary IP address until instructed otherwise. If SpecView was issuing a write to the controller at the time the failure occurred, then, depending on the exact timing of the failure, the message will either have got through to the C70R or not, and SpecView will report CommsError for that value.

Things that can be altered:
The 3 most common things that can be altered from the default scenario are:
1) SpecView can be told to switch to the secondary IP address without retrying – this could be useful if speed is an issue – SpecView can be made to flip very quickly to the Secondary IP at any failure of the Primary Network – including a CPU failover where the External Network Switch does not recognize the failover quickly.
2) SpecView can be told to monitor the Primary IP address while talking to the Secondary IP address so that when the Primary Network connection is once again available, SpecView ill ‘fail-back’ to the Primary IP address.
3) SpecView can be told to retry the write that was in progress at the time of the failure. This could have the consequence that the write is seen by the C70R coming in twice – in the case of momentary
signals, this could appear as two request to do something, in which case it is recommended that momentary requests are not used in this case.

**Turning on Redundancy in SpecView:**
SpecView maintains in internal table of primary and secondary IP addresses for the failover, but this table must be initialized correctly. It can only be initialized by having a parameter on a screen somewhere that instructs SpecView to initialize the table.

There are 2 ways to initialize the table:
1) Use the Special “IP Fail To” instrument inside SpecView – this has the added advantage that this instrument reports back which IP address is in use at all times. Create the Instrument and give it the address: `<Primary>B<Secondary>` For example, to failover from 192.168.1.254 to 10.10.0.10 enter: 192.168.1.254B10.10.0.10 as the address of this instrument. The “IP Address in use” parameter of this instrument must be on a screen that is open at some point during runtime to initialize the table correctly. Until this parameter is viewed (or logged), the Redundancy is not operating.

2) Add the Secondary IP address to one or more actual instruments that have values on commonly open screen, or values that are logged – this causes the table to be initialized any time the variables that are important are requested. To add the Secondary Address, go to the instrument and add the “B<Secondary address>” to the end of the existing address, for example, if the instrument was already addressed as 192.168.1.254,1,1 then to add the secondary address of 10.10.0.10 to it, change it to: 192.168.1.254,1,1B10.10.0.10.

Here are the common commands to alter the default behaviour of the Redundant support.
Each command is entered in the Setup COM port section.
To make the driver fail-back to the Primary address when the primary address becomes available again:

TCPFAIL2PRI = 1  (TCP Fail to Primary - the default setting is 0)
This causes the driver to check every 5 seconds to establish a link back to the primary address. If it succeeds, then it will switch back to the primary address.

To make the driver switch over quickly without attempting to retry the first connection:

TCPERBS = 0  (TCP Exhaust Retries Before Switch - the default setting is 1)

To make the driver retry a few times to keep the primary connection before resorting to the secondary (the opposite behaviour to above)

TCPRLCTOR = 5  (TCP LAN Connect TimeOut Retries - the default is 2 retries)

TCPERBS = 1

To make the driver be fault tolerant including writes in progress at the time of failure:

TCPFFLTTLR = 1  (TCP Full FailLT ToLeRance – the default setting is 0)
Note that this would have the side-effect such that while any write is in progress to any TCP/IP address, the reading of other TCP/IP addresses will be halted for the duration of the write. This could slow down throughput. Also, if the write succeeded just before the failure, but SpecView was unable to gain acknowledgement of this, then the write will go through twice with this command.

For more information please read the following TechNote, which can be downloaded from SpecView's FTP site:

SVD1950 SV Support for redundant Modbus TCP IP addresses.doc

---

4.3.9.7 **HC900 SPP Block running profile and descriptor**

To show the HC900 SPP Block’s current running profile and descriptor, follow these steps:
1) In HC Designer, find the SPP Block and take a note of the field highlighted below:

2) In SpecView, find the SPP block and right-click the name to get its address. In the 'Offset' box the number from the SPP Block in HC Designer. In this example, it’s 110, as shown below, from the block shown above.

3) Then, near the bottom of the SPP block in SpecView there will be the Profile Descriptor Fields, these can be put on the screen, as shown below:
4) In Runtime, these fields will show the correct data from the HC900:

SPP1-10-Labels.SP Profile Label: 102GEARS
SPP1-10-Labels.SP Profile Descriptor: F2-102 Harden 4
Top Level Intro

This page is printed before a new top-level chapter starts
5 Migrate V2 Configuration to a V3 Project

This utility is run by SpecView Version 3’s installer, to facilitate the migration (copying) of Version 2/2.5 Configurations to Version 3 Projects.

The most recently used configuration will be highlighted.

A single configuration is copied at a time, and this can be repeated until all configurations have been copied.

Selecting a line in the list will fill in the number of days of log files, this number can be edited before the copy.

The 'Log Days' are not necessarily consecutive days, for example, 5 days of log data is the last 5 days that data was logged on, not the last 5 days from today.

There is a line displayed under the number of days field that shows the time-span over which these log files were collected.

If no configurations are listed or if the required configuration is missing click the Advanced button.

Note that this will not convert any Trend Charts in the Version 2/2.5 Configuration to Version 3 style Trend Charts, this must be done manually afterwards.

Migration Warnings/Errors
5.1 Migration Advanced

The Advanced search can be used if no configurations are listed or if the required configuration is missing.

Use the Browse button if the location of the required configuration is known.

Or alternatively click Full Disk Scan to search every sub-folder on the C drive.

Note that the Full Disk Scan can take several minutes on a PC with a lot of files/folders, and the scan cannot be cancelled. It should only be used as a last resort to try to find the SV32 installation folder. During the scan Windows may report the program as 'not responding' but this is normal and it will recover after a time.

5.2 Migration Manually

It is also possible to run the Migration tool manually.
For further information contact SpecView Technical Support.

5.3 Migration Warnings and Errors

If the migration tool has been run once, and for some reason it is required again, then it will be necessary to run it manually.

Note: The Migrate_Configs Utility will not run if there is a version of SpecView running at the time. This is to prevent the possible file-copy conflict when copying data that is still being written to.
Top Level Intro

This page is printed before a new top-level chapter starts
6 Using SpecView in Runtime Mode

SpecView has three modes of operation: **Runtime Mode**, **Edit Mode (offline)** and **Edit Mode (online)**.

Runtime Mode is also referred to as 'online', this is SpecView's normal mode of operation - SpecView is communicating with the connected instruments.

Click the **Start** button on the splash-screen displayed when SpecView starts to go into Runtime Mode using the named project:
This will happen automatically when the countdown ends.

**NOTE**: To go directly into **Edit Mode (online)** using the named project, press and hold the **SHIFT** key while clicking the **Start** button.

To go directly into **Edit Mode (offline)** using the named project, press and hold the **CONTROL** key while clicking the **Start** button.

Click the **Select/Create Project** button to cancel the countdown and select an alternate project from the **Projects** box:
NOTE: To go directly into Edit Mode (online) using the selected project, press and hold the SHIFT key while clicking either the Go Online or Edit Project button.

To go directly into Edit Mode (offline) using the selected project, press and hold the CONTROL key while clicking either the Go Online or Edit Project button.

When in Edit Mode use the Enter Runtime Mode menu command from the File menu or the tool to return to Runtime Mode.

From Runtime Mode actions are initiated by: Clicking on an object (such as: the value of a variable, Bar chart or Button) on the GDW, by double-clicking on a (writeable) variable in a Parameter List or by using the Runtime Menu.

You will see that:
- GDW's are communicating with the instruments
- Current (or Historical Data) Data Logging is storing values for use in Log Reports
- Recipes may be selected, edited, saved and loaded

To change a value click the one you want to change. For example, click the 390 setpoint for Zone 2 to change it.
During Runtime the values of variables can be changed by any of the following:

- On the instrument itself
- From SpecView's screen via data entry
- DDE
- Strategy Controller or Button actions:
  - Parameters: Alter Value Interactively
  - Parameters: Copy From... To
  - Parameters: Download Specific Value
  - Parameters: Math Function
  - Recipe: Download Specific Recipe

### 6.1 Values on the GDW

Values of variables and instrument parameters shown on the GDW may show their value:

**Zone1.Process Value: 1750.0**

or instead of showing the value it may show one of the following:
N/R - No Response

N/R will be shown when:
1: SpecView is Offline or
2: When an instrument is not connected or
3: There is some problem with communications.

NPV - Not Present Value

Some common examples of this are:
1: Programmer instruments, where segment variables change their availability depending on segment type, for example, if the Segment type is set to 'Time' then the 'Rate' value would be NPV.
2: Instruments where optional hardware is not present, for example if output boards are not fitted, or auxiliary inputs are not configured/fitted.
3: If a thermocouple goes out of range.

If NPV is shown erroneously then set the driver command NPV = -1 (minus one) this will show the underlying value, instead of NPV.

NCA - Not Currently Available

All values are set to NCA when online before they are filled in, but those that have no values, such as PasswordUser when passwords are not enabled will stay as NCA.

N/C - No Change - used in Recipes

This is used in Recipes when a value doesn't need to be set by the recipe:
6.2 Data Entry

Any writeable variable's value which is displayed on the GDW can be changed by just clicking on it. However, it may be that some instrument variables cannot be changed unless the instrument is in the correct mode (e.g. Manual mode).
6.3 Data Entry - Numeric

Used for changing numeric values on the GDW

The current value is shown which is used as the start point for the new value.

To change the value:

Click the \( \downarrow \) \( \uparrow \) buttons OR

Use the numeric keypad and then click \( \leftarrow \) Send.

**NOTE:** Each time you click the up/down buttons the new value is sent to the instrument.

The maximum values for the different types of numeric variables are detailed in SpecView Variables.

If you make a keypad error click the Erase button: the current value will be re-read into the New Value field.

If the value is not accepted by the instrument an error code will be displayed. Check that a valid number is being sent.

**Error Codes**

**Decimal Places**

To change the decimal place resolution of the value sent with each up/down click and select from the list:

1 D.P
1 D.P.
2 D.P.
3 D.P.
4 D.P.
No D.P.
To permanently change the decimal places of a specific numeric variable edit the Dynamic Attributes of the variable.

**Auto Close**

To speed data entry check the Auto Close box

![Checkbox](Auto Close)

This applies to all data entry boxes. The box will close automatically when SpecView gets confirmation that the entry has been accepted.

### 6.4 Data Entry - Boolean

Click the button required

![Image](Zone5.Auto-Manual)

To change the wording on the buttons edit the Variable Properties using the Variables List tool.

### 6.5 Data Entry - Enumeration

Used when there are several choices of discrete settings
Double-Click (or single-click and click **Send**) on the required value

**NOTE:** Some instruments immediately change the data back to a default setting. This will cause a write error. Check to see whether the instrument has accepted the expected result. If not, maybe the wrong number of decimal places have been entered.

**Error Codes**

### 6.6 Data Entry - Text Strings

Fixed text cannot be edited. Text variables from instruments and [SpecView Text User Variables](#) can be edited in Runtime Mode.

Click the text to edit:

Click the **Keyboard** button to use an on-screen keyboard. When the text has been entered click the **Send** button.
Text Variables can contain up to 32,767 characters.

Changing the value of a text variable which is a Batch Tag will mark the end the current batch & the start of another. Setting a Batch Tag to an empty string (in other words clearing it so that it contains no characters) will mark the end this batch without marking the start of another.

An empty string will be displayed on the screen as '[]' by default, this can be changed from Preferences - Display.

### Error Codes

#### 6.7 Data Entry - Date and Time

Date and Time variables from SpecView Date and Time User Variables can be edited in Runtime Mode. Click the Date and Time to edit:

The box above shows entry of both Date and Time into one variable.

There are also boxes for entering the Date and Time separately, as shown below:
Time variables are entered in the selected format `HH:MM:SS` or `HH:MM`.

When the Date and/or Time have been entered click the **Send** button.

The maximum values for the different types of variables are detailed in SpecView Variables.

If an error occurs read Error Codes.

### 6.8 Parameter List

The Instrument View on the GDW is a representation of the instrument itself and as such the buttons on it have similar functions to the buttons on the front panel of the instrument.
Typically one of the buttons on the Instrument View will display the complete Parameter List showing the values for all the variables for the instrument.

The particular button on the Instrument View that displays the Parameter List depends on the specific instrument.

Once the Parameter List is shown, if some of the parameters seem to be missing then it may be because it is just the abbreviated list of frequently required variables. To display the full list use the Options Menu and select the Short Param List menu command. All the parameters will appear. Choose this menu item again to toggle back to the short list mode.

The Short Names menu item on the popup menu switches between a mnemonic and full name mode:

To change a value:
- Single-click a variable and then click Alter OR
- Double-Click a variable OR
- Right-click and choose Alter Value from the popup menu
The **Alter** button is disabled if the selected variable is read-only.

Click the **Print** button to save the list of parameters and their current values to disk for future printing. To send the file directly to the printer use the name of the printer, for example LPT1: as the filename.

If the **Parameter List** box has been dragged off the screen, such that it can't be seen, then its position can be reset using **Preferences - Settings** from the **File Menu**.

### 6.9 Quick List

The **Quick List** is a method of marking particularly important parameters/variables from ALL instruments and User Variables in the Variables List, such that their values can be easily accessed and modified from **Runtime Mode**.

The **Quick List** can be viewed from Runtime Mode from the **View menu** or from a button that has been assigned the action **Show Quick List**.

There is only one **Quick List**, but the **Quick List** can contain variables from any instrument and any User Variables. Writeable values can be changed by clicking the **Alter** button. The **Alter** button is disabled if the selected variable is read-only.

From Edit Mode the Variables List button on the toolbar can be used to open the Variables List to add parameters/variables to the **Quick List**.

When **passwords** are enabled access to the **Quick List** can be restricted.

See: **Setting up a Quick List in Edit Mode**
If the Quick List window has been dragged off the screen such that it can’t be seen then its position can be reset using Preferences - Settings from the File menu.

6.10 Trend Charts

See Trend Charts in Runtime Mode

6.11 Touch Screen Support

There is Touch screen support in Runtime Mode, however, touch-screens are not supported in Edit Mode.

Data entry boxes are resizeable. Their size and position is remembered, which is particularly helpful
when using a Touch Screen, as larger buttons are easier to use

The popup menu on Trend Charts in Runtime Mode can be accessed using the left mouse button, for use on touch-screens which don't have a 'right' mouse button.

In Edit Mode the popup menu is only available using the right mouse button. This because the left button selects the Trend Chart for moving and resizing.

On the Button & View tab on the Trend Chart Properties box there is the option to have the Setup button shown in the top-right corner of the Trend Chart. The Setup button is useful for touch screen users to be able to quickly and easily access the Trend Chart Properties box. The alternative method of opening this box is by choosing Setup Chart from the popup menu.

However, other Runtime Mode features such as Historical Replay batch look-up and Trend Chart setup would require the touch screen to have an on-screen keyboard.

6.12 Runtime Menubar

Accessed from the Enter Runtime Mode menu command on the Edit Mode's File menu.
6.12.1 File Menu (Runtime)

Open
Use this command to open a previously saved GDW
Close
Closes the current GDW. This is the same as the GDW Control: Close this screen

Edit Mode (remain online) and Edit Mode (go offline)
Switches to the SpecView Edit Mode

Preferences
Shortcut: Ctrl + E
Displays the Preferences box.

Print and Print Preview
Shortcut: Ctrl + P
Click the **OK** button to print the current screen (GDW) to the printer shown.

**Print Setup**

*NOTE: Landscape mode is recommended for GDW's containing Trend charts*

Use this box to select and setup the printer.

*NOTE: To change the default settings use the printer setup in Windows Control*
Panel

If Adobe Acrobat is installed then this will be shown in the list of printers and can be used to create a PDF (Portable Document Format) file.

Print to JPG

Puts an image of the whole screen, including the Windows task bar if it is visible (not just the contents of the GDW) to a .JPG (Jpeg format) file. The filename of the file that is created has the date and time in the format:

```
YYYYMMDD_HHmmSS.JPG
```

The file is written to the current Project folder. If more than one request to ‘Print to JPG’ is made at the same second, then the file will be overwritten. There is also the Button & Strategy Controller action: GDW Control, Print Screen which allows ‘JPG’ to be selected from the list.

Toggle Full Screen Mode

Described in Full Screen Mode

Restart SpecView

Restarts SpecView as if the user had exited and started it again.

Exit

Shortcut Alt + F4

Exits (closes) SpecView

6.12.2 Logging Menu

Logged data is converted into Log Reports using this menu command

6.12.3 History Menu

This menu starts Historical Replay
6.12.4 Recipe Menu

Use this menu to open the Recipe Manager for this GDW. The Recipe Manager can be displayed by the Recipe: Show Recipe Manager button attribute.

6.12.5 View Menu

Use this menu to display the Alarm Window which list the Alarms which have occurred. When the Alarm Window is displayed it can be resized. SpecView remembers the last position and size. If the Alarm Window is not visible use the Reset Window Position menu command.

The Alarm Window popup can be disabled using the Preferences - Alarm. However, the Alarm Window can be viewed from the Alarm/Event menu when desired.

**NOTE:** that with the Alarm Window set to not pop-up, there is no other indication from SpecView that the alarm has occurred. Use the SpecView.NewAlarm variable or your own variables to warn the user by some other means, for example Color Dynamics or Position Dynamics.

View Alarm Window
Use this menu function to display the list of current and old alarms. The Alarm List can also be displayed by the Alarms - Show Alarm List button attribute.

Reset Window Position
If the Alarm Window has been dragged off the screen use this menu command to reset the position. The Alarm window position can also be reset using Preferences - Settings.

View Event Window
Displays the list of events recorded by SpecView. The Event List can also be displayed by the Events: Show Event List button attribute.

Show Quick List
Displays the Quick List.

6.12.6 Password Menu (Runtime)

Use this menu to Log In to SpecView with a Password. Password Log In can be accessed by the Password: Log In or Log Out button attribute.

Log In / Log Out
Select the user from the list and enter the password.

For setting up passwords in Edit Mode read Passwords.

6.12.7 Remotes Menu

The menu items on this menu are only enabled on the Local.

The User Setup menu command is detailed in SpecView Networking - Local.

View Connected Users gives information about each Remote connection:
The columns show:

The User ID.

The version of SpecView running on the Remote.

Date & time the connection was made.

The Queue sizes column shows:

- Rx0.00kb Tx0.25kb = Receive & Transmit data rates (kb/sec)
- HQ0 MQ0 LQ0 = High, Medium & Low queue sizes
- HS0 MS0 LS0 = High, Medium & Low packet sizes

If the titlebar of this box shows: 'Remote Users Attached List - Server NOT running' then the Local has not had the networking server started from Preferences, this is detailed in Setting up SpecView Networking.

### 6.12.8 Options Menu

![SpecView Options Menu](image)

**Short Param List**

This menu command toggles the parameter list on Instrument Views between Short List and Full list modes. Full List mode lists ALL the parameters for the instrument, whereas Short List mode displays just some of the most frequently used parameters.

**NOTE:** Full List mode is not the same as the Full Names checkbox on the Parameter List dialog, which toggles between Full variable names and abbreviated variable names.

Access to the Full Parameter List can be restricted by Password Log In Level.

**Setup COM Port**

Displays the COM Port Setup box and allows the COM port(s) settings to be changed, and driver commands added, during Runtime.
Toggle DEBUG on COM1
Enable/disable debug information on COM1 by setting the `driver command`: DEBUG=1
It is not recommended to change this setting unless under the direction of a SpecView representative.

Toggle DEBUG on COM2
Enable/disable debug information on COM2 by setting the `driver command`: DEBUG=1
It is not recommended to change this setting unless under the direction of a SpecView representative.

### 6.12.9 Zoom Menu

**Up**
Zoom-in to enlarge the size of the graphics & text within the GDW. Repeatedly selecting this keeps on enlarging.
Down
Zoom-out to reduce the size of the graphics & text within the GDW. Repeatedly selecting this keeps on reducing.

100%
Restore to the original size.

For zooming Trend Charts it is best to use the Zoom menu item on the Trend Chart's popup menu.

Note: This command will not affect the size of bitmaps on the GDW.
To change the size of Bitmaps go into Edit mode, double-click on the bitmap and un-check the 'Fix to Original Size' checkbox on the Bitmap Attributes box.

6.12.10 Window Menu (Runtime)

Cascade and Tile commands are standard Windows commands to arrange open Windows.
Arrange Icons has no function in SpecView.
Select any open GDW listed to switch to that GDW.

For details on making SpecView remember window positions see Remembering Window Positions

6.12.11 Help Menu (Runtime)
SpecView Help
This menu command starts SpecView's help system and displays the contents page.

Using Help
Explains how to use SpecView's Help for maximum effectiveness.

About SpecView

Displays the SpecView version/build information and shows the serial number and status of the SpecView Dongle.

Click Release Notes to see details of changes made to SpecView such as new features and fixed problems.

If you need to contact SpecView's Technical Support you may be asked to click the Technical Info button to provide further details of your specific installation.

Click Enable Further Options to upgrade the dongle.
Free Updates until
See Free Updates Expiry

What's New in V3
Details the changes to SpecView from Version 2.5 to Version 3

Remote Support
This is used for interactive Internet Support.
Top Level Intro

This page is printed before a new top-level chapter starts
7 Editing a SpecView Project

SpecView has 2 main modes of operation: Edit Mode and Runtime Mode.

Runtime mode is when instrument(s) are ‘online’ and values are being read, displayed and logged.

Edit mode is used to configure a SpecView project, i.e. creating screens, setting up the Strategy Controller, etc.

However, there is also a method of Editing a project while remaining ‘online’ to the instrument(s), so that values continue to be read and logged.

When going from Runtime Mode to Edit Mode there are 2 choices on the File menu: Edit Mode (remain online) and Edit Mode (go offline):

To enable/disable online features use the Online Features menu:
The reason for this is to prevent the live values from affecting what is being edited, a particular example of this is Position Dynamics. If Position Dynamics was being edited while it was 'online' then the position of objects on the screen could change unexpectedly.

### 7.1 Menubar and Toolbar in Edit Mode

Accessed from the **Edit Mode** menu command on the Runtime Mode's **File menu**.

The edit mode menus and menu commands are individually described below. However, for detailed information on how to edit a project in SpecView read **Editing GDWs**

- **File Menu**
- **Edit Menu**
- **Draw Menu**
- **Object Menu**
### Edit Mode

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>New</td>
<td>Opens a new blank GDW</td>
</tr>
<tr>
<td>Open...</td>
<td>Ctrl + O</td>
</tr>
<tr>
<td>Close</td>
<td>Ctrl + S</td>
</tr>
<tr>
<td>Save</td>
<td>Ctrl + S</td>
</tr>
<tr>
<td>Save All</td>
<td>Ctrl + S</td>
</tr>
<tr>
<td>Save As...</td>
<td>Ctrl + S</td>
</tr>
<tr>
<td>Next GDW</td>
<td>Ctrl + TAB</td>
</tr>
<tr>
<td>Set As First GDW</td>
<td></td>
</tr>
<tr>
<td>Auto-open on Runtime</td>
<td></td>
</tr>
<tr>
<td>Enter Runtime Mode</td>
<td></td>
</tr>
<tr>
<td>Preferences</td>
<td>Ctrl + E</td>
</tr>
<tr>
<td>Print...</td>
<td>Ctrl + P</td>
</tr>
<tr>
<td>Print Preview</td>
<td></td>
</tr>
<tr>
<td>Print Setup...</td>
<td></td>
</tr>
<tr>
<td>Print to JPG</td>
<td></td>
</tr>
<tr>
<td>1 OVERVIEW.GD3</td>
<td></td>
</tr>
<tr>
<td>2 EFFLUENT TO SUMP.GD3</td>
<td></td>
</tr>
<tr>
<td>3 INCOMING FRESH WATER.GD3</td>
<td></td>
</tr>
<tr>
<td>4 OUTGOING EFFLUENT.GD3</td>
<td></td>
</tr>
<tr>
<td>Import Project...</td>
<td></td>
</tr>
<tr>
<td>Restart SpecView</td>
<td></td>
</tr>
<tr>
<td>Exit SpecView</td>
<td></td>
</tr>
</tbody>
</table>

**New**
Shortcut: Ctrl + N

Opens a new blank GDW
Instrument Views and Variables can be added to this new GDW by clicking on the Variables List tool and a button can be used to swap between GDW's during Runtime Mode as is described in the Quick Start Guide.

Open (Edit Mode)
Shortcut: Ctrl + O
Toolbar: Opens an existing GDW. Same function as File Open (Runtime Mode)

Close (Project)
Closes a GDW (Note: The last GDW can't be closed)

Save
Shortcut: Ctrl + S
Toolbar: Saves a GDW. This will save all changes made.
NOTE: There is no 'Replace Existing?' warning box, so to save as a different name use Save As… on the File menu.

Save As
Saves a GDW with a new name. This is used to make an exact copy of a GDW and then edit the variables. Editing Dynamic Attributes

Set As First GDW
This only applies where a project contains more than one GDW.
Click this menu command to make this GDW the first window when entering Runtime Mode.
If this is not set, then the last GDW to be edited will be the first one opened when entering Runtime Mode.

Auto-open on Runtime
Click this menu command to tell SpecView to open (start) this GDW when entering Runtime Mode.
NOTE: Be sure to click this menu command on all of the GDWs which have Trend charts. Then switching between the GDWs will show all the current information on the Trend charts. If you do not, each of the GDWs will have to be opened in Runtime Mode before the Trend chart lines will start to be drawn.

Enter Runtime Mode
Toolbar: Exits Edit Mode and enters Runtime Mode. This will start communicating with the connected instruments.

Preferences
Shortcut: Ctrl + E
Click this menu command to display the Preferences box to modify SpecView's settings.

**Print (Edit Mode File menu)**
Shortcut: Ctrl + P
Toolbar: ![Print](image.png) Prints the current GDW. Use the Print Setup menu command to change your printer settings.

**Print Preview**
Previews how the printed GDW will look when it is printed from Runtime mode.

**Print Setup (Edit Mode File menu)**
Use this to change the printer settings, such as:
- Using landscape format.
- Using a different printer, for example, if Adobe Acrobat is installed then this can be selected to create a PDF (Portable Document Format) file.

**Print to JPG**
Puts an image of the whole screen, including the Windows task bar if it is visible (not just the contents of the GDW) to a .JPG (Jpeg format) file. The filename of the file that is created has the date and time in the format: YYYYMMDD_HHMMSS.JPG
The file is written to the current Project folder.
If more than one request to 'Print to JPG' is made at the same second, then the file will be overwritten. There is also the Button & Strategy Controller action: GDW Control: Print Screen which allows 'JPG' to be selected from the list.

**Recently Used File List**
Shows the four last GDW's that were edited. Clicking on one will open it.

**NOTE:** If the GDW was in another project all dynamic links will be removed. Do not open a GDW from another project unless only the background and graphics are needed.

**Restart SpecView**
Restarts SpecView as if the user had exited and started it again.

**Exit SpecView**
Shortcut: Alt + F4
Closes all GDW's and SpecView.
7.1.2 Edit Menu

<table>
<thead>
<tr>
<th>Menu Item</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo</td>
<td>Ctrl + Z</td>
</tr>
<tr>
<td>Cut</td>
<td>Ctrl + X</td>
</tr>
<tr>
<td>Copy</td>
<td>Ctrl + C</td>
</tr>
<tr>
<td>Paste</td>
<td>Ctrl + V</td>
</tr>
<tr>
<td>Delete</td>
<td>Del</td>
</tr>
<tr>
<td>Replace</td>
<td></td>
</tr>
<tr>
<td>Select All</td>
<td>Ctrl + A</td>
</tr>
<tr>
<td>Properties...</td>
<td>Alt + Enter</td>
</tr>
<tr>
<td>Dynamic Attributes</td>
<td>Ctrl + D</td>
</tr>
<tr>
<td>Color Dynamics...</td>
<td>Ctrl + Y</td>
</tr>
<tr>
<td>Position Dynamics</td>
<td></td>
</tr>
<tr>
<td>Insert New Windows Object...</td>
<td></td>
</tr>
<tr>
<td>Links...</td>
<td></td>
</tr>
<tr>
<td>Object</td>
<td></td>
</tr>
</tbody>
</table>

**Undo**
Shortcut: Ctrl + Z

*NOTE: Undo will only undo a 'move' of an object.*

**Cut**
Shortcut: Ctrl + X
Cuts the selected object and puts it on the Window's clipboard

**Copy**
Shortcut: Ctrl + C
Copies the selected object and puts it on the Window's clipboard
SpecView has a quick way to copy drawing objects - **Quick Copy**

**Paste**
Shortcut: Ctrl + V
Pastes the contents of the Window's clipboard on the **GDW**.

*NOTE: The selection will be pasted into the same location on the GDW as the Cut or Copy was taken from. Hence copied items will be overlaid on each other and will need to be dragged into the correct position. **Objects in front behind others***

**Delete**
Shortcut: Del(ete) key
Deletes the selected object(s)
NOTE: Do not forget that SpecView does not support Undo for deleted objects.

Replace
If a GDW has been duplicated for use by another identical instrument, then this function can be used to rename all the instrument variables on the GDW from, for example, 'Furnace A' to 'Furnace B'.

Note that this will only substitute the variable names that are on the current GDW.

To use this function the new instrument must be created first (in this case 'Furnace B'), then do the Replace.
This is because the Replace function can only change to a name that already exists.

This can also be used to change the name of variables, for example,
\[
\text{SpecView.BatchZone1} \quad \text{to} \quad \text{SpecView.Boiler1}
\]
To do this, uncheck the 'At start of variable only' box, and substitute 'atchZone' for 'oilier'.

NOTE: That these name replacements will only affect the current GDW and will not be automatically reflected in the Strategy Controller. Any Strategy Controller changes will need to be done 'by hand'.

Select All
Shortcut: Ctrl + A
Selects all the objects on the GDW.
NOTE: This is useful to find stray objects such as very small drawing objects put down by mistake.
To de-select the objects just click the background.

Properties
Shortcut: Alt + Enter
Shape Properties
Edits - depending on the selected object:
- Shape properties of a drawing object
- Text attributes
- Trend chart attributes
- Bar chart attributes
There is no function for grouped objects or Instrument Views.

**Dynamic Attributes**
Shortcut: Ctrl + D

*NOTE: This is only relevant to values of variables displayed on the GDW not to the names of the variables or other objects (for example, Trend charts or bitmaps) on the GDW.*

Select the object by SINGLE clicking on it. Then use the Dynamic Attributes from the Edit menu or the shortcut key.
The Dynamic Attributes box is displayed for the selected variable.

**Color Dynamics**
Shortcut: Ctrl + Y
Select the object by SINGLE clicking on it. Then use Color Dynamics from the Edit menu or the shortcut key.
The Color Dynamics box is displayed.

**Position Dynamics**
Select the object by SINGLE clicking on it. Then use Position Dynamics from the Edit menu.
The Position Dynamics box is displayed.

If this menu item is grayed-out (disabled) then go to the Online Features menu to check that Position Dynamics is offline. This is because if Position Dynamics could be setup while 'Online' then the value could change causing the object to move unexpectedly.

**Insert New Object**
Displays the Insert New Object box which allows items created by other Windows applications to be displayed on the GDW.

**Links**
Displays the Edit Links box to allow items created by other Windows programs to be added to a GDW, for example, Excel spreadsheets.
However, this menu command will only be enabled if the Link box was checked on the Insert New Object box.

**Object**
This menu command will only be enabled if an object has been inserted onto the GDW using the Insert New Object box, and that object is currently selected.
It will then display a sub-menu with menu commands appropriate for that type of object.

### 7.1.3 Draw menu

These menu commands and Tools are used to draw graphics on a GDW.
You can also add Bitmaps (.bmp files) to a GDW.
If you are not familiar with standard Windows drawing functions please read Drawing Basics.
These drawing functions are described in greater detail under [Drawing Basics](#) below:

- Select
- Line
- Rectangle
- Round Rectangle
- Ellipse
- Polygon
- Bitmap
- Text
- Button
- Trend Chart
- Bar Chart
- ActiveX Control...
7.1.4 Object Menu

To enable these menu items have an object selected as shown.

**Line Color**
Changes the color of an already selected line AND chooses the color for the lines drawn from now on.
Note: The word 'Line' applies to both lines and the outlines of the other drawing objects.

**Line Thickness**
Changes the thickness of an already selected line AND chooses the thickness for the lines drawn from now on.
The **Shape Properties** box is opened by double clicking on the object. The Outline Weight must be greater than zero for the outline to be seen.
Note: The word 'Line' applies to both lines and the outlines of the other drawing objects.
Fill Color
Changes the fill color of an already selected object AND changes the fill color of all objects you draw from now on.
The Shape Properties box is opened by double clicking on the object. The Filled checkbox must be checked.

Text Font
Sets the default Text Font for text objects added to the GDW.

Group
Shortcut: G
Toolbar: and on the Object Menu:
Objects may be grouped together for moving them around the GDW, this is detailed in Selecting, Grouping and Saving drawing objects

Grouped objects may be saved and reused (as GDO files) with the Save Object and Load Object menu commands on the Object Menu
This menu command is only enabled if more than one object on the GDW is selected

UnGroup
Shortcut: U
Toolbar: and on the Object Menu:
A previously grouped object may be ungrouped for:
- Editing
- Changing the Dynamic Attributes
- Changing the Color Dynamics
- Adding to Recipe
Select the object and click the UnGroup tool (or choose this menu command)
This menu command is only enabled if a grouped object on the GDW is selected

Align Left/Top/Right/Bottom, Distribute evenly horizontal/vertical and Realign To Grid
If a number of objects on the GDW are selected (but NOT grouped), then these menu commands will align or distribute the objects evenly.
For align, all objects are aligned with the one furthest in the direction specified; for example, if a number of objects are Aligned Left, then it uses the left-most one to align all the others to.

For Distribute, all the selected objects are distributed between the outermost two objects in the selection.
With the exception of Realign to Grid, these sub-menu commands are only enabled if more than one object on the GDW is selected.
The grid size is specified on the View Menu.

**Move To Front**
Shortcut: Ctrl + (numeric keypad) Plus
Moves the selected object in front of ALL other objects
This menu command is only enabled if an object on the GDW is selected
**Objects In Front / Behind others**

**Move To Back**
Shortcut: Ctrl + (numeric keypad) Minus
Moves the selected object behind ALL other objects
This menu command is only enabled if an object on the GDW is selected
**Objects In Front / Behind others**

**Move Forward**
Shortcut: (numeric keypad) Plus
Moves the selected object up one layer
This menu command is only enabled if an object on the GDW is selected
**Objects In Front / Behind others**

**Move Back**
Shortcut: (numeric keypad) Minus
Moves the selected object back one layer
This menu command is only enabled if an object on the GDW is selected
**Objects In Front / Behind others**

**Save SpecView Object**
Graphics made with SpecView's drawing tools can be grouped and saved as GDO's using the Save Object menu command on the Object menu.
The saved GDO's can be re-used (using the Load Object menu command) any number of times in any GDW in any copy of SpecView.

**NOTE: Do not include variables (or Trend charts or Bar charts or ActiveX controls or Buttons which use variables) in saved objects**

Only a single entity can be saved as a GDO, such as, a single rectangle or a single group.
However, a group can contain 100's or even 1000's of other objects.
These grouped objects can be a combination of SpecView drawing objects (such as rectangles, lines, ellipses, polygons, text) and bitmaps and buttons.

The objects are saved in a file with the extension .gdo (Graphical Display Object)
A GDO can be re-used any number of times on any GDW in any SpecView project.
A GDO file can only be viewed & edited using SpecView.

The default folder to save the object to (and load the object from) is SymbolLibrary in SpecView's installation folder (so typically this would be: C:\SV3\SymbolLibrary). However, GDOs can be saved to & loaded from any folder.

If a variable, a Trend chart, a Bar chart or a Button (which uses variables) is saved as a GDO then the variable's information (including its Dynamic Attributes & Color Dynamics) will be lost when the GDO is re-loaded.

This menu command is only enabled if an object on the GDW is selected.

**Load SpecView Object**
Loads a previously saved object or grouped object
Once loaded the GDO can be positioned, resized & modified as required.

The default folder to load the object from is the Project folder. Alternatively use C:\SV3\SymbolLibrary\ which contains other GDO objects.

**Name**
Used for SpecView diagnostic purposes only
This menu command is only enabled if an object on the GDW is selected
7.1.5 View Menu

Variables and Instruments

Toolbar: Toggle the Variables List On and Off

New Instruments

Toolbar: Toggle the Templates List On and Off

Toggle Grid Lines:
Shortcut: Ctrl + G
The Toggle Grid Lines menu item (Ctrl-G) on the View menu, cycles round the 3 grid-size settings. The fourth setting is zero to disable the grid. This allows objects on the screen to be positioned manually to within one pixel, this requires very precise positioning of the mouse or by using the cursor keys on the keyboard to nudge objects by one pixel, or when holding the Shift key down nudge by the size of one grid square.
The purpose of the Grid is to help with alignment of objects when positioning them with respect to each other, as objects will appear to jump by the Grid Size setting, which saves having to move the mouse quite so precisely.
The Grid lines themselves are drawn at intervals of ten times the actual Grid size for clarity.

Set Grid Sizes:
The Grid Size menu item on the View menu allows 3 grid settings to be specified. The defaults are: 5, 10 and 20 pixels.
The dashed grid-lines are drawn at 10 times the actual grid-size for clarity, so a grid of 5 will have dashed lines every 50 pixels, etc.

Note: When putting values in tables set the grid to a larger number than the default value of 5 before starting, this will make it easier to align them.
Enter the value for a new grid size. A larger number = a coarser grid.
The Grid lines themselves are drawn at intervals of ten times the Grid Size for clarity.
Therefore, if the Grid Size is set to 5 then the Grid lines will be drawn every 50 pixels.

It is possible to disable the grid, by setting the Grid Size to zero & unchecking Grid Lines.

Screen Color
Changes the color of the GDW background
NOTE: If the GDW is going to be printed, leave the background white to save ink.

Show Objects
This toggles the highlighting of objects which have been inserted using Insert New Object… from the Edit Menu.

These are used to display the outline of the portion of the screen that would be seen if the GDW were displayed onto a screen of that resolution. This is particularly useful when creating a GDW for Remote access from a lower resolution screen to ensure that the items on a GDW are positioned appropriately.

The maximum dimensions of the grid shown in SpecView’s Edit mode is: 3837 x 2117.

The Show Screen Size Guide enables & disables this feature. The Screen Size Guide Line Color and Screen Size Guide Font allow the color & font used for the lines to be customized.

**Toolbar**
Toggles the Toolbar On and Off

**Status Bar**
Toggles the Status Bar (at the bottom of the screen) On and Off
*NOTE: Turning Off the Status Bar in Edit Mode will hide it in Runtime Mode*

**Resize Screen**
If the GDW was created on a computer with a different screen resolution it will be necessary to resize the GDW to fit the current resolution.

**Resize 1024x768 » 800x600**
**Resize 800x600 » 640x480**
Resize 640x480 » 800x600
Resize 800x600 » 1024x768
Resizes this GDW from the first resolution to the second

**Zoom**
Zooms the current GDW. This is useful for detailed editing and precise positioning of objects.

**Zoom 100%**
Returns the GDW to normal size

**Zoom 150%**
**Zoom 200%**
**Zoom 300%**
**Zoom 400%**
**Zoom 500%**
Zooms the GDW to the specified percentage of normal size

**Recipe Mode**
Toggles the Recipe Mode On and Off

*NOTE: You can also cancel the Recipe Mode by pressing ESC*

### 7.1.6 Password Menu (Edit Mode)

These commands are detailed in Passwords

### 7.1.7 Setup Menu

Note: The menu items that were on the Database sub-menu in previous versions have been moved to the
Internal Data tab on the Variables List.

**Strategy Controller**
Displays the [Strategy Engine](#) setup box

**Event Logging**
Sets the actions and events, which will be included in the Event Log

![Event Log Setup](image)

**Strategy Controller** events and actions can also be logged to the Event Log by checking the 'Log To Event Log' box

**Setup COM Ports**
Displays the COM Port Setup box and allows the COM port(s) settings to be changed and [driver commands](#) added.
Check COM Port
Checks whether the COM Port is available and working.
Does NOT check communications. The port might be a modem.

Swap COM Ports
This allows the COM ports for multiple instruments to be re-assigned without manually editing each instrument.
7.1.8 Online Features Menu

Edit Mode allows changes to be made to a project without stopping communication with the instruments or interrupting data logging. This is useful for making changes to a running system without losing any data.

Instruments can start communicating and logging data as soon as they are put out onto the GDW.

The features that continue to receive live values while in Edit Mode are selected using the Online Features menu:
All features are fully functional.

Individual features can be disabled. For example, while setting the start and end location of animated objects, Position Dynamics must be disabled.

7.1.9 **Window Menu (Edit Mode)**

**Cascade**
Standard Windows function to Cascade all open windows (GDWs)

**Tile**
Standard Windows function to Tile all open windows (GDWs)

**Arrange Icons**
This has no useful function with SpecView. (It is a standard Windows function, hence it appears on the standard Windows menu but it is not used by SpecView)

7.1.10 Help Menu (Edit Mode)

SpecView Help
This menu command starts SpeView's help system and displays the contents page.

Using Help
Starts the help system for Windows

About SpecView

Toolbar:
Displays the SpecView version and build information.
Displays the serial number, enabled options and status of the SpecView dongle.

Click Enable Further Options to upgrade the dongle.

Click the Release Notes button for details on changes made to SpecView such as new features and fixed problems.

If you need to contact SpecView's Technical Support you may be asked to click the Technical Info button to provide further details of your specific installation.

**Free Updates Until**
This shows the date of the Free Updates Expiry

**Release Notes**
Details changes made to SpecView such as new features and fixed problems.

**Technical Support**
For further information contact Technical Support

Remote Support
This launches TeamViewer (www.teamviewer.com) to allow your SpecView Representative to access your computer over the Internet to assist with technical queries and resolving problems, while speaking on the phone or using TeamViewer's 'chat' window.

This is a secure method of access over the Internet requiring you to give the ID and password generated by TeamViewer to your SpecView representative. The password is unique for each TeamViewer session so won't compromise security. Using TeamViewer is the most efficient way of allowing your SpecView representative to assist and support you.

7.2 Editing GDWs - Graphical Display Windows

The project will ideally need to have already been setup according to Setting up a Project.

Then the GDWs - (Graphical Display Windows) need to be setup. GDWs are the screens that are seen when using SpecView.

These files have a filename extension of either GDW (old style) or GD3 (new style).

Note: These files are not 'stand-alone' and therefore will not work unless they are in the same folder as the rest of the project files they were created with.

Creating / Editing GDWs

GDWs (Graphical Display Windows) also known as 'screens' or GD3s, contain background graphics and variables.

Managing Instruments and Variables
Menus and Toolbar
Creating a background graphic
Adding numeric values to a GDW
Adding a Trend chart to a GDW
Adding a Bar Chart to a GDW
Auto Backup - automatic backup while editing.

7.2.1 GDWs - Graphical Display Windows

These are the screens you look at using SpecView. GDWs (or GD3s) are created or edited in Edit Mode and used in Runtime Mode.

Data is shown on a GDW (or GD3) in four ways:
• Instrument Views
• Numerically
• As a Pen on a Trend chart
• Bar Chart

The Extruder Graphic shown below uses SpecView drawing tools to arrange data in an unambiguous way and shows both numeric values and Bar charts.

Creating and Editing GDW’s

Note: Files with the .GDW or .GD3 filename extension cannot be used alone. Consequently they cannot be used by SpecView if they have been separated from the other files in the Project sub-folder that they were created in.

Auto save & recovery of screens (GDWs) will save changes at a specified interval for later recovery in the event of failure. In this case, a list of saved items will be displayed so the items to be recovered can be selected:

7.2.2 Extruder Graphic

This is an example of a graphic made with SpecView's drawing tools with both Bar Charts and values:
Creating/Editing GDWs

Managing Instruments and Variables
Menus and Toolbar
Creating a background graphic
Adding numeric values to a GDW
Adding a Trend chart to a GDW
Adding a Bar Chart to a GDW

7.2.3 Variables List

The Variables List is used to:
- Define and/or edit connected instruments
- Add Instrument Views and/or individual Numeric Values to the GDW
- Add SpecView pre-defined variables to the GDW
- Create User Variables and then add them to the GDW
- Change the Variable Properties (such as Scaling & Offset)

Open the list by selecting Variables & Instruments from the View menu OR click on the toolbar.

There is a separate list for new instruments, these are known as instrument Templates.

To access the Templates List press the T tool on the toolbar.
An alternative way to access it is via the New menu on the Variables List.

Note: Tooltips are displayed by hovering the mouse over items such as: User Variables, Instrument Parameters and column headings:
There are multiple options for sorting instruments and variables within the Variables List.

There are a number of columns which can be selected showing Values (V), Logging (L), Alarms (A), Short-List (S) and Read-Only (R).

Live values will be shown in the Values (V) column, if enabled on the Online Features menu. This will not put a heavy load on comms because only those values visible will be requested.

Choosing Options->Flat List displays parameters from multiple instruments, so that all similar parameters from each instrument are shown together.

Instruments may be grouped together under a logical machine name. This is done using Options->Groups to create a logical name and going to the instrument's Properties and assigning it to a group.
Variables can be dragged and dropped onto the screen (GDW).

Multi-select of variables can be sequential, using the SHIFT key, or random, using the CTRL key. When using the CTRL key, variables are put on the screen in the order selected.
When a number of variables are multi-selected and dragged out onto the screen they are automatically in **Spread Mode** to assist when dragging out a number of variables for a table. This is indicated by the large black square 'handles' around them. The 'handles' can be dragged to adjust the spacing, instead of just enlarging the font. Any group of items can be put into **Spread Mode** by right clicking on the group and choosing **Spread Mode** from the popup menu.

Subsequent dragging will use the previous spacing, or use the **Reset Spacing** menu item from the **Multi-Select** sub-menu.
Drag and drop can also be used to assign a variable in a box, such as, the **Strategy Controller** Setup box.

Here the **Flat List** option has been chosen from the **Options** menu, so that all the similar parameters from each instrument are shown together. After multi-selecting the parameters, drag onto the GDW which automatically arranges them and, if enabled on the **Online Features** menu, then the live values will be shown immediately.
For Modbus instruments the Modbus address of a parameter will be displayed in a tooltip.

A summary of variables is shown in a tooltip when hovering the mouse over the bottom edge of the Variables List.
Other Variables List features include:

- Renaming with **Options->Find** and **Options->Replace** so that instrument names, parameter names, and addresses can be found and changed.
- When a User Variable is created any number in a name is recognized as such and it is incremented for the next one, e.g. Zone478 the next one would be Zone479.
- Show/Hide columns for **Logging (L)**, **Alarms (A)**, **Short List (S)** and **Read-Only (R)** attributes.
- Read-Only attribute may be applied to Read/Write variables on screen (GDW) to prevent accidental changes to the value.
- The scroll-wheel on the mouse operates the scroll bar on the Variables List.
- Instrument creation via the **Templates List**.

Note: If a button or menu item isn't enabled then a possible reason is that **Online Features** are enabled. For example, in the **Variables List**’s **Variable Properties** box the **Delete** button will be disabled (grayed out) if **Online Features** are enabled.

See **Internal Data Menu** for advanced options.

7.2.3.1 **Variables List - SpecView Variables**

The first Instrument shown in the **Variables List** is SpecView, these are the variables that exist only in SpecView but have all the same properties as other variables and can be:

- Logged
- Included in Recipes
- Put on Trend charts or Bar Charts

SpecView boolean variables are used as switches to control events in the **Strategy Controller**.
There are two kinds of SpecView variables, Pre-Defined and User:

**SpecView Pre-Defined Variables**

In order to Log pre-defined variables use 'Database->Show Logging in Variables List' from the Setup menu and check the boxes next to the relevant variables in the Variables List.

- **SpecView.Time** and **SpecView.Date** are the current Time and Date on the computer.
- **SpecView.Date&Time** This is the current Date and Time combined, which is useful for Strategy Events.
- **SpecView.NewAlarm** is a Boolean which will become True when there is a new alarm, and will remain True whilst there are any alarms left un-acknowledged. It will be set back to false when all alarms have been acknowledged.
- **SpecView.AnyAlarm** is a Boolean which will be True when there is any alarm, whether acknowledged or not. It will be set back to false when all alarms have been cleared.

For further details read Alarms.

- **SpecView.PasswordUser** is a Text variable set to the username of the current user who is logged in.
- **SpecView.PasswordLevel** is an Integer variable set to the level of the current user who is logged in.
- **SpecView.PasswordTime** is a Countdown Timer variable set to the number of seconds that this user can remain logged in.

These are shown on the Status bar. For further details read Passwords.

- **SpecView.GoodComms** is the total number of successful comms transactions coming in from all
attached ports

- **SpecView.CommsErrors** is the total number of unsuccessful comms transactions coming in from all attached ports
- **SpecView.CommsErrorCode** is the last error code from the last failed transaction
- **SpecView.CommsErrorItem** is parameter which caused the last error code

The most common error code is: 1460, which is a timeout.

All of the above Comms counters can be reset to Zero by writing to them. Writes of other values are ignored.

Currently it is not possible to determine which COM port the error(s) occurred on, if this is needed, use the Toggle DEBUG menu command on the **Options Menu** under the direction of a SpecView representative.

- **SpecView.CommsErrorDescription** gives more information about the error code
- **SpecView.FastCount**

This is a counter that counts-up accurately and continuously at rates up to 100 times per second. You can use this counter as the basis for a Strategy Controller Event that needs to be checked frequently.

For further details read **SpecView.FastCount Variable**.

- **SpecView.LogRate**

This variable stores the current value for the logging rate.

This variable's initial value when entering Runtime mode will be the value set from **Preferences - Logging**. The variable is Read Only and cannot be changed during Runtime mode, other than by using the **Logging: On/Off** action.

**SpecView Pre-Defined Variables for Recipe**
Most Recent:
- **Recipe Name** is the name of the last recipe downloaded
- **Download Date** and **Download Time** are the Date and Time that the recipe was downloaded
- **Downloaded By** is the name of the remote connection that downloaded the last recipe
- **Downloaded From GDW** is the name of the GDW from which the recipe was downloaded
- **Sent To** Is the name of the instrument to which the Recipe was downloaded
Although these variables under 'Most Recent' are the ones most commonly used, these variables are also available specifically for each individual screen (GDW).

**SpecView User Variables**
SpecView User Variables are variables that exist only in SpecView, not in the connected instruments. They are sometimes called Software Tags or Dummy Gates.
Examples include:

- **Text** variables, which are used for a single line of text that can be changed while in Runtime Mode, such as: 'Batch Numbers', 'Material ID' 'Customer Name'.
- **Times** for timers such as log report start and stop times.
- **Booleans** for automation.
- **Enum** (Enumerated type) to express multiple states, such as: Stopped/Running/Paused.
  The syntax for defining the value is, for example: 1=Stopped;2=Running;3=Paused.
- **Countup Timer** to record durations.
- **High Precision Number** the range is +/-1.7E308 with at least 15 digits of precision, whereas
- **Numbers (with decimals)** are limited to 3.4E +/- 38 (7 digits).
To define a SpecView Variable click the Variables List tool click the New menu and select the type of variable required:

Give the variable a name together with an initial value using the displayed boxes. The initial value is only used when the variable is displayed on the GDW for the very first time, subsequent SpecView runs will use whatever was the last value of the variable. SpecView will save the values of all User Variables when it exits and will restore the values on the next run.

It is possible to set a variable to have a specific default value EACH time SpecView Runtime Mode is entered. To do this use the Strategy Controller's Startup event to do the action 'Parameters: Download Specific Value'.

The new variable will be listed under 'User Variables' and grouped by type. Clicking on the '+' symbols will expand these lists.

The User Variable can now be added to the GDW in the same way as the instrument variables, by dragging it out onto the GDW.

User Variables may have a value entered manually from a GDW, or have its value set by a Button Attribute or Strategy Controller Action

The Countdown Timer may be written to as a time variable and it will count down from that value. **Note: Countdown Timers are not stopwatches. They have no reset function or start/stop capability. They are always running towards zero from the last value set. They will stop when they reach zero.**

They do NOT count when SpecView is not running. When SpecView is re-started they will resume from their last value.
In **Strategy Controller** to do something when the Countdown has finished test for the Countdown Timer being 1 (not zero because then it will trigger each time Runtime mode is started as zero is its default state).

To start a Countup Timer set it to 1, it will then commence counting up from 1.

By default SpecView will save the current values of User Variables on leaving Runtime mode. Either by exiting SpecView, or by going into Edit mode.

There is also a setting: AutoSaveUserVars which can be changed, this is detailed in Preferences.

**Maximum Values:**

Integer Variables - can contain values in the range: -2147483648 to +2147483647

Number Variables - can contain values which have the following limits:

- Largest positive number: 3.402823466e+38 (3.4E +/- 38 (7 digits))
- Smallest positive number: 1.175494351e–38
- Significant digits: 6 e.g. 1.23456 (There is further clarification of Decimal Places)

Internally, SpecView uses 15 significant digits to perform math functions.

These limits also apply to negative numbers.

High Precision Number - the range is +/-1.7E308 with at least 15 digits of precision.

Text Variables - can contain up to 32,767 characters.

Time Variables - can hold up to a maximum of  59:59:59 (hhh:mm:ss)

Countdown and Countup Variables - can be set to a maximum value of  999:59:59 (hhh:mm:ss)

However, Countup variables can count on up to 596532hrs 20m (which is about 68 years)

Date Variables - can hold dates up to the 1st January 2020.

DateTime Variables - can hold dates up to 18th January 2038.

**SpecView User Variable Names**

Enter a name for the User Variable.

It can be any length (up to 32,767 characters) but shorter names are more manageable.

Use the **Keyboard** button to get an on-screen keyboard.

To set an initial default value for a User Variable:

- While **Screen Values** are disabled on the **Online Features** menu in Edit Mode:
In this case the Properties will have an Initial Value tab. Select the variable, and click Properties, or choose Properties from the popup-menu, and click the Initial Value tab to set it.

- While Screen Values are enabled on the Online Features menu in Edit Mode: In this case the 'initial value' has no meaning.

- Variables List will have a 'V' (Values) column, therefore right click on the value in the Variables List to set it.

Boolean default value box

*Note: You can change the names of the boolean states from 'On'/"Off" to something more logical for your application (for example 'Open'/'Closed') by using the Properties of the defined variable.*

Date and DateTime User Variables

Date and DateTime User Variables can have the current computer date and time copied to them by using the Parameters: Download Specific Value button action in a Button Attribute or Strategy Controller Action

7.2.3.2 Variables List - Properties

Use Variable List Properties to:
- Change the name of a variable
- Add / Delete a variable from:
  - Data Logging
  - Alarm Checking (booleans)
  - Short List
- Scaling (for numbers with decimals)
- On/Off Labels (booleans)

Open the Variables List by clicking on the toolbar, then, navigate to the Variable that you require:

- For Instrument variables: Click the by the instrument's name.
- For SpecView Variables: Click the by 'SV' to show the pre-defined variables.
- For User variables: Click the by 'User Variables’ and click the by the type of the variable.

Then single-click the variable name to select it and click Properties, OR right-click the variable name and choose Properties from the popup-menu.
Name Information
Edits the names of variables such as alarms using the Variables Properties box.
Example: Change 'Alarm 1 Status' to 'High Alarm'
Attributes
Check the Logged box to add a variable to Data Logging.
Check the Alarm box to have SpecView monitor this boolean as an alarm; this option will be grayed-out if this variable is not a boolean type.
Check the Short List box to have the variable included in the Short List mode.

Note that the Logged, Alarm, Short List and Read-Only settings can be overridden by double-clicking in the boxes in the 'L', 'A', 'S', 'R' columns of the Variables List.

Checking the 'Apply ... To All' boxes will change those attributes on the same variables of ALL identical instruments in the project.

There is also an 'Automatically apply future changes via variable list columns to other similar parameters' checkbox. When this is checked it means that double-clicking in the columns of the Variables List to set or unset an attribute will also affect the same variables of ALL identical instruments in the project.
**Batch Tag**

Text Variables and parameters can be marked as **Batch tags**.

![Variables List Version 3](image)

**Boolean settings**

This allows the On/Off Labels (of booleans) to be changed.
Scaling settings
Scales a number with decimals (real number) using the Variables Properties box.
A simple example is changing °C to °F:
Set the scale to 1.8 and the offset to 32
For a change like this it would also be appropriate to change the variable's name from, in this example, 'Temp C' to 'Temp F'.
For more complex scaling the formulas below allow you to work out the Scale and Offset values for parameters to convert between the readings available from instrument hardware into the values seen on the screen. SpecView always takes the instrument reading, multiplies by the scale and then adds the offset.

For example, for a 4-20mA signal coming into a sensor. This sensor converts the signal into a 0 to 4095 range inside the instrument. However, the values on the screen need to show 0 to 100% for this range.

The physical signal (4-20mA in the example above) does not form part of the equation because the instrument deals with that and provides a range of values (0 to 4095 in this case). The equations for Scale and Offset convert from the 0 to 4095 instrument range into the 0 to 100 User range.

\[ \text{InstLo} \text{ to } \text{InstHi} \text{ represents the range of numbers reported by the instrument. UserLo to UserHi represents the corresponding range of displayed values in the formulas.} \]
Other common words for InstLo and InstHi are Full Scale Low and Full Scale High readings - they are the lowest and highest readings produced by the instrument and read into SpecView. The InstLo and InstHi values can be determined empirically by setting the scale to 1.0 and the offset to 0.0 inside SpecView. Then, apply the lowest possible physical input to the instrument and note the value as InstLo. Then apply the highest possible physical input to the instrument and note that value as InstHi.

Examples:
1) It is quite common for many Chart Recorders to read numbers in the range 0 to 65535 for the pen range. For example, a Pen's readings might be 0 to 100%, but over comms, this shows up as 0 to 65535.
   InstLo = 0   InstHi = 65536   UserLo = 0   UserHi = 100
   So, using the formulas above:
   Scale = 0.001525902
   Offset = 0.0

2) A 4-20mA input module where the 4-20mA range is represented by 0 to 4095 reading. User wants the range 0 to 100 displayed:
   InstLo = 0   InstHi = 4095   UserLo = 0   UserHi = 100
   Scale = 0.02442
   Offset = 0.0

3) Same as example 2, but user wants the actual mA signal value displayed. This can be stated as:
   A 4-20mA input module where the 4-20mA range is represented by 0 to 4095 reading. User wants the range 4.0 to 20.0 displayed:
   InstLo = 0   InstHi = 4095   UserLo = 4.0   UserHi = 20.0
   Scale = 0.0039072
   Offset = 4.0

4) As for example 2, but the instrument reports back numbers as 1 decimal place, so:
   A 4-20mA input module where the 4-20mA range is represented by 0 to 409.5 reading. User wants the range 0 to 100 displayed:
   InstLo = 0   InstHi = 409.5   UserLo = 0   UserHi = 100
   Scale = 0.2442
   Offset = 0.0

5) Similar to example 2, but the Instrument is physically capable of reading the whole way down to 0mA.
   So, a 4-20mA input module where the 4-20mA range is represented by 820 to 4095 reading (because 0mA would read 0, but the lowest possible input signal is 4mA). User wants the range 50 to 100 displayed:
   InstLo = 820   InstHi = 4095   UserLo = 50   UserHi = 100
   Scale = 0.0152671
   Offset = 24.96184

6) As a proof, consider converting a Centigrade figure into Fahrenheit. As we commonly know, C to F is multiply by 1.8 and add 32. In order to check this fits with the formula:
   Assume the centigrade range is 0 to 100 (Freezing point to Boiling point). This is the Instrument range.
   We know that the equivalent Fahrenheit values are 32 and 212. This is the User range. So:
   InstLo = 0   InstHi = 100   UserLo = 32   UserHi = 212

\[
\text{Scale} = \frac{(UserHi - UserLo)}{(InstHi - InstLo)}
\]

\[
\text{Offset} = -\frac{\text{InstLo}}{(InstHi - InstLo)} \times (UserHi - UserLo) + UserLo
\]
Applying these values to the formula:

\[ \text{Scale} = \frac{(212 - 32)}{(100 - 0)} = \frac{180}{100} = 1.8 \]

\[ \text{Offset} = \frac{-0}{(100 - 0)} * (212 - 32) + 32 = 0 * 0 + 32 = 32 \]

7) Fahrenheit to Centigrade: the opposite of example 6:

\[ \text{InstLo} = 32 \quad \text{InstHi} = 212 \quad \text{UserLo} = 0 \quad \text{UserHi} = 100 \]

\[ \text{Scale} = 0.555555 \quad \text{Offset} = -17.7777 \]

Note: It is useful to test values at both ends of the range and if any other values are known then try those too.

For example, the values produced in example 6 (C to F) are as expected, 1.8 and 32. In example 7 though, the numbers don’t seem to make sense. To test that they are correct:

Note: SpecView will multiply by the scale then it will add the offset, therefore:

First, 32°F: \[ 32 * 0.555555 + (-17.7777) = 0.0001 \text{ (which is approximately zero)} \]

Next, 212°F: \[ 212 * 0.555555 + (-17.7777) = 99.9989 \text{ (which is approximately 100)} \]

And one other value that is known, -40 reads the same in C as F:

\[ -40 * 0.555555 + (-17.7777) = -39.9997 \]

Saved Value

This tab is only shown when in Edit mode Offline (it is not shown while Online).

The frequency in seconds that values are saved is specified in SETTINGS.INI in the [RUNTIME] section as: \text{AutoSaveUserVars=3600}

(the default setting is 3600 seconds, which is once an hour).

If there are a large number of SpecView User Variables, then do not save them very often as this will slow down the system, especially on heavily loaded computers. The values are automatically saved whenever SpecView goes offline or is exited.
Instruments, parameters and variables can be assigned to a group to keep them together logically:
7.2.3.3 Variables List - Internal Data Menu

The Internal Data menu allows access to the information on variables stored in SpecView.

Open the Variables List by clicking on the toolbar.
List GDW Dynamics to CSV
Used for SpecView diagnostics only

Save Logging + Alarm Details
Used for SpecView diagnostics only

Load Logging + Alarm Details
Used for SpecView diagnostics only

Set All items on this GDW as Logged
Adds ALL the variables on this GDW into logging.

**NOTE: Use this feature if you want to Historically Replay ALL the variables on this GDW**

To remove any unwanted variables from logging uncheck the logging flag in the Variables List.

See [Disk Space for Logging](#) for file size details, as logging more variables will increase disk space requirements.

Export Variables List
Exports a list of all the currently defined variables and their properties to a .CSV (Comma Separated Variable format) file which can then be edited using Excel and saved again as a .CSV file, then subsequently imported using the Import Variables List menu command from this menu.

This is useful if a large number of changes need to be made to the Variables List. For example, some instruments have numerous data registers, which must be accessed indirectly using an address offset. These variables will then need to be renamed accordingly, for example, registers named with numbers D000 to D255 with an offset of 2560 will need to be renamed to D2560 to D2815 which can be done quickly using the features in Excel.

Do not attempt to use this function to change the type of a variable, for example, from an Integer to a Number (with decimals).

Import Variables List
Imports a list of all currently defined variables and their properties from a .CSV file which has been edited
using Excel and saved again as a .CSV file.

*Note: There is very limited error checking on the import, so make a good backup of this project first before importing.*

### 7.2.3.4 Variables List - Groups

Instruments can be assigned to a group to keep them together logically:

In the above example the factory has various levels and zones each made up of a number of instruments. The instruments in the Variables List can be grouped accordingly.

To add a new group name enter a name and click the Add button. To add instruments to the group choose the new group from the Assign to group drop-down menu from the instrument's Properties box.

Note that the word ‘group’ has 2 meanings in SpecView:

1. When instruments and/or parameters and/or variables are grouped together into a named logical group within the Variables List as described above.
2. When objects are grouped together on the GDW so they can be moved all together.

7.2.3.5 Variables List - Find/Replace

Items in the Variables List can be searched for (Find) or substituted (Replace). This is useful when a large number of items need to be found and/or renamed.

Find:

Results replace selection - unselects any items that are currently selected and instead selects the items that were found.
Add results to selection - keeps the currently selected items and adds the items that were found to the selection.

Replace:
7.2.4 Templates List

There is a separate list for new instruments, these are known as instrument Templates. The templates make up a database of instruments that SpecView recognises. The templates contain information about the instruments' parameters, the parameter addresses and types.

To access the Templates List press the T tool on the toolbar. An alternative way to access it is via the New menu on the Variables List.
Scroll down the Templates List and click the ‘+’ by the manufacturer name, then select the module type, and click `Create Inst`:
Instrument properties

**Name**: The name for the instrument, for example, Furnace 1.

**COM Port**: To increase the number of available COM ports set MaxPorts.

**Baud Rate**: Check the Baud rate configured on the instrument, see the instrument manufacturer's manual.

**Parity**: This is the 'data bits', 'parity' and 'stop bits', for example, 8N1 is 8 data bits, no parity and 1 stop bit. Check these settings on the instrument, see the instrument manufacturer's manual.

**Slave Address**: Check the slave address configured on the instrument, see the instrument manufacturer's manual.

**Decimal Places**: Specify the number of decimal places required for values from this instrument, for example ‘123.4’ is 1 decimal place.

It is important to read decimal places because there are other points to note when setting this.

**Offset**: This is the address offset for the parameters. Click Help for Address or Instrument for more details. Leave blank if no offset required.

**Extra**: Only used by instruments like the Honeywell HC900 to access the the SPP block’s Profile Descriptor Fields.

**Assign to group**: Use this to give a name to a group of instruments as required.

Note: these instrument properties cannot be changed (will be shown grayed-out) while the instrument is online.

Instruments that are not listed can still be supported by SpecView if they use the Modbus protocol, in that case SpecView's Generic Modbus template can be used. Otherwise, it may be possible for SpecView to communicate with the instrument using OPC.
Alternatively, please contact a SpecView representative.

### 7.2.5 Instrument Views

Instrument Views are a pictorial representation of a connected instrument. In most cases it will look like and have buttons that operate in a similar way to the actual instrument when SpecView is in Runtime Mode.

A simple measurement instrument typically has a single instrument view. A programmable controller will have separate Instrument Views for the programmer module and the controller module. A multi-loop controller will have separate Instrument Views for the programmer module and for each of the loops.

**Adding an Instrument View to a GDW**

To add an Instrument View to a GDW, open the Variables List and drag and drop the instrument's name from the list out onto the GDW.

**Resizing an Instrument View**

An Instrument View cannot be resized on the screen. If a larger (or smaller) Instrument View is required then the graphic can be redrawn manually, grouped and saved as a GDO 'Graphical Display Object' (from the Edit menu) for future use. However, this will not save the variables, therefore each time it is put on the screen the variables will need to be put out manually.

### 7.2.6 SpecView.FastCount Variable

The SpecView Pre-Defined Variable called 'SpecView.FastCount' is a count up counter that counts accurately and continuously at rates up to 100 times per second. This counter can be used as the basis for a Strategy Controller Event that needs to be checked...
SpecView.FastCount can be reset to Zero by writing Zero to it, but writing other values will have no effect.

The counter will count up to 4294967295 and then reset. At a rate of 10 counts per second, this will take about 13.5 years. At 100 per second, it will take about 500 days. The SpecView.FastCount counter is set to Zero whenever SpecView enters Runtime Mode.

The rate at which the counter counts is determined by a value in SETTINGS.INI. SpecView.FastCount will only have a value if this rate is set, otherwise it will show N/R.

In the [RUNTIME] section, add a line:
FastCountRate=MS

Where MS is a number of milliseconds.
Typical values might be:
FastCountRate=500  Twice per second
FastCountRate=100  10 times per second
FastCountRate=50   20 times per second

Note that when using the SpecView.FastCount as a Strategy Controller event, such as: 'Watch for
SpecView.FastCount Changed by 0’, it is possible for the Strategy Controller to miss counts if the
computer is very busy and the FastCountRate is very fast. Although the Event might not trigger for every
change of SpecView.FastCount, the number in SpecView.FastCount will increment at the correct rate.

A typical use of the SpecView.FastCount counter is to write values to a file using the Line Writer
to generate a form of ‘Log File’ faster than the current maximum logging rate of 1 second.

To do this, proceed as follows:

When writing a line with the Line Writer, it is useful to have a better idea of the time interval, since
SpecView.Time is only accurate to 1 second. By setting the FastCountRate=100 will give a 10th of a
second counter.

It is possible to extract the 1/10ths of a second from this as follows:

Create a SpecView Integer user variable set to -1 (e.g. SpecView.MinusOne) and Two SpecView Text
user variables. (SpecView.RawCount and SpecView.LastDigit).

In the Strategy Controller, create an event that does ‘Watch for SpecView.FastCount Changed by 0’
Which has the following actions:
1) Copy SpecView.FastCount to SpecView.RawCount
2) Math Function SpecView.RawCount MINUS SpecView.MinusOne into SpecView.LastDigit
The 1/10th digit will be in SpecView.LastDigit and this can be put into the lines written to the file.

7.2.7 Adding Numeric Values to a GDW

Open the Variables List by clicking on the toolbar

To add value(s) to a GDW, first click the by the instrument you want. Then there are 3 ways to add a variable or parameter to a GDW:

1) Double-clicking on the variable in the Variables List. The value will be put on the GDW in the top left corner. Note: Move objects down the screen before adding more values, otherwise they will all appear on top of each other.

2) Drag & Drop the variable from the Variables List to the required location on the GDW.

3) Multi-select and drag & drop multiple variables from the Variables List onto the GDW.

When a number of variables are multi-selected and dragged out onto the screen they are automatically in Spread Mode to assist when dragging out a number of variables for a table. This is indicated by the large black square ‘handles’ around them. The ‘handles’ can be dragged to adjust the spacing, instead of just enlarging the font. Any group of values can be put into Spread Mode by right clicking on the group and choosing Spread Mode from the popup menu.

Subsequent dragging will use the previous spacing, or use the Reset Spacing menu command from the Options->Multi-Select sub-menu.
To include the variables’ name use the Options->Include Name menu:

If either Options->Include Instrument Name or Options->Include Parameter Name have been selected then:

NOTE: This will mean that when a variable is first displayed on a GDW the name of the variable and its value will be separate objects with their own set of eight handles to show they are selected.
To move either of them drag from the middle of the object.
To move both of them together Group the name and value together using the 'G' or Group Tool

With both Instrument Name and Parameter Name:
With just Instrument Name:

Zone1: 1750.0

With just Parameter Name:

Process Value: 1650.0

Without Name:

1750.0

In either case if the value is not available (either because SpecView is in Edit Mode (Offline) or if the instrument isn’t communicating for another reason) then the ‘N/R’ (No Response Value) will be shown. The ‘N/R’ (No Response Value) can be changed on the Display tab from the Preferences menu command on the File menu:

![Preferences menu](image)

The text font and color are defined using the **Text Font** menu command on the **Object menu**

For details on aligning text **Text Justification**

### 7.2.8 Alarms

An alarm is a status flag within an instrument, which is typically set when a value goes beyond a setpoint. SpecView will display the Alarm box and write an entry into the Alarm logfile when an alarm
status is received from an instrument.

SpecView Boolean User Variables can also be set to be alarms by selecting the boolean variable in the Variables List, clicking the Properties button to display the Variable Properties box and checking Alarm on the Attributes tab. This will cause SpecView to display the Alarm box and write an entry into the Alarm log file when this boolean variable becomes true.

Alarms are configured using Preferences - Alarm, by an action from a button or via the Strategy Controller. To view the Alarm window at any stage during Runtime, use either the Alarm/Event menu or the button action Alarms: Show Alarm List

Using the Strategy Controller's Run External Program it is possible to launch a program when an alarm occurs, for example, one which sends an email or SMS text msg to the operator's mobile phone, this is described in more detail in the User Guide.

7.2.9 Dynamic Attributes Box

This is accessed from the Dynamic Attributes menu command on the Edit menu.
Dynamic Attributes - Variables
On a GDW values of variables have Dynamic Attributes, a Bar chart will also have the Dynamic Attributes of the variable that it is associated with.

The Dynamic Attributes menu command on the Edit menu also allows for the setting of attributes from many objects in a selection (not a group). This allows quick changes of Recipe level or scan rate for a number of items.

Variable
The name of the variable in this box may be edited directly.
If the new name is not valid this box will appear:

Check the exact spelling on the Variables List.

However, the preferable method for changing a variable's name is to use the Replace menu command on the Edit menu. As this will change all references to this variable name on this GDW to the new name.

In Recipe / Level
In Recipe is checked if this variable is included in this GDW's Recipe and can only be changed using the Recipe Mode
The Level, can be changed and determines the order that the values will be sent to the instruments.

Scan Rate
Sets the rate SpecView gets the value from the instrument. Use this setting to change the rate at which the value of a variable is read over communications.
The times associated with the four settings are defined under the File Menu - Preferences

Display Format
The Display Format determines how the data is displayed.
Sets the number of *decimal places* used to display a numeric value on a GDW.

**Free** - means that the display will take the value reported by communications.

**D.P. Sci** - means display in scientific format.

**Hex** - (Integers only) display in hexadecimal

Some examples are:

- **Process Value: 17.7**
- **Process Value: 1.8E+001**
- **Process Value: 1.77E+001**
- **Process Value: 1.770E+001**
- **SpecView.Integer1: 45**
- **SpecView.Integer1: 2D**

*NOTE: Some instruments send data to SpecView with the correct number of decimal places identified. Others, such as Modbus, do not tell SpecView how many decimal places the variable has. Set the number of decimal places from the Variables List Variable Properties (Add/Rename Instrument) box.*

### 7.2.10 Color Dynamics

This box allows you to setup how the color of the following:

- Value of a variable
- Button
Graphical drawing object
- Grouped object

will change based on the value of a variable:

When this box is checked the outline color of the object will change to the selected color. Unchecked the outline color will stay the same. Up to four color changes per variable can be specified so that with the default fill color a total of five colors are available.

**NOTE:** A different variable and test can be selected for each level. The last one defined will have priority over the others.

If the update rate of the Color Dynamics appears to be slow, then ensure that the actual value of a variable is on an open screen. This will ensure that the value, and hence the Color Dynamic, is regularly updated.

It is also a good idea to ensure that the items on the screen which have Color Dynamics are not Grouped together with other items.
7.2.11 Position Dynamics

Position Dynamics allows objects on the screen to be positioned according to the value of a variable, this is useful for animation of an object.

For example: a fan spinning or an object disappearing, etc.

Or the progress of a product along a conveyor belt, as shown here:

To setup Position Dynamics, for example: a carton on a conveyor belt, follow these steps:

- From ‘Edit Mode’ put the object on the screen (in this example, a bitmap of a carton) and select it.
- Either choose ‘Position Dynamics’ from the Edit menu or right-click and choose ‘Position Dynamics’ from the popup menu.

Note: if this menu item is not enabled go to the ‘Online Features’ menu and either uncheck the ‘Position Dynamics’ menu item, or choose ‘Disable All’. This is because if Position Dynamics could be set up while ‘Online’ then the value could change causing the object to move.
- Drag and drop the variable, from the Variables List, this will be used to determine the position of the object.

- If the object is not in the first position then move it there by dragging, and click the ‘Add Waypoint’ button and enter the value for the first position into the Value cell. This will mean that when the variable has this value the object will be positioned at this location.

- Move the object to the next position required for the next waypoint and click ‘Add Waypoint’ and enter the Value in the cell for that position. Etc…

- When all waypoints have been entered it is possible to verify them by clicking on each waypoint in the list in turn and see the position of the highlight change. When finished, click OK.

Once the object has the waypoints set then if the variable is an Instrument variable then when that value changes the object will move according to the waypoints.

If the variable used is a SpecView User Variable then the Strategy Controller will need to be used to change the value as required.

Position Dynamics can be setup on the following types of objects:
- Lines
- Rectangles
- Rounded rectangles
- Ellipses
- Polygons
Bitmaps  
Text items  
Buttons  
Bar charts  
ActiveX controls  
Groups of objects  
OLE objects

The types of variable that can be used to determine the position of an object in Position Dynamics are:
- Booleans - these are good for ‘On/Off’ or ‘disappear/appear’ etc.
- Integers – these can be used for multiple positions
- Numbers
- Countdown timers
- Countup timers
- Enums
- Text items
- Dates
- Times
- TimeMSs

The Choose Variable button re-opens the Variables List box, this is because while the Position Dynamics box is being displayed the main SpecView toolbar & menubar to access the Variables List are disabled.

Add Waypoint and Remove Waypoint buttons add or remove a waypoint.

Move Waypoint button – Click on a waypoint in the list to select it, then move the object to its new position and click ‘Move Waypoint’ to set that position as the waypoint.

Move Up and Move Down buttons changes the order of the waypoints in the list. The order of the waypoints is immaterial to the Position Dynamics, but having them in a logical order just makes it clearer to the user.

Note: It is not possible to setup waypoints when Online in Edit Mode, this is because if Position Dynamics could be setup while Online then the value could change causing the object to move unexpectedly. Therefore on the Online Features menu the Position Dynamics menu item should be unchecked.

7.2.12 Insert New Object

Accessed from the Insert New Windows Object menu command on the Edit menu.

NOTE: Use this command with caution. SpecView can only offer limited support as it uses features of Windows which are outside our control. This command has been known to cause problems with SpecView. Make a backup of your project before proceeding. It is particularly recommended NOT to use this for inserting bitmaps. Use the tool instead.

SpecView does not allow you to access another program using this feature in Runtime Mode so it should be primarily used for graphics objects.
7.2.13 Edit Links

Accessed from the Links menu command on the Edit menu.

NOTE: Use this command with caution. SpecView can only offer limited support as it use features of Windows which are outside our control. This command has been known to cause problems with SpecView. Make a backup of your project before proceeding.

This will insert a new object from another Windows program into the GDW. The box below inserts an existing object.
This menu command will only be enabled if the Link checkbox was checked when inserting an object using Insert New Windows Object on the Edit menu. The Windows object (for example a Word document) would then be linked to the actual document, such that should it be updated then the one shown in SpecView would be updated too.

The Links command on the Edit menu shows the Windows objects that have been linked to:

![Insert Object dialog box](image1)

![Links dialog box](image2)
7.2.14 Quick List Setup

The Quick List is a method of marking particularly important parameters/variables from ALL instruments and User Variables in the Variables List, such that their values can be easily accessed and modified from Runtime Mode.

The Quick List is opened in Edit Mode by clicking the \( QTV \) on the toolbar, which also opens the Variables List.

Drag & drop variables from the Variables List into the Quick List.

Drag & drop within the Quick List to change the order of the variables.

There is only one Quick List, but the Quick List can contain variables from any instrument and any User Variables.

When passwords are enabled access to the Quick List can be restricted.

If Screen Values is checked on the Online Features menu:
- Live values can be seen in the Quick List in Edit Mode.
- Writeable values can be changed by clicking the Alter button. The Alter button is disabled if the variable is read-only.

The Quick List can be viewed from Runtime Mode from the View menu.
There is also a Button Attribute and Strategy Controller Action to invoke the Quick List List from Runtime Mode.
If the Quick List window has been dragged off the screen such that it now can't be seen then its position can be reset using Preferences - Settings from the File menu.

See also: Quick List in Runtime Mode

### 7.3 Drawing Basics

The Draw menu and Tools are accessed from the Edit Mode menubar. They are used to draw graphics on a GDW. You can also add Bitmaps (.bmp files) to a GDW.

Menu:
SpecView uses most standard Windows rules for drawing:
- Selecting, Grouping and Saving Objects
- Shape Properties
- Selecting objects in front or behind others
- Quick Copying of Drawing Objects

**NOTE:** Do not use Cut, Copy and Paste (or Ctrl Copy) to move or duplicate objects that have variables. This includes Instrument Views, Trend and Bar Charts.

Click the tool for the type of object you want

The pointer will change to depending on the tool

Click on the screen (and HOLD DOWN THE MOUSE BUTTON) where you want the top left part of the object, and drag the mouse down and to the right.
Release the mouse button when you have the size you want.

**NOTE:** The **POLYGON** tool follows different rules from lines, rectangles etc.

The cursor does not automatically change back to the pointer after you draw the object. Use the:
- Left mouse button to draw another object OR
- The Right Mouse Button to get the normal pointer OR

Click the Select Tool on the toolbar

Hold the Shift key when drawing to:
- Snap lines to vertical, horizontal etc.
- Snap rectangles to squares
- Snap ellipses to circles

**NOTE:** Once drawn use the Handles to adjust the object
- Use the corner ones to resize with the same aspect ratio
- Use the corner ones **while pressing the Shift key** to change the aspect ratio
- Use the side ones to adjust width/height

**Drawing an Arc**
To draw an arc, first draw an ellipse of the required diameter, then use the **polygon** tool to trace the part of the circle you require, then delete the circle.

**Positioning and object**
Use the mouse to drag an object to position it, OR use the cursor keys to nudge the object by one pixel OR hold the Shift key down while using the cursor keys to jump by one grid position. (The size of the grid is set using **Set Grid Sizes** on the View Menu)

### 7.3.1 Selecting, Grouping, Moving and Saving Objects

Use the **Select Tool** OR the right mouse button to get the standard pointer
Click an object to select it
To select (or de-select) multiple objects press and hold the Shift or Ctrl key and click the object(s) OR
Click away from any object and drag the mouse while holding down the mouse button.
All objects **touched** by the dotted rectangle will be selected.

**NOTE:** SpecView draws an imaginary box around each object. **Touching the object means touching this imaginary box. You may select objects (especially lines drawn diagonally) that you do not expect to be included.**

When more than one object has been selected they may be Grouped using the **Object Menu - Group**

or the Group tool on the toolbar or press ‘G’ on the keyboard.

All objects Selected:
After Grouping:

**Objects in front/behind others**

Grouped objects may be saved (as GDO files) and reused with the Save Object and Load Object menu commands on the Object Menu.

**UnGrouping Objects:**
Select the group and use Object Menu - UnGroup or the UnGroup tool on the toolbar or press 'U' on the keyboard.

**Moving Objects:**
Cursor keys can be used to nudge objects, or multiple selected objects, or groups of objects on a screen (GDW) by one pixel, this is very useful when aligning objects by eye.

Dragging an object on the screen using the mouse, or holding the SHIFT key down while using the cursor keys, will make the object jump by one grid increment, whichever grid size is active at the time. The position of the object relative to the grid will be preserved.

The grid sizes are specified using Set Grid Sizes on the View menu and the grid size to be used is selected by choosing Toggle Grid Lines from the View menu or pressing CTRL-G to cycle through them.

To align an object with the grid use Object->Align->Realign To Grid.
To nudge an object by one pixel regardless of the grid, use the cursor keys on the keyboard (without the SHIFT key).

**Copying and Pasting of Objects:**
Objects on a screen (GDW) can be copied & pasted or cut & pasted without losing their associations with parameters or variables or Dynamic/Color Attributes.
and will work while Live Values are enabled from the Online Features menu.

Copy and paste can be done using the Edit menu, or by using CTRL-C CTRL-V to copy & paste or CTRL-X CTRL-V to cut and paste.

To make a clone of an object on the screen hold both the SHIFT and CTRL keys when clicking. However, clones of objects will NOT retain their associations with parameters or variables or Dynamic/Color Attributes.
Note that the word ‘group’ has 2 meanings in SpecView:
1. When objects are grouped together on the GDW so they can be moved all together, as described above.
2. When instruments and/or parameters and/or variables are grouped together into a named logical group within the Variables List.

### 7.3.2 Shape Properties

Double-clicking on an object OR right-clicking and choosing Properties will bring up the Shape Properties box.

![Shape Properties dialog box](image)

- **Outline Weight** changes the line thickness of the border where 0 = No Border.
- Check the **Filled** box to fill the object with the currently selected Fill Color.
- To change the color use the Fill Color menu item on the the Object Menu.

**NOTE:** With no Fill, the object is transparent - you can see objects underneath.

To mask objects, fill the object with the Screen Color (which is set from the View Menu).

### 7.3.3 Objects in front / behind others

Objects can be arranged in layers, one on top of another. If an object is masked by another, then it will need to be moved out of the way.

The easiest way to do this is to select the one that is in the way and then use Move to Back or Move Back from the Object menu, which will reveal the one behind.

However, an alternative way to select the object(s) underneath is to click the top object WITHOUT MOVING THE MOUSE click again. The object underneath will be selected even though you might not be able to see it. (If you hold the mouse button and drag, the object underneath will move.)

Subsequent clicks without moving the mouse selects successive layers down.

This shows the second object selected:
7.3.4  Quick Copying of Drawing Objects

To make a copy of an object (or Group of objects):
1. Press and hold both the Shift and Ctrl keys
2. Left-click the object and drag the mouse
A copy of the selected object will be made.

To copy an object between GDW's use either:
• The Edit menu (Cut, Copy, Paste) OR
• Ctrl-X (Cut), Ctrl-C (Copy), Ctrl-V (Paste) OR
• Use the Save SpecView Object or Load SpecView Object menu items from the Object menu

7.3.5  Select Tool

Use the Select menu command from the Draw menu OR click the Select tool on the toolbar.

Selects the normal Pointer (or Cursor) and de-selects any drawing tool.

**NOTE: The right mouse button has the same action as this function. It is a useful and quick way to de-select a drawing tool. Try drawing a rectangle and then click the right mouse button.**

Click an object to select it.

Eight Handles show that the object is selected.
Moving the pointer to one of the handles allows you to re-size the object.

7.3.6  Line Drawing Tool

Use the Line menu item from the Draw Menu OR click the Line tool on the toolbar.

The cursor changes to → Click and hold the left mouse button, then drag the line to the desired length and direction. Click the right mouse button when you have drawn all the objects you want. Press and hold the shift key to snap the line to the nearest multiple of 15 degree angles
Use the Ctrl Copy feature to make exact copies of the object
Double-Click the object to edit the Shape Properties
7.3.7 Rectangle Drawing Tool

Use the Rectangle menu item from the Draw Menu OR click the Rectangle tool on the toolbar.

Go to Drawing Basics for general instructions.

The cursor changes to . Click and hold the left mouse button, then drag the rectangle to the desired size. Click the right mouse button when you have drawn all the objects you want.

Press and hold the shift key to snap to a square.

Use the Ctrl Copy feature to make exact copies of the object.

Double-Click the object to edit the Shape Properties.

7.3.8 Round Rectangle Drawing Tool

Use the Round Rectangle menu item from the Draw Menu OR click the Round Rectangle tool on the toolbar.

Go to Drawing Basics for general instructions.

The cursor changes to . Click and hold the left mouse button, then drag the rectangle to the desired size. Click the right mouse button when you have drawn all the objects you want.

Press and hold the shift key to snap to a square.

Use the extra Handle in the top right corner to change the radius of the corners.

Use the Ctrl Copy feature to make exact copies of the object.

Double-Click the object to edit the Shape Properties.

7.3.9 Ellipse Drawing Tool

Use the Ellipse menu item from the Draw Menu OR click the Ellipse tool on the toolbar.

Go to Drawing Basics for general instructions.

The cursor changes to . Click and hold the left mouse button, then drag the ellipse to the desired size. Click the right mouse button when you have drawn all the objects you want.

Press and hold the shift key to snap to a circle.

Use the Ctrl Copy feature to make exact copies of the object.

Double-Click the object to edit the Shape Properties.

7.3.10 Polygon Drawing Tool

Use the Polygon menu item from the Draw Menu OR click the Polygon tool on the toolbar.

© 1995 - 2015 SpecView
NOTE: This tool uses different rules from the other drawing tools.

1. At the start point of the polygon click and release the mouse button.
2. Move the mouse to the next apex and click and release again.
3. Repeat for all the apexes.
4. To finish the polygon EITHER double-click the left button OR click the right button or press the Esc key.

Polygons may be re-sized by clicking on an apex and dragging the mouse.
Use the Ctrl Copy feature to make exact copies of the object.
Double-Click the object to edit the Shape Properties.

7.3.11 Bitmaps on a GDW

Use the Bitmap menu item from the Draw Menu OR click the Bitmap tool on the toolbar.

Go to Drawing Basics for general instructions.

Locate the bitmap file and click OK and the bitmap will appear on the GDW.
Double-Click the bitmap to edit its Properties.
7.3.12 Bitmap Properties

To see the **Bitmap Properties** (also known as Bitmap Attributes) box right-click on the bitmap and choose **Properties**.

**NOTE:** Some video cards are known to have problems sizing bitmaps so SpecView Bitmaps are fixed to their original size by default

![Bitmap Attributes dialog]

Uncheck **Fix to Original Size** then click **OK**, the bitmap can now be re-sized.

7.3.13 Text on a GDW

Use the **Text** menu item from the **Draw Menu** OR click the Text tool on the toolbar

Use this command to put fixed text on a GDW (so the text is NOT editable in Runtime Mode)  
(To put editable text on a GDW use a **SpecView Text User Variable**)

Go to Drawing Basics for general instructions

The cursor changes to . Click on the GDW where you want the text and the **Text Attributes** box will appear

Click the right mouse button when you have added all the text objects you want.

Use the **Ctrl Copy** feature to make exact copies of the object.

Double-Click the object to edit the **Text Attributes**

7.3.14 Text Properties

To see the **Text Properties** (also known as Text Attributes) box right-click on the text and choose **Properties**.
Text Item
Enter the text you want to appear on the GDW.
To enter a new line hold down the CTRL key while pressing the Enter key.
To enter an ampersand '&' enter two ampersands '&&', so 'Gadgets & Widgets' should be typed 'Gadgets && Widgets'.

Choose Font
Selects the font for THIS text. To change the font for ALL text you are going to put on the GDW, use Text Font on the Object Menu.
Justification
Align the text for best appearance:

Left Justified  Center Justified  Right Justified
Text aligned to the left  Text aligned to the center  Text aligned to the right

NOTE: Numeric Values added to a GDW that INCLUDE the name are LEFT justified.
Numeric Values added to a GDW that DO NOT include the name are RIGHT justified

Object Name - Text
This information is for SpecView diagnostic purposes only

7.3.15 Trend Chart Drawing Tool

Trend charts graph (or plot) variables with respect to time.

Use the Trend Chart menu item from the Draw Menu OR click the Trend Chart tool on the toolbar

Go to Drawing Basics for general instructions

After clicking the tool the cursor changes to
Use the tool as you would to draw a rectangle. As you move the mouse the Trend chart appears:

When you release the mouse button the Trend Chart Properties box and the Variables List are displayed. Use these to set up the Trend chart.

For further information:
Setting up Trend Charts
Using Trend charts in Runtime Mode

7.3.16 Bar Chart Drawing Tool

Use the Bar Chart menu item from the Draw Menu OR click the Bar Chart tool on the toolbar

Go to Drawing Basics for general instructions

After clicking the tool the cursor changes to
Use the tool as you would to draw a rectangle.

When you release the mouse button the Bar Chart Setup box and the Variables List are displayed. Use these to set up the Bar chart.

7.3.17 Buttons - Drawing on a GDW

Use the Buttons menu item from the Draw Menu OR click the Buttons tool on the toolbar

Go to Drawing Basics for general instructions

Buttons are used for specific actions such as switching to another screen (GDW), controlling Recipes and starting other programs.

The cursor changes to Click and hold the left mouse button, then drag the button to the desired size. Click the right mouse button when you have drawn all the buttons you want.
Double-Click the button to edit the Button Attributes

Once the Button Attributes have been defined the button can be made to change color on an event using Color Dynamics

Buttons can also have multi-line text, different fonts or bitmaps on them.

To enter an ampersand '&' enter two ampersands '&&', so 'Gadgets & Widgets' should be typed 'Gadgets && Widgets'.

7.4 Trend Charts

Trend charts graph (or plot) variables with respect to time:
Bar Charts

Bar Charts display variables as a moving vertical or horizontal bar.

Adding a Bar Chart to a GDW

The mouse pointer changes to: Click and drag a rectangle to the shape you want for the Bar chart. When you release the mouse button the Bar Chart Setup box and the Variables List are displayed.

**NOTE:** Bar Charts can also be used with boolean (on-off) variables. Set the bottom value to 0 and the top value to 1. This can be used to indicate alarms.

Bar Chart Setup
Bar Chart - Variables List
Drag and drop the variable to be displayed on the chart from the **Variables List** into the **Variable** field.

Bar Chart - Orientation
Vertical charts grow up / down with increasing values
Horizontal charts grow left / right with increasing values

Growth Direction
Determines the growth direction with increasing value
Use the Grow Up and Down check box (Left and Right) for variables that can go negative such as Deviation/Error and Output Power in heat/cool controllers

Bar Chart - Click Bar Action
If the variable is **writeable**, checking this box will allow the variable to be changed by clicking on the chart

Bar Chart - Scales

Shows a scale on the chart:

Bar Chart - Show Value in Bar
Shows the numeric value of the Variable in the chart:

*NOTE: Use a light chart color to make the numbers more visible*

**Bar Chart - Font and Color**
Sets the Font and outline Colors for the Border, Scales and Values shown on the chart

*NOTE: To make the chart disappear when empty, set this outline color to the same as the GDW Paper Color (accessed from the View Menu)*

**Bar Chart - Fill (empty) Color**
The color of the empty part of the chart is set by the Fill Color from the Object Menu.
Firstly ensure that the Bar Chart Setup dialog does not have the Transparent box checked.
Single Click the chart to select it (Do NOT double-click)
On the Object Menu select Fill Color
Choose the color from the palette

**Bar Chart - Top (Left) and Bottom (Right) Values**
Sets the minimum and maximum values of the displayed chart
For ± Variables (Deviation, Output Power with heat/cool) set the Bottom (Right) value to a negative number

**Bar Chart - Color When Up (Left) and Down (Right)**
Sets the color for the value part of the chart

### 7.6 Button Attributes & Strategy Controller Actions

The same list of actions is available for both Buttons and Strategy Controller Actions.

This box selects the action that will happen when the button is clicked (in Runtime Mode)

*NOTE: to display this box for a button double-click the button in question.*
**Button Attributes**

- **Caption:** Close
- **F-key:** None
- **Action:**
  - GDW: Close this screen
  - GDW: Print Screen
  - GDW: Swap to another GDW
  - GDW: Toggle Full Screen mode
  - GDW: Zoom in
  - GDW: Zoom out
  - History: Start Replay
  - Logging: Convert Specific Log File Format
  - Logging: On/Off
  - Logging: Purge Log Files
  - Logging: Show Log File Convert Manager
  - Parameters: Alter Value interactively
  - Parameters: Copy From...To
  - Parameters: Download Specific Value
  - Parameters: Math Function
  - Parameters: Show Full Parameter List
  - Password: Log In or Log Out

**Button Caption**
This is a function of the Button Attributes box
Enter the text you want on the button

**Function Keys**
This is a function of the Button Attributes box
Select a Function Key to have the same action as clicking on the button

**Button Bitmap and Resize to fit text check boxes**
Allows the button to contain a bitmap instead of text.

**Button Text, Font & Background Color**
Allows the button’s font and color to be defined.

**Button Actions**
(Those marked with an asterisk are not available from the Strategy Controller):
- Alarm: Acknowledge Alarms
- Alarm: On/Off
- Alarms: Show Alarm List
- Events: Show Event List
- GDW: Clear Trend Charts
- GDW: Close this and Swap To GDW
- GDW: Close this screen
GDW: Print Screen
GDW: Swap to another GDW
GDW: Toggle Full Screen Mode
* GDW: Zoom in
* GDW: Zoom Out
* History: Start Replay
Logging: Convert Specific Log File Format
Logging: On/Off
Logging: Purge Log Files
* Logging: Show Log File Convert Manager
Parameters: Alter Value Interactively
Parameters: Copy From...To
Parameters: Download Specific Value
Parameters: Math Function
* Parameters: Show Full Parameter List
* Password Log In or Log Out
Quick List: Show Quick List
Recipe: Download Specific Recipe
Recipe: Show Recipe Manager
Recipe: Show Recipe Manager (Read Only Mode)
Recipe: Show Recipe Manager (Read Only Send To Mode)
Recipe: Show Recipe Manager (Send To Mode)
* SpecView: Enter Edit Mode
SpecView: Exit Program
SpecView: Maximize screen, Minimize screen, Restore screen
SpecView: Run External Program
SpecView: Write Line to file/printer

7.6.1 Alarm: Acknowledge Alarms

This Button/Strategy Controller Action will cause all outstanding alarms to be acknowledged. This will also cause the SpecView variables: AnyAlarm and NewAlarm to be set to 'Off'.

7.6.2 Alarm On/Off

This Button/Strategy Controller Action turns alarm checking On and Off and sets the rate at which alarms are checked

A rate of 5 seconds (the default) means that SpecView will check the booleans identified as alarms every 5 seconds. A value of 0 seconds will disable alarm checking.
See also: Adding variables to Alarm Monitoring

7.6.3 Alarms: Show Alarm List

This Button/Strategy Controller Action will open the Alarm list (duplicates the function of the View Alarm Window menu command on the Alarm/Event menu)

7.6.4 Events: Show Event List

This Button/Strategy Controller Action will open the Event list (duplicates the function of the View Event Window menu command on the Alarm/Event menu)

7.6.5 GDW: Clear Trend Charts

This Button/Strategy Controller Action will clear all the pen lines from all the trend charts on a specified GDW.

If the current GDW is not listed in the drop down list then click the Save tool on the toolbar first.

7.6.6 GDW: Close this and Swap To GDW

This Button/Strategy Controller Action will swap to another GDW and close this GDW

NOTE: Use this action when swapping from a GDW that is only used occasionally such as setup screens. This is because a GDW left open will automatically be continually refreshed in the background and this wastes communications bandwidth.

Choose which GDW to swap to from the drop down list:

<table>
<thead>
<tr>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>GDW: Close this and Swap To GDW</td>
</tr>
<tr>
<td>Swap To:</td>
</tr>
<tr>
<td>&lt;Current GDW&gt;</td>
</tr>
<tr>
<td>ALL-FOUR.GD3</td>
</tr>
<tr>
<td>COOL1.GD3</td>
</tr>
<tr>
<td>COOL2.GD3</td>
</tr>
</tbody>
</table>

NOTE: This will clear the pen lines on any Trend chart(s) on the currently open GDW.

To swap to another GDW screen without closing and clearing the pen line(s) use GDW Control: Swap to another GDW
7.6.7 **GDW: Close this Screen**

This Button/Strategy Controller Action will close this GDW.

Note: The last GDW cannot be closed.

---

7.6.8 **GDW: Print Screen**

This Button/Strategy Controller Action will cause the selected GDW to be printed.

Selecting a GDW from the list will cause just the contents of that GDW to be printed.

Selecting <Current GDW> will cause just the contents of the currently displayed GDW to be printed.

Selecting JPG will put an image of the whole screen, including the Windows task bar if it is visible (not just the contents of the GDW) to a .JPG (Jpeg format) file.

The filename of the file that is created has the date and time in the format: YYYYMMDD_HHMMSS.JPG

The file is written to the current Project folder. If more than one request to print 'JPG' is made at the same second, then the file will be overwritten.

When this command is used as an Action in the Strategy Controller, then SpecView will force File-\>Auto-open on Runtime for that GDW.

See also the Runtime mode menu commands: 'Print...' and 'Print to JPG' on the File menu and the Edit mode menu commands: 'Print Preview' and 'Print to JPG' on the File menu.

---

7.6.9 **GDW: Swap to another GDW**

This Button/Strategy Controller Action will swap to the GDW selected in the drop down box.

**NOTE:** Use this action when swapping from a GDW that is used frequently, especially those with Trend charts. All variables on a GDW left open will be updated in the background.
7.6.10 **GDW: Toggle Full Screen Mode**

This Button/Strategy Controller Action enables & disables Full Screen Mode.

Once Full Screen mode has been enabled there will be no menus accessible, therefore it is STRONGLY recommended that a button with this action should be added to the GDW to reverse the command. (This button may be placed on another GDW accessed by a button with the action: GDW Control: Swap to another GDW).

7.6.11 **GDW: Zoom in**

This Button Action will zoom in, enlarging the size of the graphics & text within the GDW. This duplicates the function Zoom - Up on the Zoom menu. This action is not available from the Strategy Controller.

This command will not affect the size of bitmaps or Instrument Views on the GDW. Note: This action is not available from the Strategy Controller.

7.6.12 **GDW: Zoom Out**

This Button Action will zoom out, decreasing the size of the graphics & text within the GDW. This duplicates the function Zoom - Down on the Zoom menu. This action is not available from the Strategy Controller.

This command will not affect the size of bitmaps or Instrument Views on the GDW. Note: This action is not available from the Strategy Controller.

7.6.13 **History: Start Replay**

This Button Action will start Historical Replay on this GDW. This action is not available from the Strategy Controller.
7.6.14 **History: Find Batch**

This Button Action will start Historical Replay on this GDW and open the Find Batch Number box.

This action is not available from the Strategy Controller.

7.6.15 **Logging: Convert Specific Log File Format**

This Button/Strategy Controller Action will convert a specific log format

<table>
<thead>
<tr>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Logging: Convert Specific Log File Format</td>
</tr>
</tbody>
</table>

| Furnace1                                       |
| Lower Level Report                             |
| Upper Level                                    |

7.6.16 **Logging: On/Off**

This Button/Strategy Controller Action turns data logging On and Off. It is usually used as an Action in the Strategy Controller

The logging rate will be changed to this value when the button is clicked

A value of 0 seconds turns off data logging

<table>
<thead>
<tr>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Logging: On/Off</td>
</tr>
</tbody>
</table>

Rate in secs (0 = Off): 0

The current value for the logging rate is stored in the SpecView Variable LogRate.

This variable's initial value when entering Runtime mode will be the value set from Preferences - Logging

The variable is Read-Only and cannot be changed during Runtime mode, other than by using this action.

**NOTE:** This button action only changes the logging rate for THIS Runtime session. To change the default log rate use Preferences - Logging.
7.6.17 Logging: Purge Log Files

This Button/Strategy Controller Action will cause the log files older than the specified number of days to be TOTALLY deleted.
This will also delete any Batch Tag information associated with those log files.
Logging can be enabled/disabled and the logging rate specified using the action Logging: On/Off

**NOTE:** Ensure there is a reliable backup stored elsewhere before using this button action - this action is irreversible.

7.6.18 Logging: Show File Convert Manager

This Button Action displays the Log Report Setup box.
This has the same effect as the Convert Log File menu command on the Logging menu.

This action is not available from the Strategy Controller.

7.6.19 Parameters: Alter Value Interactively

This Button/Strategy Controller Action will have the same action as clicking on the variable.
Choose the desired variable from the Variables List.

7.6.20 Parameters: Copy From.. To

This Button/Strategy Controller Action will value of the first variable to the second variable.
In the example below the setpoint of Barrel Zone 2 will be copied to Barrel Zone 3:
The Copy Value Button attribute (or Strategy Controller action) will copy a value from one parameter to another. In general, the source and destination of the copy should be the same type, but some type conversions are allowed, as below:
### Parameters: Download Specific Value

This Button/Strategy Controller Action will *immediately* download the value to the instrument. The settings below will cause the Zone1 instrument's Local SP1 to be set to 50.0:
The box below shows how to set a SpecView DateTime1 User Variable to the current computer date and time:

In the Strategy Controller if the type of the variable that has been selected is a Boolean then this action has an 'Auto reset bool' checkbox:
The "Auto reset bool" checkbox changes the behavior of the button so that the value is only changed for as long as the button is held down. When the Button is clicked DOWN, the specified value is sent (for example, 'On') and when the button is released UP, the Auto-Reset happens and the opposite value is sent (for example, 'Off'). This is could be used for a button to set a digital output just for the duration of the button press.

7.6.22 Parameters: Math Function

This Button/Strategy Controller Action allows limited amounts of mathematical and other operations to be performed on Parameters.

Math functions always take the form of:
'Copy From Parameter' <Math Function> 'Operator Parameter' -> 'Copy To Parameter'
The settings below will write the value of Screw Speed x Drive Ratio to Roll Speed
The parameters chosen for the 'From', 'Operator' and 'To' fields should usually be of the same type. For example, you cannot take a date, divide it by a boolean and put the result into a text type. There are however, some exceptions listed in the table below. If you must do math on items of different types not listed below, then use the appropriate Copy Facilities to copy the value(s) to the correct type first.

**NOTE:** This feature can be used to extract part of the text, such as one read from a barcode reader.
<table>
<thead>
<tr>
<th>CopyFrom Type</th>
<th>MathFunction</th>
<th>Operator Type</th>
<th>CopyTo Type</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>Time</td>
<td>Any</td>
<td>Number (with decimals)</td>
<td>Time</td>
<td>Appropriate math is done on the time, e.g Multiply a time by 2.0</td>
</tr>
<tr>
<td>Text</td>
<td>Add</td>
<td>Text</td>
<td>Text</td>
<td>Concatenation. Use to add 2 pieces of text together.</td>
</tr>
<tr>
<td>Text</td>
<td>Subtract</td>
<td>Integer</td>
<td>Text</td>
<td>Left or Right function. If the Integer is positive, the Left-most 'x' characters are taken. If the integer is negative, the Right-most 'x' characters are taken. Examples:'ABCDE' Subtract 2 -&gt; 'AB' 'ABCDE' Subtract -2 -&gt; 'DE'</td>
</tr>
<tr>
<td>Text</td>
<td>Divide</td>
<td>Integer</td>
<td>Text</td>
<td>Mid function. The characters from the 'x'th position onward are taken, until the end of the text (First position is 0). Example:'ABCDE' Divide 2 -&gt; 'CDE'</td>
</tr>
<tr>
<td>Text</td>
<td>Multiply</td>
<td>Text</td>
<td>Integer</td>
<td>Find function. The integer is setup with the position of the first occurrence of &quot;Operator Text&quot; in the 'Copy From' text. If the text is not found, -1 is used. Example:'ABCDE' Multiply 'BC' -&gt; 1'ABCDE' Multiply 'FRED' -&gt; -1</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Bool</th>
<th>Add</th>
<th>Bool</th>
<th>Bool</th>
<th>AND function.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bool</td>
<td>Subtract</td>
<td>Bool</td>
<td>Bool</td>
<td>NOT function. Note that the Operator Parameter is not used, but must be specified. Use the same parameter for the Copy From and the Operator. The 'Copy To' boolean is setup with the opposite state of the 'Copy From' boolean.</td>
</tr>
<tr>
<td>Bool</td>
<td>Multiply</td>
<td>Bool</td>
<td>Bool</td>
<td>OR function.</td>
</tr>
<tr>
<td>Bool</td>
<td>Divide</td>
<td>Bool</td>
<td>Bool</td>
<td>XOR function</td>
</tr>
</tbody>
</table>

| Number or Integer or Enum or Time | Add or Subtract or Multiply | Number or Integer or Enum or Time | Bool | If the result of the math is 0, then the bool will be Off, if the result is non-zero, then the bool will be On. This allows an Enumerated Alarm to be 'translated' into On/Off. Note: The other Math types will all result in Bool being set to Off. |

The following three math functions use variables of type integer or number (with decimals):

- The Abs Math Function takes the first Copy From value and puts into the Copy To variable the absolute value (the positive value) of it. However, it is also necessary to specify the second Copy From variable so set it to be the same variable name as the first.
• The Max Math Function takes the two Copy From values and puts the higher value into the Copy To variable.

• The Min Math Function takes the two Copy From values and puts the lower value into the Copy To variable.

Doing math on types not listed above or not of the same type will usually result in no action being performed. Occasionally however, unpredictable results may occur. To avoid confusion, only perform math on items of the same type, or those listed above.

7.6.23 Parameters: Show Full Parameter List

This Button Action will display the parameter list of the selected instrument.

Whether the full list or short list will be displayed is determined by the Options menu.

This action is not available from the Strategy Controller.

To display a list of selected variables either customize which ones are included in Short List, or use the Quick List.

7.6.24 Password: Log In or Log Out

This Button Action will display the Password login dialog from the Password menu.

This action is not available from the Strategy Controller.

7.6.25 Quick List: Show Quick List

This Button/Strategy Controller Action will cause the Quick List to be displayed.
Recipe: Download Specific Recipe

This Button/Strategy Controller Action will download the selected Recipe. It allows you to download a Recipe from any other GDW. It is often used from the Strategy Controller.

Follow these steps:
- In Edit Mode put the variables that are going to be changed by the recipe onto the GDW from the Variables List.
- On the required GDW select the variables for recipe using the Recipe tool on the toolbar.
  - Note: This tool won't work if the objects are grouped together - so remember to un-group them.
- Create the boolean variables to use to indicate success/failure of the recipe download.
- From runtime mode create the named set(s) of recipe values using the Recipe Manager and save them.
- Then back in Edit Mode it will now be possible to select the GDW the Recipe is on from the drop-down list, then choose the specific Recipe, as shown:

Recipe Download Booleans
SpecView user variables (booleans) can be set on success or fail of a Recipe download. This most often used when a Recipe is downloaded unattended using the Strategy Controller.

NOTE: The user must arrange for the booleans to be turned off, either manually or using the Strategy Controller.
7.6.27  **Recipe: Show Recipe Manager**

This Button/Strategy Controller Action will display the Recipe Manager (This is the same action as the Recipe Management menu item on the Recipe menu)

The steps to setup a recipe are described briefly [here](#) or in more detail [here](#)

7.6.28  **Recipe: Show Recipe Manager (Read Only Mode)**

This Button/Strategy Controller Action will display the Recipe Manager in the Read-Only mode, this prevents the user from being able to change or create new recipes.

The steps to setup a recipe are described briefly [here](#) or in more detail [here](#)

7.6.29  **Recipe: Show Recipe Manager (Read Only Send To Mode)**

This Button/Strategy Controller Action will display the Recipe Manager in the Read Only - Send To mode. This is used when there is more than one identical instrument that the recipe could be sent to, and allows the instrument(s) to be chosen. This will only send instrument variables to the specified instrument, it will not affect SpecView User Variables.

This also prevents the user from being able to change or create new recipes.

The steps to setup a recipe are described briefly [here](#) or in more detail [here](#)

7.6.30  **Recipe: Show Recipe Manager (Send To Mode)**

This Button/Strategy Controller Action will display the Recipe Manager in the Send To mode. This is used when there is more than one identical instrument that the recipe could be sent to, and allows the instrument(s) to be chosen. This will only send instrument variables to the specified instrument, it will not affect SpecView User Variables.

The user is able to change or create new recipes.

The steps to setup a recipe are described briefly [here](#) or in more detail [here](#)

7.6.31  **SpecView: Enter Edit Mode**

This Button Action will go from Runtime Mode into Edit Mode mode with all Online Features enabled.

7.6.32  **SpecView: Exit Program**

This Button/Strategy Controller Action will cause SpecView to exit
7.6.33 SpecView: Maximize screen, Minimize Screen, Restore Screen

This Button/Strategy Controller Action will Maximize, Minimize or Restore the screen.

SpecView: Maximize screen - Enlarge the GDW to use the whole screen.
This is not the same as Full Screen Mode

SpecView: Minimize Screen - Removes SpecView from the view, but leaves it running.
The icon on the Windows toolbar across the bottom of the screen can be used to restore it.

SpecView: Restore Screen - Restore the GDW to its original size.

These three actions have the same function as the Windows control buttons on the top right hand corner of all windows.

7.6.34 SpecView: Run External Program

This Button/Strategy Controller Action will start another program.

For example: To send an email using the email program 'blat' from SpecView, where the email message to be sent is in the project folder enter:

C:\SV3\blat.exe test.txt -subject "%%SpecView.Subject%%" -to user@domain.com
(Change paths as appropriate)

This can also be run using the Strategy Controller so an email is sent when a certain condition occurs, such as an alarm.
See also Sending an email from SpecView.

SpecView can only run programs with the filename extension .EXE, .COM or .BAT and the program's filename must be specified in full including the extension. SpecView cannot run shortcuts (which are of type .LNK).

This command has the ability to accept the name of variables in the line. Each variable should be enclosed in double-percents, like this, showing an example of using SpecView.Time:

%%SpecView.Time%%

Another example, run the program 'C:\TEST.EXE' passing in the number contained in 'Zone1.PV':
C:\TEST.EXE  %Zone1.PV%%

You can have multiple variables, as long as they are always enclosed in the double-percents

If a program is specified without the full pathname then SpecView will first assume the program is in the current project's folder, for example, C:\SV3\Furnace
If it is not there, then it will use the PATH setting to find the program, alternatively specify the full path, see examples below.

**NOTE: Put double-quotes around any commands or commandline parameters that**
contain spaces.

Some examples of these are:

```
MyCommandFile.bat MyData.CSV
'C:\My Utilities\SendText.EXE' -n07777555666 'The furnace is overheating'
C:\WINDOWS\COMMAND\XCOPY32.EXE 'C:\My Documents\Sample.doc' C:\Temp
```

Program Launch Failed; WExec error code = 2
This error will occur during Runtime mode if the program name has been incorrectly specified.
WExec error code = 3 - The path for the file has been incorrectly specified.
WExec error code = 11 - The file specified is not in valid EXE file format.

**NOTE: Programs will be run minimized by default, see below:**

The reason that the default setting is Minimized is because this command was originally added in order to run programs to, for example, play a sound file, where it would be inappropriate to display the program's window.
It is possible to change this in the SETTINGS.INI file in the project's folder:

```
[Settings]
RunExtProgDispMode=M
```

Where the choices are:

- **M** - means start Minimized, which is the default
- **F** - means start using Full screen
- **N** - means start in a Normal window

This setting will affect all programs run by SpecView from that project.

### 7.6.35 SpecView: Write Line to file/printer

This is also known as 'The Line Writer'.

This Button/Strategy Controller Action will write a line of text allowing the writing of fixed text and SpecView variables into files. Files can be appended to or recreated each time.

Click the **Visual Editor** button to edit the line to be printed:
Either specify a filename to write to in the Filename box or use a SpecView Text variable from the list of currently defined Text variables for the filename.

**NOTE: The filename must not contain spaces.**

To write to a filename which is specified by the date, see below.

On some printers it is possible to print directly to the printer by setting the filename to the name of the printer, for example, 'LPT1:', or for a network printer '\print server\epson' a Form Feed can be added to the end of the text using the Control Codes drop down menu, described below.

It is also possible to write to a COM port by setting the filename to, for example 'COM2:'.

Check the Append box to append to an existing file, or check the Replace box to overwrite or create a new file.

The Command box defines the line(s) to be written to the file. Any text can be entered together with variable names, which are added using the **Choose** button. These will be enclosed in a pair of percent signs, such as: `%%varname%%` and will be substituted at runtime.

The number of **decimal places** to be used for Numbers (with decimals) is specified in Preferences - Runtime under Line Writer DP. This setting will then apply to all Numbers (with decimals).

**NOTE: The Line Writer requires that any variables you include in the %% items are on a screen (GDW) that is always open.**

If you fail to put a variable on a GDW, then it will probably not appear in the file. The reason for this is that the last known value for the variable must be available at the time the Line Writer needs to write the line. The Line Writer cannot read the value over comms because this may take several seconds (or minutes in cases of timeouts with bad comms). By putting the value on a GDW, SpecView will usually have the value available.
The line written always has a <CR> and <LF> automatically added to the end, but these can also be added at any point in the line to generate multiple lines.

Use the Control Codes drop down menu to add typical control codes such as <HT> (Horizontal Tab) but for the more obscure codes, type the decimal code into the Special Characters box and click Add Code. These codes may be required, for example, for printer control or for other non-SpecView software to pick up and process such as Visual Basic programs.

See below for a list of ASCII special characters (or search the web for 'ASCII character codes')

<table>
<thead>
<tr>
<th>Dec Code</th>
<th>Dec Code</th>
</tr>
</thead>
<tbody>
<tr>
<td>00 NUL</td>
<td>16 SLE</td>
</tr>
<tr>
<td>01 SOH</td>
<td>17 CS1</td>
</tr>
<tr>
<td>02 STX</td>
<td>18 DC2</td>
</tr>
<tr>
<td>03 ETX</td>
<td>19 DC3</td>
</tr>
<tr>
<td>04 EOT</td>
<td>20 DC4</td>
</tr>
<tr>
<td>05 ENQ</td>
<td>21 NAK</td>
</tr>
<tr>
<td>06 ACK</td>
<td>22 SYN</td>
</tr>
<tr>
<td>07 BEL</td>
<td>23 ETB</td>
</tr>
<tr>
<td>08 BS</td>
<td>24 CAN</td>
</tr>
<tr>
<td>09 HT</td>
<td>25 EM</td>
</tr>
<tr>
<td>10 LF</td>
<td>26 SIB</td>
</tr>
<tr>
<td>11 VT</td>
<td>27 ESC</td>
</tr>
<tr>
<td>12 FF</td>
<td>28 FS</td>
</tr>
<tr>
<td>13 CR</td>
<td>29 GS</td>
</tr>
<tr>
<td>14 SO</td>
<td>30 RS</td>
</tr>
<tr>
<td>15 SI</td>
<td>31 US</td>
</tr>
</tbody>
</table>

To write to a filename which is specified by the date
As already stated: the filename used by the Line Writer must not contain spaces, which would happen if the date format was left as: `%A, %B %d, %Y` the date would be, for example: 'Wednesday, 7 January, 2004' and the spaces and commas would cause problems. Therefore, in order to use the date for the filename, for example: `%SpecView.Date%.CSV` to create, say: 04_006.CSV then the date format needs changing to: `%Y_%j` from Preferences - Display.

Making your own 'Log Files'
Making a form of .CSV file is easy with the Line Writer. These three separate Line Writer commands illustrate the concept - note the commas between the %% to cause commas to be output in the file.

Call the file, for example LOG.CSV, and append to it each time:
+LOG.CSV Time,Zone1,Zone2
+LOG.CSV %SpecView.Time%,%Zone1.PV%,%Zone2.PV%
+LOG.CSV %SpecView.Time%,%Zone1.PV%,%Zone2.PV%

Provided that the last 2 lines are done independently by the Strategy Controller, the file may look like this:

<table>
<thead>
<tr>
<th>Time,Zone1,Zone2</th>
</tr>
</thead>
<tbody>
<tr>
<td>12:10:34,560.1,580.0</td>
</tr>
<tr>
<td>12:11:34,560.2,579.9</td>
</tr>
</tbody>
</table>

The above example shows writing a CSV (Comma Separated Values) format file, just like SpecView's
Log Reports.
The reason for using the Line Writer instead of Log Reports would be if a line was required to be written to the file only occasionally, for example, when a fault occurred.

7.7 Preferences

In earlier versions of SpecView modifications to SpecView's program settings had to be done by hand by editing the Settings.ini file. It is now strongly recommended to use Preferences... from the File menu instead.

The Preferences box, accessed by Preferences on the File menu, allows modification of almost all the configurable items in Settings.ini (This file is in the Project's sub-folder within the installation folder, which is by default C:\SV3). The exceptions are:

- MaxPorts (default: 9) set in the [COMMS] section of Settings.ini.
  Allows support for COM10 (and above). This is initially set to 9, but can be increased up to 40 to allow the use of com ports from COM1 to COM40. Note that changing the COM port settings (BAUD rate, etc.) will need to be done 'by hand' by editing Settings.ini using Notepad, this is because the 'Setup COM Ports' box (from the Setup menu) only has space for up to 9 ports.

- AutoSaveUserVars (default: 3600) set in the [RUNTIME] section of Settings.ini.
  To alter the rate (in seconds) at which SpecView saves the values of User Variables while it is running. The default 3600 is every hour. If there are a large number of SpecView User Variables, then do not save
them very often as this will slow down the system, especially on heavily loaded computers. The values are automatically saved whenever SpecView goes offline or is exited.

- **RunExtProgDispMode** (default: M) set in the [Settings] section of Settings.ini
  This specifies whether programs run using the action *SpecView: Run External Program* are started with the program's window minimized/normalized or maximized.
  Where the choices are:
  - M - means start Minimized, which is the default
  - F - means start using Full screen
  - N - means start in a Normal window
  This setting will affect all programs run by SpecView from that project.

- **InputsDisabledInHistoricalReplay** (default: N) set in the [ActiveX] section of Settings.ini
  See details [here](#).

For further details on the Preferences box tabs:
(they are also shown for each setting)

Preferences - Runtime
Preferences - Remote
Preferences - Display
Preferences - Alarm
Preferences - Logging
Preferences - Strategy
Preferences - Recipe
Preferences - Startup
Preferences - History
Preferences - Settings
Preferences - ActiveX
Preferences - Language
Preferences - Auto Backup
Preferences - Web Server
Preferences - Logfile Conversion
Preferences - DDE
Preferences - Debug

### 7.7.1 Preferences - Runtime

**GDW Refresh Rate 1/10s: 0**
- The rate at which values on a GDW page are redrawn

**Low Scan Rate 1/10s: 100**
- The speed of this Scan rate at which values are obtained over the wire.

**Medium Scan Rate 1/10s: 20**
- The speed of this Scan rate at which values are obtained over the wire.

**High Scan Rate 1/10s: 10**
- The speed of this Scan rate at which values are obtained over the wire.

**Ultra High Scan Rate 1/10s: 5**
- The speed of this Scan rate at which values are obtained over the wire.

**Trend Grid Segments: 0**
- Puts in horizontal lines to divide into this number of segments
(for example, 4 = divide into quarters)

*Comms Back Off Multiplier: 30

If a value can't be accessed over comms, then this number is multiplied by the scan rate of the parameter and used as a 'delay' factor before retrying. The values for Low/Medium/High Scan Rates are specified above. Which of these is being used for a given parameter is defined in Dynamic Attributes. When any two parameters from an instrument cause consecutive timeouts, that whole 'instrument' is treated as gone (all parameters revert to N/R), and a special 'primary parameter' (usually the Process Value) is requested. If this primary parameter can be acquired over comms, then the whole instrument is returned to active comms use. However, if the Primary Parameter still times out, it is 'backed off' as before. Then (Comms Back Off Multiplier x Scan Rate) seconds later, the primary parameter *only* is retried and the process, detailed above, starts again. The effect of this is that instruments that are switched off will cause very little effect on comms to other daisy-chained instruments that are still communicating.

Disable Edit Mode: Disabled

Used to Disable access to Edit Mode.

Hide Status Bar: Disabled

Used to Hide the Status Bar to maximize screen space.

Single Click Alter: Enabled

In Runtime Mode this is used to determine if values can be changed by just a single-click or a double-click. This is useful if Maximized is disabled on the Startup tab (see below), and there are other windows on the screen to click between, as single clicking on a variable by accident will popup the variable change box.

Disable COM Port Settings Popup: Disabled

Used to Disable COM Port Settings box

Archive/Restore Directory:

This defaults to the folder that SpecView is installed in, but it can be set to any drive and folder.

*Trend DP Override:

Allows the number of decimal places used by Trend Charts to be set.

Line Writer DP:

The Line Writer is either a button or Strategy Controller action type. This specifies the number of decimal places to be used.

Parameter List

Parameter List PPS: 15

When the Instrument View's parameter list button is clicked in Runtime Mode, this is the number of values read per second (Points Per Second) in order to display the parameter list.

Read All Parameter Values: Disabled

This forces SpecView to read ALL the parameters in the Variables List (or Parameter List). When unchecked only the visible parameters will be read, significantly improving the update rate on those parameters.

NOTE: * indicates: A change will not take effect until next entry to Runtime Mode

Full list of Preferences
7.7.2 Preferences - Remote

Preferences for Remote:
The devices shown are those which have already been configured in Windows.
- Port - Network IP Port Number
- Timeout: seconds

The devices listed are those which have already been configured in Windows.

Click the Port Number to change it, but this should only be changed with caution.

Click the Timeout to change. The timeout for Modems is the time before redialing. This is set by default to 50 seconds because many modems require some time to clear-down and so therefore a rapid redial will not succeed, so we recommend caution before changing this.

SpecView Remote
SpecView Networking via Modem

Full list of Preferences

7.7.3 Preferences - Display

No Response Value: N/R
N/R stands for No Response. This is what is used to represent the variable’s value in Edit Mode (offline) or when the value cannot be read from the instrument in Runtime Mode.

Not Present Value: NPV
NPV stands for Not Present Value. This will be shown if the value isn’t appropriate at this time - for example, if the Segment type is set to ‘Time’ then the ‘Rate’ value would be NPV. Or if a thermocouple goes out of range. If NPV is shown erroneously then set the driver command NPV = -1 (minus one) this will show the underlying value, instead of NPV.

Not Currently Available Value: NCA
NCA stands for Not Currently Available. All values are set to NCA when online before they are filled in, but those that have no values, such as PasswordUser when passwords are not enabled will stay as NCA.

Time Format HMSC: No Milliseconds
(Other options: 1 Millisecond place/2 Millisecond places/3 Millisecond places)
Whether or not to display Milliseconds in time variables.

Date Format: %b %d %Y
The % sequence used to format date variables, see below.

Date Time Format: %H.%M %b %d %Y
For the % sequences used to format date and time variables, see Date and Time Formatting.
Blank String value: [ ]
What is displayed when a text value is blank

Show scroll bars: Disabled
Enables/disables the displaying of scroll bars in Runtime Mode

Full screen mode in runtime: Disabled
Enables/disables Full Screen Mode in Runtime

Magic square size (pixels): 75
In the case where Full Screen Mode is enabled in Runtime, but without a button somewhere on the GDW which has the action: GDW Control: Toggle Full Screen Mode the menus are inaccessible. To resolve this there is a special invisible square in the bottom left-hand corner of the screen (this number of pixels in size). To use this magic square, double-click inside it, click once outside it and then once inside it again, all within a short space of time. Then return to Edit Mode and put a button somewhere on the GDW which has the action: GDW Control: Toggle Full Screen Mode.

Write Only Value: W/O
W/O stands for Write Only. This is when a variable can be written to but not read.

Timeout Value: T/O
T/O stands for Time Out. This is when a request for an instrument's parameter times-out over comms, for example if the instrument was switched off.

Recipe No Value: N/C
N/C stands for No Change. It is only possible to have one set of Recipe variables per GDW, but each Recipe can have many sets of values (Max 1295). However, not all of the variables will need to be set in each set of values, so this is what is used to indicate the variables which are not to be set.

Window Positions
Remember Positions: Disabled
This is to display screens (GDWs) at specific coordinates, which can be useful when using multiple monitors.
Allow Minimize: Disabled
This is to allow the minimize button to be disabled. This is useful when using Remember Positions.
Delete All Positions: Disabled
This clears the saved locations of windows. This is only relevant when using Remember Positions.

Full list of Preferences

7.7.3.1 Date and Time Formatting

The % sequences used to format date and time variables:

%a Abbreviated weekday name
%A Full weekday name
%b Abbreviated month name
%B Full month name
%c Date and time representation appropriate for the language (locale)
%d Day of month as decimal number (01 – 31)
%H Hour in 24-hour format (00 – 23)
%I Hour in 12-hour format (01 – 12)
%j Day of year as decimal number (001 – 366)
%m Month as decimal number (01 – 12)
%M Minute as decimal number (00 – 59)
%p Current language's (locale's) A.M./P.M. indicator for 12-hour clock
%S Second as decimal number (00 – 59)
%U Week of year as decimal number, with Sunday as first day of week (00 – 53)
%w Weekday as decimal number (0 – 6; Sunday is 0)
%W Week of year as decimal number, with Monday as first day of week (00 – 53)
%x Date representation for current language (locale)
%X Time representation for current language (locale)
%y Year without century, as decimal number (00 – 99)
%Y Year with century, as decimal number
%z, %Z Time-zone name or abbreviation; no characters if time zone is unknown
%% Percent sign

For example:
Time Format: No Milliseconds
Date Format: %b %d %Y
Date Time Format: %H.%M %b %d %Y

Gives:

Time: 11:44:30
Date: Jun 16 2014
Date&Time: 11.44 Jun 16 2014

7.7.4 Preferences - Alarm

Preferences for Alarms:

Enabled: Enabled
Whether alarms are enabled
Rate: 5
The alarm rate
Popup Enabled: Enabled
Whether an alarm displays the Alarm box

Full list of Preferences
7.7.5 Preferences - Logging

Preferences for Data Logging:

Enabled: Enabled
Whether logging is enabled
Rate (secs): 60
The default logging rate which will be used when Runtime mode is started.
Report DP: No DP Override
The number of decimal places to be logged.

During Runtime mode the rate can be changed using the action: Logging: On/Off
The current value for the logging rate is stored in the SpecView Variable LogRate.
This variable is Read-Only and cannot be changed other than by using the Logging: On/Off action.

Full list of Preferences

7.7.6 Preferences - Strategy

Preferences for the Strategy Controller:

Enabled: Enabled
Whether or not the Strategy Controller is enabled
Rate: Medium (Low/Medium/High/Ultra-High)
The speeds for these settings are defined on the Runtime tab.

Full list of Preferences

7.7.7 Preferences - Recipe

Preferences settings for Recipe:

Recipe Level Delay 1/10s: 5
The delay between downloading each of the 99 Recipe levels
Recipe Retries: 1
The number of times a Recipe download is attempted before reporting failure.
Sequence Recipe Directory (PC3000 Only):
The folder where the sequence Recipes are stored
Select Invert: Disabled
In Edit Mode when the 'knife and fork' button is clicked the Recipe values are highlighted by a box being drawn around each of them. However, on a very complex GDW screen layout the boxes may overlap too much. So this feature has been provided to highlight the values using reverse video
rather than a box. This setting will also affect the highlight style used when selecting objects for Password access from the GDW Setup dialog.

Full list of Preferences

7.7.8 Preferences - Startup

Maximized: Enabled
   Whether or not SpecView starts with its window using the whole screen.
*Project Timeout: 20
   The number of seconds to countdown on startup
*Port: 1
   The default printer port on which to detect the dongle
*Timing: 0
   This is a timing value for the dongle. It is not recommended to change this
*Auto Update of Parameter Lists: Enabled
   Whether or not SpecView will read new values added to an instrument’s definition. It is not recommended to change this
*Title screen delay: 5
   The duration that the copyright logo splash screen is displayed during start-up while instrument definitions are being loaded

   NOTE: * indicates: A change will not take effect until SpecView has been restarted

Full list of Preferences

7.7.9 Preferences - History

Preferences for Historical Replay:

Auto Pause on Short Trend charts: Enabled
   Historical replay will be paused when the Trend chart line(s) hits right-hand edge of the Trend chart on the GDW with the shortest overall duration on the horizontal axis
Auto Pause on Long Trend charts: Enabled
   Historical replay will be paused when the Trend chart line(s) hits right-hand edge of the Trend chart on the GDW with the longest overall duration on the horizontal axis
CPU Replay Factor: 10
   A number (where the units are undefined) which defines how much CPU is used by Historical Replay. The bigger the number the more CPU and hence the faster it goes, but the slower other functions in SpecView will run while a Historical Replay is in progress

Full list of Preferences

7.7.10 Preferences - Settings
List

**Font Size: 9**

The font size to be used

**Separator: comma**

This is the character used by the current language to delimit .CSV files.
This setting cannot be changed from within SpecView, it must be changed from the Regional Settings in the Windows Control Panel.
It is used by Logfile Convert, Recipe Export/Import and Export/Import variables list on the Setup menu.

**Font: Arial**

The font to be used

**Decimal separator: full stop**

This is the character used by the current language to be used as the decimal point.
This setting cannot be changed from within SpecView, it must be changed from the Regional Settings in the Windows Control Panel.

**Reset window positions for:**

- Alarm Popup
- Event Popup
- Variables List
- Historical Replay
- Parameter List
- Data Entry
- Recipe Manager
- Position Dynamics
- Line Writer
- Connected Users List
- Batch Chooser
- Password Options
- File Preferences
- Projects Found
- New Instrument Found
- Insert ActiveX Control
- Links to ActiveX Control
- Manage ActiveX Control List
- QWERTY Input
- Quick List
- New Instruments

Resets the position of the respective box on the screen, this is useful if using different sized monitors and the box is displayed too high or too far to the right where it can't be seen.

**Reset Don't Show Me Again Messages:**

This unsets all of SpecView's warning message boxes which have a checked 'Do not show me again' checkbox, so that they will then subsequently be shown.
Show Name On Move: Enabled
   In Edit Mode moving an N/R (or the value if Online) shows the name of the variable on the status bar.

Drag&Drop Target Color:
   This text color is a visual aid to assist in showing where to drop a variable being dragged into a box.

   **NOTE:** * indicates: A change will not take effect until next entry to Runtime Mode
   Full list of Preferences

7.7.11 Preferences - ActiveX

   **Enabled:** Enabled
      Whether ActiveX controls are enabled so that they can receive and send parameter values.

   **Rate:** Medium
      The rate that ActiveX controls are scanned.

   **Apply fixed value in Edit mode**
      The values which are linked to ActiveX controls (either fixed values or the values of variables) are not applied until SpecView goes online, this checkbox will force the fixed values to be applied while offline.

   **Delay Output scan until Strategy Running**
      This allows the Strategy Controller time to fully initialize before outputs from the ActiveX controls are used.

   For further Information:
      ActiveX

7.7.12 Preferences - Language

   The **Language** tab allows the language that SpecView is running in to be changed.

   **NOTE:** Any change will not take effect until SpecView is exited and restarted

7.7.13 Preferences - Auto Backup

   Specifies the backup interval (default 1 min).

   Auto save & recovery of screens (GDWs) will save changes for later recovery in the event of failure. In this case, a list of saved items will be displayed so the items to be recovered can be selected:
7.7.14 Preferences - Web Server

Preferences for SpecView's built-in Web Server option.

SpecView has a built-in Web Server which can be enabled from a dongle option. This causes a screen-shot of the current SpecView GDW (screen) to be taken every 5 seconds; this rate can be modified (see Update Rate below).

The screen-shot uses the specified JPEG Quality, where 100 is maximum definition, but uses much greater bandwidth. This screen-shot is then made available via the Web Server.

This allows a remote user to observe but not interact with SpecView. If remote interaction is required then SpecView Networking should be used.

**Enabled: Disabled by default**

- **IP Port Number:** 80
- **Update Rate:** 5 secs
- **JPEG Quality:** 70 (Range: 5 - 100)

There is also a basic way to access (read & write) values of variables in SpecView from Web Browser commands typed into the address (URL) bar of any browser on a computer, tablet or phone. These web browser commands can be stored as bookmarks in the browser making it possible to get to data in SpecView in just a few clicks or taps. The ability of the browser to set data into SpecView means that data can be sent into SpecView quickly - for example, an operator can signal their presence by invoking a bookmark on their phone when they arrive. Full details can be requested from SpecView Technical Support.

Full list of Preferences.
7.7.15 Preferences - Logfile Conversion

Preferences for Logfile Conversion:

Thread Priority: Slow
This is how much CPU priority is given to logfile conversions
Inhibit Progress Display: Disabled
Whether or not to display the Progress box for logfile conversions

Full list of Preferences

7.7.16 Preferences - DDE

Preferences for DDE (Dynamic Data Exchange):

*Application Name: SpecView (DDE application name)
*Variable Topic: var (DDE topic name)

NOTE: * indicates: A change will not take effect until SpecView has been restarted

Full list of Preferences

7.7.17 Preferences - Debug

NOTE: Do not change any of these settings unless under the direction of a SpecView representative

Debug Mode: 0
This will be a specific number given to you by a SpecView representative that is appropriate to debug the problem you have encountered.
When this is set to zero, the 'File Size' and 'No of files' detailed below are ignored because no debug files will be generated.

File Size: 0 Mb
This is the maximum file size of the Debug files created in Mb.
A good size to use is 20Mb

No of files: 0
This is the maximum number of Debug files of the above size that will be created.
A good number to specify is 10.

Debug Mode 2: 0
This will be a specific number given to you by a SpecView representative that is appropriate to debug the problem you have encountered.
Enable Strategy Debug: Disabled
Special Mode 0: Disabled
Special Mode 1: Disabled
Special Mode 2: Disabled
Special Mode 3: Disabled
Special Mode 4: Disabled
Old Ordering: Disabled
Disable Invalid Ports: Enabled
Run ProcDump to generate dump files

If there is a problem with SpecView, call a SpecView representative, they may ask you to set the Debug Mode to a specific value and set File Size & No of files to appropriate values.

Then do whatever it was that you did previously to cause the problem & then immediately EXIT SpecView.

Send your SpecView Representative all the files that have a name starting with 'SVData' from C:\SV3\

Rep Code:
Rep Code 2:

These rep codes are only to be used under advice from a SpecView representative.

Note: It is important to remember to set Debug Mode back to zero afterwards.

Full list of Preferences

7.8 Full Screen Mode

Full Screen mode in Runtime is where a GDW fills the monitor's whole screen, there is no title bar or menubar across the top of the screen or Windows toolbar along the bottom of the screen. It can be enabled/disabled by using these methods:

- Setting Full screen mode from the Preferences - Display tab. This will cause Full Screen mode to be enabled automatically when entering Runtime Mode
- Via the 'Toggle Full Screen mode' menu command on the File menu during Runtime
- Via the 'Switch to Full Screen' menu command on the File menu during Historical Replay

However, once Full Screen mode has been enabled there will be no menus accessible, therefore a button should be added to the GDW to reverse the command with the action GDW Control: Toggle Full Screen Mode. (This button may be placed on another GDW accessed by GDW Control: Swap to another GDW).

NOTE: When this mode is enabled there are no menus accessible, therefore it is STRONGLY recommended to add a button somewhere on the GDW which has the action: GDW Control: Toggle Full Screen Mode. If there is no such button then SpecView will display a warning before exiting Edit Mode. However, there is an emergency method of getting out of Full Screen mode, read 'Magic Square' in
Preferences - Display

Also note that when Passwords are used in conjunction with Full Screen Mode it is important to ensure that there are buttons on the GDW for Login and Logout.

7.9 SpecView Error Codes

There are four types of error codes within SpecView:

Error message numbers (which start with an ‘E’)
Write Errors
Generic Errors
Protocol Specific Errors

7.9.1 Error Message Numbers

All error messages in SpecView have a number which starts with an ‘E’, this number uniquely identifies the error message. This is particularly useful when SpecView has been translated into another language, as it allows us to understand which error message is being displayed.

For example:

Some errors require further explanation:

E17022 Could not write namePacket to log file (9) (or similarly worded error messages)
All the time that SpecView is in Runtime mode it is writing to the log data files. These files are stored in the Project's subfolder, which is within the folder where SpecView was installed (this is usually C:SV3\ unless this was specifically changed during the installation).

This error will occur if SpecView is unable to write the log data files. There are a number of possible reasons for this:

- The computer may have run out of disk space to store the log data files. Please check the amount of free disk space available to the folder where SpecView is installed.

- The project subfolder has been copied onto this computer from a CD. When files are put onto a CD they are automatically made Read-Only, and they have to be manually made writeable again for the log
data files to be written to. Instead use SpecView's Archive feature to archive & restore projects.

- The user has logged into the computer but doesn't have sufficient privileges to access and write files to the project's subfolder.

- The folder where the log files are put has been specifically changed to a different folder, which is now either non-existent or inaccessible to this user.
It is possible to specify a different folder to write the log files to by setting 'Path=C:\MyPath\' in the [Logging] section of SETTINGS.INI. However, it is VERY IMPORTANT that specified folder is on this computer, not on a network drive, in case of network failure.

E12272 Devices found on the Remote tab that are not present on this PC. To remove them click OK, to keep them click Cancel.

This means that this SpecView Project was originally from a different PC, which was running as a SpecView Local.

For example, if there were two PCs with IP addresses 1.1.1.1 and 2.2.2.2 and a Project is setup on the PC 1.1.1.1 as a SpecView Local, it would be 'listening' on IP address 1.1.1.1

If this Project was then moved/copied/archived onto PC 2.2.2.2 then (so long as this PC only has the one network card) SpecView would just use the IP address of the network card, so it would 'listen' on 2.2.2.2.

But going into File->Preferences would cause SpecView to notice that this Project was originally setup to listen on 1.1.1.1, so it would display this message.

Clicking OK would remove the reference to 1.1.1.1, whereas Cancel would keep the reference, this is so that if this Project was then subsequently put back on PC 1.1.1.1 it would work without the need for further change.

E12310 WARNING: The Delete key has been disabled for deleting this type of ActiveX control.

Instead please use the Delete menu item on the Edit menu. The reason for this is because it is unclear whether it should delete something within the control, or delete the control itself.

This warning message will be displayed when the delete key is used to delete an ActiveX control which has a data entry field within it. This is because the meaning of delete key becomes ambiguous in this context. So to delete the control use the Delete menu item on the Edit menu.

E12314 ERROR: ActiveX environment is not setup
E12313 ERROR: ActiveX controls cannot be registered or unregistered because you are not running as an Administrator
E12315 ERROR: ActiveX controls cannot be registered because you are not running as an Administrator
The 3 errors above are detailed here.

E12086 This GDW was not defined in this project. To prevent misleading values appearing, all dynamic items have been removed.

This is typically caused by users copying files from one project folder to another. It is important to remember that all the files in a project folder are interconnected and so cannot be copied from one
project folder to another. However, if this error occurs and it is believed that files have not been intentionally copied then please make an Archive of the project. It is important to check the ‘SpecView backups’ box, and uncheck the ‘Include Log files’ box. Then email the Archive to SpecView’s Technical Support.

7.9.2 SpecView Write Errors

In general, if you get an error code in a data entry box such as

```
Error 18210.
Value Over Range? Press F1 for Help.
```

SpecView has failed to write the value correctly. The most common cause is that the value being sent is outside the acceptable range for that parameter. Check that any limits are not being exceeded for that instrument. (Try entering the value on the instrument itself) The error codes below may help. Contact your SpecView distributor if you cannot resolve the problem.

There are also generic Error Codes. These error codes can be returned when attempting to write data to a parameter:

- **3 Timeout - Response not received from instrument**
- **18000 Internal IDF Error - Seek advice from SpecView**
- **18001 Address too long - Too many Characters in the address field**
- **18002 Address too short - Not enough typed in**
- **18003 Address is invalid for this Protocol**
- **18004 Incorrect information after the comma**
- **18005 Precision specification is incorrect**
- **18006 Parity Error at Instrument end**
- **18007 Rx Overflow on Instrument**
- **18008 Rx Overrun at Instrument end**
- **18009 Instrument message was corrupted**
- **18010 Tx Buffer overflow at Instrument**
- **18011 Instrument message was corrupted**
- **18012 Parameter value was incorrect for this parameter**
- **18013 Internal IDF Error - Seek advice from SpecView**
- **18014 Rx Buffer overflow at Instrument**
- **18015 Instrument message was corrupted**
- **18016 Write to read only parameter**
- **18017 Internal Instrument Error (Yokogawa) RJC error**
- **18018 Internal Instrument Error A/D Converter Failure**
- **18019 Parameter value was incorrect for this parameter**

**NOTE:** With Yokogawa UT550 and UT750 the setpoint is a read only variable. To change the SP you must edit Target SP 1-8, which are available on the parameter list.

- **18020 Parameter value was incorrect for this parameter**
- **18021 Internal IDF Error - Seek advice from SpecView**
- **18022 Rx Buffer overflow at Instrument**
- **18023 Internal Instrument Error - Controller Busy**
- **18024 Data Over Range**
- **18025 Data Under Range**
- **18026 Internal Instrument Error - Burn Out**
- **18027 Internal Instrument Error - Unknown - Seek Advice**
- **18028 Channel or Loop Number incorrect, or Internal IDF Error - Seek advice from SpecView**
- **18029 CPU Number Invalid**
18030 Operator Panel Address Invalid
18031 Invalid Delimiter
18032 Invalid Time To Live
18033 Read To Write Only Parameter
18034 Protocol Type Invalid
18035 Invalid Time
18036 SV ValueNotPresent: Some controllers (notably Eurotherm) return 0x8000 or 0x80008000 as a value when the parameter has not been set-up or is not present in this particular model. Therefore this is a warning rather than an error.
18037 SV No Comms Back Off: Some drivers such as the Modbus & OPC drivers report errors but 'know' that new values are imminent, therefore they are really just warnings, hence this 'error' does not cause a Comms Back Off

18200-18500 Protocol Specific Error Codes

7.9.3 SpecView Generic Error Codes

These are generic Error codes. There are also Errors that apply specifically to writing variables to instruments. They are listed here.

3 Timeout
1460 Timeout - Response not received from instrument (check the wiring connection)
10001 Cannot Open Comms - Port In use
10002 Cannot Open Comms - Port Setup Error
10003 Cannot Open Comms - Port Characteristics Error
10004 Failed Write
10005 Incorrect Baud Rate
10006 Cannot Initialize Windows Comms Subsystem
10007 Cannot Save Project
10008 Cannot Start System Timer
10009 Cannot find Folder
10010 Invalid Parameter
10011 Invalid Function
10012 Address Out of range
10013 Data Out of Range
10014 Parameter Write protected
10022 Cannot Find Required DLL - If this error code is given with a message about TCP/IP; then check the IP address that is selected on the Preferences - Remote tab.
10023 Historical Replay: There is no logged data for the day specified

Program Launch Failed; WExec error code = 2
This error will occur when the SpecView: Run External Program action is being used to launch a program for which the file name has been incorrectly specified. Similarly:
WExec error code = 3 - The path for the file has been incorrectly specified.
WExec error code = 11 - The file specified is not in valid EXE file format.

18000 - 18199 Write Errors
18200 - 18500 Protocol Specific Error Codes
20000 - 21000 Error codes from the Local computer when using SpecView Networking.

Specific error codes:
20022 This error is shown in the Event Window when a Remote connection has failed because the
versions of SpecView running on the Local & Remote are not compatible. Please update them accordingly.

32002 This error is shown when using SpecView Remote to connect to a Local which has not had the networking server started from Preferences. This is detailed in Setting up SpecView Networking. This can be confirmed by using the menu command View Connected Users from the Local's Remotes menu during Runtime mode, which would show ‘Server NOT Running’

84036 (and values above) These are OPC errors when the value being returned from the OPC server cannot be relied on. In this case please contact your OPC Server supplier.

7.9.4 Error Codes - Protocol Specific

Error codes in the range 18200 to 19103 are reserved for Protocol Specific errors returned by the equipment connected. Subtract 18200 to get the error code and then consult the Protocol or Instrument manual for details.

**Modbus:**
For example, a Modbus Instrument could return Error Code 18208. Thus, the Modbus error is 8, which is ‘Parameter to be modified is write protected’.

For Instruments using the Modbus Protocol here is a list of the standard Modbus errors:
1 (18201) ILLEGAL FUNCTION - Indicates a driver problem, contact your SpecView Rep.
2 (18202) ILLEGAL DATA ADDRESS - Indicates either:
   A. If using the Generic Modbus driver, then the address being used is invalid.
   B. If using a Modbus driver written for a specific instrument, then it indicates a problem with the instrument definition file.
3 (18203) ILLEGAL DATA VALUE - The value being used is out of range for this parameter.
4 (18204) SLAVE DEVICE FAILURE - Contact your SpecView Representative.
5 (18205) ACKNOWLEDGE - Device is busy, setting the Driver Command: ECR=5 may help.
6 (18206) SLAVE DEVICE BUSY - Setting the Driver Command: ECR2=6 may help.
Error codes 18207 to 18500 are instrument specific.
779 (18979) BUFFER OVERFLOW - Over 750 bytes of data received over comms, which is likely to be caused by faulty wiring.

**NOTE:** 18210 - With Barber-Colman Series 7 controllers you must first click the REM button on the Instrument View to enable writing to any variable.

**OPC:**
84036 (and values above) These are OPC errors when the value being returned from the OPC server cannot be relied on. In this case please contact your OPC Server supplier.

7.10 Glossary of Key Terms used in SpecView

- **ActiveX Controls**
- **Alarm**
- **Boolean**
7.10.1 Alarms

An *Alarm* is an On/Off status within an instrument, or a boolean User Variable which has the Alarm attribute enabled. When an alarm occurs SpecView will display the Alarm box and write an entry into the *Alarm logfile*. 
7.10.2 Boolean

A Boolean variable is an Instrument Variable or a SpecView User Variable which has only two possible values On or Off.

To create a Boolean User Variable use the New menu on the Variables List:
A SpecView Boolean User Variable is not significantly different to a SpecView Integer User Variable except that its values can be given different names such as: Yes/No, Auto/Manual, etc.
7.10.3 Communications Ports "Com Port"

The Communications port (or COM port) is a serial port on the computer, usually USB, but can be a 9-pin RS232 connector.
Instruments which have a serial connection typically use RS422 or RS485, therefore a convertor is required to convert, for example, USB to RS485.

Or sometimes special cards may be used that have RS422 or RS485 ports.

Windows identifies ports with the term COM1, COM2 etc. SpecView supports by default up to COM9, but it is possible to increase this limit up to 40 by setting MaxPorts.

Communication Ports are a hardware item in the computer and should not be confused with Communications Protocol.
A Communications Protocol can be thought of as the 'language' used by the instrument to send/receive values to/from the computer.

7.10.4 Communications Protocol

The communication standard used by the instrument, for example Modbus. This is how the software communicates with the instrument and is not related to the type of communications standard used by the port (RS232, RS485 etc.).

To communicate with instruments that use different communications protocols SpecView's Multiport option will be required.

The Communications Protocol can be thought of as the 'language' used by the instrument to send/receive values to/from the computer.

7.10.5 Configuration

In SpecView Version 3 a Configuration is now called a Project and Configuring is now called Editing a Project.
7.10.6 Data Logging

Storing on disk the value of selected variables at a pre-set time interval.

7.10.7 Decimal Places

Some protocols (examples include Modbus, Red Lion and Yokogawa Green Series) do not provide the computer with information about decimal places. Therefore when SpecView auto detects instruments it will have to make assumptions, for example, it assumes NO decimal places for Modbus and Red Lion, and ONE decimal place for Yokogawa Green series.

Specifying the number of decimal places for Variables is done in a number of places:

For Instrument Variables:
   The decimal places for instrument parameters are specified in the instrument definition:

   ![Image of Variables List Version 3]

   ![Image of Add/Rename Instrument]

   Also ensure the instrument variables are using the correct scaling.

For any Variables being displayed on a GDW:
   Select the value on the GDW, just the 'N/R' which may need to be un-grouped from its neighbor. Then use the Dynamic Attributes menu command from the Edit menu. This will need to be done for EACH occurrence of a variable on EACH GDW.
In Log Report (CSV) files:
To display more than one decimal place for values in a Log Report Report DP on Preferences - Logging
This is detailed under Log Reports - Specifying decimal places

On Trend Charts:
The decimal Places required for each pen are specified in the Pen Properties:

On Trend charts which are still in 'Version 2/2.5' format:
To display more than one decimal place for values on a 'Version 2/2.5' format Trend chart use Trend DP Override on Preferences - Runtime

In Trend Chart export to CSV:
The decimal places for the values in the CSV file created by selecting an area of a Trend Chart and exporting the values to a CSV file are always the full resolution of the value that SpecView obtained from the instrument. The decimal places shown in the resultant spreadsheet when loaded into Excel can be limited using Excel's column format.
7.10.8 Dongle

The dongle is a copy protection key used by the SpecView software which is required for all versions of SpecView.

There are 3 types of dongle available:

- **USB** - For connection to a USB port.
- **Parallel** - For connection to the parallel (printer) port of the computer. It will not affect the operation of the printer port.
- **Soft Dongle** - No physical key. This is described in more detail under **Soft Dongles**.

The dongle contains the information about the SpecView options which have been purchased. The dongle may be upgraded to add further options at any time.

Although the dongle is connected to either a USB port or the printer port, and is not in any way connected to the instrument, SpecView will search for the presence of the dongle for licensing purposes.

Without a dongle SpecView will run in Demo Mode, this is described in more detail under **Licensing**.
Troubleshooting
If SpecView has a problem reading the dongle & gives an error, or if it doesn't detect the dongle & continues to run in Demo mode; displaying the box:

Then on the SpecView Installation CD there is a folder containing the program SuperproMedic, which may help resolve the problem.
This program is also available for download from SpecView's FTP site; access [www.specview.com](http://www.specview.com) then click the Download link and click FTP-site.

7.10.9 Driver

Driver default settings:
On the 'Settings' or 'Parity' drop-down, ideally leave as 'Default' or 'Driver' to use the driver defaults which will be the 'factory default' for that instrument, otherwise, if the settings on the instrument have been changed then choose accordingly:

The meanings are listed below:
7.10.10 Dynamic Attributes

These attributes are associated with a variable on a GDW. They are:
- Scan Rate - The rate at which this value is read from the instrument
- Recipe - Whether or not the variable is included in the Recipe
- Recipe Level - The order in which the Recipe values are downloaded
- Decimal Places - The number of decimal places shown for this variable

Note that Dynamic Attributes won't work if the selected object is grouped, so it is necessary to ungroup the object using the Ungroup tool on the toolbar.

7.10.11 Edit Mode

SpecView has two modes of operation: Edit Mode and Runtime Mode. GDW's are created or edited in the Edit Mode, read Creating and Editing GDW's. When in Runtime Mode use the File - Edit Mode menu command to return to Edit Mode.

When starting SpecView it is possible to shortcut directly into Edit Mode on the last used project (missing Runtime Mode) by holding the Shift or Control key down while clicking the Start button on the Splash Screen:
*Hold the Shift key down and click Start to go directly into Edit Mode with online features enabled.*
*Or hold the Control key down and click Start to go directly into Edit Mode offline.*
To edit an alternative project click the **Select/Create Project** button to display the **Projects** box, then select the required project from the list and click the **Edit Project** button.

While in Edit Mode use the **Online Features** menu to select which parts of SpecView are online, for example while editing **Position Dynamics** ensure that Position Dynamics are not online.
7.10.12 GDO - Graphical Display Object

Graphics made with SpecView's drawing tools can be grouped and saved as GDO's using the Save Object menu command on the Object menu. The saved GDO's can be re-used (using the Load Object menu command) any number of times in any GDW in any copy of SpecView.

**NOTE: Do not include variables (or Trend charts or Bar Charts or ActiveX controls) in saved objects**

The default folder to save the object to (and load the object from) is SymbolLibrary in SpecView's installation folder (so typically this would be: C:\SV3\SymbolLibrary). However, GDOs can be saved to & loaded from any folder.

7.10.13 GDW - Graphical Display Window

The window (or screen) used to display data from the connected instruments. Graphics drawings are used so that the data may be arranged in a logical and unambiguous format. SpecView may have as many GDW's as disk space and Windows limitations will permit.

Creating and Editing GDW's

In SpecView version 2.5 (builds 820 and above) GDW's have been renamed GD3's following the addition of the ability to add ActiveX controls to SpecView's screens.

Throughout this text the words: 'screen', 'GDW' and 'GD3' all have the same meaning. This is because the content of a 'screen' layout is saved to a file with a .GDW or .GD3 filename extension.

**NOTE: Files with the .GDW or .GD3 filename extension cannot be used alone. Consequently they cannot be used by SpecView if they have been separated from the other files in the Project subfolder that they were created in.**

7.10.14 Group

The word 'group' has 2 meanings in SpecView:

1. When objects are grouped together on the GDW - so they can be moved all together.

   For this the **Group** tool and the **UnGroup** tool on the toolbar are used.

   Note that there are 2 functions that won't work if the selected object is grouped, these are **Dynamic Attributes** on the **Edit** menu and the **Recipe** tool so to use these it is necessary to ungroup the required object.

2. When instruments and/or parameters and/or variables are grouped together into a named logical **group**
within the Variables List.

7.10.15 Instrument

The complete device connected at a unique address on the communications link. A temperature controller, an indicator, a process controller, a PLC, a control system are all considered to be Instruments by SpecView.

7.10.16 Instrument View

A pictorial view of a connected instrument. In most cases it will look like and have buttons that operate in a similar way to the actual instrument's faceplate when SpecView is in Runtime Mode. Some examples are:
Adding Instrument Views to a GDW

7.10.17 Log Report

A text file containing the values of selected variables over a time period. The file is in a CSV (Comma Separated Variable) format. This means that the data fields are separated by commas. This format is intended to be imported into a spreadsheet program such as Excel.

Viewed with a text editor:

```
Time, Zone 1 Output Power, Zone 2 Process Value, Zone 1 Setpoint
07/06/2013 12:31, 68.9, 72.7, 90
07/06/2013 12:32, 69.2, 72.7, 90
07/06/2013 12:33, 69.1, 72.7, 90
```

The same file opened in Excel (use Type of File: Text Files (.prn .txt .csv)

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Time</td>
<td>Zone 1 Output Power</td>
<td>Zone 2 Process Value</td>
<td>Zone 1 Setpoint</td>
</tr>
<tr>
<td>2</td>
<td>07/06/2013 12:31</td>
<td>68.9</td>
<td>72.7</td>
<td>90</td>
</tr>
<tr>
<td>3</td>
<td>07/06/2013 12:32</td>
<td>69.2</td>
<td>72.7</td>
<td>90</td>
</tr>
<tr>
<td>4</td>
<td>07/06/2013 12:33</td>
<td>69.1</td>
<td>72.7</td>
<td>90</td>
</tr>
</tbody>
</table>

Log Reports in detail
7.10.18 Multiport Option

SpecView's Multiport option would be required on the dongle in the following circumstances:

- For a large number of instruments
- When instruments which use different communications protocols are being used
- For greater speed of response
- When using OPC

7.10.19 Multi-Select

Parameters (or variables) in the Variables List can be multi-selected in the standard way for Windows. Using SHIFT-Click to select a block. Or using CTRL-Click to add to the selection.

The order in which the Parameters (or variables) are dragged out onto the screen (GDW) is determined by the selection order.

Whether or not the parameters' names (and/or instrument names) are included in the drag is chosen on the Options menu 'Include Name' sub-menu.

Spread mode

The large 'handles' represent 'Spread Mode'. These allow the parameters to be dragged in the direction of the cursor arrows to spread them out evenly.

The spacing will be the same for the next group of parameters dragged out, unless 'Reset Spacing' is chosen from the Options menu 'Multi-Select' sub-menu.

Spread mode can be re-enabled on a group of parameters by right-clicking and choosing 'Spread Mode' from the popup menu.
7.10.20 Project

A project is a saved database of instruments, graphical screens (GDW's), Recipes, logging information etc. The project name is the name of a sub-folder of the SpecView installation folder (usually C:SV3). Projects can be Archived and Restored. (In previous versions of SpecView 'Projects' were known as 'Configurations'.)

7.10.21 Radio Buttons

Radio buttons are like check boxes but there is usually more than one of them and only button in the group can be selected (On) at any one time. Rather like a radio can only be on one channel at any one time. A radio button is circular, whereas a checkbox is square. Checkboxes are different to radio buttons because many of them can be checked at once.

An example of a set of radio buttons can be seen in the 'Strategy Controller' section of the Event Log Setup box, which is displayed from the Event Logging menu command on the Setup menu:

7.10.22 Read Only Variable

A Read-Only variable is either an instrument variable that cannot be changed over communications, for example, a measurement,
or another instrument variable (or a SpecView User Variable) that has specifically been set to Read-Only so it cannot be accidentally changed.

The Variables List has an ‘R’ column which shows which variables are Read-Only:

![Variables List](image)

The ‘R’ column of the Variables List shows which parameters are Read-Only and double-clicking in the box in the ‘R’ column will set (or unset) this.

Alternatively select the parameter and click Properties and use the Attributes tab to set (or unset) whether the parameter is Read-Only.

However, parameters on an instrument that cannot be changed are always read-only (for example a measurement), consequently these cannot be unset.

### 7.10.23 Recipe

This is a set of variables on a GDW which need to have their values set. The values of which are saved on disk under a Recipe name. This Recipe file can then be run by SpecView to set the variables to those values.

Only variables on the instrument that are writeable (changeable by the user) can be included in Recipes.

Every Recipe associated with a certain GDW refers to the same set of variables which means that all the recipes associated with the GDW contain exactly the same set of variables.

A recipe can be composed of up to 1295 different sets of values for a given GDW. A set of values defines the values given to each of the variables in recipe. Two different sets of values can give two different values to the same variable in recipe. If in one set of values you want to ignore a variable, you give it a ‘N/C’ (No Change) value.

Therefore it is appropriate to include in recipe all the variables that will be needed to be set by any set of recipe values.

More information is in the Recipes chapter.

Note that the Recipe tool won't work if the required object is grouped, so it is
necessary to ungroup it using the **UnGroup** tool on the toolbar.

### 7.10.24 Running SpecView as an Administrator

This is necessary because administrator privileges are required in order to initially install SpecView, and subsequently to register and unregister ActiveX controls and to restore projects that contain ActiveX controls which have not yet been registered.

See [ActiveX Need To Be Administrator](#).

**On Windows XP:**

Right-click the SpecView icon on the desktop and choose ‘Run As...’ from the popup-menu and enter an administrator username and password.

**On Windows Vista or Windows 7 or Windows Server 2008:**

Right-click the SpecView icon on the desktop and choose ‘Run As Administrator’ from the popup-menu.

*NOTE: Ensure that the Administrator has setup suitable user access rights to the folder that SpecView was installed in.*

### 7.10.25 Runtime Mode

SpecView has three modes of operation: Runtime Mode, Edit Mode (go offline) and Edit Mode (remain online).

Runtime Mode is also referred to as On-Line, this is SpecView's normal mode of operation - SpecView is communicating with the connected instruments.

Read [Runtime Mode - Using SpecView](#).

When in Edit Mode use the Enter Runtime Mode menu command from the File menu or the tool to return to Runtime Mode.

### 7.10.26 SETTINGS.INI

The SETTINGS.INI file is a file of project specific settings which is read by SpecView when a project is read.
It is located in the project folder (C:\SV3\<project_name>\SETTINGS.INI)
Values in it can be changed from Preferences, or manually by using a text editor such as Notepad to edit the file (carefully!) while SpecView is NOT running.

7.10.27 Strategy Controller

(This is an optional feature of SpecView. Without the option enabled on your dongle you are limited to two events)
A logic engine based on Events associated with Actions
Events can be based on either Time/Date or the value of a Variable
Strategy Controller

7.10.28 SV3.INI

The SETTINGS.INI file is a file of SpecView settings which is read by SpecView when it is started. It is located in the SpecView installation folder, which by default is: C:\SV3\SV3.INI

Values in it can be changed from Preferences, or manually by using a text editor such as Notepad to edit the file (carefully!) while SpecView is NOT running.
This file can be deleted to restore the settings back to the values as they were when SpecView was installed as it will be recreated when SpecView starts if it doesn't exist.

Note: When making an Archive of a project to move to another computer there may be settings in the SV3.INI file which are important to the functionality, but which won't get included in the Archive. The SV3.INI file may need to be backed-up separately.

7.10.29 Toggle

Toggle is a general term for a button or menu command which allows a setting to be turned off and turned on. When a menu command is used as a toggle, choosing the menu command will swap the option from off to on, or vice versa. A tick indicator will show whether the setting is on or off.
An example of a toggle menu command in SpecView is the 'Show Logging in Variables List' menu command accessed from the Database sub-menu on the Setup menu.
An example of a toggle button command in SpecView is the 'GDW Control: Toggle Full Screen mode'

To setup a toggle button on a GDW, such that successive clicks will toggle a boolean variable On/Off/On/....
Set the button action to do a Math Function and subtract the Boolean from itself and store the answer in itself, for example:
Copy From: Bool1
Subtract: Bool1
Copy To: Bool1
7.10.30 Tooltips

Tooltips are small information boxes which appear when the mouse is over a button or box. The text typically describes the purpose of the button or box, some examples are:

![Tooltip Example Image]

7.10.31 Variable

A variable is a specific piece of information within an instrument. The variable name is always made up of two components: `<name of instrument>.<name of parameter>`

Examples:
- Barrel Zone 1.Setpoint
- Furnace 3.Process Value

Variables may be selected and placed anywhere on a GDW, used as a Pen on a Trend chart, as a value in a Bar chart or selected to be included in a Recipe or data logging.

There are several Variable Types. The Properties of a variable can be changed.

SpecView itself is considered an Instrument with its own Variables

For those who are familiar with the abbreviated variable names used by the instrument's control panel SpecView also has the concept of variable Short Names. Read Parameter List

7.10.32 Variable Types

These are the types of User Variables that can be created in SpecView:
For more details see SpecView User Variables

### 7.10.33 Variables List

Accessed by clicking on the Toolbar while in Edit Mode, it is a pop-up box listing all the variables of all the instruments in the current project. To display a variable (name and value) on the GDW Double-Click the variable within the Variables List box.

SpecView Variables

### 7.10.34 Web Server Option

SpecView's built-in Web Server is a dongle option.

It is a built-in Web Server inside the SpecView program that allows the currently showing Computer screen to be served up as a web page from time to time to web browsers. It will show the whole screen, not just SpecView's GDWs. It allows no interaction with the system whatsoever. Its use is limited to being able to just see what is on the screen at that moment.

To properly view and interact with a SpecView at another location SpecView's Local/Remote networking facility would be required.
To use the Web Server it should first be enabled and the refresh rate set using Preferences - Web Server.

There is also a simple web page file, which is required to interact with it, this can be requested when ordering the dongle option.

This web page file should be put into the main SV3 folder and the Web server (if it is enabled) will use it to display the screen shots.

It is advisable to ensure that the pre-defined SpecView variables:
  SpecView.Date
  SpecView.Time

are displayed on the screen so that the remote user can see exactly when SpecView last refreshed the information.

### 7.10.35 Windows Filenaming Rules

A file name can contain up to 215 characters, including spaces. However, it is not recommended that you create file names with 215 characters. Most programs cannot interpret extremely long file names. File names cannot contain the following characters:

| \ ` ~ ! £ $ % ^ & * ( ) + = { } [ ] : @ ~ ; ' # < > ? , . / |

### 7.10.36 Writeable Variable

An instrument variable that can be changed over communications, for example, a setpoint

**NOTE:** Some variables can be both Writeable AND Read-Only, for example, output power in a controller can be writeable when the instrument is in 'Auto' and be Read-Only when the controller is in 'Manual'.

The 'R' column of the Variables List shows which parameters are Read-Only and double-clicking in the box in the 'R' column will set (or unset) this.

Alternatively select the parameter and click Properties and use the Attributes tab to set (or unset) whether the parameter is Read-Only.

However, parameters on an instrument that cannot be changed are always read-only (for example a measurement), consequently these cannot be unset.
Top Level Intro

This page is printed before a new top-level chapter starts
8 Trend Charts

Trend charts graph (or plot) variables with respect to time.

Use the **Trend Chart** menu item from the **Draw Menu** OR click the Trend Chart tool on the toolbar.

**Go to Drawing Basics for general instructions**

After clicking the tool the cursor changes to 

Use the tool as you would to draw a rectangle. As you move the mouse the Trend chart appears:

![Trend Chart](image)

When you release the mouse button the **Trend Chart Properties** box and the **Variables List** are displayed. Use these to set up the Trend chart.

*Note: Charts from previous versions of SpecView can be converted.*

For details on Runtime functionality see: Using Trend charts in Runtime Mode

The features of Trend Charts are:

- **Back-fill** of historical data when the screen (GDW) is opened. This is independent from Historical Replay.

  *Note: The data points for back-fill are from logged data, so the resolution of the points is in*
accordance with the data logging rate.

- **Scrollback** using the scrollback thumb to view up to 10 chart widths of previous data:

  ![Scrollback Image]

- **Chart Notes** to mark significant points on a chart.

  ![Chart Notes Image]

Chart Notes can be setup to be added automatically.

- **Zoom** - Drag an area of the chart to expand X and Y axes. The popup-menu includes options to export data in zoomed area to a CSV file. The number of intermediate values is specified on the Chart tab.

- Multiple **scales** on the left or right of the chart, for some or all of the pens, with optional value pointers.

- Popup menu - Trend charts now have a popup menu that can be accessed from Runtime Mode using either the left or right mouse buttons, for compatibility with touch-screens which don't have a 'right' mouse button. In **Edit Mode** the popup menu is only available using the right mouse button. This is because the left button is used to select the Trend Chart for moving and resizing.

The new **Trend Chart Properties** box is accessed by either choosing **Setup Chart** from the popup menu or clicking the **Setup** button (if it is enabled) from Runtime Mode.
The **Setup** button is enabled from the **Buttons & View** tab.

Settings can be saved for future use by clicking the **Save settings as default for new charts** button.

A quick way to assign variables for the pens is to multiselect a number of variables from the **Variables List** and drag & drop them into the pens box on the **Pens** tab.

Pens are assigned **default colors** according to the whether the chart background is a light or a dark color. To change the color and settings of a specific pen select it in the **Pens** box and click the **Edit** button to open the **Pen Properties** box, with the following tabs:

**Pens & Pen Properties**
- Thickness setting for each pen
- **Decimal point** setting for each pen
- **Preset tolerance band.** Example: draws ±10° lines relative to the Working Setpoint to check for deviation. This is not currently implemented, see **alternative method**.
- Pen trace can blink and/or change color on alarm
- Automatic or fixed scaling with logarithmic option
- Optional pointers for each pen on scales
- Y-Axis auto scaling

**Chart**
- Smooth Scroll – the chart scrolls to the left or downwards*; the latest value will be always shown at the right or bottom* of the chart (* depends on horizontal or vertical chart)
- Jump Scroll (like SpecView Version 2) – when the last segment is full, the chart will jump one
segment
- No Scroll – the chart will keep expanding the time axis to fit all the data. This means the chart will show all the data, which is useful if the duration of the batch process is unknown
- Time span selections (from 30 seconds to 60 days) with scroll-back management settings
- Vertical scrolling chart option for compatibility with paper chart recorders

**Pen Scales**
- Scales for any pens, left or right

**Time Axis & Gridlines**
- Secondary elapsed time display, which is useful for batch processes

**Cursors**
- 2 cursors showing the exact values of the pens and the differences in values between the 2 cursors

**Chart Notes**
- Chart notes to mark significant points on a chart. Chart Notes can also be setup to be added automatically

**Values**
- The pen values along the top of the chart can have additional information and be formatted in different ways.

**Print & Batch**
- Chart print and screen print options
- Page print to printer or JPG
- File name selection – fixed or from a SpecView variable
- Display the chart with a dark background for clarity on the screen, but when printing use a white background to save ink

**Colors**
- Automatic pen color assignment

**Buttons & View**
- Flexibility of items displayed in the top right corner of the Trend Chart

It is also possible have a chart which plots X with respect to Y (as opposed to X with respect to Time) by using an ActiveX control, for example, by buying an ActiveX XYChart from Century Soar, see here: [http://www.cstsoft.com/english/trend-gdiplus.htm](http://www.cstsoft.com/english/trend-gdiplus.htm). This may look similar to this:
8.1 Trend Chart Conversion

Old Version 2/2.5 charts can be converted by just clicking to open the Trend Chart Properties box and choosing the method of conversion:
To quickly convert many charts setup the first one as required, then click the Save settings as default for new charts button. When the others are converted it will use those defaults saving setup time.

*Note: That it is not possible to convert a chart back to Version 2 or 2.5 format from Version 3.*

### 8.2 Trend Chart Runtime Mode

Trend Chart features available in Runtime Mode include:

**Pause**
- To pause the chart right-click and choose Pause Chart from the popup menu. The scroll-thumb will scroll as the pens are drawn. However, the chart will resume when the scroll-back screens have been filled.

**Zoom**
- Click and drag an area of the chart to expand X and Y axes, and choose Zoom to area & pause from the popup menu.
The number of intermediate values used to fill in the pen trace lines when the chart is zoomed is specified on the Chart tab of the Trend Chart Properties box.

The chart will pause until scrollback space is full.

The popup-menu includes Export Range to CSV to export the data in the zoomed area to a CSV file. The CSV file will be full resolution including the intermediate values.

The zoomed chart will pause until the chart and any scrollback screens are filled, at which point the zoomed chart will continue scrolling automatically. The reason for this is to conserve computer memory.

To un-zoom a chart click and choose Zoom->Back from the popup menu.

The difference between real-time & Historical Replay is that zooming a chart while in Historical Replay will not fill in the intermediate values, because these are not logged. Therefore the resolution of the chart will be the data logging rate as opposed to using the intermediate values stored for zooming.

**Note:** Zooming a Trend Chart is separate from zooming a GDW. This is because zooming a GDW will not expand the trend chart and fill in the zoomed pen traces with the intermediate values.

**An example of zooming:**

If the chart is 2 hours wide with 10 scrollback screens which is currently showing data from 10:00 to 12:00 and the part of the trend to be zoomed is the 10 minutes from 10:15 to 10:25, then the middle of this range is therefore 10:20.

The Scrollback thumb will be repositioned to the middle of that range, which in this example is 10:20, and there will be 5 scrollback screens to the left of center, going back 5 x 10 mins to 09:20, and 5 scrollback screens to the right of center, going forward 5 x 10 mins = 11:10.

Therefore, when zoomed-in there are +/- 5 screens to the left/right of the center of the zoomed time period.

To see the detail beyond those 5 screens, exit zoom to go back to normal and re-zoom elsewhere.

**However, there are exceptions to this:**
Assuming the same 2 hour chart as described above, 10:00 to 12:00 with a current time of 12:00

To zoom in on the final 10 minutes - 11:50 to 12:00, there are no screens to the right as there is no data available yet, so the 10 scrollback screens will be positioned to the left.

*Note: The number of scrollback screens in Zoom mode is the same as the number of scrollback screens in un-zoomed mode. Therefore, if there are 6 scrollbacks, then there will be +/- 3 around the center. However, if the Realtime chart has less than 3 scrollbacks (e.g. 0) a new value of 4 is used for the duration of zooming (so there will be +/- 2).*

**Back fill**
- Trend charts are back filled with logged data when they are opened. It is necessary to select Start on Right on the Trend Chart Properties Chart tab for the back-filling to work.

*Note: A Trend Chart will only be able to be 'back filled' if there is some logged data.*

*Note: If there are no scroll-back screens specified on the Chart tab and if the chart is set to Start on Left, then back filled data will not be seen.*

**Scrollbar**
- Trend charts can be scrolled back using the scrollback thumb along the time axis. The settings for this are specified on the Chart tab of the Trend Chart Properties box.

**Cursors**
- Trend chart cursors are 2 cursors that can be positioned on the chart to show the exact values of the pens and the differences in values between the 2 cursors.

**Chart Notes**
- Chart notes are used to mark significant points on a chart. Chart Notes can also be setup to be added automatically
- Chart notes that are not assigned to a pen will be seen on all trend charts.

**Trend Chart Pen Scales**
- If the trend chart only has one value scale, then to see the scale of any of the other pens, click the pen labels along the top. However, this will only become noticeable if the Pens have different scales and/or colors because the scale and color will change too.

*Note: If, for example, there are 4 pens but only 3 scales have been added then it will not be possible to see the scale of the 4th pen. Therefore either have just one scale, or have a scale for each pen.*

**Auto-open on Runtime**
This menu command on the Edit Mode File menu should be used if a project has more than one GDW defined which contain Trend Chart(s).
In this case the menu command should be used on each of the GDW's to ensure that their traces start whenever SpecView goes into Runtime Mode.

*NOTE: Be sure to click this menu command if the GDW has a Trend chart. If you do not, the GDW will have to be opened in Runtime Mode before the Trend chart...*
will start.

8.3 Trend Chart Runtime - Export Range to CSV

Select an area of the chart and choose ‘Export to CSV’ from the popup-menu. This will create a CSV file containing the values of ALL the variables on the chart between the time at the left of the box to the time at the right of the box.

This is similar, but not the same as, doing a ‘Log Report’ of those variables between that ‘Start Time’ and ‘Stop Time’. The amount of data stored is not the same as the data logging rate – because more data is stored for a trend chart to be used for zooming in ‘real time’. The CSV file will also have an additional column for milliseconds to give more time precision. This column can be disabled if it is considered more important to have the same columns as in a Log Report than to have the time precision.

[TREND]
CSVExportDateTimeSeparated=1
CSVExportSuppressMS=1

To set the amount of data data stored use the Chart tab on the Trend Chart Properties.

The width of the chart in pixels and the duration of the chart determines the update rate of the chart.
The number of intermediate values gives added detail (precision) for zooming and for export to CSV file.

In this example the 0.1s means that the CSV file will contain about 600 lines for each minute.

To have the same number of lines in the CSV file (for a given duration) as in a Log Report over the same duration, set the number of intermediate values to zero.

However, in this case zooming-in will not give any greater resolution on the data.

8.4 Trend Chart Properties - Pens

The pens on a Trend Chart are setup using the Pens tab on the Trend Chart Properties box. Variables can be assigned by selecting (or multi-selecting) in the Variables List and dragging & dropping directly into the Pens box.
Note: If a variable that is not currently being logged is added to a Trend Chart then logging is automatically enabled for this variable. This can be disabled by subsequently un-checking the logging checkbox in the Variables List.

**Maximum number of Trend chart Pens**
There is no limit to the number of pens on a Trend chart BUT the number of labels that can be shown is limited by:
- The length of the label
- The width of the chart
- The size of the Font selected for the chart

If more pens are defined than can be shown on the top line of the chart:
- A '>' symbol to the right of the last label indicates that not all of that label is displayed
- A '+' sign to the right of the last numeric value indicates that not all of the defined pens are shown

The **Move Up** and **Move Down** buttons set the order of the pens along the top of the chart. They also determine the priority of each pen trace, with the highest priority pen at the top of the list, such that if a pen trace overlaps another then the higher priority pen trace will be drawn on top.

Clicking the **Add** or **Edit** buttons opens the **Pen Properties** box:
If a variable isn’t already assigned then drag and drop from the Variables List, or click the Choose button. The pen Label, Units and Description can be entered. Check the boxes on the Values tab to see the Units/Description on the Trend Chart.

DP is used to set the decimal places, up to 4 DP and also in scientific notation. Or in the case of plotting a time variable, the precision of it.

The appearance of the pen trace can be made to change based on a boolean alarm.

**Drawing Mode:**
- Tolerance Band allows 2 lines to be drawn (+/-), one either side of a process value. This makes it easy to see when the process value goes outside the tolerance band. The tolerance band can be based on another variable. This is not currently implemented, see alternative method.
- Other drawing modes will be available in a future version.

**Scale:**
- The Scale box works in conjunction with the Pen Scales tab. Use the Pen Scales tab to specify which parameters have a scale, and whether they are shown on the left or right.
- By default, scales are set to Auto. This means that the scale will automatically adjust according to the value.
- The scale can also be Fixed to a Max and Min, or set From Variables, for example, Lo Range and Hi Range instrument variables. If the scale is From Variables and these values are not available over comms the Fixed Max and Min will be used for the scale.
- The scale can also be Logarithmic, which is useful for pressure and vacuum measurements.
Note that scientific notation is available on the DP drop-down-menu for very big or small values.

- The scales can have **Major Divisions/Minor Divisions** shown either as just tick-marks or with **Show Values**.
- If the divisions are set to **Auto** then the **Minor Division** will be half the **Major Division**.
- Use round numbers if using fixed scales (such as numbers that end in a 0 or a 5); this allows the divisions to be better placed for clarity.

**Gridlines:**

- When the orientation of the chart is horizontal (as specified in the **Chart** tab) then the gridlines will be horizontal.
- Fixed lines can be set in addition to the Major and Minor division lines.
- If the gridlines for the **Major Divisions** and/or the **Minor divisions** are setup on more than one pen trace, and those gridlines happen to overlap, then the gridlines for the pen nearest the top of the list of pens on the **Pens** tab will take precedence (be drawn on top).

**Scales for any pens, left or right:**

This chart has 2 scales on the left and 2 on the right:
The further up the list a pen is, the closer it is to the plotting area of the chart, hence the topmost pen in these lists will be adjacent to the chart plotting area. So in the example above the scale for Oven 1 is shown nearest the chart plotting area.
8.5 Trend Chart Properties - Chart

### Determining the resolution of a Trend Chart

SpecView will draw one pixel on the Trend Chart pen line according to the time span of the chart & the width of the chart in pixels. Therefore if the time span of the chart is 28 days & the chart is 1000 pixels wide then one pixel will be drawn and every 40 minutes. This also applies to the rate at which the values shown along the top of the chart will be updated.

To ensure the current values can be seen put the values out onto the screen from the Variables List.

### Time Span

Trend charts can have a scrollback thumb along the time axis to allow the chart to be scrolled back to view up to 10 chart-widths of previous data. This data is independent of Data Logging and Historical Replay. Therefore, scrollback will still work even if Logging is disabled and if there is no Historical Replay option on the dongle.

*Note: When there is no Historical Replay option on the dongle then scroll-back is limited to ONE chart-width only.*
• **Duration** is the width of the time-axis of the visible chart. The rate that pixels will be added to a pen trace on the chart can be calculated by taking the actual width of the chart in pixels on the screen, and dividing by the chart **Duration**. For example, a chart with a duration of 30 mins (1,800 seconds) that is 400 pixels wide, will have one pixel added to each pen trace every 4.5 seconds.

• **Scrollback screens** specify the amount of previous data, as a multiple of the duration, that can be accessed using the scrollback thumb. For example, if the Duration is 30 minutes, and there are 10 **Scrollback screens** then the total amount of previous data that can be viewed using the scrollback thumb is 300 minutes. The number of scrollback screens cannot be set if **Scrolling** is set to **None**, this is because all the data is visible in the plot area.

  Note: Beware of memory usage. This is because, for example, a 30 minute chart with 10 scrollback screens, storing 10 **Intermediate values**, would use about 26Mb of memory.

  Note: When there is no **Historical Replay option** on the dongle then scroll-back is limited to ONE chart-width only.

• **Store this many intermediate values for zooming** - is the number of additional data values that are stored (but not Logged) between pixels and can be used to fill in the pen trace lines when the chart is zoomed. For the chart in the example above, where a pixel is added to the pen traces every 4.5 seconds, if the **Intermediate value for zooming** was 8, then a point would be stored every half second. These extra points would be seen when the chart is zoomed. However, these intermediate values are only stored in memory and are not logged to disk for use in Log Reports and Historical Replay.

  Note: To avoid compromising the performance of the system, it is important that the speed of these intermediate values is not too high, otherwise comms could be overwhelmed.

  Note: It is not possible to zoom a chart in **Edit Mode** as clicking to drag out a zoom rectangle
would conflict with clicking to drag the chart to move it.

Colors
- **Chart Surround** and **Plot Area** - choose colors that have good contrast with the text and the trace line colors. The **Colors** tab is where the default pen colors are set for both dark and light background charts. Dark background charts are considered to be easier to read on a screen, and light background charts are used for printing to save ink.

Border
- **Outer Color**, **Inner Color** and **Thickness** - choose colors that compliment the **Chart Surround** and **Plot Area** colors.
- **3D** gives the edges of the Trend Chart a beveled appearance, however it needs to be thick enough for the edge to be visible.

Start & Close modes
- **Start on Left/Right** - indicates whether the pen trace should start on the left or the right of the plot area.
- **Set T=0 at start or clear** - sets the elapsed time (T) to zero when the chart starts or is cleared. To clear a chart right-click and choose **Clear Chart** from the popup menu. The elapsed time (T) can be displayed along the time axis from the **Time Axis & Gridlines** tab.
- **Prefill from historical data** - note that the prefilled data will only be seen if the chart is set to **Start on Right** and/or scrollback screens are defined.
- **Auto open** - begins filling this chart (GDW) as soon as communications start. This happens when going into Runtime Mode, or in Edit Mode when **Online Features** are enabled from the menu.
- **Prevent close** - to avoid the operator from closing the chart and stopping it from being updated.

Orientation
- **Vertical Chart** will make the chart scroll in a way that looks similar to paper chart recorders.
Scrolling

- **Smooth** - (continuous) scrolling charts are better visually, but be aware of CPU usage as this feature makes heavy use of the CPU.
- **Jump** - charts that jump use less CPU, because they are redrawn less frequently, which is useful when optimal performance is required.
- **None - rescale time to fit** - these charts will also jump, which makes efficient use of CPU. These are ideal for batch processes when the whole batch needs to be viewed at once. However, it is not possible to scroll-back a chart in this mode because all the data is visible in the plot area.

8.6 Trend Chart Properties - Pen Scales

This tab specifies which pens should have scales, and whether they should be on the left or right of the Trend Chart.
Or, in the case of a vertical chart, at the top or the bottom.
The pens nearest the top of each list will have their scales nearest the plot-area of the chart. Hence in this example, the scale for Oven1 is nearer to the plot-area than the scale for Oven2.

Change scale 1 to selected pen - this will only take effect while in Runtime Mode (not in Edit mode)
and only if there is just one scale. Clicking the pen values will switch the scale to show the scale for the selected pen.

If the trend chart only has one value scale, then to see the scale of any of the other pens, click the pen labels along the top. However, this will only become noticeable if the Pens have different scales and/or colors because the scale and color will change too.

*Note:* If, for example, there are 4 pens but only 3 scales have been added then it will not be possible to see the scale of the 4th pen. Therefore either have just one scale, or have a scale for each pen.

**Auto rescale Y axis to show data** - Instead of using the Min and Max specified for the scale, it will automatically adjust to fit the values. Therefore, values will never be outside the range of the scale.

---

### 8.7 Trend Chart Properties - Time Axis & Gridlines

This tab is used to setup the time axis and its gridlines.

Choose colors that contrast with the background, and ideally which are different to the colors of the pen traces.

Selecting Auto for **Time Axis Major Divisions** and/or **Time Axis Minor Divisions** will mean that the Time Span of the chart will be used to calculate appropriate time intervals for these divisions.

The **Show real time X axis** shows the current time along the time axis, and depending on whether the **Use 24 hour clock** box is checked either shows, for example 16:32:59 or 04:32:59PM.

The **Show elapsed time X axis** shows the time that has elapsed since T (Elapsed Time) was last set to zero. This axis will commence updating once T has been set to zero.

T can be set to zero in one of 3 ways:

1. From the **Chart** tab use **Set T=0 at start or clear**, one or more of these can be specified
2. Clicking on the chart and choosing **Set <current time> as 0 Elapsed Time** from the popup menu:
3. The **Automatic Batch Interaction** on **Print & Batch** tab can monitor batch interactions, and will set T=0 whenever the specified text variable (with the batch tag property) is given a value to start a batch.

These actions to set T=0 can be performed as often as required.

The current elapsed time will always be recorded, and cannot be removed. Such that the Elapsed time can be seen in Historical Replay if the Elapsed Time axis is being displayed.

### 8.8 Trend Chart Properties - Cursors

Trend Chart cursors are used to display the values of the pen traces at 1 or 2 positions.

When 2 cursors are on the chart then the difference in values is shown.

Cursors are available by right-clicking on the chart and choosing **Place cursor 1** or **Place cursor 2** from the popup menu.

Use the cursor keys '->' or '<-' on the keyboard to nudge the selected cursor left or right. The selected cursor is indicated by a '>' at the top, whereas the cursor with a 'V' at the top is not the selected cursor.

The cursor keys will skip the cursor to the next data point, so it may be necessary to press the cursor keys many times on a dense chart, or it may jump a large distance, when data points are further apart, such as when in Historical Replay.

So the best method of positioning a cursor is to click and place the cursor as close as possible to the required position and then fine-tune with the cursor keys.
To select the other cursor, in order to be able to move it with the cursor keys, it is necessary to 'place' it again, and it will become the selected cursor, indicated by a '><' at the top.

The style, thickness and color of both cursors can be specified from the **Cursors** tab on the **Trend Chart Properties** box.
The location on the chart to show the values at the cursors can also be specified, in the following ways:

1. **Show in-chart**:
   - The values and difference between the values are shown in the plotting area:

2. **Override pen labels**:
   - When only one cursor has been placed then the values shown will be the values at the cursor.
   - When both cursors have been placed, the values shown will be the difference between the values at the cursors.
3a. **Auto expand values area to show cursor values** - and when **Horizontal** is selected on the **Values** tab.
This shows all the required information at a glance, but reduces the available space for the chart itself.

3b. Or, **Auto expand values area to show cursor values** - and when **Vertical** is selected on the **Values** tab.
This uses screen space more efficiently especially when many other boxes are checked on the Values tab:

<table>
<thead>
<tr>
<th>Value</th>
<th>Left</th>
<th>Right</th>
<th>Diff</th>
</tr>
</thead>
<tbody>
<tr>
<td>Oven1</td>
<td>1750.0</td>
<td>1385.4</td>
<td>1327.5</td>
</tr>
<tr>
<td>Oven2</td>
<td>1750.0</td>
<td>482.4</td>
<td>1124.7</td>
</tr>
<tr>
<td>Oven3</td>
<td>1800.0</td>
<td>1600.0</td>
<td>1600.0</td>
</tr>
</tbody>
</table>

8.9 Trend Chart Properties - Chart Notes

Chart Notes allow the user to add annotations to the chart:

Chart Notes are setup initially on the Chart Notes tab of the Trend Chart Properties box:
Note Color and Font:
The color and font of the expanded Chart Note. The color of the push pin is set on the 'Add Chart Note' box.

Show as Push-Pin:
The Chart Note will be shown as a Push Pin instead of expanded to show the text. Click the Push Pin to expand it.

Show as vertical line:
This feature is not yet implemented.

Require re-login to authenticate contents:
If passwords are enabled then this will prompt the user for their password before they can create a Chart Note.

Allow delete:
Controls whether or not Chart Notes can be deleted.

Require Level 5 password for delete:
If passwords are enabled then this will only allow a Chart Note to be deleted if a 'Level 5' user is logged in.

Automatic Chart Notes:
For details on adding Chart Notes automatically see Automatic Chart Notes
The Color is the color of the Chart Note’s Push Pin and also the border color of the Chart Note when it is expanded.

Note: The color of the Chart Note when it is expanded is set using 'Note Color' on the Chart Notes tab of the Trend Chart properties box.

Associate with pen:
When a Chart Note is associated with a pen the value of that pen is shown in the expanded Chart Note together with the note’s text and time.

Always print expanded:
This forces the Chart Note to be printed in its expanded form (not just as a Push Pin) using the color as defined by 'Note Color' on the Chart Notes tab of the Trend Chart properties box.

For details of how information added as Chart Notes to Trend Charts can be saved see Log Report.

8.9.1 Automatic Chart Notes

Chart notes can be added automatically to the chart based on events in the process, without relying on manual intervention.
Click the **Add** button under **Automatic Chart Notes**.
A boolean variable can be assigned, and the chart note text specified for the annotation when that boolean variable changes.

*Note: It is advisable to keep the text for chart notes concise.*

Automatic chart notes can be used, for example, to mark when doors are opened on furnaces and to mark batch endings.

A chart note can be triggered when a boolean is On and/or Off by using **Trigger on True**, **Trigger on False** or **Trigger on both**.

If a chart note is associated with a pen, the chart note will appear on the pen trace. 

*Note: If the pen associated with a chart note is on multiple charts then the chart note will automatically be added to all charts with that pen.*

If the chart note is *not* associated with a pen (**Pen Association** is **None**), the chart note will appear along the edge. 

*Note: If there are multiple charts then the chart note will automatically be added to ALL charts containing one or more of the pens on this chart.*

Optionally, the time between selected notes can be added to the annotation:
If using **Trigger on True** or **Trigger on False** then checking **Add time since note** adds the elapsed time since the last time the specified automatic chart note was created. This can be specified as *<This One>* meaning this automatic chart note. This is useful where an auto-note is signaling the end end of a batch, in this case, the duration is automatically calculated.
If using **Trigger on both** then checking **Add time in '1' state** adds the duration that it was in the 1 state.
This is useful where an automatic chart note is, for example, marking the end of a batch. The duration of the batch is automatically calculated.

The **On Delay** and **Off Delay** are useful when a value fluctuates causing a boolean to flicker on and off before stabilizing.
For example, a boolean indicating whether the Process Value has reached a Setpoint could flicker as the process value approaches the Setpoint.
This delay will mean that the position of the chart note will be at the beginning of the first time it stays **On** for this delay:

Without the **On Delay** and **Off Delay** the automatic chart note would keep recurring during the stabilization period of the value.

The color of the chart note should be set to a color that contrasts with the chart background color.

There is no limit to the number of automatic chart notes that can be defined on a chart.

### 8.10 Trend Chart Properties - Values

This tab of the Trend Chart Properties box controls what is shown in the 'Values' area of the chart. The 'Values' area is along the top of the chart, which by default contains the **Current value** and **Label** for each pen.

Additionally it is possible to show other information:
Horizontal - the information for each pen is shown as a horizontal table - with the pens going across, which uses screen space more efficiently when there are many pens:

Vertical - the information for each pen is shown as a vertical table - with pens going down, which uses screen space more efficiently when many of the other other boxes are checked on this tab.

The information about cursors can also be influenced by what is checked on the Cursors tab.

The Values Area Color is usually kept the same as the Chart Surround color on the Chart tab.
8.11 Trend Chart Properties - Print & Batch

Auto print screen to printer:
When the chart is full auto print the whole screen.

Auto save chart to JPG:
When the chart is full auto save the chart to a JPG file.
File name selection – fixed or from SpecView variable
Display the chart with a dark background for clarity on the screen, but when printing use a white background to save ink. The pen colors for the white background can be made to automatically switch appropriately, as defined on the Colors tab.

Always print white background:
This is a setting to save printer ink.

Auto Name:
The filename of the JPG file will be the name of the GDW followed by the date and time, for example: SPECVIEW1.GD3_20140812_150430.JPG

Automatic Batch Interaction
This can monitor text variables which have their Batch Tag property set, and will set elapsed time (T) to zero whenever the batch variable is given a value to start a batch.
To see elapsed time (T) enable Show elapsed time X axis on the Time Axis & Gridlines tab.
8.12 Trend Chart Properties - Colors

A chart with a dark background in the plot area is normally easier to see on a screen, however, when printing, a light background is preferable to save ink.

Default Colors
- These colors are the default colors of the pens unless the pen color is overridden in the Pens Properties box.
- Choosing Auto Select means that SpecView will assess the color specified for the Plot Area on the Chart tab and automatically determine if that color is dark or light and choose the set of default pen colors accordingly.
- The pen colors for printing with a white background can be made to automatically switch as appropriate on the Print & Batch tab.

8.13 Trend Chart Properties - Buttons & View

This tab sets up the items displayed in the top right corner of the Trend Chart.
Show Setup/Help Button

These enable the respective buttons. However because chart space is limited in the top right corner these buttons obscure the date. Therefore it is recommended to either have the Date or the Setup and Help buttons. If the date is also required then put the SpecView Variable SpecView.Date out onto the screen and position it near the chart.

To access the Trend Chart Properties box in Runtime Mode, if there is no Setup button, it is necessary to click on the chart and choose Setup chart from the popup menu. For touch screens, or laptops with touch pads, it is more convenient to use the Setup button.

Date Format:
For the % sequences used to format date variables see Date and Time Formatting.

8.14 Trend Chart Gridlines

Horizontal and Vertical gridlines on Trend Charts are specified differently depending on whether the chart’s orientation is Vertical or Horizontal.

The orientation of a chart is specified on the Chart tab:
- Horizontal orientation:
  - X axis is the time - time gridlines are vertical
  - Y axis is the value - value gridlines are horizontal

© 1995 - 2015 SpecView
Vertical orientation:
X axis is the value - value gridlines are vertical
Y axis is the time - time gridlines are horizontal

Value gridlines - are defined from the Pens tab by clicking the Edit button for the selected pen to open the Pen Properties box.
Time gridlines - are specified on the Time Axis & Gridlines tab.

### 8.15 Trend Chart - CSV Export

When exporting a chart or part of a chart to a CSV file there are some options that can be set in the Settings.INI file in the [TREND] section (add this section header if it's not already there):

To separate Date & Time into 2 separate columns instead of having date and time in one
column:
CSVExportDateTimeSeparated=1

To disable the MS (Milliseconds) column:
CSVExportSuppressMS=1

The reason the MS (Milliseconds) column was added is because when the chart is exported from live data (as opposed to data which has been read from Logged Data) then there is additional data which is stored for zooming which can give greater than 1 second resolution, and which will be in the exported file, hence the need for milliseconds to give a more precise time stamp.

Whereas, when the chart is exported from data which has been displayed on the chart from previously recorded as Logged Data using Historical Reply or chart backfill then there is no need for milliseconds because the fastest logging rate is once per second.

See also Decimal Places
Top Level Intro

This page is printed before a new top-level chapter starts

Part IX
9 Instrument Connectivity

For the latest list of supported instruments see the SpecView website: http://www.specview.com/html/instruments.html

Instrument Installation and Wiring
Instrument Settings
RS422 (EIA422-A) Instruments
RS485 (EIA485) Instruments
Ethernet and TCP/IP
Communications Protocol
Increasing Speed of Instrument Communication
Multiport Option

OPC Client Support
DDE (Dynamic Data Exchange)

See also:
   Troubleshooting Instrument Communication
   Connections for SpecView Networking

9.1 Instrument Installation and Wiring

**NOTE:** If communications cannot be established between SpecView and the connected instruments first check the instrument manufacturer’s manual for correct wiring instructions. For further assistance please contact the instrument manufacturer. They may have test programs that will check your converter and connections.

USB
Most computers have built in standard USB ports.

RS422/RS485
If the intention is to use RS422 or RS485 wiring to connect the instrument, then an external converter from USB to either RS422 or RS485 (as appropriate) must be used. SpecView recommends converters made by B&B Electronics.
The reason the B&B device is recommended is because it has 'Automatic Send Data Control', this automatically switches from transmit to receive and so works very well with SpecView.

RS232
Some computers have built in standard RS232 (9-pin) ports specified as:

<table>
<thead>
<tr>
<th>Pins</th>
<th>Code</th>
<th>Description</th>
<th>Input/Output</th>
</tr>
</thead>
</table>

© 1995 - 2015 SpecView
If the intention is to use RS232 wiring to connect the instrument, then the wiring and the connection to the instrument will be specified by the instrument's manufacturer.

RS232 is point-to-point, therefore it has a maximum of a single instrument connection. Whereas RS422 and RS485 allow multiple instruments to be daisy-chained together, here is an example of this:

Please note that RS422/485 connections should be terminated correctly, please see the instrument manufacturer's instructions.

**NOTE: We strongly caution against using internal 422/485 cards**

Unless you are expert in testing and troubleshooting communications, we recommend using internal RS232 ports and external isolated converters. Since all computers have serial ports a second computer can be used to determine whether a problem is in the computer or wiring if an external converter has been used.

- Each serial port MUST operate with its own interrupt unless special interrupt sharing cards and software are used.
- Serial ports using 16550 UARTS or above are strongly recommended, especially if BAUD rates above 9600 are going to be used. They are required for instruments that use block mode data reading.

The number of controllers that can be connected to SpecView is only limited by the available addresses on the controllers. Most instruments go to 99 addresses and SpecView supports up to 9 COM ports as standard and can be to 40 ports.

RS422 and RS485 would need repeaters if there are more than 16 or 32 instruments respectively. Please see the instrument manufacturer's instructions or the converter's manual.

**Instrument Settings**
9.2 Instrument Settings

SpecView has help available for several makes of instruments:

The Ports and Protocols box (which is accessed by clicking the Test Comms for New Project button on the Projects box) is used for automatic detection of connected instruments.

On this box when a protocol is chosen, for a given port a Help button appears for that port. Each port can use a different protocol if required, but the Multiport dongle option will be required.

Clicking the Help button will open a separate help file specifically for that protocol. Refer to it for details on setting your instruments.

This help can also be accessed by double-clicking on the instrument name in the Variables List by clicking the Variables List tool.

9.3 RS422/EIA422

RS422 this is a 4 wire connection and has a maximum cable length of 1.2 km and a maximum of 10 instrument connections.

All four wires MUST be used. Follow the instrument manufacturers instructions carefully, paying attention to shielding in electrically noisy environments.

The converter will have two Transmit (sometimes called Send) and two Receive connections.

These are marked either ’+’ & ’-‘ or ’A’ & ’B‘ (or both)

- In general, the Transmit connections on the converter go to the Receive connections on the instrument.
- In general, the Receive connections on the converter go to the Transmit connections on the instrument.
- In general, the ’+’ or ’B’ connections on the converter go to the ’+’ or ’B’ connections on the instrument.

NOTE: Most instruments made by Eurotherm Controls DO NOT follow this convention. In most cases connect Converter T+ (or B) to Instrument R-, Converter T- (or A) to Instrument R+ and so on. Please check this in Eurotherm’s Instrument Manual.

9.4 RS485/EIA485

RS485 this is a 2 wire connection and has a maximum cable length of 1.2 km and a maximum of 32 instrument connections.

Although this is normally a two wire connection some instruments use four wires.
Follow the instrument manufacturers instructions carefully, paying attention to shielding in electrically noisy environments.

**Two wire converters** will have connections marked 'A' or '-' and 'B' or '+'. These go to the corresponding connections on the instrument.

If the instrument has four connections you should **use a converter with four connections**. If you are told by your instrument manufacturer that you can use a two wire converter, **on the controller** jumper the Transmit + (or B) to the Receive + (or B) and the Transmit - (or A) to the Receive - (or A). This leaves you with one '+ ' (or B) connection and one '-' (or A) connection to make to the converter.

**Four wire converters** will have two Transmit (sometimes 'send') and two Receive connections. If your instrument has four connections read the RS422/EIA422 help. These marked either '+ ' & '-' or 'A' & 'B' (or both).

If your **instrument** has two connections, **on the converter** jumper the Transmit + (or B) to the Receive + (or B) and the Transmit - (or A) to the Receive - (or A). This leaves you with one '+' (or B) connection and one '-' (or A) connection.

### 9.5 Ethernet and TCP/IP

SpecView also supports communications via modbus/TCP through Window's TCP/IP networking, or by external TCP converter modules.

Further information on addressing is detailed in Modbus addressing

### 9.6 Communications Protocol

A communications protocol is the specification of the bits and bytes that go between the computer and instrument.

Many instrument manufacturers have in the past defined their own proprietary protocols. SpecView has drivers for many of these proprietary protocols. Although some of them are an additional driver dongle option charge.

**Modbus**

There are 3 types of Modbus protocol: Modbus RTU, Modbus TCP and Modbus ASCII. Many manufacturers are now using Modbus RTU and Modbus TCP protocols which are industry standards. SpecView's Modbus driver (for both Modbus RTU and Modbus TCP) is included as a standard driver in the base product.

**Note:** SpecView does not support the Modbus ASCII protocol.

**OPC**

Some instruments, typically PLCs (Programmable Logic Controllers), use OPC and the manufacturer supplies and OPC server for it. OPC is used to 'translate' the proprietary protocol into a format that can be understood by an OPC Client. SpecView's **OPC Client** is a dongle option.
9.7 Increasing Speed of Instrument Communications

To improve the performance of instrument communications so that the rate that instrument variables are updated is increased:

For values on the screen adjust the Medium scan rate using File->Preferences: Runtime tab.

SpecView's maximum rate of update of a value on the screen is once every 1 tenth of a second.

SpecView's maximum rate of update of a Trend chart is once a second. However, check the resolution of the Trend Chart.

The fastest rate that values can be logged to SpecView's Data Log files is once per second. Although it is possible to write values to a separate file at a faster rate using FastCount.

However, the different parts of SpecView request values at rates that are specified below:

- **Screen** Preferences - Runtime - Medium scan rate (default 20 tenths of a sec).
  To adjust the rate at which individual variables on a GDW are sampled edit the Dynamic Attributes.

- **Data Logger** Preferences - Logging - Rate (default 60 secs, maximum 1 sec).

- **Parameter List** Preferences Runtime - Parameter List PPS (Points Per Second, default 15).

- **Strategy** Preferences - Strategy - Rate (default Medium, as defined above).

- **DDE** DDE (default Medium, as defined above).

When the mouse isn't being moved the rate that instrument variables are being read is displayed in Points Per Second (PPS) in the 'status bar' along the bottom of the screen (GDW).

If the instrument is using the Modbus protocol then the maximum points per second (PPS) that SpecView can obtain from a single COM port at 9600 baud is about 30 individual points & at 19200 baud the maximum is between 40 & 50 PPS.

The maximum speed that SpecView can obtain over a good TCP/IP connection from a fast Modbus instrument can be many hundreds of points per second. However, the 'bottleneck' is often the instrument itself.

However, SpecView also has to read Alarms & request all variables marked for logging as well as anything which is being used by the Strategy Controller. So the 30 PPS isn't just reading the ProcessValue of each instrument.

SpecView's Instrument Views & Parameter lists have been designed to request data in blocks where possible to increase comms throughput. The amount of time that a block of data is stored can be changed using the Driver Command 'TTL' (Time To Live). The difficulty is tuning the setting of Time To
Live; too long & the data on the screen won't get updated from the current instrument values; but too short & the block could have timed out before SpecView has had a chance to use the data in the block & so will have to re-request it. This is especially the case if a number of instruments are turned off, or if there is a poor comms connection.

It is well worth creating a 'test' Project with just one or two instruments defined & just the minimum number of parameters out on a screen, together with GoodComms, CommsErrors, CommsErrorCode, CommsErrorItem & CommsErrorDescription, as detailed below, and noting the PPS rate.

The load can be spread over more than one COM port by using SpecView's Multiport option.

When SpecView fails to read a parameter the 'Comms Back Off Multiplier' (default value 30) is used as a delay factor before retrying. This is set from Preferences - Runtime. If instruments are intentionally turned off then to avoidSpecView repeatedly checking them set the 'Comms Back Off Multiplier' to a high value, such as 200. Although this will mean that when they are then switched back on SpecView will take longer to notice.

To see whether SpecView is having trouble reading instrument values because of a poor communications link, put these SpecView Pre-defined variables onto a screen:

SpecView.GoodComms
SpecView.CommsErrors
SpecView.CommsErrorCode
SpecView.CommsErrorItem
Specview.CommsErrorDescription

CommsErrors should be showing zero for a good communications link. Any error codes can be referenced in Error Codes. More detail can be found in Troubleshooting Instrument Communications.

While a Project is being developed, & so maybe not all the instruments are available, the 'missing' instruments can be re-addressed in SpecView to those instruments which are present, for example, if only 2 instruments are available (which are Modbus instruments at addresses 1 and 2):

1,0J
2,0J
3,0J readdress to 1,0J
4,0J readdress to 2,0J
5,0J readdress to 1,0J
etc...

This will allow the Project to run at full speed rather than wasting time trying to gather data from instruments that are not connected. Remember to set the addresses back when all the instruments are connected.

The design of a Project can effect the apparent speed of variable update, as the more parameters which are on 'open' screens (GDWs) then the more data requests are made by SpecView. Consider whether the buttons which are being used to navigate between screens should use the action:

GDW Control: Swap to another GDW
or:
GDW Control: Close this & swap to another GDW

The 'Swap to' action leaves screens open, so these continue to request data for the variables which are on them. Whereas 'Close this & swap to' will close the screen, so use this to ensure that only the necessary screens are left open. Although, screens which contain Trend charts should be left open so that the charts continue to update.

Similarly, check which screens have 'Auto-open on Runtime' enabled on them from the File menu.
The rate that variables update when using SpecView Remote can be altered by editing the Remote connection and changing: Update rate, Packet size, Packet timeout & Packet count.

For OPC connections the OPC Server itself can be tuned, please refer to the documentation supplied with your OPC Server.

If all these items have been checked & yet the update rate is still inadequate then contact your SpecView Representative. They will be able to check that the driver commands in SpecView's communications driver, such as the timeout & number of retries, are correctly set for the specific instrument(s) being used. This is done by using the Setup COM Port menu command from the Options menu.

The fastest rate that values can be logged is once per second.
If a faster rate of logging is required then the SpecView variable FastCount can be used together with the Line Writer.

### 9.8 Multiport Option

SpecView's Multiport dongle option is required in the following circumstances:

1. **For a large number of instruments:**
   If the number of instruments exceeds the maximum number of instruments for communication via a single COM port. For RS485 the maximum number is typically 32 instruments. However, more can be connected if the electrical connection is very clean & if a fast response time is not particularly necessary (this may require the use of RS485 repeaters).

   The number of controllers that can be connected to SpecView is only limited by the available addresses on the controllers. Most instruments go to 99 addresses and SpecView supports up to 40 ports.

2. **When instruments which use different protocols are being used:**
   This is because a single COM port can only communicate using one protocol. For example, if a number of instruments are all using the Modbus protocol, then they can all share a COM port, but if other instruments are added that use, say, a proprietary ASCII protocol then they would need to be connected via a separate COM port.

3. **For greater speed of response:**
   When many instruments are being used in an application for which speed of response is very important then more COM ports can be used to optimize the speed of communications.

   SpecView's maximum rate of update is once every 1 tenth of a second. However, the maximum logging rate is once per second. (Although FastCount can be used to simulate a faster logging rate.)

4. **When using OPC:**
   The Multiport OPC option will be required if it is necessary to communicate with more than one type of OPC server.
SpecView User Manual for Version 3

9.9 OPC Client Support - Overview

SpecView offers an OPC Client; initially the client only supports local OPC Servers (when support for remote OPC Servers is available in SpecView then this will be a free upgrade to existing OPC Client customers). SpecView supports any OPC Server that provides an OPC Data Access standard 1 or 2 interface – this currently means that all OPC Servers are supported (if in doubt then check with your SpecView representative).

In order for OPC to function you must have the OPC option in your dongle.

Since OPC is treated within SpecView as another 'channel'; you can mix OPC ‘instruments’ with COM port and TCP/IP based ‘instruments’.

OPC is implemented in SpecView in both Edit Mode and Runtime Mode. In Edit Mode you can use SpecView’s OPC Browser to view all of the OPC Servers currently available. This is achieved either by using the Test Comms for New Project button, then clicking the OPC button, for example:

or the New Manual Project button, then clicking the Template List tool on the toolbar and clicking the OPC button at the bottom of that box.
9.9.1 **OPC Browser**

SpecView's OPC Browser will list the available OPC Servers, see below. If your OPC Server is not listed, then it may not be running, if so click the **Cancel** button on the OPC Browser screen, start up the OPC Server and then restart the OPC Browser. If you wish to use SpecView to monitor/control an instrument/controller (via an OPC Server) that has access levels in it, then you should set the required access level in the instrument/controller before you start up the OPC Browser. If this is not done, then when you try to create a SpecView instrument you may find that SpecView cannot retrieve the parameter(s), or tag(s), that you require.
When you click an OPC Server SpecView will contact that Server and retrieve a list of ‘Groups’ and ultimately ‘Item IDs’, **this process can take a long time.**

If the required OPC Server isn't listed because it is running on another PC then enter the name of the OPC Server into the ‘OPC Server Name:' box, being careful to type the name accurately & enter the network name of the Remote PC into the 'Remote PC Name:' box & click the Add button.

The ‘Groups’ and ‘Item IDs’ are pre-programmed and stored in a hierarchy by the OPC Server’s manufacturer. SpecView will then display this hierarchy.

Click the individual ‘Groups’ to open them up to see further ‘Groups’ or a list of their ‘Item IDs’, for example:
Create a SpecView ‘instrument’ from any of the ‘Groups’ listed. If you have the Multiport option enabled on your dongle then you can have ‘Groups’ from multiple OPC Servers. To create a SpecView ‘instrument’ you just click the ‘Group’ you wish to select and then click the Create Inst button. You will then be asked to give your new SpecView ‘instrument’ a name (one will be suggested using the group hierarchy, but you can override it). Once you have typed in a new name and clicked OK then SpecView will again contact the OPC Server to retrieve details about the ‘Item ID’ that it requires to build a SpecView ‘instrument’. As a result of this process you will be informed if there are any ‘Item IDs’ that are not supported by SpecView (see below).

9.9.2 Supported OPC Servers

**CALServer**
This server allows you to monitor/control CAL controllers – see http://www.cal-controls.com/. You should be aware of the following issues:
- If you want to run this server alongside another OPC Server then start this server first as it does not like contending for COM ports with other software.
- You must set the access list to the level that you want to retrieve parameter/tags for e.g. if you wish to see Level 3 Registers and below then you must set the access level to 3.
- Most ‘Item IDs’ are supported as Strings, which appear to be writeable, however the server accepts no writes. Numerics are writeable.
- If any of your PC software crashes whilst this server is running then you will have to reboot your PC to get this server working again.

**Hexatec**
This server allows you to monitor PC disc space – see http://www.hexatec.com/.
There are no known issues with this server.

**Honeywell HMX RAE OPC Servers**
There are 2 OPC Servers that SpecView will find:
- The “Hmx.RaeServer_I” is an “in process” server, which SpecView will not communicate with.
- The “Hmx.RaeServer_O” Use SpecView build #770 and later to use this OPC server with SpecView.

**TrendServer Pro**
This server will work with SpecView but has the following limitations:
If the instrument being monitored by the OPC Server is very busy then it’s communications may not be current and the OPC Server will report back “bad” values which appear as ‘N/R’s in SpecView
- There is a limit of 100 items per SpecView Update Rate in the OPC Server. If your variable is constantly showing ‘N/R’s then change it’s Update Rate in SpecView
- Ensure that you are running version 1.0.0.23 or later of the OPC Driver (SVOPC) as a fix was applied to correct Strings which are shown as constantly changing inside SpecView but in reality are constant in the OPC Server.

**iTools**
This server allows you to monitor/control Eurotherm instrument/controllers – see http://www.eurotherm3.com/itools/.
The only known issue with this server is running it on a different operating system than that of your OPC Client. If you have this situation then open iTools ModBus Server, goto Edit-Server Settings-Advanced. Check Bypass NT COM/DCOM security settings. This must be a solid black check, not grayed out.

**KEPServerEx**
This server allows you to monitor/control a wide variety of instrument/controllers/PLCs – see http://www.kepware.com/.
There are no known issues with this server when using build #702 onwards; prior to this build not all of the groups/items were visible.

**MSI.Modbus.OPCServer**
This server allows you to monitor/control a Marathon Sensors (aka Marathon Monitors) Inc instrument/controllers.
There are no known issues with this server, aside from possibly having to register the OPC Server to Windows if it does not appear in the Local OPC Servers list (this is covered in the OPC Servers manual but the command line is “MSIModbusOPCServer /RegServer”).

**MSL Datascan**
See http://www.msl-datascan.com
If you are using version 1.11 or later of this server then it will work with all SpecView builds. If you are using an older version e.g. 1.10 then you must use SpecView build #755 or later; prior to this build this server was NOT supported.

**OPC.SimaticNet**
This server is supplied by Siemens and works with their PLCs. By default it will NOT put items into groups (which is what SpecView requires!) and so will NOT work with SpecView. You have to copy/program your inputs, outputs etc into a local dbase and then import them using the supplied OPC Scout into groups. Once you have done this then SpecView will see the
groups and you can then create SpecView instruments from them. SpecView build #810 or later will allow you to create a SpecView instrument from the top-level OPC Server group in the tree list. This version also fixes previous problems when talking to the OPC.SimaticNet OPC Server.

**RSLinx OPC Server**

This server is an integral part of RSLinx. It only becomes available to clients when an activation key is installed that enhances it to one of the following RSLinx versions:
- Single Node (1 local client, no remote clients)
- OEM (local clients, no remote clients)
- SDK (local clients, no remote clients)
- Professional (local clients, no remote clients)
- Gateway (local clients, remote clients)

You will need to have installed SpecView build #812 or later to use this OPC Server. Since release 2.43.00 of RSLinx OPC Server SpecView builds #812 and 813 will report error E12179 Failed to retrieve any groups from the OPC Server 'RSLinx OPC Server'. Ensure that the OPC Server is running and correctly configured.

Only SpecView builds #814 and later are compatible with release 2.43.00 of RSLinx OPC Server. You will need to update your copy of SpecView to be able to connect to release 2.43.00 of RSLinx OPC Server.

If you have an older version of RSLinx OPC Server than 2.43.00 and you get the E12179 error message from SpecView builds #814 and later then there is a workaround that provides compatibility with older versions of RSLinx OPC Server. You will need to shutdown SpecView and add the following lines to the SV3.INI in the SpecView installed folder:

```
[OPC]
BrowseRSLinxOPCServerHierarchically=Y
```

Restart SpecView and try to browse the RSLinx OPC Server again.

**Signatrol SL400**

This server works with SpecView aside from one problem area. The Signatrol SL400 OPC Server will report values as having a bad quality when it is in "sleep" mode. SpecView will report such values as 'N/R's since they are clearly in an undetermined state! The only way to force SpecView to treat the good value as the current value is to setup a strategy event and action to copy the OPC parameter upon change of value. In this way SpecView will only copy the good value and ignore the bad value.

It should be noted, however, that SpecView does not approve of using such a process as it fools the end-user into thinking that the current value is the last good value which could be considerably out of date!

**Software Toolbox TOP Server**

This server allows you to monitor/control a wide variety of instrument/controllers/PLCs – see http://www.softwaretoolbox.com/store/item_pages/itempage_929.asp from http://www.softwaretoolbox.com.

There are no known issues with this server.

**Sunware’s OPC Servers**

- Allen Bradley SLC500 (DF1 Protocol) OPC Server
  As yet untested with SpecView
- Mitsubishi A Type OPC Server
  As yet untested with SpecView
- Mitsubishi FX Type OPC Server
  As yet untested with SpecView
- Modbus (RTU/ASCII) OPC Server
  As yet untested with SpecView
- Nudam OPC Server
  As yet untested with SpecView
9.9.3 OPC - Frequently Asked Questions (FAQs)

I cannot see any OPC buttons anywhere in SpecView.
You need to update to the latest build of SpecView, go to http://www.specview.com

The OPC Server I want does not appear in SpecView’s OPC Browser.
You should cancel out SpecView’s OPC Browser and then start up the OPC Server; then go back into SpecView’s OPC Browser. If the OPC Server still does not appear in SpecView’s OPC Browser then try reinstalling the OPC Server.

The SpecView ‘instrument’ I created does not have all of the ‘Item IDs’ in it that were listed in SpecView’s OPC Browser.
This is either because:
- The access level in the instrument/controller is not set high enough so that the ‘Item IDs’ can be accessed.
Or:
- Not all of the ‘Item IDs’ data types are supported (see Supported Data Types below).

‘N/R’s are shown for some ‘Item IDs’ but not all.
The OPC Server is returning the value back for the ‘N/R’ ‘Item IDs’ as bad, hence SpecView shows them as ‘N/R’s. Consult the OPC Server manufacturer for the cause of the bad value.

I cannot connect to a remote server that I know exists and is running.
Check that the case of the OPC Server and PC name you have typed in is correct and try again.
If you are still having problems then it could be an authorization issue. Does the ‘remote’ PC, with the OPC Server running, have authorization for the PC with SpecView running on it. In other words, the user logged onto the PC with SpecView running must be setup as a user (with the same password) of the PC with the OPC Server running on it and possibly even logged in and running the OPC Server. This is all dependent upon which version of Windows you are running.

NOTE: The following steps are taken at your own risk, beware that you will be editing registry settings; possibly losing personalized settings and rebooting your PC several times. Read these instructions through VERY CAREFULLY before trying them:
If you are still having problems then it could be that DCOM has not been configured on the OPC Server PC to “Enable remote connection”; to do this is rather involved and may require reboot(s) of your PC.
What you have to do is to run DCOMCNFG.EXE (which is normally found in your Windows SYSTEM folder). This in itself may require you to go to the Network icon in the Control Panel and set User-level access control under the Access Control tab (and the Obtain list of users and groups from: to be your Computer Name: from the Identification tab) before DCOMCNFG.EXE will run. NOTE: This step will cause your PC to lose its Shares and personalized settings for all users.
DCOMCNFG.EXE has a tab called Default Security. Go there and check that Enable remote connection is checked. If it is enabled then you have a separate problem; if it is not checked then check it and (probably after a reboot) go back to the Network icon in the Control Panel and set Share-level access control under the Access Control tab on your OPC Server. This whole process will have removed any Shares that you had setup on the OPC Server PC, so reset them as the last step.
If you are still having problems then ensure that the following registry entry has the value 1 (this is
documented in Microsoft’s article Q174024 “DCOM95 Frequently Asked Questions”:

HKEY_LOCAL_MACHINE\Software\Microsoft\Ole\LegacyAuthenticationLevel

NOTE: If you are still having problems then consult the OPC Server manufacturer.
If you still have a problem then consult SpecView’s website http://www.specview.com

I am experiencing problems with an OPC Server such that the OPC Server crashes or runs up and then disappears.
Try adding the following to SV3.INI, which may solve the problem:

[OPC]
OPCServersToBeTraversedByBranch1=<OPC Server Name>=1
OPCServersToBeTraversedByBranch2=<OPC Server Name>=1
etc.

Replacing <OPC Server Name> with the OPC Server Name

For example:
OPCServersToBeTraversedByBranch1=MSL.Datascan=1

Supported Data Types
Currently SpecView only supports the following OPC data types:

VT_BOOL
VT_BSTR
VT_DATE
VT_FILETIME
VT_I1
VT_I2
VT_I4
VT_INT
VT_R4
VT_R8
VT_UI1
VT_UI2
VT_UI4
VT_UINT

If your SpecView instrument does not contain the ‘Item IDs’ that you expect, then check with the OPC Server’s manufacturer to see if it is a type in the above list.

9.9.4 OPC - PC Specification/Performance

To provide some idea of the overhead that OPC puts on a PC we ran SpecView (build #693) and created project that included a Eurotherm 2404 connected to running iTools running on the same PC.

<table>
<thead>
<tr>
<th>Operating System</th>
<th>Processor</th>
<th>Memory (Mb RAM)</th>
<th>Time taken to for OPC Browser to appear</th>
<th>Time taken to load up the Eurotherm.ModbusServ.1 with Groups and Items in the OPC Browser</th>
<th>Time taken to create an instrument for the 2404 with 4,438 parameters</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows XP</td>
<td>AMD Athlon 1100</td>
<td>256</td>
<td>&lt; 1 second</td>
<td>&lt; 1 second</td>
<td>16 seconds</td>
</tr>
<tr>
<td>Windows</td>
<td>Pentium III 450</td>
<td>380</td>
<td>3.3 seconds</td>
<td>3.8 seconds</td>
<td>34.1 seconds</td>
</tr>
</tbody>
</table>
The above test was used to give a worse case scenario – it is doubtful that any user would put 4,438 parameters on open GDW's. However it is good at pointing out that using a good specification of PC is worthwhile.

**Debugging**

SpecView can generate debug messages for errors generated by the OPC Browser. To turn debugging on or off use Preferences - Debug from the File menu.

**SpecView Error Codes**

You will see these if you have turned debugging on and look at the debug.txt file in your project folder e.g. C:\SV3\Furnace

<table>
<thead>
<tr>
<th>Error code</th>
<th>Description</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>18219</td>
<td>OPC Server status cannot be obtained</td>
<td>The OPC Server must be shutdown and restarted.</td>
</tr>
<tr>
<td>18229</td>
<td>OPC Server status indicates not running normally</td>
<td>The OPC Server must be shutdown and restarted.</td>
</tr>
</tbody>
</table>

The explanations for other codes are in Error Codes and Error Codes Protocol Specific.

**OPC Error Codes**

You will see these if you have turned debugging on and look at the svdata.txt file in your SpecView installation folder e.g. C:\SV3

<table>
<thead>
<tr>
<th>Error code (in hex)</th>
<th>Description</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>0004000D</td>
<td>OPC_S_UNSUPPORTEDRATE</td>
<td>The OPC Server cannot handle the scan rate in your project. Change the scan rates in File-&gt;Preferences under the Runtime tab and retry.</td>
</tr>
<tr>
<td>80010108</td>
<td>RPC_E_DISCONNECTED</td>
<td>The OPC Server has gone off line. Go into Edit Mode or exit SpecView. Then OPC Server must be shutdown and restarted. Then go online to SpecView.</td>
</tr>
<tr>
<td>80040154</td>
<td>REGDB_E_CLASSNOTREG</td>
<td>Update to build #693 or above. If you are using a build of #693 or above then contact your SpecView representative to pass on your svdata.txt.</td>
</tr>
<tr>
<td>800706BA</td>
<td>RPC_S_SERVER_UNAVAILABLE</td>
<td>OPC Browser is trying to connect to remote OPC Server. OPC Browser cannot connect to remote OPC Server as either it is not running or you do not have security access to it or access to DCOM.</td>
</tr>
<tr>
<td>800706D3</td>
<td>RPC_S_UNKNOWN_AUTHN_SERVICE</td>
<td>OPC Browser is trying to connect to remote OPC Server. OPC Browser cannot connect to remote OPC Server, as you do not have security access to it or access to DCOM.</td>
</tr>
</tbody>
</table>
9.10 DDE (Dynamic Data Exchange) - Overview

The SpecView DDE Server allows the retrieval and setting of Instrument parameters across the Windows DDE Interface.

NOTE: DDE is an option for SpecView. If the option has not been purchased DDE will not function. To find out if it is available see the list under Help - Registration Info
You can upgrade your copy of SpecView by phone. Contact your SpecView distributor for details.

**DDE Application Name**

**DDE Topic Name**

**DDE Status Topic**

**SpecView DDE Restrictions**

Getting data from [SpecView via DDE (DDE Read)] and [Example of getting data]

Setting data into [SpecView via DDE (DDE Poke)] and [Examples of setting data]

The SpecView DDE Interface is somewhat unorthodox in its implementation due to practical considerations. as follows:

Normally, a DDE server would 'register' a whole set of topics and items for which conversations can be transacted. For SpecView, this would mean that each and every variable in the SpecView Variables List would have to be registered, and furthermore, each one would have to be requested over the comms link to supply any DDE Client that happened along. This is clearly unfeasible.

Consequently, the SpecView DDE Server registers no variables by default - nor does it request anything from the comms. When a DDE request comes in from a DDE Client, if it is the name of a variable or parameter that SpecView understands, then that variable begins to be requested over comms. In the meantime, SpecView must have answered back to the DDE Client to allow the client to continue processing. SpecView can only answer back that the request succeeded - even if the instrument is down or the comms link has failed - this is because it could be up to 3 or 4 seconds before the comms engine knows (due to re-tries etc.) that the variable is not online.

9.10.1 DDE Application Name

This setting defines the name that the SpecView DDE Server registers when SpecView starts. It is defined in Preferences - DDE
Although you can choose anything for the application name, it is recommended that this setting be left as ‘SpecView’.

Return to DDE help topics
9.10.2 DDE Topic Name

This setting defines the topic for which SpecView's DDE Server will 'listen' for requests for real time data on. It is defined in Preferences - DDE. By default it is set to 'var', meaning variables. The fixed Status topic is not affected by this setting. Return to DDE help topics.

9.10.3 DDE Status Topic

There are 3 items that SpecView registers for DDE under the Status topic:

- LastError: The last reason for failure of a DDE request.
- ErrorItem: The item that caused the above failure.
- PokeStatus: The running Status of the current (or last) poke command.

**NOTE:** The upper/lower case of the requests is significant (unlike the variables).

Examples:
1) Suppose a request is made for 'Specview\var!ANameThatDoes.NotExist'. This will cause 'LastError' to be set to 'Unknown Variable' and 'ErrorItem' to be set to 'ANameThatDoes.NotExist'.
2) A DDEPoke request to set a setpoint above the Setpoint High Limit for that particular instrument might result in the final PokeStatus being 'Write Error 18023'. Return to DDE help topics.

9.10.4 SpecView DDE Restrictions

For reasons explained in the Introduction to DDE, SpecView only supports the getting of data using the DDE Advise (or 'Hot' Link method). DDE Request is not supported for one-off conversations. Data can be Set into Instruments using the DDEPoke mechanism. DDEExecute is not supported.

**NOTE:** The CF_TEXT format is the only format supported by SpecView. All data is sent in this text form.

SpecView must be in Runtime Mode and showing a GDW for DDE Server activity. If the SpecView is taken out of Runtime Mode, then all DDE links are terminated. SpecView DDE can support multiple simultaneous clients, requesting the same data items, and at different speeds. Return to DDE help topics.

9.10.5 Getting data from SpecView DDE

SpecView supports the DDE Advise mechanism for supplying DDE Clients with data. (restrictions). Read the DDE Read Example
SpecView listens on the \*\*var\*\* topic (or that setup by the user in Preferences - DDE) for an item that is the name of the variable you want to read. The format of the item is:
Instrument Connectivity

Instrument <dot> parameter <comma> rate(optional)

All items are not case sensitive, and the parameter can be either the short or long name of the parameter.
The rate can be omitted, in which case 'medium' is assumed, or can be specified as M,L,H or U,
meaning Medium, Low, High, Ultra-High rate. The actual rate used depends on
the settings for the project.

For example:
Zone1.pv Gets process value at medium rate
Zone1.Process Val The same
Zone1.PV,m The same
zOnE1.PROCess VAL,M Still the same.
Zone1.PV,U Gets the PV at the Ultra High Rate.

When a request for a new variable comes in via the DDEAdvise mechanism, it is checked by SpecView
to see that the variable exists. If it does exist, then SpecView begins to request that variable over
comms and from then on supplies the Client with the data at the given rate (or faster), until the Client
signals that data is no longer required. If the variable does not exist, then the SpecView DDE Status
information reflects this.

**NOTE: Due to the potentially long startup time of any given request, a blank answer
is sent back to the DDE Client first. Thus, the very first item of data from SpecView
should be ignored for each new item that is requested.**

In the event of comms errors or missing instruments, no data is sent across DDE.

Return to DDE help topics

9.10.6 Setting data into SpecView DDE

Data can be sent down to the Instrument using the DDEPoke command.
Read the DDEPoke Examples

Due to the fact that (A) there can be a significant time delay before the data is sent, and (B) the data
may not be accepted by the instrument (over-range etc.), the SpecView DDE Server reports back
immediately that the DDEPoke succeeded. It is the responsibility of the Client to only make one Poke
request at any time.

The Status of the write process is reflected in the SpecView DDE Status Information. These DDE items
can have one of the following values:

- Idle
- Writing
- Written
- Write Error X

When a Client makes a DDE Poke request, it should monitor the PokeStatus item. This will be
changed as the state changes. The Client will only know that the Poke request actually gave data to the
instrument if the PokeStatus shows 'Written'. If 'Write Error X' is shown, then the write failed for the
reason given.

'Idle' is shown before the very first Poke request is actioned, and never afterwards (because 'Written' or
'Write Error' is shown after any Poke.

Data is sent to SpecView using the CF_TEXT format, and SpecView formats it to the correct type
depending on the variable prior to sending. This may or may not require more or less decimal places for
numbers that is supplied. SpecView will add or truncate as necessary, so it is always best to send the
full resolution (all decimal places) to be written.

Return to DDE help topics
9.10.7  DDEPoke Examples

The following example shows just the Poke section of making a DDEPoke request - the client program should include code to monitor the status of the Poke using the Status Hot Links provided by the SpecView DDE Status Information.

For Microsoft Excel and Microsoft Access, a small piece of BASIC code is required to be written. For Excel, a Macro (module) can be associated with a button (show me how to do this) and the following code assigned to that macro:

This example uses 4 cells to define what and where to write to:

```
Set appToPoke = Worksheets('Sheet1').Range('B3')
Set topicToPoke = Worksheets('Sheet1').Range('C3')
Set itemToPoke = Worksheets('Sheet1').Range('D3')
Set valuetopoke = Worksheets('Sheet1').Range('E3')
```

```
On Error Resume Next
Dim Chan
Chan = DDEInitiate(appToPoke, topicToPoke)
If Err Then
    Exit Sub
End If
DDEPoke Chan, itemToPoke, valuetopoke
If Err Then
    Exit Sub
End If
DDETerminate (Chan)
```

For Microsoft Access, a button on a form can be used to cause a similar effect:

This example assumes a small form with 4 input fields has been defined, and a button to call this:

```
On Error Resume Next
Dim Chan
Chan = DDEInitiate(Me![App], Me![Topic])
If Err Then
    Exit Sub
End If
DDEPoke Chan, Me![Item], Me![Value]
If Err Then
    Exit Sub
End If
DDETerminateAll
```

Return to DDE help topics

9.10.8  Setting up an Excel DDE Poke Example

This example is for Excel 2000:
This is a simple example that sends the contents of Cell A1 on Sheet1 to the SpecView User variable called SpecView.Number1

1. Open a new Sheet inside Excel
2. Show the Forms Toolbar
3. Choose the Button tool from the Forms Toolbar
4. Draw out a button on the sheet
5. When the Assign Macro box appears, click New
6. Type (or paste) the following lines of code in between the 2 lines, for example:
   Sub Button1_Click()
       channelNumber = Application.DDEInitiate(app:='SpecView', topic:='var')
       Set rangeToPoke = Worksheets('Sheet1').Range('A1')
       Application.DDEPoke channelNumber, 'SpecView.Number1', rangeToPoke
       Application.DDETerminate channelNumber
   End Sub

7. Save and close Microsoft Visual Basic
8. Click on the button with MB2, choose Edit Text to modify the button's label.
9. Set A1 to, for example 20.5
10. Click your button to do the Poke.

For a slightly more complex example which allows the name of the variable as well as the value to be defined by a Cell, follow points 1 to 5 above, then:

6. Type (or paste) in the example code from the previous help section in between the 2 lines, for example:
   Sub Button1_Click()
       channelNumber = Application.DDEInitiate(app:='SpecView', topic:='var')
       Set rangeToPoke = Worksheets('Sheet1').Range('A1')
       Application.DDEPoke channelNumber, 'SpecView.Number1', rangeToPoke
       Application.DDETerminate channelNumber
   End Sub

7. Save and close Microsoft Visual Basic
8. Click on the button with MB2, choose Edit Text to modify the button's label.
9. Then set the cells to, for example, as follows:
   Set B3 to: SpecView
   Set C3 to: var
   Set D3 to the variable to be set, for example: 'Zone1.Setpoint
   Set E3 to, for example: '20.5
10. Click your button to do the Poke.

This example is for Excel 97:
1. Open a new Sheet inside Excel
2. Show the Drawing Toolbar
3. Choose the Button tool from the Drawing Toolbar
4. Draw out a button on the sheet
5. When the Assign Macro box appears, choose New Macro
6. Type in the example code from the previous help section
7. Save the Macro
8. Then set the cells to, for example, as follows:
   Set B3 to: SpecView
Set C3 to: var
Set D3 to the variable to be set, for example: 'Zone1.Setpoint
Set E3 to, for example: '20.5

9. Click your button to do the Poke.

Return to DDE help topics

9.10.9 DDE Read Example

An example of Excel reading some items from an Instrument called 'Zone1' follow.
See the important note at the bottom of this section.
Type these formulas into cells on the Spreadsheet:

`=SpecView|Status!LastError` To get the Error Reason in case of an error.
`=SpecView|Status!ErrorItem` To get the Item for which the last error occurred.
`=SpecView|var!Zone1.pv` Get the Process Val at medium rate
`=SpecView|var!Zone1.OP` Get the Output Power at medium rate
`=SpecView|var!Zone1.pv,h'` Get the PV at the high rate. The quotes allow Excel to not treat the comma as part of some strange formula.
`=SpecView|var!Zone1.Output Power'` Get the OP, using its full name.
`=SpecView|var!SpecView.Number1` To get the SpecView User Variable called Number1

Since you are typing this into Excel as a formula, there are certain restrictions you must observe. In particular, where the name of an Instrument or variable contains any character likely to affect Excel's formula engine, then the item must be enclosed in quotes so that Excel does not see it. For example, suppose (hypothetically) you had named an instrument 'Zone + 2'. If you just type in:

`=SpecView|var!Zone + 2.pv`

Then this is a formula that takes 'SpecView|var!Zone' and adds two to it.
To get Excel to correctly read the formula, you need to put quotes in:

`=SpecView|var!'Zone + 2.pv'`

This applies particularly to the following cases:
'Output Power' - has a space.
'Auto/Manual' - has a slash - could be seen as a divide.
'inst.param,RATE' - the comma will confuse - so if a rate is specified, use the quotes.

Return to DDE help topics
Top Level Intro

This page is printed before a new top-level chapter starts
10 Data Logging

Data logging functions in SpecView are in two parts:
1. Specifying which items to log to the hard disk
2. Using the logged data to create reports and replay logged data on screens (GDWs) using Historical Replay. (Historical Replay is a dongle option.)

**NOTE:** Data Logging is a background function. Variables do not have to be on an open screen (GDW) to be logged. Conversely, a variable on an open GDW may not be logged.

Three types of data may be logged:
- **Variables** This is the saving of the values of all variable types (numbers, booleans, text, dates, times, etc.). Both instrument variables and user variables can be logged
- **Alarms** SpecView time stamps and saves all items (of type boolean) which are marked as alarms
- **Events** SpecView records actions as specified in Event Logging

Data logging is **active** by default (at a rate of 60 secs) when SpecView is started. To de-activate use Preferences - Logging or adjust the Logging Rate to zero.

The instrument variables that are logged by default have been pre-configured by SpecView as part of the instrument's definition.
Typically for control instruments, the variables that are logged by default are: Process Value, Set Point and Output Power.
For indicators or data acquisition modules, just the Process Value is logged by default.
To see which variables are being logged see the 'L' column of the Variables List:
The logged data is used for two purposes:

1. Historical Replay of a screen (GDW)
2. Creating a text file Log Report which can be stored on any drive/folder in your system. Log Reports can also be generated from the Remote computer, which is detailed in Log Reports from the Remote.

**NOTE:** If an item is not available when using Historical Replay or when creating a log report it is probably not included in logging. Add the variable to logging as described in Data logging - Variables

Read Disk Space for Logging for file size details
Changing the Logging Rate

### 10.1 Data Logging - Variables

Variables are any items in the Variables List. Types include numbers, integers, boolean (on/off), date, time and text. This topic tells you how to see what variables are being logged and how to add or remove a variable to/from logging.

**NOTE:** Only variables that have been selected for logging will be available for Log Reports and Historical Replay.
Which variables will be logged can be selected using the Variables List. Double-clicking in the 'L' column will add/remove this parameter from logging. Alternatively, select the parameter and use Properties to add/remove the Logging Attribute.

**NOTE:** The Properties box should be used when needing to select the same variable in multiple instruments. For example, if there are a large number of the same type of instrument and you want to add Working Setpoint to logging for each of them then you should check 'Automatically apply changes to other similar parameters' on the Properties box.

All the variables on a GDW can be added to logging with a single command using the 'Set All items on this GDW as Logged' menu command:
This will set as logged only those instrument variables which have been specifically put onto the current GDW.
This feature is most useful when a GDW is frequently used with Historical Replay and it is desired that all the variables replay. This is typical of an Overview screen.

**NOTE:** However, use caution. For example, if used on a GDW that has several hundred items for a ramp/soak program, all those items can be added to logging with a single mouse click. But once selected, the only way to remove them from logging is by double-clicking in the boxes in the 'L' column, as described above.

Creating Log Reports

10.2 Data Logging - Disk Space Requirements

The data is stored by SpecView in the Project Folder. This location is can be changed, but only with care, read User Guide: Changing Log Data location or folder.

**NOTE:** Log files are usually stored in the Project folder. To store the files in another location on the same computer, set the Path as described in User Guide: Changing
Log Data location or folder. To backup the files to a network drive use a Logfile
Conversion triggered by a Strategy Controller event, the Strategy Controller topic
gives an example.

The amount of space taken up by log files depends on how often data is logged and how many variables
have been selected for logging. Each numeric value logged to the files uses 14 bytes.

The SpecView logging system uses up to 7 files per day, all with the prefix YY_DDD
(Where YY is the year number, e.g. 03 for 2003, and DDD is the day within the year so 1st January is:
000 and the 1st February is: 031):

- .LOG file - Variables data
- .IDX file - Index file used in report conversion and Historical Replay
- .LNM file - Names of the logged variables
- .ALM file - Alarm data
- .EVT file - Event data
- .BTC file - BatchTag data
- .CHN file - Chart Notes

Note: Not all of these files may be present for a given day, but all the files for that day
MUST always be kept together as a set. These MUST also be kept in the same folder
as their associated project files in order to be used.

The exact size of log files depends on the type of variables logged (for example, text strings take more
space than integers). A typical variable logged every minute (which is the default rate) will take about
25KB of disk space per day. Therefore, 100 variables will take about 2.5MB per day.

Logged data should be Archived together with the Project.

10.3 Data Logging - Rate

By default data logging is running whenever SpecView is in Runtime Mode or when Online Features are
enabled in Edit mode.
SpecView stores values of the selected variables at the Logging Rate.

The default rate is 60 seconds. The rate may be changed using:
1. The Preferences box Logging tab.
2. The Button (or Strategy Controller) action Logging: On/Off

The Preferences box is used to change the default rate. It is accessed from the File menu in either
Runtime Mode or Edit Mode.
Logging can be turned off by:

- Unchecking the **Enabled** checkbox on the Preferences box
- Setting the rate to 0 on the Preferences box
- Using the Button (or Strategy Controller) action **Logging: On/Off**

Using a **Button Attribute** or **Strategy Controller** event to change the rate is a *temporary* change. The next time the Runtime Mode is entered the rate will return to that specified in the Preferences box.

The current value for the logging rate is stored in the SpecView Variable **LogRate**.
The LogRate variable's initial value when going online will be the value set from Preferences - Logging.

The LogRate variable is Read-Only and cannot be changed during Runtime mode other than by using the action: Logging: On/Off.

**NOTE:** Use caution when adjusting the rate. Disk space is not expensive. If you forget to change the value back then you may have logging at the wrong rate (or turned off) without realizing it.

It is recommended that:
- For continuous processes (for example, monitoring storage freezer temperatures) - leave the logging rate the same throughout.
- For batch processes that have a long duration between batches - turn off or decrease the logging rate between batches using the Strategy Controller.
- For batch processes that have a short duration between batches - leave the logging rate the same throughout.

## 10.4 Log Reports

A Log Report is a text file in CSV (Comma Separated Variable) format. Most Windows operating
systems have this file type registered to Excel. This means that double clicking on a file of this type will automatically start Excel and open the file into it. For help in using this type of file please consult your Windows advisor.

**NOTE: To be available for inclusion in a Log Report a variable must be selected for Data Logging.**

Use the Logging menu:

OR an on-screen button, if one has been defined to do the Button Attribute Logging: Show Log File

The Log Report Setup box will be displayed.

There are two steps to generating a log report:

1. Choosing the Report Format
2. Choosing a Start & Stop date/time for the report. Or by choosing the relevant Batch.

The number of decimal places written to a Log Report can be specified. There are other settings that can be changed on the Preferences - Logfile Conversion tab. Whether or not also produce a Report of Alarms and/or Events.

The CSV Files will be delimited by the Windows settings for Decimal separator and List separator. The current settings for these are typically determined by the language being used. They can be viewed (but not changed) from Preferences - Settings.

Information added as Chart Notes to Trend Charts will be saved as a Log Report.

Log Reports can also be generated from the Remote computer, which is detailed in Log Reports from the Remote.

### 10.5 Log Report Setup

This box is used to convert logged data into a Log Report:
Step 1: Choose a Report Format (or create a Log Report Format by clicking the Create... button)

Step 2: Enter the 'Start From' Date and Time and 'Stop At' Date and Time
(If you click on one of the 'Log Files Available' in the list shown then the start and stop times of that day will be entered automatically.)
Alternatively click the Find Batch Number button to select the Start and End time based on a Batch Tag.

It is important not to change the Report Format after doing Step 2 as this will affect how the since 'Last Conversion of this format' will operate.

When you have chosen the Report Format & Start/Stop Time click the Generate button.

Log Files Available
A list of all log files available on the system is shown in the list box. They include start date and time and end date and time of the files. A file is created every day.

Start From - Stop At
Enter the time & dates for the start and stop times of the desired report.
If a report has been previously generated, SpecView will use the stop time & date of the previous report...
as a suggested start time for the next report. By checking the current time box the current date and time will be entered in the Stop At boxes.

A Log Report can also be generated from the Remote computer, which is detailed in Log Reports from the Remote.

### 10.6 Log Reports from the Remote

Generating a Log Report using the Log File Convert Manager or by using the Button: Logging: Convert Specific Log File Format may be done from the Remote. However, it is not possible to create or edit a Log Report Format from the Remote, so those buttons have been disabled.

When the Generate button is clicked, the Log File Conversion Destination box is displayed. It allows the user to decide whether the resultant Log File Report should be stored on the Local or the Remote computer. If saving to the Remote then the folder may be specified. It is also possible to save the Log File Report to a network drive.

In this example the name of the Remote connection is 'Factory' and the SpecView project on the Local computer is called 'Furnace'. When the project is copied by SpecView to the Remote it is named <ProjectName>_<ConnectionName>, hence the name: 'Furnace_Factory'.

The filename is determined from the selected Log Report Format.

If the Output filename in the selected Log Report Format has the '6 Characters' box checked (where SpecView adds a number to the name automatically), then SpecView will create the next file in the sequence, depending on which files already exist in that particular folder, and that may be different on the Local and Remote.

If a Button is used to perform the action: Logging: Convert Specific Log File Format using a Log Report Format for which the Output Path has not been specifically defined, then the path for 'Save to Local' will not be displayed, although it will function as expected and save to the SpecView Project folder on the Local.
10.7 Log Report Format

This box sets up:
- The variables that will be included in this report
- The name of the file generated and where it is to be stored
- The start/stop times of the Report

**Format Description**
Name the format for easy identification, some examples are: 'Line 1 - PV's only', 'Line 2 Barrel Zone diagnostics', 'Furnace 3 Run Data'.
An unlimited number of report formats can be defined.

**Replace Format and Add to format list**
These buttons save the report format
When creating a new format click **Add to format list**
If you edit an existing format you can save the edits by clicking **Replace Format** OR save as a new format by editing the name and clicking **Add to format list**

**Choosing Variables**
Select the variables you want in this report: Click on the ones you want and then click **Add->** If you select one you do not want, click on it again to de-select it. The order in the 'Order In Report' window is the order of columns in the text file produced when the report is 'generated'.
Note that if the intention is to load the Log Report into Excel, older versions of Excel (before Excel 2007) have a limit of 256 columns. In newer versions this limit has been increased to 16,384.

**Log Report: Include Alarm/Event Log**
To get a printable report of either the event log or alarm log check these boxes:

- [ ] Include Alarm Log
- [ ] Include Event Log

Each will generate a Comma Separated Variable file using the same name as defined in the 'Output File Name' but with the filename extension .cse (events) & .csa (alarms). The files will be in the location specified in the 'Output File Path'.

**Output File Name**

*NOTE: Standard file naming conventions must be followed. Long file names are supported if the name is taken from a SpecView text variable. All log files are in the format 'Comma Separated Variable' format.*

Filename extensions used are: .csv for values; .cse for events; .csa for alarms

**Option 1 (default) - Select (up to) the first six characters of the file name**
Choose any characters: e.g. line1- furn1- but the fewer characters used the better, as this name will be padded out to 8 characters with zeros, resulting in the report files having names such as: line1-02.csv; furn1-05.cse

If all 6 characters are used in the name, then only 2 digits will be used to number the reports created, therefore: line1-01 to Line1-99 (giving 99 log reports before log reports are overwritten.). Whereas, if just 2 characters are used in the name, then 6 digits will be used to number the reports created, therefore: LR000001 to LR999999 (giving 999999 log reports)

**Option 2 - Select the specific file name**
The file will always use the same name, and the previous file will be overwritten.

**Option 3 - Get the name from a SpecView string User Variable**

- From SpecView Sting:
  - Current Batch ID
  - Customer
  - Next Batch ID

The value entered by the operator for 'Current Batch ID' will be the filename for the log/alarm/event report (s).

**Log Report: Output File Path**
Specifies where to put the log files. This can be any folder on any drive available to the SpecView computer - i.e. it can be any drive on a network.
Default selects the project folder.

**Start Time / Stop Time**
This area defines the Start and Stop Time and Date of a report.

**Manual Report Generation:**
The radio buttons for 'Last Conversion of this format' and 'Current Time' are selected as the default values. These are typically used when reports are being generated manually. When a report is generated manually (as opposed to via the Strategy Controller) the stop time is remembered. When the Log Report Setup box is next selected, the previous stop time is automatically used as the 'Start From' date and time.
The manual generation of a log report requires the user to select the Log Report Setup box (either from the Logging menu or from a Button Attribute) and clicking the Generate button.

*NOTE: The 'Last Conversion of this format' feature is disabled when the report is generated automatically by either a Button Attribute (Logging - Convert specific log format) OR by a Strategy Controller action. When using these features the Start and Stop time must be obtained from SpecView Date/Time User Variables (see below, or from a Batch Tag).*

**Automatic Report Generation:**
One of the most popular features of SpecView is to generate log reports automatically when an event occurs. The Strategy Controller option is needed to achieve this.
The two most common are:
1. At a fixed time period (every day; every shift; every week etc.)
2. At the end of a batch process

To do this it is necessary to define two SpecView Date/Time User Variables. One is used as the Start time and one as the Stop time.
To define the User Variables:
1. Open the Variables List (click 'V' on the toolbar)
2. Click the New menu and select New Date/Time User Var
3. Enter a name for the first variable ('Batch Start') and click OK
4. Click Close on the default data entry box
5. Repeat these steps to create the second variable ('Batch End')

On the Log Format Setup box click the Var: radio buttons: and select the User Variables that have just been created:

![User Variables](image)

It is then up to the actions defined in the Strategy Controller to get the desired values into these BatchStart and BatchEnd User Variables. Read Strategy Controller for examples of doing this.
10.8 Log Reports - Specifying decimal places

If the number of Decimal Places (DP) for the values in the converted log files (.CSV) needs to be changed then use Preferences from the File menu:

This facility forces the DP setting of ALL floating point numbers in the log files, regardless of the individual parameter's DP as known to SpecView.

At present, this facility is only available to ALL of the parameters in the file, and also applies to ALL log file CSVs generated, regardless of the Project.

Therefore it should be used with caution.

It does not affect the underlying precision with which the data is logged - data is logged including its whole precision, so, in the event that a report has too few DP, it can be run again with a higher DP setting and no information will be lost.

The settings are as follows:

- 0 decimal places Produces Zero DP, e.g. 0.
- 1 decimal place Produces 1 DP, e.g. 0.1
- 2 decimal places Produces 2 DP, e.g. 0.12
- 3 decimal places Produces 3 DP, e.g. 0.123
- 4 decimal places Produces 4 DP, e.g. 0.1234
- 1 D.P. Sci Produces 1 DP Scientific Notation, e.g. +1.1E+000
2 D.P. Sci Produces 2 DP Scientific Notation, e.g. +1.12E+000
3 D.P. Sci Produces 3 DP Scientific Notation, e.g. +1.123E+000
4 D.P. Sci Produces 4 DP Scientific Notation, e.g. +1.1234E+000

Log Reports
Decimal Places

10.9 Data Logging - Alarms

**CAUTION: SpecView’s alarm monitoring MUST IN NO WAY be used as a safety feature! Use fully redundant approved safety devices only!**

To specify which boolean variables are monitored as alarms use the Variables List, in a similar way to selecting/removing variables from logging:

The Variable List’s ‘A’ column will show which variables SpecView is checking as alarms:

Double-clicking in the ‘A’ column will set/unset this parameter as an alarm (only boolean variables can be selected, the gray ‘X’ indicates those that can’t be selected).
Alternatively, select the parameter and use Properties to set/unset the Alarm Attribute.

The rate at which they are checked is defined on the Alarm tab of the Preferences box.
The default value is every 5 seconds. 

_If instrument(s) are disconnected from communications by either being removed or turned off, alarm checking can cause excessive slow-down of communications to the remaining instruments. It may be necessary to set a slower rate for alarm checking, turn it off (remove the 'enable' check) or remove specific variables from alarm checking._

When an alarm condition is detected the **New Alarms** window appears:

![New Alarms Window](image)

Clicking the **Acknowledge** button time stamps the 'Time Acknowledged' column for all unacknowledged alarms and displays the 'Alarm History' window:
Pressing the spacebar on the keyboard once will Acknowledge the Alarms, pressing it again will close the window. This is a quick way to Acknowledge & Close the window.

The Alarm History window shows all the alarms since Runtime was last entered. If SpecView is just restarted (either the program or by coming from Edit Mode) then all of TODAY's alarms are shown (up to a maximum of 1000 lines).

There is no way to clear or delete alarms

This window cannot currently be printed

To get a printable report of the alarms, convert any log format for the time span required, with the 'Include Alarm Log' checked.
Logrpt.csa opened in Excel:

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Variable</td>
<td>Time Occurred</td>
<td>Time Cleared</td>
<td>Time Acknowledged</td>
</tr>
</tbody>
</table>
10.10 Data Logging - Events

A very powerful feature of SpecView is to record all specified actions made by the user in Runtime Mode. Any changes made to the connected instruments are logged. Which events are logged is set up using the Event Logging menu command on the Setup menu.

NOTE: there are separate settings available for the Strategy Controller. This is a very powerful tool for helping to debug complex strategy events and actions.

To view the Event list in Runtime choose Event Window from the View menu.
The event list shown will include all the events since SpecView went online was entered. If SpecView is closed or goes offline the current days events will be shown.

This window cannot currently be printed

To get a printable report of the events, generate any log format for the time span required with 'Include Event Log' checked.

This is an example of a event report '.cse' file opened in Excel:

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>09/30/13 09/30/13 14:39:54 Value Set</td>
<td>Zone 1.Setpoint</td>
<td>77</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>09/30/13 09/30/13 14:39:56 Alarm Ack</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>09/30/13 09/30/13 14:40:03 Value Set</td>
<td>Zone 1.Setpoint</td>
<td>92</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>09/30/13 09/30/13 14:40:35 Value Set</td>
<td>Zone 1.Alarm SPI</td>
<td>25</td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>09/30/13 09/30/13 14:40:42 Value Set</td>
<td>Zone 1.Proportional band</td>
<td>1</td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>09/30/13 09/30/13 14:41:24 Log file Convert</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

10.11 Data Logging - Chart Notes

Log Reports and Chart Notes:

When a Log Report is generated from logged data if any Chart Notes have been defined during that time interval then an additional text file will be automatically produced with a CSN filename extension (CSN = Comma Separated Notes), for example, LOGRPT01.CSN
This file is a text file so it can be opened using, for example, Notepad.

Or it can be opened in Microsoft Excel (the filename extension .CSN will need to be associated with Excel), then once loaded into Excel select Column A and use Text to Columns on the Data tab to split Column A into separate columns (Delimited by commas).

10.12 Historical Replay Option

This is accessed from the History menu during Runtime mode. Historical Replay is an option for SpecView. If the option has not been purchased you are limited to replaying the last 4 hours of data.

Historical Replay Control Panel
Historical Replay - Start Time
Historical Replay - Find Batch Number
Historical Replay - Rate
Historical Replay - Options

You can upgrade your copy of SpecView by phone. Contact your SpecView distributor for details.

10.13 Historical Replay - Control Panel

When Historical Replay is started from the History menu during Runtime; SpecView makes a copy of the current GDW and shows the Replay Control Panel:
Historical Replay - Start Time
Historical Replay - Find Batch Number
Historical Replay - Rate
Historical Replay - Options

10.14 Historical Replay - Start Time

The six ‘-XXh’ buttons set the start time at 1 to 24 hours back from the current computer time. The Other... button lets you choose the start date & time from the log files in the project.
Enter a start date & time into the boxes

NOTE: Click on any of the 'Log Files Available' and the start time of that file will be inserted automatically

Or click **Find Batch Number** to find a named batch which will set the **Start From** to the start time of that batch.

**10.15 Historical Replay - Find Batch Number**

The Start time can also be set by clicking the **Find Batch Number...** button to find a set of data based on its **Batch Tag**.
Enter the number of days batches to show.

Either enter the exact name of the batch, or use the 'wild card' characters to find batches:

"*" to match any (or zero characters) characters. For example, to find all batches that start with 'abc' enter 'abc*'.

or

"?" to match a single character - this can be thought of as a blank tile in the game of Scrabble to match batch names.

The search is always case sensitive.

Click the to expand the list of available batches.

Use the 'Rescale Trend Charts to batch duration' checkbox to show the whole batch on the chart.
10.16 Historical Replay - Rate

1x to 240x sets the rate at a multiple of real time. If data has been logged every minute (default) 60x will give one point per second on the replay GDW.
'Max' should only be used for trend chart replay. Numeric items & Bar Charts are not refreshed at this rate.

10.17 Historical Replay - Options

Auto Pause will stop the Historical Replay when the Trend Chart has filled with new data.
If there are two (or more) charts on the GDW that have different time spans, as specified in the Trend Chart Properties box, check the box for the one you want to pause the replay.

The CPU 'Max' load Factor (default value: 10) allocates the amount of CPU time to be used for
Historical Replay activity. The bigger the number the faster the Trend Chart(s) will fill, but other computer activity will slow. Experiment to get the best performance for your computer.

10.18 Batch Tags

Often there is the need to mark the start and end of a period of Log file data and 'label' it with a Batch number. Then subsequently be able to refer to this period of data by its Batch number during either Logfile Conversion or Historical Replay.

Logfile Conversion

To select a Batch for Logfile Conversion click the Find Batch Number... button from the Log File Convert Manager.

A Batch number can contain both letters and numbers, so it can be also thought of as a Batch name or
Batch ID.

Both SpecView Text User Variables and certain Instrument variables which are text strings (such as Recipe names) can be used in this way. Once a variable is marked as a Batch Tag from the Variables Properties box, when SpecView is online any changes to the value are recorded, together with the date and time of the changes.

Changing a Batch Tag from one value to another value effectively marks the end of one batch and the start of another batch.

Setting a Batch Tag to an **empty string** (in other words clearing it so that it contains no characters) will mark the end the batch without marking the start of another.

Note that an **empty string** will be displayed as ‘[ ]’ by default, this can be changed from Preferences - Display.

A batch is not considered complete until its Batch Tag has been changed either to another Batch number or to an **empty string**. As the values of SpecView's User Variables are saved when it goes offline, a batch can continue when SpecView is back online.
For example, if SpecView was monitoring multiple furnaces, then create a SpecView Text User Variable to use as the Batch Tag for each furnace, such as SpecView.Furnace1Batch, SpecView.Furnace2Batch, etc.

Here is some sample data showing 3 batches:

<p>| | | | | | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Time</td>
<td>Furnace1Batch</td>
<td>Furnace2Batch</td>
<td>Base Temp</td>
<td>Core Temp</td>
<td>Hi Temp</td>
</tr>
<tr>
<td>2</td>
<td>24/12/2013 14:52</td>
<td>First Batch</td>
<td>119.1</td>
<td>255.2</td>
<td>278</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>24/12/2013 14:53</td>
<td>First Batch</td>
<td>119.2</td>
<td>256.3</td>
<td>278</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>24/12/2013 14:54</td>
<td>First Batch</td>
<td>Second Batch</td>
<td>119.3</td>
<td>256.4</td>
<td>278</td>
</tr>
<tr>
<td>5</td>
<td>24/12/2013 14:55</td>
<td>First Batch</td>
<td>Second Batch</td>
<td>119.4</td>
<td>255.5</td>
<td>278</td>
</tr>
<tr>
<td>6</td>
<td>24/12/2013 14:56</td>
<td>First Batch</td>
<td>First Batch</td>
<td>119.5</td>
<td>256.6</td>
<td>278</td>
</tr>
<tr>
<td>7</td>
<td>24/12/2013 14:57</td>
<td>First Batch</td>
<td>First Batch</td>
<td>119.6</td>
<td>256.7</td>
<td>278</td>
</tr>
<tr>
<td>8</td>
<td>24/12/2013 14:58</td>
<td>Third Batch</td>
<td>First Batch</td>
<td>119.7</td>
<td>256.6</td>
<td>278</td>
</tr>
<tr>
<td>9</td>
<td>24/12/2013 14:59</td>
<td>Third Batch</td>
<td>First Batch</td>
<td>119.8</td>
<td>256.9</td>
<td>278</td>
</tr>
</tbody>
</table>

This data would be listed as:

Only show batches for last: (days)
Enter the number of days to find batches for, any number from 0 to 10,000 days, as there could have been many hundreds of batches.

Only show batches that match:
Either enter the whole Batch number (which is case sensitive) or use wildcard characters to filter out all occurrences of a particular batch from potentially many hundreds of batches. Some examples of the use of wildcard characters are:

<table>
<thead>
<tr>
<th>Wildcard:</th>
<th>Means:</th>
<th>Would match:</th>
</tr>
</thead>
<tbody>
<tr>
<td>*</td>
<td>All</td>
<td>Anything</td>
</tr>
<tr>
<td>*Hot</td>
<td>Ends with 'Hot'</td>
<td>Hot, VeryHot, MediumHot, 123Hot</td>
</tr>
<tr>
<td>Hot*</td>
<td>Begins with 'Hot'</td>
<td>Hot, Hotter, Hottest, Hot6789</td>
</tr>
<tr>
<td>H?t</td>
<td>'H' one character 't'</td>
<td>Hot, Hxt, H9t</td>
</tr>
<tr>
<td>H???t*</td>
<td>'H' two characters 't'</td>
<td>Heat, Heater123, Hoot</td>
</tr>
<tr>
<td><em>Hot</em></td>
<td>Has 'Hot' anywhere in it</td>
<td>Hot, 123Hot456, VeryHotInHere</td>
</tr>
</tbody>
</table>

**Force CSV filename to Batch Number:**
This checkbox is only shown when finding batches for Logfile Conversion. This overrides the filename that the specified format would normally produce, replacing it with the name of the selected batch. Any characters in the Batch number which don’t fit with the Windows Filenaming Rules are converted into underscores.

There is no way to delete batch information from SpecView's data Logfiles without also deleting the data Logfiles themselves. The action Logging: Purge Log Files also purges batch information.

*Note: In order to ensure that a batch contains all the relevant data it is necessary to ensure that the Batch Tag is changed (to mark the start of the batch) before the batch starts for real. Similarly the batch run must have completed before the Batch Tag is changed (to mark the end of the batch).*

**When a Batch has been selected for Log File Conversion:**
The Start From/Stop At dates & times will be set according to the Batch and the Batch number will be shown in the Log Report Setup box:

![Start From/Stop At Dates and Times](image)

**When a Batch has been selected for Historical Replay:**
To select a Batch for Historical Replay click the Other... button on the Historical Replay Control Panel then Find Batch Number... (see below)
Will display this box:
Rescale Trend Charts to batch duration:
This checkbox is only shown when finding batches for Historical Replay.
This will rescale the Trend Chart's time span to be appropriate for the duration of the batch. For example if the batch is 3 minutes long then it will use a 5 minute time span.
The chart will be drawn as a 'best fit' between the fixed graduations of time along the X axis.
Note: that there is no link between a GDW & a batch, so ensure the correct screen is open to display the relevant Historical data.

Select the required batch, then the Start From date & time will be set according to the Batch and the Historical Replay will run according to the rate set.
If there is a Trend chart on the GDW and Auto Pause has been selected in the Options, then it may pause when the Trend Chart is full.
At the end of the replay of the Batch data it will show End of batch Auto Pause in the Control Panel:

Clicking Play will then continue the Historical Replay beyond the end of the selected Batch.
**Hints & Tips:**

- An example of the use of Batch Tags could be where the **Strategy Controller** is used to watch a 'Profile running status' and when the profile (or recipe, or program) has reached its end state, then a Strategy Controller Action sets the Batch Tag to blank to signal the end of the batch.

- If a batch number is to be entered manually then it is useful to put a Text User Variable on the screen (which is not marked as a Batch Tag) for the number of the next batch (For example, SpecView.NextFurnace1Batch). Then when the batch is ready to be started the first action is to immediately copy the NextFurnace1Batch to Furnace1Batch to start the batch before performing the other actions necessary to start the batch.
Top Level Intro

This page is printed before a new top-level chapter starts
11 Recipes

A Recipe is when SpecView saves the values of selected variables so that the values can be later uploaded to the connected instruments.

Recipes are useful for the following:

- Eliminating operator error in setting machine parameters
- Taking a snapshot of the current process values when a good product is being made
- Exactly reproducing previous machine setup
- Displaying the loaded Recipe on screen
- Saving and reloading instrument setup parameters
- Reviewing and editing complex programmer profiles

There are four steps to creating a recipe:

1. In Edit Mode: Create a screen (GDW) and put all the variables on it that are intended to be set using Recipe. This screen can be thought of as a Recipe screen.
   Note: The variables do need to be writeable so that they can be changed.

2. Select these variables for Recipe using the Recipe tool.

3. In Runtime mode: Create the sets of values.

4. To use the Recipe(s) in Runtime Mode go to the Recipe menu and choose Recipe Manager. Alternatively, to make it easier to use in Runtime Mode, go into Edit mode and either:
   - Setup a button to do a button action for Recipe, such as: Recipe: Download Specific Recipe
   - Setup an automatic Recipe action via the Strategy Controller

Each screen (GDW) in SpecView can have one Recipe associated with it. When the Recipe mode is selected a highlight (box) appears around all the variables selected for Recipe.

The Recipe defines the set of variables, and there can only be one of these per GDW, but there can be up to 1295 different sets of values for these variables which are saved as files to disk. However, each set of values may not need to set all the variables in the Recipe, therefore in order to set only some of the variables at a time the value N/C (No Change) can be used.

NOTE: A Recipe is therefore made up of two parts:

- The full list of variables which can be included in a Recipe (and there can only be one of these per GDW).
- The named sets of values for these variables (and there can be 1295 different sets of values).

Recipe names may be any length and include spaces and any special characters.
A description, which for example, may include special instructions to the operator, can be associated with each set of Recipe values.

Button actions or the Strategy Controller can make use of Recipes.

The order that values are downloaded into variables can be defined using Recipe Levels.

SpecView will automatically retry Recipe value downloads if there is a failure.

**Selecting Variables to be Included in Recipe**
- Recipes - Using
- Recipe Warning
- Recipe Names
- Recipe Description
- Recipe Hide this box
- Recipe Save & Save As
- Recipe Import/Export
- Recipe Send
- Recipe 'Send To'
- Source and Target Instruments
- Recipe Send To: Warning
- Recipe 'Send To' Problems
- Setting the Recipe download order
- Preferences - Recipe
- Recipe on Remote

### 11.1 Selecting Variables to be Included in Recipe

*NOTE: In order to be able to do this you must first have setup a GDW containing all the variables which you intend to put in to the Recipe. Read Adding Numeric Values to a GDW*

In Edit Mode open the GDW which is to have the Recipe defined on it.

Select Recipe Mode by clicking on the toolbar (or View Menu - Recipe Mode)

The cursor changes to a knife and fork and any variables that have already been selected for Recipe will highlight.

To add or remove a variable, click the value with the knife and fork cursor. However, if a variable is Grouped with other items on the GDW then it will need to Ungrouped for use in Recipe.
NOTE: As you move the cursor over each variable the Status Bar shows the name of the variable

Be sure NOT to select any variables that are Read Only.

11.2 Recipes - Using

Recipes are Setup from Edit Mode by the following steps:

1. In Edit Mode: Create a screen (GDW) and put all the variables on it that you wish to change using Recipe. This screen can be thought of as a Recipe screen.

2. Then Select these variables for Recipe.

3. The sets of values are then created as follows:

From Runtime Mode either click Recipe Management.

OR click which is a button that has been previously defined in Edit Mode to perform the required Recipe action. The Recipe box will appear.

If no items have been previously selected in Edit Mode for Recipe for this GDW this box will appear:
In which case the variables need to be selected using ✂️ on the toolbar in Edit Mode.

To define the values for each variable click the highlighted values on the GDW itself and enter the new value. Do this for each variable.

While the Recipe box is being displayed any values entered in the highlighted boxes will not be sent to an instrument or saved to a User Variable until the **Send** button is clicked.

If a variable does not need to be changed in this set of values, just click the **No Change** button on the data entry box for that variable.
Then click the **Save As...** button to save the set of values to a name. This name can then be used when in Edit Mode for button actions or by the Strategy Controller.

You can define numerous different sets of values (up to 1295), each given a different Recipe Name, but typically only a few sets are needed for most requirements.

If the Recipe box has been hidden using the Hide this box button, then

![Recipe Management](image)

**NOTE:** Items in the Recipe may show Color Dynamics based on the Recipe value. This can cause confusion in some cases if some color dynamics are a result of the Recipe and others are not.

The sets of values can then be associated with a button or Strategy Controller event.
4. In Edit mode: Setup these sets of values to be used. This could be by defining a button to do a button action for Recipe, such as: Recipe: Download Specific Recipe or via the Strategy Controller to do a Recipe action.

11.3 Recipe Warning

The highlighted values on the GDW are not updated from the instrument while the Recipe box is on the screen.
When a Recipe has been selected from the list, or if a highlighted variable has been edited then the values shown are no longer current while the Recipe dialog is being shown.
11.4 Recipe Names

Click a Recipe name (which has previously been saved using the Save As button) and the highlighted values on the GDW will change to the stored values.

Click the Send button to write the values to the instruments.

If required, the values may be edited before sending (click a highlighted value on the GDW to edit it). The changes may be stored by clicking Save (overwriting the existing Recipe) or Save As (save as a new Recipe).

The Recipe defines the set of variables, and there can only be one of these per GDW, but there can be up to 1295 different sets of values for these variables which are saved as files to disk.

Recipe names may be any length and include spaces and any special characters.

11.5 Recipe Description

Any text may be typed into the description box.

The description is part of the Recipe so it is necessary to click the Save tool after exiting the description box.
11.6 **Recipe Hide this box**

The Recipe box may be covering some of the Recipe variables on the GDW. The **Hide this box** button hides the Recipe box while editing the Recipe values. This is useful if values are behind the box.

Click **Recipe Management**

OR

to restore the Recipe box.

11.7 **Recipe Save & Save As**

**New Recipes:**
Click the **Save** button when the <Current Values> line is highlighted OR
Click the **Save As...** button. In either case you will be asked to enter a name:
Names may be any length and include any characters (SpecView assigns the file names. A maximum of 1295 sets of recipe values are allowed per GDW)

*NOTE: This is the same data entry box as used for Project names and SpecView User Variable names.*

**Existing Recipes:**
The Save button saves the current values *overwriting the old ones.*

*NOTE: There is NO 'overwrite existing' warning box.*

### 11.8 Recipe Import/Export

**Recipe** Import and Export are used to save a recipe to a file in a format that may be edited using Microsoft Excel and then subsequently imported into SpecView. This allows you to distribute recipes to other SpecView users in an easy to use manner. The exported recipe is in Comma Separated Value (CSV) format and can be directly edited in Excel. Editing restrictions are detailed below.

**Recipe Import**
The Import button on the Recipe Management screen is always enabled.
The recipe which is imported does not relate to the one which is currently selected. It is just used to create the default name. Hence the default name will be the <name of the recipe currently selected>.CSV
If a folder is not specified then the recipe CSV file will be imported from the current project folder. Alternatively use the Browse button to select a folder and file to import from. The file selected must be in CSV format and have been exported using the Export button from within SpecView. When you click the OK button you will be prompted to discard any outstanding changes. Then the recipe CSV file will be read. Each line representing a recipe item is validated to ensure that it can be imported correctly. If not then an error is displayed and you may cancel the import if required. The number of recipe items being imported is checked, if it does not match the items currently in recipe then you are prompted. If there are fewer then the remainder will have their values set to ‘No Change’. Extra items in the CSV file will be ignored.

Recipe Export
The Export button is only available once a recipe to be exported has been selected on the Recipe Management screen. The Export will prompt for a file name, the default will be the <name of the recipe>.CSV If a folder is not specified then the recipe CSV file will be saved in the current project folder. Alternatively use the Browse button to select a folder and file to save to.

Editing the exported recipe
The recipe CSV file can be edited before importing it back into SpecView. This can be done using MS-Word or a text editor, such as Notepad or WordPad, as well as Excel
The name of the recipe on the first line may be changed and the recipe item’s new value in the 4th column. However, do not remove any of the commas that separate the columns, or change the data in first 3 columns as these are used by SpecView to match up the recipe items when importing the recipe. Whole lines can be removed if you wish to remove a recipe item from recipe, but be aware of the importing issues detailed above.

11.9 Recipe Send

(Also Send To)
Sends the recipe values shown on the GDW to the instruments. A progress box will be displayed. However, if an instrument does not accept the value sent by SpecView then an error will be shown, for example:

Recipe Send: Auto Continue
SpecView will continue to send the Recipe and ignore all future write errors

Recipe Send: Abort
The Recipe send is aborted

*NOTE: Values already sent will be the values in the instruments. Previous values are not restored.*

Recipe Send: Continue
Clicking Continue will resume the Recipe send. The loading will pause again if there is another write error.

11.10 Recipe Send To

This box is only displayed when there is more than one identical instrument that the recipe could be sent to, and allows the Source and Target instrument(s) to be selected:
This will only send instrument variables to the specified instrument, it will not affect SpecView User Variables.

Problems

11.11 Source and Target Instruments

If more than one instrument has Recipe values on the GDW they will be shown in the Source Instrument window. Select one and then select one or more Target Instruments to receive the values associated with that source instrument.
Then select the next Source Instrument and select target(s) for its values, and so on. 
In this example, the values for Furnace 1 on the GDW will be sent to Furnaces 2 and 4. When all required targets have been selected, click the Send Now button

**NOTE: At least one target must be selected.**

### 11.12 Recipe Send To: Warning

No Target Instruments have been selected (to send the recipe to) for the Source Instrument Furnace 1, select the target instruments, for example:
11.13 Recipe Send To: Problems

If at least one Target Instrument has not been selected (to send the recipe to) for each Source Instrument:

Click Yes or No as required.

If an instrument does not accept the value sent by SpecView:
Recipe Send To: Skip Entire Instrument
SpecView will not attempt to send any more values to that target instrument

**11.14 Setting the recipe download order**

It is sometimes necessary to send recipe values to instruments in a specific order. Examples are:

- Setting a controller to 'Manual' BEFORE setting the output power
- Setting a programmer segment or step number BEFORE setting a target time or setpoint

**NOTE: Setting the Recipe download order is only required if the order of the download matters for the particular instrument variables used by the Recipe.**

<table>
<thead>
<tr>
<th>Segment Number</th>
<th>N/R</th>
<th>N/R</th>
<th>N/R</th>
<th>N/R</th>
</tr>
</thead>
<tbody>
<tr>
<td>Target SetPoint</td>
<td>N/R</td>
<td>N/R</td>
<td>N/R</td>
<td>N/R</td>
</tr>
<tr>
<td>Segment Time</td>
<td>N/R</td>
<td>N/R</td>
<td>N/R</td>
<td>N/R</td>
</tr>
</tbody>
</table>

In this picture all these variables have been selected for Recipe. It is required that the following order is followed:

1. The first segment number
2. The first target SP and Time
3. The second segment number
4. The second target SP and Time
5. And so on...

SpecView supports up to 99 download levels which specify the order. Any number of parameters may be sent at any level. It is advisable to leave one or two spare levels at the top. So typically the first item (the first segment number, in this example) will be set to level 3, the next to level 4 and so on. The reason for this is in case you need to add something in the future that needs to be set first.

To set the download level:
First ensure is NOT enabled on the toolbar.

- Single-click the value to select it
- Press the shortcut: Ctrl + D or use the Edit - Dynamic Attributes menu command:

```
Segment Number | N/R
Target SetPoint | N/R
Segment Time   | N/R
```

Select the required level
SpecView will send the Recipe in the specified order.
There is a pause between levels to allow the controller (the instrument) enough time to register the values and be ready for the next data. This pause is adjustable in Preferences - Recipe

Then click the Save tool and the Runtime tool to save and run.

11.15 Recipe on Remote

Recipes are stored on the Local, they are downloaded by the Remote whenever the Recipe Manager is invoked.

A change to a Recipe on the Remote will cause the change to be sent back to the Local.

It is possible that a Recipe may be edited by both the Local & Remote, or indeed by more than one Remote, at the same time.

If this occurs then SpecView will display a warning when the Recipe is edited. Saving the recipe under these circumstances should only be done with caution as changes may be overwritten.
Top Level Intro

This page is printed before a new top-level chapter starts
12 Strategy Controller

The Strategy Controller is used to automate functions in SpecView such as:

- Automatic Recipe Downloading
- Automatic Log Report Generation
- Turning a Variable On/Off when an event occurs
- Setting Variables to new values
- Timing events such as Down Time
- Counting events
- Implementing cascade control
- Performing multiple adjustments from a single click such as incrementing several set points at once

Using the Strategy Controller involves two steps:
1. Defining an Event
2. Defining one or more Actions to go with the Event
This may also be thought of as an 'IF - THEN' statement.

**NOTE: There is no ELSE function in the Strategy Controller.**

If an event is defined such as:

'Zone1.Process Value > 200 ➔ Turn On Outputs.Relay3'

SpecView will do nothing when the value falls below 200. A second event:

'Zone1.Process Value <= 200 ➔ Turn Off Outputs.Relay3'

must be defined.

**EVENTS are tested continuously and in no particular order (see below)**

**ACTIONS are executed in the order that they are shown in the list**

Below is a step-by-step example which explains the function of each item available in the Strategy Controller. It is strongly suggested that the user follow through this example, even if it is not relevant to the application, to become familiar with the concepts of the Strategy Controller. Both the Events and Actions of the Strategy Controller can be logged to the Event Log.

**Programming the Strategy Controller**

**Step-by-step example** showing how to use the Strategy Controller to generate an automatic log report for a duration of a process.

**Event Type**
- Value (Variable) Based Event Setup
- Time Based Event Setup

**Strategy Controller Actions**
- Examples of Value Based Events
  - Turn on a digital output on a New Alarm
  - Cascade Control
  - Totalizer
- Examples of Time Based Events

In the **User Guide** there is also an example of using the Strategy Controller to generate a daily log report at midnight covering the previous 24 hours.
12.1 Programming the Strategy Controller

The Strategy Controller is an event driven engine and therefore requires a completely different approach to programming from the more traditional procedural programming such as Basic.

The events are edge-driven so that they only fire when a change occurs. Therefore in an event that says, for example, 'If Bool1 = On' will only fire once, and will only fire again if the Boolean goes to Off and then back to On.

The order which events fire cannot be predetermined. The only way to ensure a particular sequence is to use the Enable-if mechanism.

For example:

Event: 'When Temp > 100'
Event: 'When Pressure > 20'

If it is important that the Temp is checked first (and its actions performed) and then the Pressure, use the Enable On Boolean as an 'AND' operator:

(This example uses a SpecView User Variable 'Bool1')
Event: 'When Temp > 100 enable-if Bool1 is Off'
Action: ...
Action: 'Set Bool1 to On'
Event: 'When Pressure > 200 enable-if Bool1 is On'
Action: 'Set Bool1 to Off'
Action: ...

The actions for an event are performed in the order that they are listed.

The 'Startup event' is a 'Value Based Event' and can be used to initialize variables. There can only be one Startup event defined, but it can have many Actions, which are typically used for initialization of variables.
Therefore in order to create a Strategy Controller ‘program’ it is necessary to think of it in terms of events & actions. Write down all the significant events (such as values going outside thresholds) then think of the actions which need to be done when those events occur.

The list of Events in the Strategy Controller are always listed in alphabetic order. Therefore to make reading and understanding the list easier it is useful to number the events so that they are shown in an order which the programmer would expect,

For example:

000 Startup
010 When Temp > 100 & Bool1 Off
020 When Pressure > 20 & Bool1 On
030 etc...

Leave intervals of, say, 9 between the event numbers to allow the addition of events in the future without the need to re-number them.

Step-by-step example of using the Strategy Controller
12.2 Enable On Boolean

Use the Enable On Boolean as an ‘AND’ operator.

This example uses a SpecView User Variable ‘Bool1’

Event: 'When Temp > 100 enable-if Bool1 is Off'
Action: ...
Action: 'Set Bool1 to On'

Event: 'When Pressure > 200 enable-if Bool1 is On'
Action: 'Set Bool1 to Off'
Action: ...

12.3 Example: Automatic Log Report

This example will show the steps for a simple log report. A more complex example that incorporates some extra features is described later in this section.

To use the Strategy Controller you must first plan the steps needed and define any SpecView variables that will be required. In this example we want to watch a programmer controller to see when it starts a program and note the time it starts. When the program is complete we want to note that time and create
a log report that covers the duration of the run.
These steps are required:
1. Create two SpecView Date/Time User Variables, one for the start time and one for the stop time.
2. In Runtime Mode, define the log report format that you want to use.
3. Define the first Strategy Controller event that watches for the start of the program.
4. Define an action to time stamp the program start.
5. Define the second Strategy Controller event that watches for the end of the program.
6. Define an action to time stamp the program end.
7. Define another action to generate the log report.

**Step 1:**
Create two SpecView DateTime User Variables, one for the start time and one for the stop time.

Open the Variables List by clicking the tool and choose 'New DateTime User Var' from the New menu:
Enter the name: ‘Program Start Time’

Click **OK** to create the User Variable.

Repeat the above steps to create a second User Variable called ‘Program Stop Time’.
*(Note: To see the values of these DateTime User Variables when in Runtime Mode drag and drop them onto the screen (GDW), or add them to the Quick List.)*

**Step 2:**
Define the log report format that you want to use for the file.

Click the Save tool to save the changes and click Run

Create the **Log Report Format** to be used for the automatic report.
Choose **'Convert Log File'** from the **Logging** menu:

Click the **'Create...'** button on the Log Report Setup box:
Select the variables from the list on the left to put into the report and click **Add**.
Then for the **Start Time** and **Stop Time** click **Var** and choose the variable from the drop-down-list:
Ensure that the 'Start Time' and 'Stop Time' fields use the same SpecView User Variables that you created in Step 1.

**Step 3:**
Define the first Strategy Controller event that watches for the start of the program.

Go back into Edit Mode (offline) and choose **Strategy Controller** from the **Setup** menu.

*Note: Ensure Strategy is 'Offline' on the **Online Features** menu while editing the Strategy.*

The Strategy Engine box is displayed:
Click the Add button to add a new Event.

*(The left side of the Strategy Engine setup box is for the Events and the right side is for the Actions associated with those Events.)*

The **Value Based Event** box is displayed:

Click the **Value based** button
In the Description field enter: 010 Watch Program Start

Events are listed in alphabetical order so it is a good idea to use a numeric prefix so that related events may be grouped together in the list. (this is for convenience - list order has no impact on how events are triggered).

Then click the Choose button to select the variable that the Strategy Controller will monitor.

The Variables List will appear. Find the variable that you want to monitor to determine the start of the log report.

In this case, the parameter is ‘Program Status’. The type of instrument that you are using will determine which parameter you want. If in doubt, please contact the instrument manufacturer.
Click the arrow to drop down the list for 'Test to Perform' in this case we want '=' (Equal To)

Next Click the **Set Value** button. The type of parameter that you selected to watch will determine the type of box that appears. In this case it is an 'enumerated' variable, which gives you a list to choose from. Double click the one you want, in this case 'Run'

The Value Based Event box should now look like this:

Click **OK** to close the 'Variable Based Event' box

The **Strategy Engine Setup** box should now look like this:
Step 4:
Define an Action to time stamp the program start
Click the Add button on the Action side of the box. The Action box is displayed:
Enter a description, such as 'Time Stamp Program Start'.

*Actions will remain in the same order, so no additional numbering is required. To change the order use the 'Up' and 'Down' buttons.*

The default action is 'Download Specific Value' and that is the one needed now.

In the Variables List click the plus sign by 'User Variables', the plus sign by DateTime. Click and drag 'Program Start Time' into the Action box.
We want SpecView to copy the current time to this variable so click the Current Time checkbox:

Click OK.

The box should now look like this:

<table>
<thead>
<tr>
<th>Strategy Engine Setup</th>
</tr>
</thead>
<tbody>
<tr>
<td>Event</td>
</tr>
<tr>
<td>010 Watch Program Start</td>
</tr>
<tr>
<td>Action</td>
</tr>
<tr>
<td>Time Stamp Program Start</td>
</tr>
</tbody>
</table>

**Step 5:**
Define the second Strategy Controller event that watches for the end of the program
Click the Add button on the Event side of the box. Enter a description. Click the Choose button and select the variable to watch that will tell SpecView that the program is complete. Select '=' (Equal To) for the Test to perform. Click the Set Value button and choose the appropriate value. The box should look something like this, depending on the variables you have chosen.
Step 6:
Define an action to time stamp the program end
Click the Add button on the Action side of the box. Enter a description, such as 'Time Stamp Program End'.
The default action of 'Download Specific Value' is the one that is needed now.

In the Variables List click the plus sign by 'User Variables', the plus sign by DateTime. Click and drag 'Program Stop Time' into the Action box and check the 'Current Time' box:

Step 7:
Define another action to generate the log report

Click the Add button again on the Action side of the box. Enter a description and select 'Logging: Convert Specific Log File Format' as the action type. Choose the log format you defined in Step 2. Click OK.

The Strategy Engine Setup box should now look like this:
The setup is now complete. Click OK to save the Strategy.

Strategy events in SpecView are 'Edge Triggered'. This means that the Event is triggered when SpecView sees that occurrence of the Event conditions. When SpecView is started (either by starting the program or by going into Runtime Mode from Edit Mode) all the events are checked. If an event is true, the Strategy Controller will execute the actions associated with that event. In this example, if the program is already running when SpecView is started '010 Watch Program Start' will trigger and the time stamp will be done. If this is a problem extra Strategy steps and intermediate boolean variables must be used to prevent the unwanted triggering of the event. An example of this is shown later in this section.

**NOTE:** This 'Edge Triggering' is such that once an Event has triggered, for example, Process Value > 200, then the Event will not be triggered again until the value has gone below 200 and then above 200 again.

### 12.4 Event Type

- **Value Based** events test the value of a Variable against either a constant or another Variable.
- **Time Based** events monitor Time, Day, Date, Day of Week etc.

### 12.5 Value (Variable) Based Event Setup

**Examples**
Description is a text field to identify the event. Events are listed in alphabetical order so it is a good idea to use a numeric prefix so that related events may be grouped together in the list.

When the 'Log to Event Log' box is checked each occurrence of the event will be time stamped in the Event Log. (If the event log has been set to record specified events)

'Value to Watch' is where the variable is selected that SpecView will check or 'watch'. This can be any variable, including SpecView variables, from the Variables List.
This is where the type of test SpecView will apply is specified.

'Changed' means changed by more than the amount given. This includes time, booleans and values. When using this with a boolean it is necessary to ensure that the Value to test against is set to False.

'Comms Error' will become true any time SpecView does not receive a response from the instrument when the variable is requested. This can be used to alert an operator that communications has been lost or corrupted.

The 'Value to test against' may be a constant value OR the value of another variable.

A constant value would be used when the test is always the same. If a constant value of zero is used then this means any change to the variable.

Other Variable is used when two values are to be compared such as Zone 1.Process Value > Zone 2.Process Value.

Or if a test involves comparing a value to a setpoint that requires adjustment. For example, a counter is to be reset when the count value exceeds a particular value, and that value is to be set by the user. A SpecView variable would be defined called 'Count Reset Value' that is put on a GDW. The Strategy Controller event is: 'Counter.Value > SpecView.Count Reset Value'

**Using Event Control (Enable On Boolean) to do an AND function**

Event Control (using: Enable On Boolean) allows an AND function with a secondary boolean

For example: Zone 1.Process value < 200 AND Furnace.Door = Open

If it is required to AND a variable that is not a boolean, such as a number, an intermediate event must be defined:

For example, Zone 1.Process Value > 250 AND Zone 3.Process Value > 300

A SpecView boolean User Variable must be defined 'Zone 3 over 300'
A second event: 'Zone 1.Process value < 200 AND SpecView.Zone 3 over 300 = True' completes the required statement.
In such an example do not forget to have an event to turn OFF the boolean since the Strategy Controller has no implied ELSE function.

When this box is checked the Strategy Controller will NOT test the event.

The Startup Event is a special event that is always true when SpecView is started or Runtime Mode is entered from Edit Mode. It is not necessary to define any variable to watch or specify any test.

Using Event Control (Enable On Boolean) to specify the order of Events
If the order that events are tested is important, then it is possible to force SpecView to do one set of actions before another by the use of the 'Event Control - Enable On Boolean'. To do this create a SpecView Boolean User Variable then add an action to the events to set the Boolean and use the 'Enable on Boolean' to determine which will be invoked as follows:

For example, the 2 events can have their sequence controlled as follows:

<table>
<thead>
<tr>
<th>Events</th>
<th>Actions</th>
</tr>
</thead>
<tbody>
<tr>
<td>If ProcessValue changed &amp; Bool is Off</td>
<td>Set Bool On</td>
</tr>
<tr>
<td></td>
<td>Do your required action</td>
</tr>
<tr>
<td>If ProcessValue changed &amp; Bool is On</td>
<td>Set Bool Off</td>
</tr>
<tr>
<td></td>
<td>Do your required action</td>
</tr>
</tbody>
</table>

NOTE: When an event has been tested as true the event will not invoke its associated actions again until the event has become false, and then true again.

12.6 Time Based Event Setup

Examples
Description is a text field to identify the event. Events are listed in alphabetical order so it is a good idea to use a numeric prefix so that related events may be grouped together in the list.

When the 'Log to Event Log' box is checked each occurrence of the event will be time stamped in the Event Log. (If the event log has been set to record specified events)

The time at which the event will trigger is determined by the settings in these lists.

This event will last for one second every Monday at 6 o'clock in the morning. If 'Any' had been left in the 'Second' field the event would be true any time between 06:00:00 and 06:00:59. But the event will only be triggered ONCE during that minute, and will not trigger again until next Monday at 6am.

Note the 'Any 5, Any 10 etc. that are at the bottom of the Minute and Second lists. When possible, these should be used in place of the 'Repeat Every' function described below.
Only use the 'Repeat every' setting with caution. The event will trigger every 6 hours with the setting shown. What SpecView does is compute when the next event should occur and automatically enter those values into the time and day fields.

If the first event was set to be 06:00 on Monday, as shown above, and it is March 5, 2002 when the event is first triggered SpecView will compute that the next event will be:

<table>
<thead>
<tr>
<th>Hour</th>
<th>Minute</th>
<th>Second</th>
<th>Day Of Week</th>
<th>Day</th>
<th>Month</th>
<th>Year</th>
</tr>
</thead>
<tbody>
<tr>
<td>12</td>
<td>00</td>
<td>00</td>
<td>Monday</td>
<td>5</td>
<td>March</td>
<td>14</td>
</tr>
</tbody>
</table>

If SpecView is not in Runtime Mode at that precise moment the event will be missed and will never be triggered again. The user will need to re-edit the Strategy Controller event to get it to trigger again.

**NOTE:** It is recommended that a Value based event watching SpecView.Time with a test of Changed by a constant value be used instead of a time based event using 'Repeat every'.

**Using Event Control (Enable On Boolean) to do an AND function with a time based event**
Event Control allows an AND function with a secondary boolean

- **Event Control**
  - **Enable On Boolean:** AutoRecipeLoad
  - **True (1) / False (0)**

For example: Every Monday at 06:00 AND SpecView.AutoRecipeLoad = On

If it is required to AND a variable that is not a boolean, such as a number, an intermediate event must be defined:
For example, 06:00 on Monday AND Zone 3.Process Value > 300
A SpecView boolean User Variable must be defined 'Zone 3 over 300'
A second event: ‘06:00 on Monday’ AND ‘SpecView.Zone 3 over 300 = True’ completes the required statement.
In such an example do not forget to have an event to turn OFF the boolean since the Strategy Controller has no implied ELSE function.

When this box is checked the Strategy Controller will NOT test the event.
12.7 Strategy Controller Actions

For more details on these functions see the descriptions for Button Attributes.
Choose an Action off the list:

If the 'Event Log' box is checked then the action will be time stamped in the event log each time it is executed. (If the event log has been set up to record specified strategy items. This is the default setting of the event report).

12.8 Examples of Value Based Events

Turn on a digital output on a New Alarm
Cascade Control
Automatic Log Report
Totalizer

Contact your SpecView distributor for more examples.

12.9 Turn on a digital output on a New Alarm

SpecView can monitor any boolean variable as an Alarm, also Alarm/Event Menu

This Strategy Controller example shows how to turn on a digital output whenever SpecView detects a
new alarm.

![Strategy Engine Setup](image)

This event is watching (or monitoring) the SpecView variable 'SpecView.NewAlarm' which will be set to 'On' when any of the boolean variables or boolean instrument parameters - which have the 'Alarm' property enabled - change to 'On'.

When there is a new alarm condition and the SpecView User Variable 'Alarm Check' is 'On', the event will trigger. The use of event control would allow the user to disable this event by setting the SpecView.Alarm Check variable to 'Off'.

The appropriate action is shown below - The variable 'Relays.Dig Output 1' will be set to 'On':
12.10 Cascade Control

The Strategy Controller can be used to trim the set point of one controller based on the output of another. This is used in many applications where the desired measurement is ‘thermally remote’ from the heat source. Examples include:

- Controlling from the internal (part) sensor of a furnace
- Using ‘Deep/Shallow’ thermocouples on an extruder barrel

In this example the output of the ‘Master’ controller is used to adjust the set point of the ‘Slave’ controller. (If the master is a programmer type controller then ‘Master.Working SP’ should be added to the ‘SpecView.SP Trim’ instead of the ‘Slave.SP’)  

The example below shows the use of a SpecView User Variable to give more flexibility in tuning:

1. Define two SpecView Number (with decimals) User Variables, called ‘Cascade Gain’ and ‘SP Trim’
2. Add a value based event: Value to watch = Master.Output; Test to Perform = Changed
4. Add a second math function action: COPY FROM Slave.Setpoint ADD Strategy Controller.SP Trim COPY TO Slave.Setpoint

The Strategy Controller boxes for this example are shown below:
Action 1:

Description: Calculate SP Trim

Action:

Parameters: Math Function

Copy From:
Choose... Master:Output Power

Operator:
Choose... Multiply Cascaded Gain

Copy To:
Choose... SP Trim
12.11 Totalizer

Some instruments have a built-in totalizer. But if this is not the case then SpecView can be configured to do this for you. However, it is important to consider what it is that you need SpecView to do, for example:

- When should the totalizer result be reset back to zero?
- What is it that is being measured?
  - If the instrument does an on/off for every unit of consumption then these can be counted.
  - If the value is a flow-rate then the calculation needs to be done carefully to ensure that the total is a true one.

A basic totalizer would need a SpecView Number User Variable to store the running-total and a Strategy Controller event which would add the current value to the running-total.

Totalizing a flow-rate is more like calculating an average. However, it is particularly important to have thoroughly thought through exactly what is needed:

- What are the units of the flow rate?
- Is the flow generally constant or rapidly changing?
- How often should the flow-rate be sampled?
- Over what period of time will the totalizer run for, such as, over a few minutes or maybe over a few days.
- At what stage should it be reset?
- Should the reset be done automatically or manually by the operator?
How accurate does the total value need to be?
Should the total value be marked for logging?

Here's an example of a flow-rate in litres per minute, where the flow-rate is added up every second and at the end of each minute divided by 60 & added to the total:

Create an 'every second' event (see the note below), with the action to add the current value of the flow-rate to the running-total.
Create an 'every minute' event, with the action to divide the running total by 60 & add the result to the total. (For the constant value 60, create a SpecView Number User Variable called 'Sixty' and set the initial value to 60).

To show the duration that the totalizer has been running:
- Create two SpecView Time User Variables (call them StartTime and Duration) and when the process starts set StartTime to the Current Time and set both the running-total & the total to zero.
  - Then add an action to the 'every second' event (which you've already created) to subtract StartTime from SpecView.Time & put the result in Duration.

When the values are displayed on the screen (GDW), it maybe that more than one decimal place needs to be shown, this can be changed using Dynamic Attributes.

For an example of this please see the Demo projects on the SpecView CD, or contact your SpecView distributor.

NOTE: It is recommended that for events that need to 'fire' every second, or every minute a Value based event watching SpecView.Time with a test of 'Changed' by a constant value be used instead of a Time based event using 'Repeat every'.

### 12.12 Examples of Time Based Events

This event will trigger every Monday at 6 o'clock in the morning:
(Note that it is 'Enabled' by a SpecView boolean User Variable called 'SpecView.AutoRecipeLoad'. This means that this event will only trigger when that boolean is 'On')
This event will trigger every 10 minutes:

\[
\text{Description:} \quad \text{050 Every 10 Minutes}
\]

NOTE: It is recommended to use this method to get a recurring event rather than use the 'Repeat Every' function.
Top Level Intro

This page is printed before a new top-level chapter starts

Part XIII
13 Passwords

**NOTE:** Passwords are optional. If they are not needed then skip this section.

SpecView has the facility of password protection, which can be used as detailed below:

- Up to 5 levels of password access
- Any object on any screen may be password protected
- Adjustable inactivity timeout
- Hierarchical or non-hierarchical operation - meaning access is 'inherited' (or not) from lower-levels.
- Menu command blocking to unauthorized users
- Window controls or PC key blocking to unauthorized users
- It is possible to allow 'Level 1' users to use the system without having to login
- Password login/logout events can be recorded in the Event Log.

To save time it is a good idea to setup the Password system once all the screen layouts (GDWs) for a Project are complete.

Ideally there should be a thorough understanding of how the screens will be used in practice, in terms of who needs to use which parts of which screen.

For example, if there are 4 screens: MAIN.GDW, FURNACE.GDW, COOLER.GDW & SUPERVISOR.GDW and 2 users: Operator & Engineer, then to setup the Password system use the GDW Setup menu command and go to each screen in turn and choose the 'Level' of the user (for example, 1 for Operator & 3 for Engineer), then select the objects on EACH screen that the user needs to have access to. Remember to save the changes to the screens.

For the Engineer level (in this example this is Level 3) it is advisable to check the Allow Edit Mode checkbox, and for Operator level (in this example this is Level 1) have this unchecked. This will just allow the Engineer level user to enter Edit Mode.

It may also be worth considering using Full-Screen mode.
In this case it will be necessary to put a Button with the action: Password: Log In or Log Out on at least the first screen.
Put a Button to Toggle Full-Screen Mode onto a screen which is accessible by the Engineer level user.

To Setup users use the User Control menu command to create user IDs and Passwords for the users at the required levels.

Finally uncheck the Disable Password System checkbox (on the GDW Setup dialog) and test that each user has access to the correct parts of each screen.

For future changes to the project, to save time in repeatedly entering the password every time Runtime Mode is used for testing, it is a good idea to disable the password system, make the amendments, test them, modify the password system appropriately so that any new items on the screen are accessible by the correct level of user, and then once everything is completed, re-enable the password system.

**NOTE:** When setting up the password system it is necessary to ensure that all variables, which may need to be changed during Runtime, are accessible by at least one user.
NOTE: that when Passwords are used in conjunction with Full Screen mode it is important to ensure that there are buttons on a GDW for Login and Logout.

When Passwords are enabled it is not possible to go directly into Edit mode using the shortcut of holding the Shift or Control keys and clicking the Start button to force SpecView to go directly into Edit Mode when it starts. It is necessary to login as a user who can access Edit Mode and temporarily disable passwords.

For traceability it is recommended that each individual user is given their own ID and password - even if they use the same Level as other users. This is because Password login/logout events can be recorded in the Event Log and the user ID that was logged in at a certain time can be traced.

It is also important to set the Password Timeout to the shortest possible time, so the user is automatically logged out after the briefest possible period of inactivity.

For information about the use of Passwords with ActiveX controls see here.

13.1 Passwords - GDW Setup
Selected Object Access Levels

SpecView provides (up to) 5 levels of log-in access:

- Level 0 is the default (unless 'Start at Level 1' is checked) - where only the Password menu command or a Login button is accessible
- Level 1 (Operator) is the first level - typically only minimal access is given to Level 1 users
- Level 2 would typically have more access than level 1
- Level 3 would typically have more access than levels 1 and 2
- Level 4 (Configuration) would have the most access, but not necessarily access to everything - otherwise they could just use level 5

When a user is logged in at Level 5 everything on all GDWs is accessible. Be aware that just because a variable has been marked as accessible at a level on one GDW does NOT mean it is accessible on another GDW.

Level 0 and Level 5 are not included in the drop-down-list because '0' is no access, and '5' always has access to everything.

Select All / UnSelect All Buttons

These buttons provide a quick way to Select / UnSelect all the objects on a GDW. The Select All button is useful to highlight ALL the objects which the user may need access too, and then click (to deselect) the ones that you don't want this level to have access to.

Global - These apply to ALL levels of user:

- Disable Password System (Default = On) - this applies to ALL Levels
  When checked the password system is not active and the system is unlocked at all times. This is useful during project development when switching frequently between Edit Mode and Runtime Mode.

- Hierarchical Behavior - this applies to ALL Levels
  When checked each level behaves in a hierarchical way; i.e. When an object is marked as accessible at level 1, it is automatically accessible at levels 2, 3 and 4.
**NOTE:** The following example should be studied in order to understand how this behavior could be confusing.

- An object, say Zone1.Setpoint, is marked as accessible at Level 1 (Operator)
- It is therefore accessible at all higher levels
- The user switches to Level 4 (Configuration)
- The user clicks by mistake on Zone1.Setpoint, de-selecting it
- Seeing the mistake, the user clicks again on Zone1.Setpoint to re-select it…

However, because de-selecting it LOCKED it at Level 4 AND ALL LEVELS BELOW, re-selecting it only made it accessible at Level 4 - it is STILL LOCKED AT LEVEL 1. You MUST return to Level 1 and re-select it at that level.

**Start at Level 1**

This allows Level 1 users access without them having to login. This is commonly used when there are many operators who need to be able to walk-up to the system and click on a few things quickly without having to login first. In this case Level 1 users should only be given minimal access - and should need to login at a higher level to do anything that needs to be traceable. Password login/logout events can be recorded in the Event Log.

**Password Timeout** - These apply to ALL levels of user:

**Timeout**

Select a time for the inactivity timeout.

Inactivity is defined as not accessing a variable. Moving the mouse is not activity.

The time left on the timeout is shown in the status bar

It is important to set the Password Timeout to the shortest possible time, so the user is automatically logged out after the briefest possible period of inactivity.

**Timeout Returns To**

Select the required action:

- Last Logged In Level - this goes back to the level of the last user logged in, if their level was less than the current level, otherwise it goes back to Level 0
- Level 0 (all Locked) - this is the most secure choice
- Level 1 (Operator) - this is similar to 'Start at Level 1' but it is necessary to login at Level 1 initially when SpecView first goes online.

**Level** - These only apply to the level of user selected:

**Disable Window Controls - this applies to the current Level selected**

When checked the Window's menus are hidden and the maximize/minimize controls are disabled for this level of user. In addition to this, the following Windows keys will also be disabled:

- Ctrl-Esc
- Alt-Tab

‘Windows’ Key (which is positioned on the keyboard between the Ctrl and Alt keys) and on Windows 95/98/Me: Ctrl-Alt-Del is also disabled. However, on Win NT, Win 2000, Win XP, Ctrl-Alt-Del cannot be disabled.

Note: The Maximize window control will continue to be available for use. To avoid this being accidentally clicked use Full Screen Mode.

**Allow Edit Mode - this applies to the current Level selected**

When NOT checked the Edit Mode menu command is not available on the File menu to this level of user.

**Short List Only - this applies to the current Level selected**

- When checked the parameter button on Instrument Views will be restricted to the short list
- The Short Param List menu command on the Options menu will also be disabled
This will also affect the contents of the Parameter list which is displayed by the button (or Strategy Controller) action ‘Parameters: Show Full Parameter List’.

**NOTE:** If a variable is listed in the short list, and the user has access to the Parameter list (either via the Instrument view’s button, or via another button) then they will be able to change the value of that variable.

**Allow Quick List**

This allows this level of user to access the Quick List from Runtime Mode.

**Allow Trend Chart Setup**

This allows this level of user to access the Trend Chart Setup box from Runtime Mode.

### 13.2 Passwords - Selecting Objects for Access

Use the GDW Setup menu command on the Passwords menu which will display:

![Password Operation Setup](image)

**Selected Objects are ACCESSIBLE at Level:** Level 1 (Operator)

- **Global**
  - Disable Password System
  - Hierarchical behavior
  - Start at Level 1

- **Password Timeout**
  - Timeout: 1 Minute
  - Timeout returns to:
    - Last Logged In Level
    - Level 0 (all Locked)
    - Level 1 (Operator)

- **Level**
  - Disable Window Controls
  - Allow Edit Mode
  - Show Short List Only
  - Allow Quick List
  - Allow Trend Chart Setup

- **Select All**
- **UnSelect All**

- **Hide this box**
- **Cancel**
- **OK**
When the Hide this box button is clicked the cursor changes to the padlock shown above.

Click to highlight those objects on the GDW you want TO BE ACCESSIBLE at the level shown. Each object selected will highlight (as shown above) in either reverse video or with an outline box. (As for Recipe, the highlight type is defined by the Select Invert check box in Preferences - Recipe)

13.3 Passwords - User Control

This is used to enter the names and passwords of the users of the system
1. The User Control menu command brings up the 'Password Setup - Users' box
2. Then click the Add or Edit buttons to get the 'Add/Edit User Password' box

Up to 5 levels of user access are provided - use as many (or as few) as you wish

**NOTE:** Use only the levels that you know you need. Too many levels can be
counter-productive.
The designations 'Operator' and 'Configuration' are provided only as a reminder that higher numbers mean a higher level of access in hierarchical mode.

For traceability it is recommended that each individual user is given their own ID and password - even if they use the same Level as other users. This is because Password login/logout events can be recorded in the Event Log and the user ID that was logged in at a certain time can be traced.
Top Level Intro

This page is printed before a new top-level chapter starts
14 Multiple Users

SpecView Networking allows SpecView screen(s) to be accessed from other computers across the network or Internet.

It is possible to use other 'remote access' software such as Windows Remote Desktop or third-party software, for example: VNC, TeamViewer, Ammyy, etc.

However, using this kind of software would take control of the Local computer (which is the computer that is running SpecView and communicating with the instruments).

The advantage of using SpecView Remote to access SpecView from other computers is that it allows actions to be carried out on Remote computer(s) independently from the operator of the Local computer and other Remotes.

The following actions would not be 'seen' by other computers (Remotes or Locals). These are therefore independent actions:

- Swapping the screen (GDW) which is being viewed.
- Historical Replay
- Changes to Trend charts, such as adding pens. (Edits to Trend charts on the Remote will be overwritten the next time the connection is made. Therefore permanent changes need to be made on the Local).
- Viewing the Alarm or Event log windows.
- Viewing the Instrument Parameter List from the Instrument View.
- Converting a Log File. This can be set up so that the resulting file will be written either to the Local or to a Remote computer.

The following actions would be 'seen' by other Remotes connected to the same Local computer:

- Changing values of variables being displayed on the screen (GDW).
- Changes to Recipes using the Recipe Manager. These are always stored on the Local computer.

SpecView Remote is a secure method of access, as each connection requires a password.

However, it is not possible to go into Edit Mode from a Remote Computer.

Note: Strategy Controller events and actions take place on the Local. Therefore actions that affect, for example, the values of variables will be 'seen' by a Remote by way of the change to the variable. However, actions that affect, for example, which screen (GDW) is being viewed will only be 'seen' on the Local.

SpecView Networking uses simultaneous licenses:
In this example, SpecView would need to be installed on all 4 computers, but no dongle would be needed in the computers B, C or D.
The dongle in computer A would need at least one Remote License enabled on it.
This would allow any of the SpecView programs running on computers B, C or D to connect to the SpecView program running on computer A.
With additional Remote Licenses, any number of remote computers can connect, so long as there are only a maximum of the number of licenses connected to SpecView at any one time.

For further information:
- Connections for SpecView Networking
- SpecView Networking - Local
- SpecView Networking - Remote
- SpecView Networking - Via Modem
- SpecView Networking - Runtime Functions (on Remote)
- SpecView Networking - Runtime Functions (on Local)
- SpecView Networking - Troubleshooting
- SpecView Networking - Minimum Requirements

14.1 Multiple Users - Connections

For Multiple Users the connection can be made in 4 possible ways:
1. Via TCP/IP over a LAN (Local Area Network).
2. Via TCP/IP over a WAN (Wide Area Network) using an 'always connected' phone line or Broadband connection.
3. By making the Local computer available to the Internet so that the Remote computer(s) can access it over their Internet link. However, this has security implications so is not recommended.

4. By using modems for SpecView to make a direct-dial connection between the computers when needed.

The diagrams below show example projects:

It is possible for a PC to run one SpecView Local and several copies of SpecView Remote simultaneously:
14.2 Multiple Users - Quick Setup

Further details on all these steps are provided below, but in brief:

On the Local (which is the computer connected directly to the instruments):
- Ensure the dongle connected to the Local has the Networking Option enabled for the required number of simultaneous remote users
- From Runtime Mode use the Preferences menu command from the File menu. Click the Remote tab and ensure that at least one of the checkboxes for Network & Modem are checked
- Use the User Setup command from the Remotes menu to setup username(s) and password(s)

On the Remote (which is the computer connected to the Local via the network):
- If using a Modem connection then first ensure that the Modems are correctly configured
- On the Projects Found dialog click the Remote button
- Click New and create a new connection, then click Connect

To check it is all working:
- Check instrument values are updating as expected
- On the Local use the View Connected Users menu command from the Remotes menu.

Connections
- Local
- Remote

Runtime Functions (on Remote)
- Runtime Functions (on Local)

Troubleshooting

Minimum Requirements
- Modems

It is also possible to have SpecView Remote start automatically when the computer is started using SpecView's Command Line options.
To do this:
1. Edit the shortcut properties of the SV3 icon on the desktop to add -r <connection name>
   For example: C:\SV3\sv3.exe -r 'Factory Floor'
2. Copy the shortcut to the Startup folder.

14.3 Multiple Users - Local

A dongle (copy protection key) with the Networking Option enabled must be connected to the Local computer.

The next step is to ensure that the required SpecView Project has been created.

When developing a SpecView Project which is intended to be accessed by SpecView Remote, it is very useful to put all of these SpecView pre-defined Variables on to an accessible screen (GDW):
- SpecView.Date
- SpecView.Time
- SpecView.GoodComms
- SpecView.CommsErrors
- SpecView.CommsErrorCode
Then if the Remote computer is not showing the expected values from the instruments, it is easy to check if there is a problem with the SpecView Local's instrument communications.

Once the development of the Project is complete; from Runtime Mode use the Preferences menu command from the File menu. Click the Remote tab:

Check the appropriate box for whether the Remote is to use the LAN or Modem for the connection. If more than one of the devices is checked then SpecView will 'listen' on both for remote connections.

Note that these will take effect immediately, you do not need to restart SpecView for changes on the Remote tab to take effect.

The Timeout value is used in the event of a network failure. This is the number of seconds after which the connection will be dropped.

The next step is to register the remote users. Use the User Setup menu command on the Remotes menu. Each user will be assigned a password and will be assigned either 'Read Only' (Level 1) or 'Read & Write Access' (Level 2) or 'Alarm Acknowledge' (Level 3).

Read Only will prevent the Remote user from changing the values of variables on the Local.
Click Add, or select the user's name and click Edit:

Note that this is an extra security mechanism for Networking. It is independent of SpecView's Password system, which will continue to function on the Remote.

SpecView will decide whether a variable can be changed on the Local, based on the Access Level setting for the Remote user (in the box above) and SpecView's Password system.

The options are:
1 Read Access - Allows just Read Only access, so that variables cannot be changed from the Remote.
2 Read & Write Access - Allows Read & Write access, so that variables can be changed from the Remote.
3 Alarm Acknowledge - Allows Read & Write access, as well as allowing Alarms to be acknowledged from the Remote.

We recommend that careful thought is given as to whether Remote users can change (Write to) variables or Acknowledge Alarms, as they could be some distance away and oblivious to the subsequent effects of their change.

Setting Up SpecView Networking
14.4 Multiple Users - Remote

The Remote computer(s) do not require dongles.

When SpecView starts click the Remote... button:

The Connections box is displayed:

The user can select which Local computer to connect to, or click New... or Edit... to create or modify a connection:
The Description can be any name. This name will be appended to the name of the project from the Local computer when the project is copied to the Remote. For example, if this name is 'Production Line PC' and the project is called 'Batch Run' then the name of the Local project once it is copied to the Remote will be: 'Batch_Run_Production_Line_PC'. This is to distinguish between identically named projects copied from different computers.

**Network:**
Enter the IP address (or network name) of a PC running SpecView Local or click **Browse**. SpecView's default TCP/IP port number is 3413; it is recommended to use this, as it is registered with: http://www.iana.org/assignments/port-numbers and therefore should not conflict with other communications software running on the PC.
To confirm the address is correct, click the Check button. The Check button will only check that the other computer is contactable over the network, it will not at this stage check to see if it is running as a SpecView Local.

**Modem:** Select the Modem to be used from the list and enter the number to dial in the Call: box. This is detailed in [SpecView Networking via Modem](#).

**Redial attempts:** (Default: 1) The number of times the connection will be tried before giving up.

**Reconnect on fail:** (Default: Off) Whether the connection will automatically try to reconnect if it fails.

**Timeout:** (Default 25 secs) The number of seconds that SpecView Remote will wait for a reply from SpecView Local, before timing out.

**Inactivity timeout:** (Default: 5 mins) In the event of a network failure this is the number of minutes after which the connection will be dropped. A value of 0 is not allowed. In addition:

**Auto log off:** (Default off) When checked, the user will be logged off after the Inactivity timeout period, if there has been no user activity, such as clicking buttons.

When it is unchecked, the user will not be logged off, the connection will remain open indefinitely.

This is useful if the Remote machine is likely to be left unattended.

**Update rate:** (Default 2 secs) This is the rate at which the Remote will update from the Local. Reducing this time will increase network traffic, but will mean that the Remote will be more tightly in-sync with the Local.

**Packet size:** (Default 1000 bytes) This is the maximum number of bytes sent between the Local and the Remote. Adjust this together with Packet count according to the type of network.

For rapid transfer of data over a lightly loaded LAN connection, set Packet size to 8000 and set Packet count to 50.

For a Direct Modem to modem connection, to allow a timely response to user-initiated activities, set Packet size to 1000 & Packet count to 5.

If you experience reductions in transfer rate, such as on a heavily loaded LAN, then a higher Packet count would be advisable, however, this will adversely affect the response time to operations like Parameter Downloads by the user.

The minimum Packet count is 5 and the realistic maximum value is 500.

**User Name & Password:** The user name and password to be used to connect to the Local. If these fields are left blank then the Username & Password will be prompted for when the connection is made, which is useful if many users will be using this connection.

These will need to have been previously set up using the User Setup menu command on the Remote menu on the Local computer.

Then click Save.

Now clicking Connect on the Connections dialog will display the Network Status dialog:
SpecView Remote will check to see if it already has a copy of the project which is running on the Local computer. There is the option of either copying the project which is running on the Local computer to the Remote computer using the **Update & Go Online** button, or vice versa, using the **Send Project back to local machine** button.

The **Update automatically next time** checkbox will have the effect of clicking the [Update & Go Online] button automatically.

Full update takes the whole project, so that it can be worked on off-line at the Remote.

A SpecView project can be created/modified on either computer. To do this on the Local computer SpecView's Edit Mode can be used directly.

However, on the Remote computer, SpecView's Edit Mode is disabled, therefore, SpecView will need to be run in 'Stand-alone' mode. To do this, select the project and then hold the shift key down while clicking the **Go Online Now** button on the Projects Found box.

Once the **Update & Go Online** button, or the **Send Project back to local machine** button has been clicked, it will then go on-line. Note that if the project is the same as it was last time then it will immediately go online, without the need to click a button.

When a GDW is displayed on the Remote computer, the values of the variables on the GDW are sent from the Local computer.

SpecView Local is able to process requests from multiple Remote computers simultaneously.

The Local user will be unaware that a remote user is accessing it, other than by viewing the Remote Users Attached list, by using the View Connected Users menu command from the Remotes menu:
Or via the Events Window, as the Event Logger will record all Network Login and Network Logout events and all values sent to the instruments by the remote user (Network Set Value).

The reporting of these events can be disabled using the Event Logging menu command on the Setup menu.

Setting Up SpecView Networking

14.5 Multiple Users - Runtime Functions (on Remote)

The following will be 'seen' by other Remotes connected to the same Local computer:
- Changing values of variables being displayed on the GDW.
- Changes to Recipes using the Recipe Manager. These are only stored on the Local computer.

However, the following will not be 'seen' by other computers (Remotes or Locals):
- Swapping the GDW which is being viewed.
- Changes to Trend charts, such as adding pens. (Edits to Trend charts on the Remote will be overwritten the next time the connection is made. Therefore permanent changes need to be made on the Local.)
- Viewing the Alarm or Event log windows.
- Viewing the Instrument Parameter List from the Instrument View.
- Converting a Log File. This can be set up so that the resulting file will be written either to the Local or to a Remote computer.

Note: Strategy Controller events and actions take place on the Local. Therefore actions that affect, for example, the values of variables will be 'seen' by the Remote by way of the change to the variable. However, actions that affect, for example, which GDW is being viewed will only be 'seen' on the Local.
14.6 Multiple Users - Runtime Functions (on Local)

Certain functions are restricted to the Local computer, such as:
- Setting Users & User passwords from the Remote menu
- Setting Preferences
- Displaying the View Connected Users dialog from the Remote menu.
- Going into Edit Mode. Note that this will disconnect all the Remote connections.

14.7 Multiple Users - Troubleshooting

If you are using Modems to make the connection
Then check the section on Modem troubleshooting.

If you see the message 'E12214 Local is not available or the connection failed.'
Then the following checks should be made:

1. Is the address (or network name) and port number right?
   To confirm this; on the Local, look at the title bar of the Remote Users Attached list, accessed by using the View Connected Users menu command from the Remotes menu. The address (or network name) and port number will be displayed in the title bar. Ensure this is what is being used by the Remote then click the Check button on the Remote to confirm it can reach the Local computer.

2. Is SpecView Local running and is it in Runtime Mode?
   On the Local has Networking been enabled? Ensure that, on the Local, at least one of the checkboxes for Network and Modem have been checked on the Preferences Remote tab. This is accessed by using the Preferences menu command on the File menu.

3. Are there remote users setup (i.e. login names/passwords) and are there enough remote users setup?

4. Is the version of SpecView running on the Local the same as the version running on the Remote?
   If this is the problem then the Event Window on the Local will show that there has been a connection failure with error code 20022.

If it still doesn't connect use Ping and Telnet to check the connection.

If you see the message 'TCP/IP is not installed on this PC' and you are using Windows95
Then the version of Windows Sockets (WinSock) will need to be updated to version 2.2 in order for SpecView to communicate using TCP/IP.
To do this download the Sockets2 update from:
If the Remote appears to be running slowly
Then it is useful to look at the information on the Remote’s Status bar:

The time is the time that the last updated value on the Local was updated, so this is the real data time lag. If this stops then there may be a network fault. The Tx and Rx show the data rate in kb (kilobytes) going across the connection. The Q shows the size of queue of data trying to be sent to the Local. If the queue size increases to above 20 then there may be a problem with sending data to the Local.
The Local’s Status bar shows the same information as above, but for the total of communication with all Remotes.
From the Local to see information about individual connections use the View Connected Users menu command on the Remotes menu:

The columns show:
The User ID.
The version of SpecView running on the Remote.
Date & time the connection was made.
The Queue sizes column shows:

Rx0.00kb Tx0.25kb = Receive & Transmit data rates (kb/sec)
HQ0 MQ0 LQ0 = High, Medium & Low queue sizes
HS0 MS0 LS0 = High, Medium & Low packet sizes

NOTE: that the name of the computer and port number are displayed in the title bar of this dialog. This can be used to check that these are correctly set on the Remote if there is difficulty making a connection.

Setting Up SpecView Networking

14.7.1 Using Ping and Telnet to Test

Using the command utility Ping to check if a TCP/IP address exists.
(Ping is like driving along a road to see if a particular house exists at an address)
Using Telnet to check to see if SpecView will have any possibility of connecting to a remote computer on a given IP address over TCP. *(Whereas Telnet is like knocking on the front door to see if anyone is there at that address)*

On Windows 7 the ‘telnet’ client utility program is not available by default.

Administrator privileges will be required to enable it.

Go to the Windows Control Panel ‘Programs and Features’ to enable it, see below:

4 Once telnet is enabled

Close and re-open the command prompt window.

then enter:
telnet 192.168.200.201 3413

If this gives an error like this:

then there is a problem with the network…..
In which case try: ping 192.168.200.102
This will possibly give additional information.
(You can think of ‘ping’ as driving down a road to see if a house exists. Whereas, ‘telnet’ is like knocking on the front door to get an answer.)

If ‘ping’ works, but telnet doesn’t then possibly the instrument isn’t answering on port 502 (port 502 is the default port for Modbus instruments over TCP.)
In which case check the port settings.

If ‘telnet’ gives a blank screen with a flashing prompt, then it has connected successfully.
Press CTRL+] to get a ‘>’ prompt, then to close telnet type: quit

If telnet connected successfully, then once telnet has closed (it is not possible to have both telnet and SpecView connected at the same time) then SpecView should be able to connect. If not then please contact SpecView. Email: support@specview.com

14.8 Multiple Users - Minimum Requirements for Multiple Users

SpecView is a 32-bit Windows application (also 64-bit) that will run on Windows 95/98/NT/2000/Me/XP/ Vista/7/8.
Any computer that runs Windows and programs such as Word or Excel should run SpecView. A minimum of a Pentium with 64 MB RAM is recommended. Normal SpecView activity does not put any great load on computer performance.

For SpecView Remote the specification above applies.

For SpecView Local, the number of simultaneously connected users affects the required specification. If there are going to be many, then more computer power is appropriate, hence at least a 400MHz Pentium processor would be required.

It is almost impossible to exactly specify the requirements because the load on the computer is dependant on what the Local computer's project is doing, how much data it is acquiring, which screens the Remotes are looking at, how many Remotes are connected or what they are doing. Coupled with this are any Strategy Controller and Logging overheads.

As a rough starting point, if the PC running SpecView already (before Local operation is enabled or used) is quick to respond in all areas, then a small number of Remotes should not impose any noticeable load. If the PC is already feeling 'slow', then it will be a little worse!

The biggest single effect that may be seen is the situation where the data update rate on the Local PC appears to slow down when remotes are connected. This will happen because one or more remotes may be asking for additional data across the Local PC's communications links to the connected instruments. This extra data means that the Local PC can only get data at a slower rate across saturated links. This can often happen if a remote user displays a large Parameter list, but the effect is no worse than a Local user displaying the same parameter list.

It is important that the screen resolution of the Remote is comparable with that of the Local to allow the Remote to adequately display the contents of the Local's screen. Use the 'Show screen sizes' menu command on the View menu to ensure that the items on a GDW are positioned appropriately.

For Windows95 the version of Windows Sockets (WinSock) will need to be updating to version 2.2 in order for SpecView to communicate using TCP/IP. To do this download the Sockets2 upgrade from:

http://www.microsoft.com/windows95/downloads/contents/wuadmintools/s_wunetworkingtools/w95sockets2/

Follow the instructions on the screen carefully, as there are several steps that need to be performed.

Minimum Requirements for running SpecView
Setting Up SpecView Networking

14.9 Multiple Users - Remote in Standby

If there is a network error where the connection between a Remote and a Local is broken then the Remote enters Standby Mode:
This can also happen if the Local is put into Edit Mode but the Local user will have been warned that Remote users will be disconnected:

In Standby Mode the Remote retries to re-connect to the Local, if successful it will then go online to the Local; if unsuccessful returns to Standby Mode.

The Remote user can cancel Standby Mode by clicking the Cancel button on the Standby Mode box or the progress bar.

14.10 Multiple Users via Modem

Although this is unlikely these days - in situations where a LAN or WAN or Internet connection between the Local & Remote(s) is not appropriate; SpecView Remote can be used to dial directly into the Local.

If more than one simultaneous connection is needed then more than one modem will need to be connected to the Local, each with a different telephone number.

However, for this SpecView relies on having modems which have themselves been correctly configured, PLEASE REFER TO THE MODEM’S USER GUIDE. Then test the modem connection using Hyperterminal.

SpecView should work with all makes of data modems, but it has been found that some combinations work better than others, these are listed under Modem types.

Additionally it is important that the SpecView project has been setup so that both ends have sufficient
information to be able to make a successful dial-up connection.

14.10.1 Multiple Users via Modem - Setup

There are 6 steps to follow:

**On the Local:**
1. When developing a SpecView Project which is intended to be accessed by SpecView Remote it is very useful to put all of these SpecView *pre-defined Variables* on to an accessible screen (GDW):
   - SpecView.Date
   - SpecView.Time
   - SpecView.GoodComms
   - SpecView.CommsErrors
   - SpecView.CommsErrorCode
   - SpecView.CommsErrorItem
   - SpecView.CommsErrorDescription

   Then if the Remote computer isn't seeing the expected values on the instruments then it is easy to check if there's a problem with the SpecView Local's instrument communications.

2. In either Edit or Runtime mode: Choose the Preferences menu item from the File Menu and click the Remote tab. Check the appropriate box to enable the Modem:
Click the Timeout to change it. The timeout for Modems is the the time before redialing. This is set by default to 50 seconds because many modems require some time to clear-down and therefore a rapid redial will not succeed, so we recommend caution before changing this.

3. In Runtime mode: Choose the 'User Setup' menu item from the Remotes menu and define some User ID(s) with appropriate Levels.

4. Display the 'Remote Users Attached List' which is displayed by choosing 'View Connected Users' from the Remotes menu. This will provide information about the connection status.

**On the Remote:**
1. At startup: Click the [Remote] button on the 'Projects Found' box which is displayed at startup. Click [New…], then on the Edit Connection dialog give the connection a name, check the Modem checkbox and fill in the fields as appropriate.
   The 'Reconnect on fail' checkbox will automatically reconnect & go online if the line is dropped.
   Entering a Username & Password will mean that these will automatically be filled in on connection.
   Ensure these are also setup on the Local.
   Click [Save]

2. Click [Connect] to make the connection.
14.10.2 Multiple Users via Modem - Failure

To troubleshoot a problem with Modem connection follow the points below:

1. On the Local always display the 'Remote Users Attached List' which is displayed by choosing 'View Connected Users' from the Remotes menu. This will provide useful information about the Local's connection status.

2. On the Local always have a screen which shows the 5 SpecView variables:
   - SpecView.Time
   - SpecView.GoodComms
   - SpecView.CommsErrors
   - SpecView.Comms ErrorCode
   - SpecView.Comms Error Item
   - SpecView.Comms Error Description
   This will provide information about the instrument data coming into the Local, because unless the Local is able to reliably access the instrument data, then the Remote will not be able to request this data from the Local.

3. Ensure that this is a supported Modem

4. Check the version of TAPI installed on your PC

5. Ensure HyperTerminal can make a successful connection.

6. Performance:
   The transfer rate on the Remote (Rx and Tx in kb/sec) is shown in the status line at the bottom of the SpecView32 screen. On the Local you will see the transfer rate on the Remotes->View Connected Users screen.

   If the transfer rate/throughput between Local and Remote is not as quick as expected, then this is normally caused by modems negotiating a low baud rate, due to compatibility or line quality. Try redialling or replacing one or both of the modems.

7. Resends high:
   On the Remote the resends are shown as a percentage on the status bar at the bottom of the SpecView32 screen e.g. Res:30.00%
   On the Local the resends are shown as a packet count on the Remotes->View Connected Users screen e.g. Res:20

   High resends such as 20% or more could be due to a very bad line or a modem hardware issue.

   Redial to retry the connection. If there is still a high resend rate then prove that the modems are OK by using HyperTerminal to send/receive a large text file. Use the Zmodem protocol to send a large file (say 20Mb or more) and watch the Retries which indicate failure to send/receive. If HyperTerminal reports problems then suspect that there is a modem issue. If HyperTerminal shows no issue then contact your SpecView Representative.

14.10.3 Multiple Users via Modem - HyperTerminal

If you find that SpecView is not making a successful modem connection then the first thing to try is to
do the same action using HyperTerminal.
This was a component of Windows and therefore is an independent piece of software. However, in
Windows Vista, Windows 7 and 8, HyperTerminal is not included, but it is possible to download this
useful tool from various websites, the files needed are:

hypertrm.exe
hypertrm.dll

In most cases SpecView will perform the same as HyperTerminal. With HyperTerminal you can either
connect to:

- Direct to the COM Port of the TAPI device – this allows you to use AT commands (see:
  www.computerhope.com/atcom.htm).
- Direct to the modem – this allows you to dial a number via an easy to use interface and best
  emulates what SpecView will do

Remember: If HyperTerminal cannot do it, then SpecView cannot either!

Where is HyperTerminal?
You will find HyperTerminal under:

- WinXP
  o “Start->All Programs->Accessories->Communications”.
- Win98
  o “Start->Programs->Accessories->Communications”.
  o If you do not have it installed then you will need to visit the “Control Panel->Add/Remove
    Programs->Windows Setup”. Check the “Communications” box. Hit the “Details” button.
    Ensure that “HyperTerminal” is checked.
- Win95
  o “Start->Programs->Accessories”.
  o If you do not have it installed then you will need to visit the “Control Panel->Add/Remove
    Programs->Windows Setup”. Check the “Communications” box. Hit the “Details” button.
    Ensure that “HyperTerminal” is checked.

Using HyperTerminal to simulate SpecView Remote connecting to SpecView Local:
Firstly ensure that the modem speakers are on. This is done via Windows Control Panel. This will help
considerably in understanding what’s going on.

1. To check that the modem on the Remote PC is basically working and can be ‘seen’ on the COM port,
do the following:
   On the Remote PC use HyperTerminal 'Direct to the COM Port' that the modem is connected to.
Type AT (although the AT characters will not necessarily be shown on the screen) it should respond with OK which will prove that the modem can be accessed on the COM port.
Then exit HyperTerminal.

2. Check that the modem on the Local PC can be accessed:
By doing the same as above on the Local PC.

3. Then on the Local PC run HyperTerminal again but this time select the modem from the list (enter any telephone number as this won't be used)

Click [Cancel] instead of [Dial], then choose the 'Wait for call' menu command from the Call menu.

Now on the Remote PC run HyperTerminal and again select the modem from the list enter the telephone number of the modem on the Local and click [Dial] and watch the call status until it shows 'Connected'. Then characters typed will echo into the other HyperTerminal screen.
To disconnect use the 'Disconnect' tool on the toolbar.

If any of this doesn't work then contact your computer's administrator and ask them to:
- Check the modem drivers have been recognised by checking the Windows Control Panel - Modems on the PCs at both ends of the connection.
- Check the wiring connections
- Check that the number being dialled is correct
- Do the noises being heard reflect what's going on, for example is a ringing tone heard.

It is very important to ensure that these steps work correctly BEFORE attempting to use SpecView

Remember: If HyperTerminal cannot do it, then SpecView cannot either!
4. Once the above steps have been completed and are all working OK then:

Use SpecView to make the connection, first ensure HyperTerminal isn't running (because SpecView & HyperTerminal cannot run at the same time using the same COM port).

Run SpecView Local and setup the connection.
Then in the Remote PC run SpecView and click the [Remote] button.
Either click [New...] to add a new connection, or [Edit...] to edit an existing connection. Ensure the number to dial & settings are correct as described in setup. Click [Save] then [Connect].

**Modem Troubleshooting**

### 14.10.4 Multiple Users via Modem - Modem Types

The Modem models which have been used are:

- Ambient 56K bps External (MD5660) Modem
- Bluetooth Modem
- Conexant SmartHSFiV.9x 56K Speakerphone PCI Modem
- Conextantd480 MDC V.92
- HayesAccura 56K Speakerphone External
- HayesAccura V92 Speakerphone External
- Intel V92 External Modem (Actually: Generic unbranded modem)
- Practical Peripherals PM288MT II V.34
- Standard Modem (Actually: Generic Rockwell 28.8K internal ISA card modem)
- Sportster 33600 FAX VOICE EXT
- SupraExpress 56e PRO
- SupraMax 56K USB (not recommended for connection to a Local)

However, this is not a complete list, it should be considered more as a guideline.
Therefore, if the modem being used is not listed there is still a good chance it will work correctly.

**SpecView Networking via Modem - General**  
**Modem Troubleshooting**

### 14.10.5 Multiple Users via Modem - TAPI Versions

SpecView32 requires at least TAPI version 1.4, as this was the version “bundled” in Windows 95 and is designed for 32-bit applications. This allows SpecView to support Windows 95 and hence versions of TAPI included with more recent versions of Windows. SpecView has been tested with TAPI versions 1.4, 2.1 and 3.1.

**Windows XP Pro:**
Version(s) included: 2.2 & 3.1

**Windows XP Home:**
Version(s) included: 2.2 & 3.1
**Windows 2000:**
Version(s) included: 3.0

**Windows NT Server 4.0:**
Version(s) included: 2.0
Version available for download: 2.1 which is in Service Pack 6a (SP6a)

**Windows NT Workstation 4.0:**
Version(s) included: 2.0
Version available for download: 2.1 which is in Service Pack 6a (SP6a)

**Windows 98:**
Version(s) included: 2.1

**Windows 95:**
Version(s) included: 1.4
Version available for download: 2.1
From: ftp://62.49.124.34/TechNotes/TAPI/Win95_tapi21.exe

1.4 Included in Windows 95.
1.5 Included in Windows CE 1.0.
2.0 Included in Windows NT 4.0 with SP3.
2.1 Included in Windows NT 4.0 with SP4 and Windows 98.

**SpecView Networking via Modem - General**
**Modem Troubleshooting**
Top Level Intro

This page is printed before a new top-level chapter starts
15 ActiveX Controls

ActiveX controls are self-contained pieces of software which have a specific functionality & purpose. These controls can be added to SpecView projects to enhance the functionality & usability of SpecView. The controls themselves are purchased from the author of the controls, not from SpecView. Although a few controls written by SpecView will be available for purchase, (please see the SpecView website for details of these: www.specview.com).

Examples of sets of ActiveX controls are:
- Symbol Factory from Software Toolbox Inc. - see: www.softwaretoolbox.com
- Instrumentation Studio for ActiveX from Century Soar Technology Co. Ltd. See: www.cstsoft.com

It is also possible to develop ActiveX controls oneself, although this requires a high degree of software development expertise.

Examples & tutorials of a good range of ActiveX Controls written in Visual Basic can be seen at: http://pages.cpsc.ucalgary.ca/~saul/vb_examples/

In general there are 3 types of ActiveX control:
1. Those with just a graphical component, but with no values or functionality, such as a pipe graphic.
2. Those with both a graphical component & which also have input and/or output values(s), such as a slider control, where the inputs might be the maximum & minimum values for the slider bar & the output would be the position of the slider on the bar.
3. Those with no graphical component, which might for example do a calculation on some input values & put the result into an output value.

ActiveX - Steps to add an ActiveX Control

The addition of ActiveX controls has affected the Backward Compatibility of SpecView Projects.

15.1 ActiveX Steps to add an ActiveX Control

There are a number of steps to adding an ActiveX control to SpecView:
1. Firstly decide which control is required & ensure its functionality is fully understood, having read the author's documentation.
2. Install the required ActiveX control(s), following the installation procedure supplied with the control. They cannot be installed from within SpecView.
3. Use: Object->ActiveX Control->Register Controls to see if the required controls are listed, if not, use the Register button to register them with SpecView.
4. If the ActiveX control is one which has input and/or output values(s) that need to be linked to SpecView's Instrument or User variables, then the required instruments and/or User variables will need to be defined in SpecView.
5. Use: the ActiveX tool on the toolbar and use the ActiveX cursor to draw the control on the GDW. This can be done by clicking somewhere on the screen & dragging out to the required size, or by just clicking on the screen to position a control using its default size. (The 'hotspot' of this cursor is by the top of the 'A').

Even controls which don't have any graphical components will need to be placed somewhere on the screen, but as they will not be displayed in Runtime they can be drawn any size, anywhere on the
6. The 'Insert ActiveX Control' box will be displayed:

![ActiveX Control Insertion Dialog]

Select the control required, if it isn't listed, then click [See More ActiveX Controls] to add the control to the list, or if the control isn't shown then the control will need to be Registered & then select the control from the list.

7. When all the required controls have been drawn press the ESC key to restore the cursor to the 'pointer' cursor.

8. Select the control on the GDW.

   Note: To select an ActiveX object on a screen (GD3):

   - Either move the mouse over the edge of the control, until the cross-hair cursor is shown, then click to select the object.

   - Or click the background & drag to enclose the object(s), when the button is released all objects enclosed will be selected.

9. Use: Object->ActiveX Control->Setup (or Right-Click on the control, or press Alt-Enter) to setup the control according to the author's documentation.

10. If the ActiveX control is one which has input and/or output values(s), which need to be linked to SpecView's Instrument or User variables, then use: Object->ActiveX Control->Link to Variables (or Alt-X)
**Input** tab: An **Input** is an input into the Control (SpecView setting a value into it)

**Output** tab: An **Output** is an output from a Control.

**Methods** tab: A **Method** is something that can't be classed as an input or output. For example, something that has no inputs or outputs, such as an 'About...' box.

**Change allowed on Remotes** checkbox: This is OFF by default. When checked this allows users logged in from Remote versions of SpecView to change the Inputs on this ActiveX Control. This maybe desirable for a control such as a graphical slider, but NOT desirable for, say, an averaging control.

**Ignore first value on Outputs** checkbox: This is OFF by default. When checked this means that the very first value out of each Output for this control is ignored. This maybe desirable when the first value is a start-up condition or to be considered as an out of range value.

**Receive every value** checkbox: This is ON by default. When ON this means that the control receives all changes in values that are set for Inputs to this control. When set to OFF this means that the control is just sent the latest value when its Inputs are set.
This can be used when it is NOT necessary to see all values on a heavily laden system, particularly when the control is being used on a SpecView Remote, or if accuracy is not the control's purpose, or if the latest value is the only relevant value that is needed to be processed.

**Invoke** button: This can be used to run a Method to test it.

**Enable/Disable** button: Will enable or disable a control. All controls can be enabled/disabled using the File->Preferences ActiveX tab.

For example:
If the control is a graphic & it has an Input such as 'BlinkSpeed' then in order to set this it is necessary to read the author's documentation to find out the following information:
- The type of the value, for example, an Integer or a Number with decimals.
- The units of the value (Seconds, tenths of seconds, etc.)
- The range of values.
- Then also whether a related Input parameter needs to be set, for example to 'turn on' the blinking.
To set the BlinkSpeed parameter from a SpecView variable create a SpecView User Variable of the required type & then click the BlinkSpeed parameter on the Input tab, click the Variables List button & select the variable from the list.

To set a parameter to a constant value, such as BlinkMode=1 to turn on blinking, replace the word 'ignore' with '1'. To set a parameter to a color or font select from the dropdown list:

![Parameter List](image)

**These constants will be applied on entry to Runtime mode or by clicking the Invoke button.**

To monitor what is happening with an ActiveX control during Runtime mode via the Event window, it is necessary to check the 'ActiveX Controls' checkbox on the Event Log Setup box from the Setup menu. By default this is not checked as it produces a large number of entries in the Event Log.

For information about ActiveX controls and Passwords see here.

See also:
ActiveX Overview
ActiveX Licensing
ActiveX Insert Control
ActiveX Preferences
ActiveX Variables Inputs
ActiveX Variables Outputs
ActiveX Variables Methods
ActiveX Register
ActiveX Manage Control List
ActiveX Control Not Licensed
ActiveX on SpecView Remote

ActiveX Controls and Passwords

ActiveX Controls and Historical Replay

15.2 ActiveX Licensing

It is important to read the licensing agreement supplied with the control & to understand how the licensing is enforced, in order to avoid being in breach of the licensing agreement.

ActiveX Controls which are developed specifically for use with SpecView will have SpecView's licensing scheme built into them, this is described below. But ActiveX Controls (such as: Symbol Factory & Instrumentation Studio) which have been developed for general release will not, so for these Controls it is important to read the licensing documentation supplied with them.

*Note that Microsoft's licensing strategy is not supported by SpecView & therefore any ActiveX controls which use Microsoft's licensing will not run.*

If SpecView's licensing scheme is built into an ActiveX Control then:

- If SpecView is being used in 'Demo' mode, where SpecView will run for 10 minutes with no dongle attached, then ActiveX controls can be added to a project and then run for the 10 minute limit in Runtime Mode.

- If SpecView is running with a dongle, but which doesn't have the ActiveX option enabled then SpecView will not allow the adding, editing or running of any ActiveX controls. The dongle will require upgrading to add the ActiveX option.

- If the dongle has the ActiveX option enabled and the class of the ActiveX license on the dongle is correct then it will run. SpecView has a number of classes of ActiveX licensing, each Control has a class, such as Class1, Class2, Class3, etc. and the dongle's ActiveX licensing will also have a class assigned to it and only Controls of the correct class will run. The dongle will require upgrading to add the correct Class.
See also:
ActiveX Overview
ActiveX - Steps to add an ActiveX Control

15.3 ActiveX On SpecView Remote

When an ActiveX control is being added to a screen which may be displayed on a Remote PC via SpecView Remote, then it is important to consider whether the control is intended for use on the Remote, such as a slider control to set an instrument setpoint, then it is important that the 'Change allowed on Remotes' checkbox is checked on the Object->ActiveX Control->Link To Variables box. This is detailed in ActiveX - Steps to add an ActiveX Control

See also: ActiveX Overview

15.4 ActiveX Insert Control

Please refer to ActiveX - Steps to add an ActiveX Control for full details on inserting an ActiveX Control.

When ActiveX controls are first used within SpecView a full list of all the installed controls is generated and shown in the 'Insert ActiveX Control' box. To reduce this list to just contain the ActiveX controls which are being used. Click the 'See More ActiveX Controls' button and select those required. Then just that abbreviated list will be shown. Subsequently the full list can be seen by clicking the 'See More ActiveX Controls' button.
15.5 ActiveX Preferences

Enabled: This is ON by default. Allows all ActiveX controls to be enabled/disabled throughout SpecView.

Design Mode: This is OFF by default. Some controls have a run mode and a design mode & behave differently, this allows Design mode to be used. It is important to read documentation supplied with a ActiveX Control. This is a SpecView wide setting, to set this on a per control basis select the control & use: Object->ActiveX Control->Design mode

Rate: Default is every 2 seconds. This is the ‘heartbeat’ same as Scan rate (which is on the Preferences Runtime Tab). This controls the rate at which ActiveX Control outputs are invoked.

Apply fixed value in edit mode: This is OFF by default. When ON this causes the fixed values specified against a control to be applied when entering Edit mode.

Delay Output scan until Strategy Running: This is ON by default. When ON all of the ActiveX Controls inputs are NOT scanned until Strategy start-up is complete. If there are no strategy start-up events then there is no delay. This delay can be useful to ensure Strategy start-up actions that set Inputs are completed before anything else such as Outputs could affect the Input values.
15.6 ActiveX Variables Inputs

An Input is an input into the Control (SpecView setting a value into it).

Select the control, then press ALT-X to display the ActiveX Control Links box & click the Inputs tab:

To assign an ActiveX Control's Inputs to SpecView variables it is necessary to have first thoroughly read & understood the Control's documentation supplied by the author of the control.

It is possible to assign one of four kinds of input:
1. **Constant values**: To set a parameter to a constant value, such as BlinkMode=1 to turn on blinking, replace the word 'Ignore' with '1'.

Note that to assign a constant that is the same as a SpecView variable or parameter it is necessary to enclose it in double-quotes. Otherwise SpecView will substitute the value of the variable rather than just sending its name in.

For example: SpecView.Number1 sends the value of Number1 to the control whereas, 'SpecView.Number1' sends the string 'SpecView.Number1' to the control.

2. **SpecView variables or Instrument parameters**: Click the required parameter on the Input tab then click the Variables List button:

```
<table>
<thead>
<tr>
<th>Ignore</th>
<th>FillColor (Integer)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ignore</td>
<td>linkSpeed (Integer)</td>
</tr>
<tr>
<td>Ignore</td>
<td>BlinkColor (Integer)</td>
</tr>
</tbody>
</table>
```

& select the instrument or SpecView User variable to link it to.

When choosing a variable from the Variables List there are checkboxes to allow the type of variables to be changed:
- Do not convert
- Color
- Font
- Date
- Time
- Number with decimals
- Integer (which can be Signed or Unsigned)
- String
- Display format - This is used only when converting a number into a String to specify the number of decimal places or whether scientific notation is required.

However, it is always preferable to use a variable which is itself of the correct type.

Note that it is sometimes possible for an input to a control to be split across more than one input parameter. For example, the Time could be split into 3 separate parameters of hours, minutes & seconds. However, in this case whenever one of the parameters changes then all 3 will be sent by SpecView to the Control, but the other 'parts' of the parameter may not yet have been updated.

3. **Colors**: Choose 'Select Color' and select the required color. The color will be shown in notation, for example: 'Color_65280', not as the name of the color, for example: 'Green'.

4. **Fonts**: Choose 'Select Font' and select the required font. The font will be shown in notation, for example: 'Font_Arial,10,0,400,0', not as the name of the font, for example: 'Arial Regular 10'.

Note that if the name (in notation form) of a color or font needs to be assigned to a string then the name will need to be enclosed in double-quotes, otherwise SpecView will substitute the actual color or font in place of its name.

Enable/Disable: This button will enable or disable the selected item, or if none are selected then it will enable/disable the entire control.

All controls can be enabled/disabled using the File->Preferences ActiveX tab.

Invoke: The Invoke button can be used to read an Input to test it.
See also:

ActiveX Overview
ActiveX - Steps to add an ActiveX Control

15.7 ActiveX Variables Outputs

An Output is an output from a Control (Putting the value into a SpecView variable).

Select the control, then press ALT-X to display the ActiveX Control Links box & click the Outputs tab:

To assign an ActiveX Control's Outputs to SpecView variables it is necessary to have first thoroughly read & understood the Control's documentation supplied by the author of the control.

It is possible to assign an output to a SpecView variable or Instrument parameter. Click the required parameter on the Input tab & click the Variables List button:
& select the instrument or User Variable to assign the value to.

When choosing a variable from the Variables List there are checkboxes to allow the type of variables to be changed, such as converting a Text variable '25 Dec 2005' to a Date variable: 25th Dec 05.

- Do not convert
- Color
- Font
- Date
- Time
- Number with decimals
- Integer (which can be Signed or Unsigned)
- String
- Display format - This is used only when converting a number into a String to specify the number of decimal places or whether scientific notation is required.

However, it is always preferable to use a variable which is itself of the correct type, as type conversion should only be required on rare occasions when the control's documentation specifies.

Note that it is sometimes possible for an output from a control to be split across more than one output parameter. For example, the Time could be split into 3 separate parameters of hours, minutes & seconds. However, in this case whenever one of the parameters changes then all 3 will be sent to SpecView from the Control, but the other 'parts' of the parameter may not yet have been updated.

Enable/Disable: This will enable or disable the selected item, or if none are selected then it will enable/disable the entire control.

All controls can be enabled/disabled using the File->Preferences ActiveX tab.

Invoke & Show As Font:

Invoke & Show As Color:

Some ActiveX controls are written such that they have some Outputs that can be represented as Colors or Fonts. However, please refer to the Control's documentation for further information on this.

Invoke: The Invoke button can be used to generate an Output to test it.

See also:

ActiveX Overview
ActiveX - Steps to add an ActiveX Control

### 15.8 ActiveX Variables Methods

A Method is something that can't be classed as an input or output. For example, something that has no inputs or outputs, such as an 'About...' box.
To assign an ActiveX Control's Methods to SpecView variables it is necessary to have first thoroughly read & understood the Control's documentation supplied by the author of the control.

It is possible to assign one of four kinds of value to a Method:

1. **Constant values**: To set a parameter to a constant value replace the word 'Ignore' with the value.

2. **SpecView variables or Instrument parameters**: Click the required parameter on the Methods tab then click the Variables List button:

   & select the instrument or SpecView User variable to link it to.

3. **Colors**: Choose 'Select Color' and select the required color. The color will be shown in notation, for example: 'Color_65280', not as the name of the color, for example: 'Green'.
4. **Fonts**: Choose 'Select Font' and select the required font. The font will be shown in notation, for example: 'Font_Arial,10,0,400,0', not as the name of the font, for example: 'Arial Regular 10'.

**Enable/Disable**: This will enable or disable the selected item, or if none are selected then it will enable/disable the entire control.

All controls can be enabled/disabled using the File->Preferences **ActiveX** tab.

**Invoke & Show As Font**:  

**Invoke & Show As Color**:  

Some ActiveX controls are written such that they have some Outputs & Methods that can be represented as Colors or Fonts. However, please refer to the Control's documentation for further information on this.

**Invoke**: The Invoke button can be used to run a Method to test it.

See also:  

[ActiveX Overview](#)  

[ActiveX - Steps to add an ActiveX Control](#)  

15.9 **ActiveX Register**

Registering a control is similar to installing it.

**NOTE**: To register or unregister a control it is necessary to be **running SpecView as an Administrator** because SpecView updates the Windows Registry during this process, which requires Administrator privileges.
Most sets of ActiveX controls will come with their own installation program, which is likely to register the control automatically. However, some controls (maybe where one has been written as a bespoke control) will need to be registered.

To Register a control using SpecView use: Object->ActiveX Control->Register Controls...
Click 'Register...' and browse to find the control.
If in doubt about this then please contact the vendor of the control.

Projects that contain ActiveX controls, which are not yet installed (or registered) on the PC, can now be Restored & run. Although a warning message will be displayed informing the user that the ActiveX controls need to be installed. However, in this case the screens (GDWs) will not be able to be saved after modification, unless the missing ActiveX controls are deleted from the GDW.

See also:
ActiveX Overview
ActiveX - Steps to add an ActiveX Control

These messages will be displayed when the version of the ActiveX controls in a Project differs from the version of ActiveX controls which are installed (registered) on the PC. In the case of a minor change to the naming of the inputs/outputs/methods within the new version of the ActiveX control, this will be
automatically adjusted within the Project, so that it will continue to work with the new version.

However, it is always wise to ensure that a backup of the Project has been made before going into Edit Mode and saving the automatic adjustments.

If this ActiveX control is being used on multiple GD3s then it is necessary to open and save each of the affected GD3s. To ease this process a new menu option has been created to perform that function: 'Object->ActiveX Control->Save All GD3s for Version Changes' this menu item is only enabled if an ActiveX Control has had a version change in this project.

Registering ActiveX controls from SpecView on Windows Vista, Windows 7 and Windows Server 2008

Registering ActiveX controls requires administrative privileges, which under these versions of Windows requires user confirmation in the form of a 'User Account Control' box, which is now displayed when SpecView starts.

15.10 ActiveX Controls and Passwords

When enabling SpecView's Passwords on a project which uses ActiveX Controls it is important that the ActiveX controls are enabled at the appropriate level.

Although an ActiveX control which is intended for user interaction (such as a slider), will allow the user to operate it regardless of the password settings, the variable which is linked to it as the output will only be updated IF BOTH the ActiveX control and the output value is accessible by the user.
To select ActiveX controls with the padlock cursor, watch for the ‘tick’ appearing in the cursor as it passes over the edge of the control:

and that is when clicking will select it.
15.11 ActiveX Manage Control List

This is the full list of all ActiveX controls which have been registered on this PC. Those that are selected are the ones to be included in the 'Insert ActiveX Control' box this keeps the list to a manageable size!

Make Default Control: This is enabled when just a single control is selected. Checking this will help to reduce the number of mouse-clicks required to insert many instances of the same type of control.

See also:
- ActiveX Overview
- ActiveX - Steps to add an ActiveX Control

15.12 ActiveX and Historical Replay

When SpecView is in Historical Replay the ActiveX controls on the screen will also replay if the input parameters are marked for logging in the Variables List.

However, if this is not required then it is possible to 'turn off' ActiveX Controls in Historical Replay in the SETTINGS.INI file in the project's folder:

[ActiveX]
InputsDisabledInHistoricalReplay=Y

See also:
- ActiveX Overview
- Preferences
15.13 ActiveX Control Not Licensed

This error will be displayed if the SpecView dongle either doesn't have the ActiveX option enabled, or if the class of the ActiveX license on the dongle is incorrect. SpecView has a number of classes of ActiveX licensing, each Control has a class, such as Class1, Class2, Class3, etc. and the dongle's ActiveX licensing will also have a class assigned to it and only Controls of the correct class will run.

The dongle will require upgrading.

Please refer to ActiveX Licensing for full details on ActiveX Control licensing.

See also:

ActiveX Overview
ActiveX - Steps to add an ActiveX Control

15.14 ActiveX Need To Be Administrator

E12314 ERROR: ActiveX environment is not setup:
This error will occur if SpecView wasn't installed by a user with 'Administrator' privileges on this computer which would have prevented the Registry from being setup for SpecView to run correctly. This error will cause SpecView to exit. It will be necessary to run SpecView as an Administrator once. After that you just run it as a standard user.

**E12313 ERROR: ActiveX controls cannot be registered or unregistered because you are not running as an Administrator:**

This error will be seen when trying to register or unregister a control when not running SpecView as an Administrator. It is necessary for SpecView to update the Windows Registry during this process, which requires Administrator privileges.

**E12315 ERROR: ActiveX controls cannot be registered because you are not running as an Administrator:**
This error will be seen when trying to restore a project which contains ActiveX controls which need to be registered when not running SpecView as an Administrator. It is necessary for SpecView to update the Windows Registry during this process which requires Administrator privileges.

15.15 ActiveX Edit->Copy not supported by this control

E12331 Edit->Copy failed with error 'No such interface supported':

This error will occur if the ActiveX control itself doesn't support the actions 'Copy' or 'Cut' from the Edit menu.

To make a copy of this control it is necessary to create another instance of it.

To delete this control please use Edit->Delete instead of Edit->Cut.

See also:
ActiveX Overview
ActiveX - Steps to add an ActiveX Control
Top Level Intro

This page is printed before a new top-level chapter starts
16 Troubleshooting

Troubleshooting Instrument Communications
Hyperterminal
Telnet
Technical Support
Frequently Asked Questions (FAQ)

See also: Improving Performance (Speed) of Instrument Communications

16.1 Troubleshooting Instrument Communication

What to do if your instrument is just displaying 'N/R' instead of the correct values when in Runtime mode:

Is this a new installation of SpecView, which has not as yet ever worked?
Is this happening for ALL of the instrument's variables?
If the answers to the above 2 questions is Yes, then:
  o Has the wiring between the instrument & the PC been checked?
  o Has the instrument's manufacturer's manual been checked for any relevant information? For example, the setting of the instrument's address (address 0 should not be used).
  o Is the instrument's **address**, **baud-rate** and **parity** correctly set on the instrument?
  o Is the instrument's **address** is correctly specified in SpecView? (Click the Variables List tool, select the instrument's name and click Properties, then click Address Help)
  o Check the instrument is connected to the correct COM port, as specified in SpecView.
  o Does the COM port on the computer work? (Use HyperTerminal to test the COM port). And is the correct type of COM card fitted in the instrument?
  o Is the instrument's **baud-rate** and **parity** correctly specified in SpecView? From Runtime mode use the 'Setup COM Ports' menu command on the Options menu, click the tab for the appropriate COM port. Check the baud-rate & note down the name & version number of the driver. When the Settings are show 'Default' that means that the data-bits, parity & stop-bits have been set according to the factory defaults as specified in the instrument manufacturer's manual.
  o Is the instrument using the correct protocol? (for example, ASCII protocol versus modbus protocol)
  o Is the instrument terminated correctly?
  o Do you need a converter, which is needed for: RS422 or RS485 serial comms? (The reason the B&B converter is recommended for SpecView is because it has 'Automatic Send Data Control', which automatically switches from transmit to receive).
  o Does the converter work? Has it been wired up correctly according to the wiring diagram supplied with it? Does it require power and is it switched on? Have any dip-switches been set according to the instructions? Do other connected instruments work? Is it possible to swap it around to test it?
  o Has SpecView's Online Technical Notes been checked for this instrument type? Access www.specview.com then click Download and click FTP-site and open the TechNotes folder.
  o Some instruments have to be setup to allow their variables to be read. For example, setting the access level.
  o If the N/R is coming from an OPC Server, then contact your OPC Server's administrator to see if the OPC Server is running correctly.
  o If all of this has been checked then please contact your instrument's supplier.
If SpecView has been working successfully, but has now stopped working, or if just some of the instrument's variables are displaying as 'N/R' or 'NPV', then:

- Firstly be aware that some instruments are designed in such a way that, depending on the instrument setup, instrument mode or program considerations, some values are legitimately unavailable - these variables will be shown as 'NPV's. This is normal & correct behaviour for that instrument. Two common examples of this are: 1: Programmer instruments, where segment variables change their availability depending on segment type. 2: Instruments where optional hardware is not present, for example output boards not fitted, or auxilliary inputs not configured/ fitted. Please see the instrument manual for which variables may or may not be available under these circumstances.
- Is this an intermittent failure?
- What is the value of the variables: SpecView.CommsErrors, SpecView.GoodComms, SpecView.CommsErrorCode, Specview.CommsErrorDescription & SpecView.CommsErrorItem? These variables can be added to a GDW and/or logged. To Log these variables, use 'Database->Show Logging in Variables List' from the Setup menu and check the boxes next to these variables in the Variables List, then from Runtime mode use Convert Log File from the Logging menu to create a Log File Convert Format which contains these variables. Note that the variables will not be listed in the Log Format Setup box until they have been logged according to the rate defined in Preferences - Logging or from the action Logging: On/Off.
- Has the wiring between the instrument & the PC been checked and tested?
- Has anything been altered or added to either hardware or software?
- Has SpecView's Address Help for the instrument been checked? To view this go into Edit mode, use the Variables List tool, select the instrument's name and click the Properties button, then click Address Help.
- Has SpecView's Online Technical Notes been checked for this instrument type? Access www.specview.com then click Download and click FTP-site and open the TechNotes folder.

Using the Line Writer to troubleshoot comms problems:
This will create a file which lists the date, time & cause of any comms errors. (This will be a file separate to SpecView's standard Log Files or Log File Reports).

To do this create a Strategy Controller value based event: 'When CommsErrors changes' that watches SpecView.CommsErrors and when it changes does the action SpecView: Write Line to file/printer of:

```
```

It is also a good idea to remove the commas from the date format in Preferences - Display to prevent these commas from adding unnecessary columns to the CSV file.

Using SpecView's Driver Debug:
If all the above has been thoroughly checked then the next step is to send your SpecView representative Debug files.
These debug file(s) need to be as small as possible, at the same time as being as relevant as possible. The extra effort taken to create these will be much appreciated by your SpecView representative and will enable them to give you an answer promptly.

Therefore the aim is to have a minimal Project (by using the New Manual Project button) with just a single GDW displaying just one of the instrument variables which is causing trouble.

Alternatively, create a new GDW in an existing Project, and put just one of the variables which is
causing trouble out on to it. Then using File->Preferences disable Logging (on the Logging tab), disable Alarms (on the Alarms tab) and Strategy (on the Strategy tab). Ensure that none of your other GDWs have File->Auto-open on Runtime enabled. (NB: Once the problem has been resolved these changes will need to be reversed).

To create the Debug file(s) follow the steps below:

If your instrument is NOT using the Modbus (or Modbus TCP/IP) protocol then use:

\[ \text{DEBUG} = 1 \]

Note: Not all drivers support \text{DEBUG} = 1, in which case you will see the error: 'Driver commands not accepted' if this occurs please contact your SpecView representative.

If your instrument is using the Modbus (or Modbus TCP/IP) protocol then use:

\[
\begin{align*}
\text{DEBUG} & = 15 \\
\text{DEBUGSIZE} & = 1 \\
\text{DEBUGAUTODEL} & = 9
\end{align*}
\]

(This will create up to nine 1Mb files)

To set these up:

From SpecView's Runtime mode use the Setup COM Port menu command from the Options menu, click the appropriate tab for the port being used.

In the bottom-left-hand box enter DEBUG, then in the next box enter either 1 or 15 appropriately, then click the Add button:

The Driver Commands box will now show the value for DEBUG.

Then (if required) do the same for: DEBUGSIZE = 1 and DEBUGAUTODEL = 9

Then wait for at least one minute, but no more than three minutes, then Exit SpecView

In your Project's folder under SpecView's installation folder (usually C:\SV3) you should now find some .TXT files where the names start with 'debug', for example: debug_COM1.txt

© 1995 - 2015 SpecView
Email these file(s) to your SpecView representative. You will also need to email an SVA (SpecView Archive) of your Project. To do this use SpecView's Archive button (which is on the Projects Found box when SpecView starts up). Ideally this should be done with the 'Include log files' checkbox unchecked.

Remember to set Debug back to zero afterwards.

16.2 Cannot Open COM Port

There are many reasons why this error can occur:

Firstly, from SpecView's Edit mode open the Variables List and check the Properties of the instrument to see which COM port(s) SpecView is using to communicate with the instrument(s):
Then use the Windows Control Panel Device Manager to check the status of the COM port:
Use HyperTerminal to test the COM port.

If there are many instruments using the wrong COM port then use 'Swap COM ports' from the Setup menu to change which port SpecView is using to communicate with the instrument(s).

Note that if the instrument(s) are connected to a COM port which has a number above 9 then it will be necessary to set MaxPorts.

### 16.3 HyperTerminal

How to use HyperTerminal to test if the COM port that the instrument(s) are connected to is functioning correctly:

HyperTerminal may already be installed, however it isn't available by default on Windows 7. To download this very useful tool:

Google for: Windows 7 Hyperterminal
Alternatives include 'putty'

Once downloaded, run HyperTerminal from the Start button: Programs menu (or it may be under the Accessories - Communications sub-menus).

From HyperTerminal's 'Connection Description' dialog enter any name & choose any icon, then click OK.

On the 'Connect To' dialog - to test, for example, COM1 then select 'Direct to Com1' from the 'Connect using' list box, and click OK, then click OK on the 'COM1 Properties' dialog leaving the 'Bits per second' and the other settings as they are.
If the status bar along the bottom of the window now says ‘Connected 00:00:00’ and starts counting up in
seconds, then COM1 is OK. Otherwise an error dialog will be displayed. If HyperTerminal cannot
connect to the COM port, then SpecView will also be unable to communicate with it.

16.4 Telnet

Use the Windows utility 'telnet' to check if it will be possible for SpecView to connect to an instrument
on a given IP address over TCP.

Note: On Windows 7 the 'telnet' client utility program is not available by default. Administrator privileges will be required to enable it.
Go to the Windows Control Panel 'Programs and Features' to enable it. Click 'Turn Windows Features on or off' (on the panel on the left of this box).
When the list is displayed enable (tick) 'Telnet Client'.

This is an example of testing the connection to a an instrument at IP address: 192.168.200.102
using port 502:

First ensure that SpecView is NOT running because it is not possible to have both telnet and SpecView
connected at the same time.

Open a 'Command Prompt' window, then enter: (Note that there is a just a space between the IP
address and the '502' port number)

telnet 192.168.200.201 502

If this gives an error then there is a problem with the network, in which case try:

ping 192.168.200.102

The 'ping' utility just checks if an address exists (so it doesn't need the port number), whereas 'telnet'
actually connects, which is more useful when troubleshooting.

If 'ping' works, but telnet doesn't then possibly the instrument isn't answering on port 502 (Port 502 is
the default port for Modbus instruments over TCP) in which case check the port settings on the
instrument.

If 'telnet' gives a blank screen with a flashing prompt, then it has connected successfully.
Press CTRL+] to get a ‘>’ prompt, then to close telnet type: quit

If telnet connected successfully, then once telnet has closed (it is not possible to have both telnet and
SpecView connected at the same time) then SpecView should be able to connect. If not then please
contact a SpecView representative.

16.5 Reporting Bugs

To report an issue with this release of SpecView please email bug reports to V3bugs@specview.com
detailing:

Name: 
Company Name: 

© 1995 - 2015 SpecView
Email: 
SpecView Version & Build number: 
SpecView Dongle Serial Number: 
Microsoft Windows Version: 
Using SpecView 32bit or 64bit: 
Error Message: Was an error message displayed and if so what was it? 
Reproducible: Does the problem reoccur? 
Configuration/Project Name: Please also if possible email an Archive of the configuration. 
Instruments: Please give manufacturer, model(s), COM port(s) and address(es). 
Runtime/Edit Mode: Did the problem occur in Runtime or Edit Mode? 
Crash: Did it crash? If so, when & what was the module and version that it crashed in? 
Comments: Please give full details of the problem, ideally with screenshots. 
Priority: High/Medium/Low

If a more serious problem occurs, such as a crash or hang, then please generate a dump file and send it to SpecView.

16.6 Generating Dump Files

If a more serious problem occurs, such as a crash or hang, then it is possible to generate a DUMP file that can be sent to SpecView for analysis to help investigate the problem.

Using PROCdump

There is a utility available from Microsoft called PROCdump.EXE

This is included the SpecView Version 3 and will be in the C:\SV3 folder. It can be run automatically each time SpecView is run from Preferences Debug. Note: In some versions of Windows Procdump will generate a dump file each time the File->Open box is displayed, this is a known Windows problem and can be ignored.

Ensure the PROCdump.EXE file is in your main SpecView folder, this is usually C:\SV32 for Version 2.5, or C:\SV3 for Version 3.

Here is the recommended way of using it:

Either before SpecView is running, or after you have started SpecView:

Start a Command Prompt, then type one of these commands:

**For Version 3 of SpecView:**
```
CD \SV3 (or wherever you have installed SV3)
PROCdump -E 1 -H -MP -N 10 -W SV3
```

**For Version 2.5 of SpecView:**
```
CD \SV32 (or wherever you have installed SV32)
PROCdump -E 1 -H -MP -N 10 -W SV32
```
You can put this into a Batch (.BAT) file to save typing this every time.

The resulting dump file is typically named: SV3_Date_Time_.DMP

Please then ZIP the DMP file to make it much smaller and eMail it us, or use a file exchange service such as Dropbox to allow us to collect it. Please also email these details.

Creating DUMP (.dmp) files using TaskManager

This is not recommended - please use Procdump as described above.

If an error message appears saying that a crash has occurred, immediately open the TaskManager and click the Processes tab, find either SV3_32.exe or SV_64.exe in the list and right-click on it and choose Create DMP File from the popup menu.

However, it is difficult for us to debug a 64-bit DMP file from a 32-bit SpecView running on a 64-bit system.

Therefore, if you are running SpecView 32bit on a 64bit system (because of ActiveX), then it is necessary to run a 32bit version of the TaskManager to create a DMP file. The 32bit TaskManager is located in C:\Windows\SysWOW64 folder and the name of the file is taskmgr.exe

Note: Be careful, because if the normal 64bit TaskManager is running, then starting the 32bit one from the \WINDOWS\WOW64 folder will appear to work, but it will just bring the 64bit TaskManager to the front. It is possible to check which one is running from the TaskManager Processes list because 'taskmgr.exe' will have *32 after it for the 32bit version, or nothing after it for the 64bit version.

16.7 Technical Support

If you encounter a problem with SpecView, in the first instance please contact your SpecView distributor.

The latest version of SpecView can be downloaded free-of-charge from our website http://www.specview.com for 2 years from the date of purchase. However, if SpecView was originally purchased over 2 years ago, then there will be a charge for the update. Please contact your SpecView supplier.

Please also check the Frequently Asked Questions section of this Help.

However, if you need to contact SpecView's Technical Support then use one of the following:
- Electronic Support e-mail and Internet
- Telephone Support in The Americas and the Far East
- Telephone support in the UK
- Telephone support in Europe and the rest of the World
Please quote the version number of SpecView that you are using, this can be found by using the About SpecView menu command on the Help menu. Please give both the version number & the 3-digit build number.

If you have purchased SpecView, then please also give the Serial Number of your dongle. The Serial Number can be found either on the printed label attached to the dongle, or by using the Registration Information menu command on the Help menu.

If you have problems with a specific Project, it is most helpful if the entire problem Project folder is saved to a single file and attached to an e-mail message. This can be done using the Archive/Restore button. This will allow our Technical Support team to run exactly what you are running.

You may also be asked to click the Technical Information button on the About SpecView box (by using the About SpecView menu command on the Help menu) to provide further details on your specific installation.

16.7.1 USA Contact Numbers

Telephone: (253) 853-3199
Fax: (253) 853-3801
If dialing from outside the USA and Canada, the country code is (+1)
Time zone: PST (GMT -8 Hours)

16.7.2 UK Contact Numbers

Telephone: (01825) 766 566
Fax: (01825) 766 966
Time zone: GMT

16.7.3 Europe Contact Numbers

Telephone: (+44) 1825 766 566
Fax: (+44) 1825 766 966
Time zone: GMT

16.7.4 Internet Support

Sales and application information: sales@specview.com
Technical Support: support@specview.com
World Wide Web page: http://www.specview.com

Remote Support
If your computer is connected to the Internet, then we can quickly and easily help you with SpecView Technical Support issues, by taking control of your computer using SpecView Remote Support. Only run this application when instructed by SpecView's Technical Support staff.
This is totally secure (see below), requires no installation or configuration by you or your IT department, and will allow us to help you in the quickest possible way.

When instructed by SpecView's Technical Support staff, run the Remote Support application from the Help menu:
And tell us the ID and Password. We will then be able to take control of your computer, so you can sit back & watch what we do, whilst discussing the problem by phone to reach a quick resolution.

Security
The SpecView QuickSupport application is completely secure because:
- It is only active when you run it - no files are installed on your computer that would allow anyone else to get in without your knowledge.
- The ID is unique to your PC.
- The password is valid for this session only, and will be different the next time you run the program.
- The TeamViewer System is managed by secure encrypted servers owned by the TeamViewer company.

Read more from TeamViewer’s website: www.teamviewer.com and their security statement here: www.teamviewer.com/products/security.aspx
Top Level Intro

This page is printed before a new top-level chapter starts

Part XVI
17 Quick Start Guide

This Quick Start Guide covers the installation and initial configuration of SpecView as a step-by-step guide to the most frequently used features of SpecView:

Quick Start:
- Quick Start - Overview
- Quick Start - Starting SpecView
- Quick Start - Manual Project
- Quick Start - For Instruments using the Modbus Protocol
- Quick Start - Automatically detect instruments and display instrument views
- Quick Start - Add a variable to the GDW
- Quick Start - Draw a trend chart
- Quick Start - Define a second GDW
- Quick Start - Add buttons to switch between GDW's
- Quick Start - Add a Bar chart
- Quick Start - See how it works in Runtime mode

17.1 Quick Start - Overview

This Quick Start Guide covers the installation and initial configuration of SpecView.

When the computer is connected to an instrument via a serial port (RS232/RS485/RS422/USB) or by Ethernet (TCP/IP), SpecView gets data from and can send data to the instrument. Unlike conventional SCADA (Supervisory Control and Data Acquisition) software, where each data point has to be defined by the user, SpecView has a pre-built database of hundreds of instruments. Most instruments, if already connected to the computer, can be Automatically Detected by SpecView. If the instrument is not connected to the computer, or if that instrument does not support the auto-detection feature, the user selects it from a list. In SpecView this is called Manually Defining Instruments.

Below is a step-by-step guide to the most frequently used features of SpecView:

Once all the steps below have been followed, the screen should look similar to this:
**Note:** The **Instrument View** (the Zone1 box at the top left) will depend on the specific instrument being used.

The steps are as follows:

1. Installing SpecView
2. Starting SpecView

**If there are Instrument(s) connected, then follow:**

3. Automatically detecting instruments and displaying Instrument Views

**Or, if there are no instrument(s) currently connected to the computer then follow:**

4. Manual Definition

**and continuing:**

5. Add a variable to a screen, known as a GDW (Graphical Display Window)
6. Draw a Trend Chart
7. Define a second GDW
8. Add buttons to switch between GDW's
9. Add a Bar chart to a GDW
10. See how it works in Runtime Mode
Once installed, follow through these steps by first clicking the link: Starting SpecView.

When running SpecView there are numerous 'Help' buttons that will open a relevant topic in the Help, or press the F1 key at any time.

**Note:** SpecView's name for each screen is a GDW (Graphical Display Window).
Each GDW is saved as a file on disk with a filename extension of .GD3 (similar to a Word document having a filename extension of .doc).
From SpecView version 2.5 build 820 (dated 2006), these GDW files have changed their filename extension to .GD3.
However, a GDW (or GD3) file is not a standalone file and must be accompanied by all the other files within its Project folder.
An easy way to keep them together when backing-up is to use SpecView's Archive.

## 17.2 Quick Start - Starting SpecView

Once SpecView is installed, double-click the SpecView icon or click Start and select SpecView from the Programs menu.

**Note:** For further information on the 32-bit and 64-bit versions of SpecView see: 32bit and 64bit SpecView

Select your language:

If SpecView is started with a dongle connected this box is displayed:
Click the Select/Create Project button to open the Projects box, see below:

If there is an instrument connected, click the Test Comms For New Project button to Automatically detect instruments and then enter an appropriate name for the new Project.

If there is no instrument connected SpecView can still be configured by clicking the New Manual Project button which goes to Manual Project.
If SpecView was started without a dongle connected there will be limited functionality, in this case click the Demo button to open the Projects box, as shown above.

17.3 Quick Start - Manual Project

If you have no instrument connected clicking on New Manual Project will display the Input Required box
Enter a name for the project. SpecView will create a sub-folder with this name in the SpecView folder (which is normally C:\SV3). The name you enter should follow the Windows file naming rules and should not be too long.

Remember this name. This folder will be where all log files and project files will be stored. Log Reports will also be stored here unless another folder is specified.

When a name has been entered click **OK** and this will immediately go into Edit Mode displaying a blank Graphical Display Window (GDW) grid.

Click the Variables List tool on the Toolbar to display the Variables List. At this stage the only item listed will be SpecView.

*Note: When using the Toolbar, move the pointer over a tool and the Tool Tip will say what it does.*

Click the Templates tool on the Toolbar to display the Templates List, which will list the pre-defined instrument types:
Scroll down the list of available instruments to find the name of the instrument that is intended to be connected.
Click the symbol beside the instrument to display the specific instrument types. Select the appropriate one, then click **Create Inst.**
Choose the **COM Port** from the list (for example COM1) and enter the **Slave Address** for the instrument together with the address **Offset** if needed and the number of **Decimal Places** that the values will need to show.

(To add instruments at COM ports greater than COM9 see setting **MaxPorts**)

**Extra:** This is only used by instruments like the Honeywell HC900 to access the the SPP block's **Profile Descriptor Fields**.

For help click the **Help for Address or Instrument** button.

For more information on Modbus addressing: [Modbus instrument addressing](#)

The instrument can be added to a group which allows a number of instruments that are being used for a specific purpose to be kept together in a logical way. For example, a furnace, warehouse, etc.

Enter the **Baud Rate** and **Parity** appropriate for the instrument and click **OK**.

Please consult the instrument manufacturer's manual for more information.

**Note:** To test if the COM port that your instrument(s) are connected to is **functioning correctly**.
The instrument has now been defined within SpecView and will be listed in the Variables List. If the instrument has a large number of parameters, such as a multi-loop controller, then the parameters will be divided into a number of ‘logical instruments’ called Instrument Views.

For example, an 8-loop controller could have an Instrument View containing the parameters for the controller itself in addition to 8 Instrument Views containing the parameters for each of the loops.

The instrument View can itself be dragged out onto the GDW:

Parameters can be dragged out onto the GDW individually:

Or a number of parameters can be multi-selected and dragged out. If using multi-select then the parameters will have additional ‘handles’ around them, which can be used to spread them out.

This is now configured as if the instrument was already connected and you had clicked the Test Comms for New Project button to automatically detect the instrument. Therefore you can now skip the next section, and go straight to Edit Mode, starting with Add a variable to the GDW.
17.4 Quick Start - For Instruments using the Modbus Protocol

If the instrument you are using uses Modbus protocol you need to know how the instrument is configured.
If there is a choice between Modbus or J-Bus protocol choose J-BUS.
If there is a choice for Data Bits choose 8 (EIGHT).
If there is a choice for Parity choose NONE.
If there is a choice for Stop Bits choose 1 (ONE).
The format of the address specification for Modbus is:

\[ AA,PT;O \]

Where:
- **AA**: Two-digit address of the instrument in decimal.
- **P**: Number of decimal places for user defined items (see Note 1 below).
- **T**: Type of protocol: J for J-Bus, M for Modbus (see Note 2 below).
- **O**: (Optional) Address offset (see Note 3 below).

Examples:
- **1,1J**: Address 1, 0 decimal place, J-Bus parameters
- **2,1J;2**: Address 2, 1 decimal place, J-Bus parameters, offset by 2
- **10,0M**: 0 Decimals, Modbus parameters

**Note 1 (Decimal Places):**
0 / 1 / 2 / 3 SpecView will put a decimal place in the position indicated by this setting. The setting affects those variables where the number of decimals required is based on an instrument setting such as the range that has been selected. Some items, such as Output Power are fixed at a given number of decimal places and are not affected by this setting. AutoDetect may assume 0 decimal places when detecting instruments. This might result in values being 10 or 100 times too large on displays. If this is the case, then edit the address for the instruments from AA,0T to AA,1T (See below for the meaning of this).

**Note 2 (Protocol):**
If in ANY doubt, do not enter anything for this item. SpecView will add it for you. There is often confusion between Modbus 'Registers' and 'Addresses'. With SpecView the user does not need to fully understand the difference but the correct setting MUST be made here. When 'J' (for J-Bus) is used the 'Address' that has been pre-defined by SpecView is sent to the instrument. When 'M' (for Modbus) is used ONE is subtracted from the pre-defined address. SpecView pre-defined instruments ALWAYS assume the address and NEVER the register. Unless advised otherwise by SpecView either leave the letter out or use 'J'.

**Note 3 (Address Offset):**
Some instrument companies use an address structure so that a particular instrument view can be reused with the appropriate address offset. This feature is also used with SpecView's 'Generic Modbus' instrument views. The addresses for each instance of the instrument are the same, offset by a fixed number. See Generic Modbus for more details. Also, where this feature is required for a specific instrument, refer to the help for that instrument.

The rate at which the Modbus driver will supply the values of variables from the instruments is defined by the **driver command** WTTL (default=19 tenths of a second). This can be set using the Setup COM Ports menu command on the Setup menu.

For Instruments using Modbus TCP/IP
The address, as detailed above, is prefixed with the full IP address followed by a comma. For example: 192.168.1.99,1,2J

17.5 Quick Start - Automatically detect instruments and display instrument views

Click the button, to detect the connected instruments automatically.

The Input Required box is displayed:

Enter an appropriate name for the project. SpecView will create a sub-folder with this name in the SpecView folder (which is normally C:\SV3), the name you enter should follow the Windows file naming rules and should not be too long.

Remember this name. This folder will be where all the log files and project files will be stored. Log Reports will also be stored here unless another folder is specified.

When a name has been entered for the project, click OK, then the Ports and Protocols box is displayed:
Ports and Protocol
You will need to know which COM port(s) on your computer the instrument(s) are connected to and the type(s) of the instrument(s). If in doubt about this please consult your instrument manufacturer's manual.

For the appropriate COM port(s) select the type(s) of the instrument(s) under Protocol. When you select a protocol for a COM port, a Help button is displayed on the same line. Click it for help on the driver selected.

If the default port settings do not match the settings for your instruments, click to set up the port.

BAUD Rate
If there is any uncertainty as to the BAUD rate used by the instrument then leave it set to 'Auto' to allow SpecView to try a range of BAUD rates. If the BAUD rate is known then set it appropriately.

TCP/IP
There is also TCP/IP Auto Detection available for some instrument types.

Start Scan
Click **Start Scan** SpecView will begin to scan the ports and determine what instrument(s) you have connected. As each instrument is found this box is displayed:

![New Instrument Name for MMTCPSTC TCP/IP Addr:1](image)

This allows the name for each instrument to be assigned (or use the default names), specify the **decimal places** and if required assign to a **group**.

Instrument Views (which are typically pictures of the front panel of the instruments) will be displayed on the Graphical Display Window (GDW) behind the Ports and Protocols box. When all your instruments have been auto-detected for this port, if there are further instruments connected to other COM ports then click **Skip to Next Port**, otherwise if there are no further instruments click **Stop**. A window will be displayed to say that all channels have been scanned:

![SpecView -](image)

Click OK to continue and enter Edit Mode.

The Edit Mode screen will look something like that shown below.

However, if no Instrument View(s) appear then SpecView is not communicating with the instrument(s). Check your connections and settings and rescan. If problems persist first read **Troubleshooting** then if unresolved contact your instrument supplier.
You have now created a GDW containing Instrument Views.

The actual Instrument View displayed will depend on the instrument type, other examples of Instrument Views are shown below:

Instrument Views can be repositioned on the GDW by clicking and dragging.

Click the Save tool and then the Save button to save this GDW as SPECVIEW1.GD3 in the project sub-folder.

For the next step read: Add a variable to the GDW

### 17.6 Quick Start - Add a variable to the GDW

To add a variable to the GDW (Graphical Display Window) or GD3 click the Variables List tool to display a list of the instruments that SpecView has detected.
The name SV also appears in the list as this represents a list of pre-defined variables that are associated with SpecView.

There is also a list of User Variables.

Click the symbol next to an instrument name to see all the parameters.

Click and drag a parameter, or multi-select and drag and spread out a number of parameters out onto the GDW.

The name of the variable will also be displayed on the GDW together with the value of the variable itself. *This is assuming that Include Instrument and/or Parameter Name is selected on the Variable List's Options Menu:*
Note: If the value of the variable(s) are shown as N/R then first go to the Online Features menu and check it is Online then if unresolved go to Troubleshooting.

When the name of the variable and its value are initially put onto the GDW, they are put out as two separate items. In order to move them both together (as a pair) to a different position on the screen they will need to be grouped together.

To do this use the Group tool (or press G) which will group them together:

Use the mouse to drag into position on the GDW. To position on the screen exactly use the cursor keys to nudge by one pixel.

Dragging an object on the screen using the mouse, or holding the SHIFT key down while using the cursor keys, will make the object jump by one grid increment, whichever grid size is active at the time. The position of the object relative to the grid will be preserved.

The grid sizes are specified using Set Grid Sizes on the View menu and the grid size to be used is selected by choosing Toggle Grid Lines from the View menu or pressing CTRL-G to cycle through them.

To align an object with the grid use Object->Align->Realign To Grid.

Remember to Ungroup them afterwards using (or press U).

To change the name of a variable, it is best to do this from the Variables List BEFORE putting the variable onto the GDW. This is done by right-clicking and choosing Properties from the popup menu.

More information on variables see the Variables List.
In order to change, for example, the font or color of a variable or its name, use the Ungroup tool (or press U) to ungroup the variable and its name, then double-click the name to display the Text Attributes box:

Click the Choose Font button to choose an alternative font or font color.

Note: To change the default text font use the Text Font menu command from the Object menu.

Click the Save tool and then Save to save this GDW again.

Click the Runtime tool to enter Runtime Mode.

Alarms List box may be displayed if there is an alarm active on the instrument, close it by clicking the Close button.

NOTE: The obvious differences between Edit Mode and Runtime Mode are that Edit Mode displays a grid across the screen (GDW). Although it is possible to disable the grid (Using Toggle Grid Lines from the View menu) this is not recommended as the grid helps with aligning items when positioning them. There are also significant differences between the contents of the menus in the two modes. Edit Mode also has a toolbar. It is best to use Edit Mode only when setting up SpecView or changing screen layouts, and go into Runtime Mode once this is done. This prevents any accidental changes being made. Edit mode can also be Online depending on the settings on the Online Features Menu.

For the next step read: Draw a Trend Chart
17.7 Quick Start - Draw a trend chart

Go back to Edit Mode by selecting Edit Mode (either Edit Mode (remain online) or Edit Mode (go offline)) from the File menu.

Click the Draw Trend Chart tool and the cursor changes to:

Click and drag on the GDW to draw a rectangle. When you release the mouse button a Trend chart is drawn.
and the Trend Chart Properties box is displayed. Click the Add button to display the Pen Properties and the Variables List boxes:
This is used to choose which parameters are displayed on the Trend chart and the appearance of the chart, colors etc.

From the Variables List expand the list of parameters for the instrument from which you wish to display data by clicking the symbol if it is not already open.

Initially the Pens list (on the Pens tab) is blank, drag parameters from the Variables List either directly into the Pens List, or into the Pens Properties box.

The scales and pen colors will be automatically defined. Other attributes of the pens can be changed using the Pen Properties box.

Note: A Pen is the word used to refer to a single trace line on a Trend chart.

The Time Span of the chart can be set on the Chart tab. The Time span can range from 30 seconds to 60 days.

Add some more pens to the chart, then click OK to close the Trend Chart Properties box.

Click the Save tool to save this GDW again.

To subsequently edit the chart while in Edit Mode, click anywhere on the chart and choose Setup Chart from the popup menu.
More information on setting up Trend Charts

For the next step read: Define a second GDW

17.8 Quick Start - Define a second GDW

The first GDW (Graphical Display Window) has already been saved.

Now click the New GDW tool to get a new blank GDW.

Click the Trend Chart tool and draw another chart onto this new GDW. Any variables may be used for the pens, even the same ones as before.

Also, many types of variable can be plotted on a Trend chart, including boolean (On/Off functions).

Click the Save tool and give this new GDW a name so it can be saved.

Note: When SpecView enters Runtime Mode it will normally start by opening the GDW last edited. To specify which GDW is opened on Runtime use the Set As First GDW menu command from the File menu while in Edit Mode.
To open more than one GDW at startup use the Auto-open on Runtime menu command. It is important that this feature is used for all GDW’s that contain Trend Charts in order to start their trace lines when SpecView starts.

For the next step read: Add buttons to switch between GDW's

17.9 Quick Start - Add buttons to switch between GDW's

To put a button on the GDW click the Draw Buttons tool.

Draw the button by clicking and dragging the mouse until the button is the size and shape you require.

Position the button using the mouse or cursor keys as described previously.

Double-click the button to display the Button Attributes box:
Change the text in the **Caption** box to say, for example, 'Return to first screen'.

Then from the **Action** list, select **GDW: Swap to another GDW**, then select the name from the **Swap To** list that you gave to the first GDW:

Click **OK** to close the Button Attributes box, then click the Save tool to save this new GDW again.

Open the first GDW by either
clicking the Open GDW tool and then selecting the name of the GDW from the list and clicking OK, or by selecting the name of the GDW from the Window menu.

Click the Draw Buttons tool and draw a button on this GDW as before, double-click this button and change its attributes.
Change the Caption to say, for example, 'Go to second screen'.
From the Action list, select GDW Control: Swap to another GDW, then select from the Swap To list the name that you gave to the second GDW, click OK.

Click the Save tool to save again.

For the next step read: Add a Bar chart

17.10 Quick Start - Add a Bar chart

Adding a Bar chart to a GDW is very similar to adding a Trend chart.

Click the Draw Bar Chart tool and the cursor changes to
Click and drag on the GDW to draw a rectangle as shown below. When the mouse button is released a Bar chart is drawn on the GDW.

The Bar Chart Setup box and Variables List are also displayed:
This is used to choose the variable to be displayed on the Bar chart and the appearance of it. Select the variable to be displayed from the Variables List by clicking the symbol next to the name of the instrument, if it is not already open. Drag and drop the variable from the Variables List into the Variable field in the Bar Chart Setup box.

Orientation defines how the value is displayed within the bar chart; Vertical for up/down, Horizontal for left/right.

Enter a Top Value (such as 100) and a Bottom Value (such as 0). Choose the color of the bar, and whether the bar should grow from the bottom up, from the top down, or both up and down. In the Scales section of the box choose whether to display a scale for the Bar chart and whether or not to show the value numerically within the bar.

Once all the changes are made click OK and then click the Save tool again.

See how it works in Runtime Mode
17.11 Quick Start - See how it works in Runtime mode

Click the Enter Runtime tool to see the project you have just set up working in Runtime Mode.

The GDW screen should now look similar to this:

The Instrument View, variable, Trend chart and Bar chart on the first screen of the GDW will be displaying data (if not, see Troubleshooting).

Clicking on the button(s) shown within the Instrument View(s), in this example the PAR button, should perform similar actions to clicking on the respective buttons on the front panel of the actual instruments themselves.

Clicking on the value of the variable, in this case 26.1:

Zone1.Input 1: 26.1
could, if the variable was writeable, allow this value to be changed. However, as the variable 'Input 1' is not a writeable variable this is not possible in this example.

The Trend chart lines will initially be invisible. However, after a few moments the lines will start to be
drawn depending on the time-span that was specified for the Trend chart when it was created.

If the Setup button and/or Help button were enabled on the Buttons & View tab then:
  Clicking on the Setup button in the top right-hand corner of the Trend chart allows the Trend Chart to be modified from Runtime mode.
  Clicking on the Help button will display help for the Trend chart attributes.

Clicking on any of the Pen labels along the top of the Trend chart switches the vertical scale to match the scale that you defined for that Pen.

Clicking on the **Go to second screen** button will switch to the other GDW which you defined, which may look similar to this:

CONGRATULATIONS! You have just created your own custom multi-screen supervisory system in just a few minutes.

Remember to make a backup of the project using SpecView’s Archive/Restore facility.
Now explore the Data Logging and (optional) Historical Replay features. Then you can go back into Edit Mode and explore the custom Graphics, Recipes, Networking and other features of SpecView.
Top Level Intro

This page is printed before a new top-level chapter starts
18 User Guide

The User Guide explains how to configure a SpecView project to fulfill tasks that are frequently required and to provide links into other relevant topics within the help.

If there is a requirement for further help then please contact SpecView Technical Support.

18.1 Setting up a Project

Here are the basic steps in setting up SpecView. The order can be changed to some degree and each step can be edited at any time.
Firstly, you will need to select either Manual or Automatic Instrument Detection:
1a. Manual Definition of instrument(s):
   This is only required in the following cases:
   • If the instrument(s) are not physically connected to the computer for auto detection
   • If the instrument(s) are special such that they cannot be auto detected
   • If the instrument(s) are being added to an existing project
   Define the instruments you are going to be using by clicking the Show New button to display the full list of available variables

Or:
1b. Auto Instrument Detection

Then:
2. Add/Rename Instruments
   Edit the names of each instrument if required.
3. Create your GDW(s)
   Define any SpecView User Variables required
   Create / Import any graphics
   Add Buttons to the GDW’s to switch between them
   Put numeric values on the GDW
   Add Trend and Bar Charts
4. Put the four SpecView pre-defined variables for Comms on a screen to show the status of instrument communication.
5. Add or remove any variables from Data Logging
6. Choose variables to be included in Recipe
7. Configure the (optional) Strategy Controller

18.2 Creating Graphics/Mimics

Graphics and Mimics can be created in SpecView using a number of methods:
Photo/Image:
Take a photo or scan a picture or draw a digital image and convert the JPG file into a BMP file using any image processing software, or use Microsoft Paint and use 'Save As' to save it as a BMP file. It is an idea to grey-out the image to reduce its contrast. It is also a good idea to resize the image smaller so that it is nearer the correct size. This avoids making the project slow to open and will also save disk space when Archiving the project.

Then use SpecView's Bitmap tool to display the bitmap. Double-click the bitmap and uncheck the 'Fix to Original Size' checkbox so it can be resized to exactly the size required.

Values, buttons, barcharts, etc. can be put on top of it for easy visual feedback. If the bitmap seems to be 'on top' of the values then select the bitmap and choose 'Move to Back' from the Object menu.
GDO (Graphical Display Objects):
Graphics made with SpecView's drawing tools can be grouped and saved as GDO's using the Save Object menu command on the Object menu. The saved GDO's can be re-used (using the Load Object menu command) any number of times in any GDW in any copy of SpecView.

Color Dynamics:
Color Dynamics can be used to change the color of objects and text on the screen according to the value(s) of variables(s).

Position Dynamics:
Position Dynamics allow objects on the screen to be positioned (moved) according to the value(s) of variables(s). This allows a basic form of animation, such as a showing something moving along a conveyor belt.

ActiveX:
ActiveX controls to represent the appearance and functionality of components and HMI elements can be purchased from various third-party developers and be displayed on SpecView's screens (GDWs).
18.3 Improving Performance

To improve performance so that the rate that instrument variables are updated is increased see here.

18.4 Remembering Window Positions

It is possible to make SpecView remember positions of windows - this is particularly useful when using very large monitors or multiple monitors.

Limitations
SpecView's screens (also known as GDWs or GD3s) are not independent windows, so they can't be positioned outside the main screen.

A screen's position will only be stored when that screen is closed, or SpecView is exited.

Therefore, it is necessary to ensure that the main screen (in other words the screen that has 'File- >Set As First GDW' set) is made large, by dragging it out.
Then open each of the screens and position them as required, then exit SpecView.
So the next time SpecView is run it will have remembered the last positions of each of the screens.

Method
Use a program like Notepad to edit the file:  SV32.INI
Which is in the folder that SpecView was installed in (usually: C:\SV32\)

Then go to the [WindowPos] section of this file and add the line:
RememberWindowPositions=1
And also remove the line starting   SV=    with the coordinates of its last position.
Go to the [SETTINGS] section and change the line:
StartMaximized=Yes  so it says:    StartMaximized=No

(With exact spelling and no spaces, the uppercase letters are important)

The size and position of the main screen is stored in SV32.INI, the size of the individual windows is stored in: C:\SV32\<YourConfig>\SETTINGS.INI
Uses

The ‘remembering’ of window positions is particularly useful when using multiple monitors on a single computer in order that certain windows (GDWs) will subsequently appear on a particular monitor.

To do this:
- Windows Control Panel – Display – Multiple displays – Extend displays (not duplicate)
- Position the windows while in Runtime Mode and close each of them (then re-open to check position saved)

  Note that the positions of windows are only remembered when the window is closed (not when SpecView exits)
- It is necessary to have a dongle attached (not just run in ‘Demo’ mode)
- Highly recommended to enable passwords and check ‘Disable Window Controls’ for Operators (so they can’t accidentally click them).

Note: An alternative to this for positioning GDWs on multiple monitors is to use SpecView Remote and run both SpecView Local and SpecView Remote(s) on the same computer. Where the Local runs on one screen and the Remote(s) on the other(s). However, in this case each time SpecView is run the SpecView main screen will need to be repositioned. Note also that SpecView Local needs to be started first and the Remotes started afterwards.
18.5 Sending an email from SpecView

It is possible to setup SpecView's Strategy Controller to send email(s) when a certain condition occurs, such as an alarm. There are 2 ways to do this:

1. There is a program that can be downloaded free-of-charge called 'Blat' (see: www.blat.net )
   It uses the SMTP protocol to send emails, and it has a simple command-line interface which can be used by SpecView.
   First download this and read the associated help file. Put the text of the email to be sent into a file, called for example: test.txt
   Then:
   Create a SpecView Text User Variable called, for example 'Subject'
   And use the Button/Strategy action: 'SpecView: Run External Program'
   To run the command:
   blat.exe test.txt -subject "%%SpecView.Subject%%" -to user@domain.com
   Where both blat.exe and test.txt are in the Project's subfolder (C:\SV3\<project >\)
   Or alternatively include their full pathnames.
   Once this is working correctly, then it is possible to use SpecView's Strategy Controller to send an email automatically, for example, when an alarm occurs.

   Note: Sending an email using blat from a 'gmail' (Google Mail) account involves the use of stunnel – if this is needed or if there are any other questions then please contact SpecView Technical Support for more details.

2. Using the ActiveX control AddEmail which is available from www.traysoft.com. Please contact SpecView's Technical Support for further help.

18.6 Sending an SMS text message from SpecView

Please be aware that due to the mobile phone network text messages are not guaranteed to arrive in a timely manner and therefore should not be used in time critical situations.

Using 'blat' and a text messaging service

It is possible to send text messages using 'blat' to email an email address that will then send a text to that mobile number (such as: www.world-text.com)
For example:
   blat.exe - -body "%%SpecView.EmailMessage%%" -subject "Routine Maintenance Due" -to 07777123456@sms.world-text.com

It is necessary to have setup an account with www.world-text.com to send emails to a mobile number.

Using 2sms

It is also possible to send texts directly (without using blat) using 2sms (www.2sms.com)
2sms has a command line interface that works well with SpecView and 2sms is fully supported on Windows 7
See the 2sms website for details.

However they have a multitude of pricing structures, see their pricing page here: http://www.2sms.com/cost.aspx

This is an example of using 2sms to send a text message using the Button/Strategy Controller action 'Run External Program':

C:\Program Files\2sms.com\Desktop SMS\desktopsms.exe /m:"%%SpecView.Time%%, Routine maintenance due: %%SpecView.MaintDateTime%%" /n:"07777123456" /s

18.7 Playing a noise when an alarm occurs

Can I get SpecView to play a noise (or tune) when something happens?

Use the Strategy Controller action: SpecView: Run External Program to run a separate program, for example, Playwav.exe, to play a tune on the sound card, if one is fitted. Playwav can be downloaded from: www.muconsulting.com/playwav

If Playwav.exe is placed, for example, in the SV3 folder, then to play a WAV file, for example, NOISE.WAV which has also been placed in the SV3 folder, use SpecView: Run External Program and use a command such as:

C:\SV3\PLAYWAV.EXE C:\SV3\NOISE.WAV

Note that it is important to specify the full path of the .EXE file (including the .EXE filename extension), as well as the full path of the WAV file, because SpecView needs to know where the files are. Just typing 'playwav noise' will not work.

Note: Use quotes if there are spaces in the filename, for example: C:\SV3\PLAYWAV.EXE "C:\SV3 \LOUD NOISE.WAV"

Alternatively, if there is hardware connected such as a digital relay which could be wired to an alarm bell, then the digital output could be set by the Strategy Controller to make the alarm bell ring.

18.8 Trend Chart Tolerance Bands

Setting up tolerance bands on a trend chart pen (max & min allowable values) can be done in the following ways:

- Warning 'flashing' of the pen line on a Trend Chart when out of range using the Blink on Alarm from box on the Pen Properties setup box

- Warning flashing using Color Dynamics

- Warning messages using Position Dynamics

- Ramp/Soak controllers have a Working Setpoint, so plotting the Working Setpoint on the chart can be used to indicate a tolerance band. This can be done with User Variables that have been set using the
Strategy Controller to the Working Setpoint plus or minus a tolerance

18.9 Trend Chart Batches

Processes can either be considered as ‘continuous’ or ‘batch’ processes.

For batch processes it is useful to be able to give names to the batches and to be able to find them at a later date to review the data, using the ‘batch chooser’ from either Historical Replay or Log Reports.

For detail on the steps needed see video on YouTube: 4500 - SpecView Version 3 Trend Chart: Batch Tags

There are some settings in Trend Chart setup that are useful when displaying a batch on a chart - for example, on the Chart tab set Scrolling mode to None - rescale time to fit. This will make the chart fit the batch.

It is also possible to add Automatic Chart Notes when a batch changes:

![Trend Chart Properties](image)

The BatchChanged trigger would be a Boolean User Variable that it set to 'On' when the BatchID changes using Strategy Controller.

For more information contact SpecView Technical Support.
18.10 Integrating SpecView with other software

SpecView can interface to other software in 4 ways:

1. CSV (Output from SpecView only):
   SpecView can write a CSV file – either by a logfile report or using SpecView’s LineWriter. Other software could read this. But unfortunately SpecView cannot read a CSV file that has been written by other software.

2. DDE (Both output from SpecView and input to SpecView):
   SpecView supports DDE Read and DDE Poke to read and write the values of variables to other DDE enabled software. For example Microsoft Excel is DDE enabled.

3. ActiveX control (Both output from SpecView and input to SpecView):
   SpecView can input and output the values of variables via ActiveX controls. For example one of our resellers has written ActiveX controls in Visual Basic to allow SpecView to read/write data in a Microsoft Access database.

4. OPC (Both output from SpecView and input to SpecView):
   This is an unlikely solution - however, SpecView can read and write via OPC – SpecView has a built-in OPC-Client - but this would need the other software to have an OPC-Server – either built-in or a third-party OPC-Server.

18.11 Setting up an automatic Log Report

How can I setup a Log File Conversion to occur, automatically on a regular basis, for example, every day at Midnight? For a detailed example of setting up the Strategy Controller to do an automatic Log Report at the end of a process run, please read: Example: Automatic Log Report.

Below is an abbreviated example, specifically for doing a Log Report at midnight:

For any automatic report generation you will need two SpecView ‘DateTime’ User Variables, one for the start time of the report (called: ReportStart), and one for the stop time (called: ReportStop). Put both of these DateTime User Variables on a GDW.

**NOTE: The Date/Time variables used for the start and stop times of the report MUST be on an open GDW in runtime for the report generation to work. They can be small or even behind an object like a trend chart, but they must be on an open GDW.**

In this example a SpecView Text User Variable is going to be used (called: BatchRef) for the Report’s file name. Create this variable and put it onto the GDW.
Also set the **BatchTag** property on this variable, so that it can also be used for **Historical Replay** purposes.

Ensure the Instrument and User Variables which are needed to be in the Log File Report are marked for logging. To do this check the 'Logged' attribute for the variables shown in the **Variable Properties** box, or by selecting Show Logging In Variables List on the **Setup menu**

In Runtime Mode, click the current value of BatchRef and enter a name, such as a batch number.

**Setup the Report Format:**
- Save all GDW's and go into Runtime Mode
- Select the Convert Log File menu command from the **Logging menu**
- Click the Create button on the Log Report Setup Box
- Edit the fields as follow
  - Give the format a name, such as 'MidnightReport'
  - Add the variables required in the report, for example, by clicking 'Add All->'
  - Check the 'From SpecView String' checkbox and choose BatchRef from the options
  - Check the 'Start Time from Var' checkbox and choose ReportStart from the options
  - Check the 'Stop Time from Var' checkbox and choose ReportStop from the options
Then click 'Add to Format List'
- Click 'Cancel' to exit the Log Report Setup box
- Select the Edit Mode menu command from the **File menu**

The actual Log File Conversion can be done automatically using the **Strategy Controller**
Select the Strategy Controller menu command from the **Setup menu**
- Add a Time Based Event called 'At midnight generate Log Report', and set Hour=00, Minute=00, Second=00, the others leave set to 'Any'
- Add the Action: 'Time stamp ReportStop' to do: 'Parameters: Download Specific Value' using the variable ReportStop, setting it to 'Current Time' by checking the box
- Add the Action: 'Generate Log Report' to do: 'Logging: Convert Specific Log File Format' using the format just created
- Add the Action: 'Time stamp ReportStart' to do: 'Parameters: Download Specific Value' using the variable ReportStart, setting it to 'Current Time' by checking the box

Click OK

Enter Runtime Mode and enter a name for tonight's converted log file report into BatchRef.

For the first day that this is run ReportStart will need to be set manually, so this value will need to be put on a screen in a convenient place so it can be manually set on the first day.

### 18.12 Using the date & time for a Log Report filename

This example shows how to create a filename containing the date & time for use when generating Log Reports:

There are many ways to do this depending on exactly what is wanted. For example, the filename may need to be built up from a combination of the line name, product name, batch name and date & time. Part of this may be from a scanned barcode. The triggering of the Log
Report would typically be triggered automatically by the Strategy Controller when the process starts.

However, for this simple example, the filename will just be the date & time and the triggering of the Log Report will be done by clicking a button.

Create the following User Variables:
- DateTime: StartDateTime & StopDateTime
- Text: LogFileName
- Bool: LogReportButtonClickedBool

Then put the variables on the screen (GDW):

Put a button on the screen to be used to trigger the Log Report:
Go into Runtime Mode and setup a Log Report Format as shown:

Go back to Edit Mode (Offline) and from the Setup menu choose Strategy Controller.

Note: For this example only one Strategy Event is required, and as 2 Strategy events are included as part of the base product there is scope to add more. However, if more than 2 events are needed then the
**Strategy Controller option will need to be purchased.**

The Event is: If LogReportButtonClicked is equal to 'On'
The Actions for this event are:
- Set LogReportButtonClicked to Off - (Ready for the next time, using: 'Parameters: Download Specific Value')
- Set StopDateTime to current time - (Using: 'Parameters: Download Specific Value' to set StopDateTime to 'Current time')
- Copy StopDateTime to filename - (Using 'Parameters: Copy From … To' to copy the StopDateTime to the filename)
- Generate Log Report - (Use 'Logging: Convert Specific Log File Format' and choose the Log Report Format that was created in the previous step)
- Set StartDateTime to now - (Using: 'Parameters: Download Specific Value' to set StartDateTime to 'Current time' ready for the next Log Report)

From the File menu choose Preferences, click the 'Display' tab and set the 'Date Time Format' format so that it is: %y-%m-%d_%H-%M-%S
This will ensure that when a Date Time variable is used for a filename the files will be in date order when sorted by name.
Then click return to Runtime Mode and click the 'Create Log File Report' button. The Log Report file itself will be in the project's folder and can be opened either in Microsoft Excel or in any text editor such as Wordpad.

### 18.13 Changing Log Data location or folder

**Can Log Files be written into another separate folder?**

It is possible to set this in SETTINGS.INI (This file is in the Project's sub-folder within the installation folder, which is by default C:\SV3). Add to the [Logging] section (or create a Logging section if it is not there) the line, for example:

Path=C:\MyPath

**NOTE:** However, there is a problem if this folder is on a networked computer, because should the network fail, then SpecView will fail when it attempts to write to the logfile. So we recommend this is only used for logging to a folder which is on the same PC as SpecView is running.

Also, if the folder which is specified is not within the SpecView Project folder, then the Archive 'Include Logfiles' checkbox will not archive the logfiles. If the folder is in the Project folder then to archive the logfiles both the 'Include Logfiles' and 'Include subfolders' will need to be checked.

Therefore, in light of this, you may wish to consider:
- Making a copy (for example, every 24 hours) of the Log File data using the Strategy Controller. This could then be done to a Network Server. See example below.

Alternatively:
- Modify the Log File Report Format to cause the resultant Log File Reports to be written to another folder.

**How to I make a copy of SpecView’s Log Files to, for example, a Network Server?**
Typically this would be done just after midnight, for example, one second after midnight (00:00:01) by the Strategy Controller.

If the logfiles are copied using the standard Windows ‘copy’ command then this will copy all the files each time, including those which have already been copied. Therefore using the ‘xcopy’ command is preferable.

To copy the files, and to keep a record of which files were copied & when, 2 files will be needed:
- empty.txt - just containing one carriage-return character.
- xcopythem.bat - containing:

```bash
date < empty.txt >> xcopylog.txt
type empty.txt >> xcopylog.txt
time < empty.txt >> xcopylog.txt
type empty.txt >> xcopylog.txt
C:\WINDOWS\COMMAND\XCOPY /D /C /Y C:\SV3\DEFAULT\??_???.* C:\SAFE >> xcopylog.txt
type empty.txt >> xcopylog.txt
```

In this example the logfiles to be copied are in C:\SV3\DEFAULT they are being copied to: C:\SAFE and the XCOPY command is in C:\WINDOWS\COMMAND

Please note the underscore character between the two and the three question marks.
You may want to set the ‘Close on exit’ property on the xcopythem.bat batch file using Windows Explorer.

This will create an output file (xcopylog.txt) which contains the date & time of each copy together with a list of the files copied.

**18.14 Translating SpecView into other languages**

If a SpecView Configuration needs to be made available in more than one language, normally, this would involve many screens having to be duplicated in each different language, with the associated errors and inconsistencies that that may cause.

Since all occurrences of the same word on different GDWs are referenced only once, this procedure makes it easy to translate consistently and quickly without duplication.

In order to address this SpecView (from Version 2.5 Build 781 onwards) on entering Runtime mode, reads an TAB-separated spreadsheet from the file CONFIG.SVT. Then, when a GDW is opened at Runtime, any strings on the screen are replaced with corresponding strings from the spreadsheet.
This makes it possible to have a Master Configuration in one language that can be displayed in a variety of other languages without editing GDWs or creating duplicate language-dependant configurations.

CONFIG.SVT is a TAB separated file, similar to a Comma Separated Value (.CSV) file, but using tabs to delimit the fields. This allows the text to contain commas.

**NOTE:** To create the CONFIG.SVT automatically there is a utility that extracts ALL text strings from ALL GDWs in the Configuration. Please contact SpecView for further information on this automatic text string extraction utility.

This spreadsheet has the following columns (shown here with examples for Cancel & Browse):

<table>
<thead>
<tr>
<th>ENU</th>
<th>SubString</th>
<th>Comment</th>
<th>GDW</th>
<th>DEU</th>
<th>FRA</th>
<th>ITA</th>
<th>NLD</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cancel</td>
<td>Button</td>
<td>MAIN.GDW</td>
<td>SCREE</td>
<td>Abbrechen</td>
<td>Annuler</td>
<td>Annulla</td>
<td>Annulieren</td>
</tr>
<tr>
<td>Browse</td>
<td>SAVE.GDW</td>
<td>TREND</td>
<td>Browse</td>
<td>Parcourir</td>
<td>Sfoglia</td>
<td>Zoek</td>
<td></td>
</tr>
</tbody>
</table>

ENU The source language text (in this case ENU)
SubString Substring - explained below
Comment Any comment string, such as: Must have space at end of text
GDW The GDW(s) that the string occurs on. This is just for reference to help find the context
DEU The German translation (these columns can be in any order)
FRA The French translation
ITA The Italian translation
NLD The Dutch translation

If the CONFIG.SVT file does not exist then no substitution takes place at Runtime.

Similarly, if there is no translation available for a given row & column then no substitution takes place.

The Comment and GDW columns are not used in the translation, they serve only as a helpful guide to the Translator.

If a 'Y' or a 'y' exists in the SubString column then the text in Column1 (Source Language) is looked for as a SubString, this prevents a word from having to be repeated numerous times, for example:

Screen 1
Screen 2
Screen 3
Screen 4
...
Screen Y

In the above example, the one occurrence of "Screen" is replaced in each of the "Screen 1", "Screen 2" etc strings, thus saving duplication.

However, it is worth noting that the substitution of SubStrings can take considerable CPU time, and so should only be used sparingly.

The matching process is both case-sensitive and whitespace-sensitive.
If the Source String is a multi-line string then the characters: \n\n represent the new-line. These characters must be left intact in the translated strings.

The CONFIG.SVT applies only to the specific configuration it is in. There is no 'global' file that translates across all Configurations. To implement a global file make a subset of all the common words as a template and include it into each CONFIG.SVT as required.

If a string has '=', '+' or '-' as its first character then put a single quote before it, otherwise spreadsheet programs such as Excel will interpret the string as a formula. As an alternative, change the column format to Text. But it is important to note that this information is not stored in the Tab Separated File format so will be lost when you re-open the sheet. To avoid this either:
1. Don't use '=', '+' or '-' as the first character of any string.
2. Save the worksheet as an XLS and use that as the Master for re-editing to preserve the column format.

A CONFIG.SVT file can be created manually by creating an Excel spreadsheet by hand in the format specified above. This MUST be saved as a TAB separated file unless it is in this format SpecView will be unable to read it.

To create the CONFIG.SVT automatically there is a utility that extracts ALL text strings from ALL GDWs in the Configuration. This takes some time to run. Please contact SpecView for further information on this automatic text string extraction utility.

Running a SpecView configuration in a different language:

So to run a SpecView configuration in one of the other languages…. First be sure SpecView is NOT running, then:
Edit C:\SV3\SV3.INI using Notepad
In the '[Settings]' section add the line:
   ForceForeignLanguageXlat=FRA

This just defines the column in the CONFIG.SVT file that is to be used. So in this example the 'FRA' column will be used. But if there is nothing in that column then the first column (ENU) is used.

18.15 Instrument Support in SpecView

How can I find out if SpecView supports a particular instrument?

Is the instrument specifically listed on: www.specview.com
if it is, then the answer is yes.

If not, then:
1. If the manufacturer & instrument series is listed, but just not the specific model number (i.e. 'XYZ series 1200' but yours is model: 1250) then:
   Try connecting using the most similar instrument definition. If it doesn't work or only partially works, then see: 'New Driver (or Driver modification)' below.

2. If the manufacturer is listed but no similar model number is shown, then:
See: "New Driver (or Driver modification)" below.

3. If the manufacturer is not listed, then:
   Check the technical documentation for the instrument which details the protocol it uses:
   3a. If the protocol is modbus-RTU or modbus-TCP then this may be possible using SpecView's
       Generic modbus driver. (However, SpecView does not support the Modbus-ASCII protocol).
   3b. If the instrument supports OPC, then SpecView's OPC client can be used which is a chargeable
       option.
   3c. If the protocol is ASCI then, it may be possible, see 'New Driver (or Driver modification)' below.
   3d. If the protocol is proprietory then see 'New Driver (or Driver modification)' below.

**New Driver (or Driver modification)**

If a new driver or a driver modification is required then give us as much information as possible (in writing via email or fax), including the technical documentation for the instrument which details the parameter addresses (or let us know where we can obtain it from).

If the instrument has many hundreds of parameters, but you only require access to a few of them then let us know. Similarly, If you have a specific time-scale requirement then we'll need to know this too.

Based on this information and the commercial potential we will provide a quotation & time scale.

Be prepared to send us the instrument in question, so that we can use it for test purposes. If it is not possible for us to be sent the instrument, then instead we can send you a Driver based on the technical documentation for you to try.

**18.16 Running SpecView Automatically From Computer Startup**

SpecView cannot currently be run as a 'service' as it does require a user to be logged-in.

However, once a user has logged-in to the computer SpecView can be run automatically, however, it is necessary to ensure that the dongle driver has had time to initialize before SpecView starts. For further information please contact Technical Support.

One scheme that can be used, which does **not** require anyone on the shop floor be to start and log-in, is to run SpecView on a dedicated server and have the computers that the operators interact with to be SpecView Remotes. On these computers the operators can select/edit recipes, enter batch data and process comments. These computers do not collect and store data themselves as the server is doing this.

**18.17 Running a program when SpecView exits**

A program can be run when SpecView exits. The program is run in the same way as when using the action Run External Program.

This can be used to:
   - Send an eMail to indicate that someone exited SV
- Restart SpecView if SpecView is exited
- Display a message
- Copy files to another location automatically on exit, for example, to copy debug files into a different folder to preserve them

To do this follow these steps:

In the SETTINGS.INI file for the Project add this line to the '[SETTINGS]' section:

```
ExitProgToRun=C:\SV3\RUNME.BAT
```

Then, when SpecView has finished running that Project and is exiting, it will run the Batch file.

Note: does not work if SpecView exits abnormally, it will only run if SpecView exits normally.

The RUNME.BAT file should do whatever is required. This could be, for example:

```
@ECHO OFF
CD \SV3
START /MIN ProgramToRunMinimized.exe
EXIT
```

Here are three interesting examples that can be done:

(1) **Display a Message Box** on the screen (Also useful in normal RunExternal program while SV is running)

Save and unzip the attached Usermessage.vbs in the SV3 folder, then the batch file would be:

```
@ECHO OFF
CD \SV3
WSCRIPT usermessage.vbs
EXIT
```

This example .vbs has a 10 second timeout on the message, which can be useful. The .vbs file is a text file, so it can be easily changed to the message of choice.

(2) **Copy COMMS debug files** from the project folder (e.g. MyProject) to a subfolder named by date to save them before the next run of SpecView overwrites them:

```
@echo off
cd \sv3\MyProject
setlocal enableextensions
for /f "tokens=1-5 delims=:" %%d in ("%time%") do SET MassTime=%%d-%%e-%%f
for /f "tokens=1-5 delims=/ " %%d in ("%date%") do SET MassDate=%%d-%%e-%%f-%%g
set foldername=DebugsFrom_%MassDate%_%MassTime%
md %foldername%
MOVE debug*.txt %foldername%
EXIT
```

REM folder looks like this: DebugsFrom_17_12_2014_16_02_47.70

(3) **Restart SpecView** after a short (10 second) delay. Starts SpecView Maximized instead of minimized.

```
@ECHO OFF
CD \SV3
TIMEOUT /T 10
START /MAX SV3.EXE
```
EXIT

1 & 3 could be combined together to display a message informing the user that SpecView is being restarted.
Top Level Intro

This page is printed before a new top-level chapter starts
19  Frequently Asked Questions (FAQ)

For the answers to the following questions please see the relevant section of the FAQ:

**FAQ - Installation/Update/Upgrade**
- Does SpecView work with Win95/98/NT/2000/Me/XP?
- Do I need to send the dongle back in order to get it upgraded to add further options?
- Will updating affect my existing Projects?
- Can I copy SpecView to another PC & how can this be done?
- During installation I get an error about DCOM.

**FAQ - Instrument**
- Why am I seeing: 'N/R' or 'NPV' or 'NCA' or 'N/C' or 'T/O' or 'W/O' on the screen where the instrument's values should be?
- On my generic Modbus instrument how do I access higher registers?
- Why are the instrument values shown 10 or 100 times too big (or too small)?
- Why are the wrong values being returned from the instrument?
- How do I use a BarCode Scanner with SpecView?
- How can I avoid affecting communications throughput if some instrument(s) need to be turned off or disconnected for a reason?

**FAQ - SpecView Runtime**
- Can I monitor SpecView remotely?
- How do I view previous Event Logs?
- How can I restore the Historical Replay Control Panel window to its original size?
- Why am I getting steps or gaps on my Trend Chart rather than a smooth curve?
- I am getting empty logfiles, what could be the reason for this?
- How can performance be improved - so that the rate that instrument variables are updated is increased?
- How can I make the color of things on a GDW change according to a value?
- How can I modify one of SpecView's Demo Projects so it will work with my instruments?
- Running a program using 'SpecView: Run External Program' the program's window is minimized.
- How can I improve the speed that SpecView starts up?
- Can I run SpecView from the Windows Startup Group?
- Why am I not seeing all the Instrument Parameters I expect to see in the Parameter List?
- The Trend Chart doesn't appear to be updating, why might this be?

**FAQ - SpecView Edit Mode**
- Can I develop complex screen(s) for one instrument (e.g: Furnace1) then copy it/them for another instrument of the same type (e.g: Furnace2)?
- Double-clicking on an item on the GDW seems to have no effect, when usually it would display the relevant attributes box for that item.
- I can't seem to add a variable on a GDW into Recipe.
- I can't seem to edit a value's Dynamic Attributes.
- Changing the color of text on the screen (using Object->Text Font...) doesn't appear to have any effect.
- How do I configure SpecView Networking (Remote/Local)?
- What can I do if Auto detect doesn't work for my instrument?
- How do I do a Strategy Controller event every second?
- How do I do a Strategy Controller event every minute?
- My variables list box doesn't appear, why not?
- How do I animate a graphic using the Strategy Controller?
- How do I make clicking somewhere on a GDW do a button-type action?
- I've set the Fill Color of a shape but it isn't being filled, why?
- Why is it that using the Edit->Paste of an object doesn't appear to work?
- What can I do if comparing an instrument value (with decimal places) with an integer in the Strategy Controller doesn't work?
- Can I copy a whole Project?
- Adding a bitmap to a GDW makes the GDW much larger, why?
- How do I archive logfiles?
- How do I delete logfiles?
- I am confused about the difference between Log Files and Log File Reports created by Log File Conversion.
- How can I make the Strategy Controller run another program?
- How do I run a DOS .BAT file from the action: SpecView: Run External Program?
- How do I setup the Strategy Controller to do a delay (for example, 5 seconds) ?
- How can I make a button on a GDW do more than one action?
- How can I make a button toggle a Boolean so that successive clicks turn it On/Off/On/...?
- What is the maximum value for an Integer or Number variable?
- How can a value be displayed on a GDW using scientific notation (showing mantissa & exponent)?
- Opening a screen in Runtime mode with a Trend Chart; the chart is always initially blank with no pen lines. What can be done about this?
- How can a screen (GDW) be printed to an Adobe PDF (Portable Document Format) file?
- How can I make a Strategy Event which will keep 'firing' all the time that something is 'true'?
- How can I make something blink/flash on screen?
- How can I position items on a screen & align them to within a pixel & stop them 'jumping' to the grid?
- How can I make some text appear on the screen using the Strategy Controller when something happens?
- How can I run a Help (HLP) file from a button on the screen?
- How can I use COM ports 10 and above?
- Why am I not seeing all the Instrument Parameters I expect to see in the Variables List?

19.1 FAQ - Installation/Update/Upgrade

Does SpecView work with Win95/98/NT/2000/Me/XP?
- Yes, this is detailed in Minimum Requirements, however SpecView does not work with Windows CE, which is a reduced version of Windows used in Windows embedded devices.

Do I need to send the dongle back in order to get it upgraded to add further options, (such as adding the Strategy Controller option)?
- No, once you have decided to upgrade the dongle, and have raised a purchase order
- Use the Registration Info menu command from the Help menu
- Click Enable Further Options.
- Write the Step 1 code, which is generated, on to the order and fax it to your SpecView distributor.
- They will then give you the Step 2 code(s) by voice/fax/email to complete the upgrade.

Will either updating to a new version of SpecView, or upgrading to add further SpecView options to the dongle, affect my existing Projects?
- Both updating the version of SpecView software & upgrading the dongle add further options, preserves existing Projects.
- However, as with all computer files, taking regular backups is a good idea.
- To do this use the Archive button on the Projects Found dialog to save an entire Project.

**Can I copy SpecView to another PC & how can this be done?**
- Yes, it may be copied freely because, without a dongle connected, it will only operate in Runtime Mode for 10 minutes, or as a Remote. Dongles are not limited to a specific PC and can be transferred.
- In order to copy SpecView together with your Project and Log Files, follow the steps below:
  - First install SpecView (preferably using the latest version) either from the CD or via download.
  - Then use SpecView's Archive to create a backup file of the Project's sub-folder (this folder contains data only, no software) which is within SpecView's installation folder (usually C:SV3).
  - Copy this file to the new PC which has had the latest version of SpecView installed and use SpecView's Restore to install the data.

If the existing version of SpecView was the 16-bit version then read SpecView Upgrading from a previous version

**During installation I get an error about DCOM.**
- There is a file which SpecView needs which doesn't exist in early versions of Windows 95, 98 or Me. During the installation process it will install DCOM95 or DCOM98 appropriately. This file is needed for SpecView's OPC functionality, and because part of the OPC functionality is built-in to the base product, the file is required even if SpecView's OPC option isn't being used.

---

### 19.2 FAQ - Instrument

**Why am I seeing: 'N/R' or 'NPV' or 'NCA' or 'N/C' or 'T/O' or 'W/O' on the screen where the instrument's values should be?**
- For 'N/R' this is correct operation while offline in Edit Mode. However, if this occurs while in Runtime Mode then please read Troubleshooting Instrument Communications for the steps to take.
- For the others, they explained in Values on the GDW.

**On my generic Modbus instrument how do I access higher registers?**
- Use an offset on the address specification by adding a semicolon followed by the offset, for example 1,0J;256

**Why are the instrument values shown 10 or 100 times too big (or too small) or without the decimal point positioned correctly?**
- Check the address specification to see if the number of decimal places is correct.

**Why are the wrong values being returned from the instrument?**
- Check the instrument's manual, as some instruments return raw data (for example, Chessell & ABB Chart Recorders), which needs to be scaled.
- This can be done from the Properties button on the Variables List.

**How do I use a BarCode Scanner with SpecView?**
- This is detailed under Using a BarCode Scanner with SpecView.

**How can I avoid affecting communications throughput if some instrument(s) need to be turned off or disconnected for a reason?**
There are 2 answers to this depending on whether the dongle has the Multiport option enabled:
- If the Dongle has the Multiport option enabled then:
Set the 'COM port' of the missing controllers to something else, like 'COM2'. That way all the failed reads & timeouts won't affect the communication stream coming in from the other COM port.

- If the Dongle hasn't got the Multiport option enabled then:
Go to File->Preferences & on the Runtime tab set 'Comms Back Off Multiplier' to a larger number. It is a trade-off as to how high to set it because if it is very high, then when the instruments are subsequently reconnected on it will take SpecView that long to 'notice'. Be aware that it'll also affect the 'retry' timeout on the live instruments too, so it is important to put the variables:
SpecView.CommsErrors
SpecView.GoodComms
SpecView.CommsErrorCode
SpecView.CommsErrorItem
SpecView.CommsErrorDescription
on a screen somewhere & when all the instruments are connected check that CommsErrors stays at zero - if there is a weakness in instrument communication then increasing the Comms Back Off Multiplier would not be a good idea.

19.3 FAQ - SpecView Runtime

Can I monitor SpecView remotely?
- Yes, use SpecView Networking

How do I view previous Event Logs?
- Use the Convert Log File menu command from the Logging menu
- Create a Report Format which has Include Event Log checked.
- This will create a .CSE file, which can be viewed using Excel.

How can I restore the Historical Replay Control Panel window to its original size?
- Use File->Preferences Settings 'Reset Historical Replay Window Position'

Why am I getting steps or gaps on my Trend Chart rather than a smooth curve?
- This could be because SpecView is busy trying to read non-existent instruments, or getting repeated comms failures. Maybe increasing the Comms Back Off Multiplier to 1000 may help.
- Alternatively the PC could be busy, so check the loading on the PC.
- Gaps can be caused by the PC's Power Save function.

I am getting empty logfiles, what could be the reason for this?
- Use the Show Logging in Variables List menu command on the Setup->Database sub-menu.
- Then, using the Variables List, check that the required variables are set as logged.
- Or maybe the logging rate needs adjusting from Preferences Logging

How can performance be improved - so that the rate that instrument variables are updated is increased?
See here

How can I make the color of things on a GDW change according to a value?
A variable's color can be made to change according to its own value or another variable's value, for example, a text string's color 'Warning: Overheating' could appear in red when a temperature reading is above a certain value. Then set to white (which would make it disappear) otherwise.
In this example, select the text string, then choose **Color Dynamics** from the **Edit menu**.

**How can I modify one of SpecView's Demo Projects so that it will work with my instruments?**

It is likely that the problem is caused by the instrument address(es) being incorrectly set. In **Edit Mode** click the 'Variables List' tool then select the instrument's name and click the **Properties** button. The address field will show the address that SpecView is using. Either alter the address in **SpecView** or change the instrument's address according to the instrument manufacturer's instructions. **Modbus address format**

**When I run a program using** **SpecView: Run External Program** **the program's window is minimized.**

- It is possible to change this in the **SETTINGS.INI** file in the Project's folder:

```
[Settings]
RunExtProgDispMode=M
```

Where the choices are:

- **M** - means start Minimized, which is the default
- **F** - means start using Full screen
- **N** - means start in a Normal window

This setting will affect all programs run by SpecView from that Project.

The reason that the default setting is Minimized is because this command was originally added in order to run programs to, for example, play a sound file, where it would be inappropriate to display the program's window.

**How can I send email from within SpecView?**

It is possible to setup SpecView's Strategy Controller to send email(s) when a certain condition occurs, such as an alarm. There are 2 ways to do this:

1. Using **SpecView: Run External Program**:

   There are programs available, but we don't currently know of any specific examples, which have a command line interface so that the email address & the file containing the message to send can be specified on the command line.

2. Using **SVEmail**:

   SVEmail was written by us to send an email via a MAPI compatible email program. However, due to the recent tightening of security on the use of MAPI to send emails because of the problems caused by automated spamming, this will only work on older versions of Microsoft Outlook (such as Outlook 2000). We are not aware of which other email programs it will work with, although there are a great many email programs available so it should be possible. The best thing to do is to try it out, please contact your SpecView distributor to request SVEmail free of charge.

**How can I improve the speed that SpecView starts up?**

When SpecView starts up it loads all the Instrument Definition Files (IDF) in the installation folder (usually C:\SV3\), which takes some time. To improve the speed of startup it is OK to move the Instrument Definition Files (IDF) that are not being used into another folder. It is best not to delete them in case they are needed in the future, so we recommend creating a folder, such as C:\SV3\IDF and moving the IDF files that are not being used into there.

**NOTE:** To see which IDF files are still being loaded, go into Edit mode, click the Variables List [V] tool and click 'Show New' this lists all the Instrument types which have been read from the IDF files during startup.

**Can I run SpecView from the Windows Startup Group?**

If SpecView is put into the Startup Group, then often it will start before other parts of the system are ready. To resolve this, use a delay program, such as:
Why am I not seeing all the Instrument Parameters I expect to see in the Parameter List?
- To display the full list use the **Options Menu** and select the Short List menu command. All the parameters will appear. Choose this menu item again to toggle back to the **short list** mode. To include/exclude parameters from the Short List use the **Variable Properties** box.

The Trend Chart doesn't appear to be updating, why might this be?
Firstly determine the resolution of a Trend Chart as SpecView will draw one pixel on the Trend Chart pen line according to the time span of the chart & the width of the chart in pixels. Therefore if the time span of the chart is 28 days & the chart is 1000 pixels wide then one pixel will be drawn and every 40 minutes. This also applies to the rate at which the values shown along the top of the chart will be updated.
To ensure the current values can be seen put the values out onto the screen from the **Variables List**.
If the values still aren't updating as expected then put the variables: **SpecView.CommsErrors**, **SpecView.GoodComms**, **SpecView.CommsErrorCode**, **SpecView.CommsErrorItem** & **SpecView.CommsErrorDescription** onto the screen to check **instrument communications**.

19.4 FAQ - SpecView Edit Mode

Can I develop complex screen(s) for one instrument (e.g: Furnace1) then copy it/them for another instrument of the same type (e.g: Furnace2)?
Yes, once you have created the screen(s) for the first instrument and you are happy with them, use File->Save As... to save them to different names. Ensure the other instrument(s) are in the **Variables list**, either by adding them **Manually**, or by having initially done an auto-detect of all connected instruments. Then go to one of the newly saved screens (using File->Open) and use **Edit->Replace** to substitute the names (e.g: Furnace1 to Furnace2).
This will change all occurrences, but only on the current GDW so if there is more than one GDW per instrument it will need doing for each. However, it will not affect the **Strategy Controller** so this will need to be changed as necessary.

Double-clicking on an item on the GDW seems to have no effect, when usually it would display the relevant attributes box for that item.
- The item may be Grouped with another item on the GDW, click on the item once so that it is selected and click the Ungroup tool (detailed in the **Object menu**)

I can't seem to add a variable on a GDW into Recipe.
- The value and the variable's name may still be Grouped together, un-click the **Recipe** tool, then click on the variable and click the Ungroup tool (detailed in the **Object menu**)

I can't seem to edit a value's Dynamic Attributes.
- If the **Dynamic Attributes** menu command appears to have no effect then the value and the variable's name may still be Grouped together, click on the variable and click the Ungroup tool (detailed in the **Object menu**)

Changing the color of text on the screen (using Object->Text Font...) doesn't appear to have any effect.
- It is possible that the text is Grouped together with another item on the GDW, click on the item and
click the Ungroup tool (detailed in the Object menu). Then select them individually.

**How do I configure SpecView Networking (Remote/Local)?**
- Details in SpecView Networking

**What can I do if Auto detect doesn't work for my instrument?**
- Use Manual Instrument Configuration

**How do I do a Strategy Controller event every second?**
- In the Strategy Controller create a Value Based event
- Value to watch: SpecView.Time
- Test to perform: Changed
- Value to test against will default to Constant Value: 00:00:00

**How do I do a Strategy Controller event every minute?**
- In the Strategy Controller create a Value Based event
- Value to watch: SpecView.Time
- Test to perform: Changed,
- With the Constant Value 00:00:59

**My Variables List box doesn't appear, why not?**
- It may be off screen,
- use File->Preferences Settings 'Reset Variables List Window Position'

**How do I animate a graphic using the Strategy Controller?**
- Set a SpecView User Variable to represent the phase of the animation.
- Create a number of shapes for the animation
- Use Edit->Color Dynamics to make the shapes change color between the background color and another color, to make them 'appear' & 'disappear' according to the value of the User Variable. However, it is not possible to animate a bitmap.

**How do I make clicking somewhere on a GDW do a button-type action?**
This can be used to make a part of a GDW sensitive to a click.
- Create a polygon with Outline Weight (or line width) = 0 and position it appropriately and note its name shown in the Shape Properties box.
- Create a button and position it off-screen with the required action
- Change the caption of the button to be exactly the same as the name of the polygon (this is case sensitive).
Now clicking on the polygon will have the same effect as clicking on the button.

**I've set the Fill Color of a shape but it isn't being filled, why?**
- Double-click the shape & uncheck the fill-none box

**Why is it that using the Edit->Paste of an object doesn't appear to work?**
- It has been pasted over the top of the original, move it to one side to reveal the one beneath.

**What can I do if comparing an instrument value (with decimal places) with an integer in the Strategy Controller doesn't work?**
- Comparisons of variables must be between variables of the same type.
You will need to create a User Variable of type Number (with decimals) and copy the integer into it before making the comparison.

**Can I copy a whole Project?**
- Yes, either use Windows Explorer to copy the Project folder
- or use Archive/Restore

**Adding a bitmap to a GDW makes the GDW much larger, why?**
- This occurs if a bitmap is added using the Insert New Object menu command on the Edit menu.
- It is recommended to use the Insert a Bitmap tool on the toolbar (or Draw->Bitmap...) instead.
Can I write a line of text at the top of a Logfile Report?
- Use the SpecView: Write Line to file/printer action for a Button or via the Strategy Controller.
- Use this to write the line you require to a file called, say, LINE.TXT.
- Generate a log report to, say, REPORT.CSV
- Create a file called, say JOIN.BAT, containing a line something like:
  COPY LINE.TXT+REPORT.CSV FINAL.CSV
- Then use the action SpecView: Run External Program to run JOIN.BAT.

How do I archive logfiles?
- There are (up to) 6 files which make up a day's logfiles: .LOG .LNM .EVT .ALM .IDX .BTC (These are detailed further in Data Logging - Disk Space Requirements).
- Using Windows Explorer go into the Project's sub-folder and sort by name
- This will ensure that all logfiles are listed first
- These can be copied or zipped as required.
- The first part of the logfile names are in the format YY_DDD, where YY is the current year number, and DDD is the current day number within the year (starting from 000. So for: 1st January 2003 the file names will be: 03_000).
Or see the example below that uses: xcopy

How do I delete logfiles?
- The best method is to use the Strategy Controller or Button action: Logging: Purge Log Files

I am confused about the difference between Log Files and Log File Reports created by Log File Conversion.
- Log Files are automatically created and updated all the time that SpecView is in Runtime Mode. There are a set of (up to) 6 files which make up a day's data log.
- The contents of Log Files cannot be viewed directly, they must first be converted into a Log File Report using Log File Conversion.
- In order to generate a Log File Report first a Report Format will need to be setup, this defines which values in the Log Files should be listed in the Log File Report, and in what order.
- The Log File Conversion can then be done directly by a user action, either from the Logging menu during Runtime, or from the Button/Strategy Controller actions Logging: Convert Specific Log File Format or Logging: Show Log File Convert Manager.
- The Log File Report can then be viewed using any program which can read .CSV (Comma Separated Variables) files, such as Excel.

How can I make the Strategy Controller run another program?
- Use the action SpecView: Run external program
- It is important to include the full pathname of the program to be run, for example, C:\TEMP\MYPROGRAM
Without the full path SpecView will only look in the current Project's sub-folder in the installation folder (usually C:\SV3) for the program.
- To run a .BAT file create the file in the Project's sub-folder with the commands to be run. If you require the MS-DOS Prompt window to disappear when the .BAT file has finished then add the command 'exit' as the last line of the .BAT file. Also on the MS-DOS Prompt's properties check the 'Close on exit' box. However, note that any error messages from the running of the .BAT file may then be lost.

How do I run a DOS .BAT file from the action: SpecView: Run External Program?
The .BAT file can be in SpecView's current Project's folder, or in a folder specified by the PATH setting in Windows, then just the filename can be used:
Example.bat
or, if there are spaces in the name use double quotes:
"Example Two.bat"
Similarly use double quotes around commandline parameters with spaces:
  Example.bat "This is an example with spaces"

Alternatively specify the full pathname, again using double-quotes if there are spaces in the name, for example: "C:\My Documents\Example.bat"

Also you may wish to write the .BAT file so that any output or errors are redirected to a file and then set the 'Close on exit' property on it using Windows Explorer so that the MS-DOS Prompt window closes immediately the .BAT file has finished running.

**How do I setup the Strategy Controller to do a delay (for example, 5 seconds)?**
- Create a Countdown Timer **User Variable**
- Set the value to 6
- Use a Value Based event to watch for the Countdown Timer becoming = 1
  (Going from 6 to 1 is better than going from 5 to 0 because once it has reached 0 it will remain there)

**How can I make a button on a GDW do more than one action?**
- Create a Boolean SpecView User Variable (& set it to 'Off')
- Create a button that sets the Boolean to 'On'
- Use a Strategy Controller value based event to 'watch' the boolean, when it is set to 'On' do the required actions, then as the last action set the boolean back to 'Off'.

**How can I make a button toggle a Boolean so that successive clicks turn it On/Off/On/...?**
- Set the button action to do a **Math Function** and subtract the Boolean from itself and store the answer in itself, for example:
  - Copy From: Bool1
  - Subtract: Bool1
  - Copy To: Bool1

**What is the maximum value for an Integer or Number variable?**
The ranges are detailed under SpecView **User Variables**.

**How can a value be displayed on a GDW using scientific notation (showing mantissa & exponent)?**
This is done using by setting the **Dynamic Attributes** of a variable on a GDW.

**Opening a screen in Runtime mode with a Trend Chart; the chart is always initially blank with no pen lines. What can be done about this?**
Use the 'Auto-open on Runtime’ menu command from the **File menu** to tell SpecView to open (start) this GDW when entering Runtime Mode.

Also when creating **buttons** to change screens use **GDW Control: Swap to another GDW** to swap to another GDW screen without closing it and clearing the trace line(s), instead of using **GDW Control: Close this and Swap To GDW**, which is intended for use with infrequently used GDW screens, such as setup screens that don't contain Trend Charts.

**How can a screen (GDW) be printed to an Adobe PDF (Portable Document Format) file?**
Firstly Adobe Acrobat (or another program that can create PDF files) needs to be installed on the PC. Then there are 2 ways of doing this:
1. By using either the Print or Print Setup menu commands from the **File menu**, because when Adobe Acrobat is installed it will be shown in the list of printers and can be selected to create a PDF (Portable Document Format) file.
2. If the File Menu is not available (because **Full Screen mode** is enabled), or if the printing is to be done
from the **Strategy Controller**, then use the Printer Setup from Windows itself to set Adobe to be the 'Default Printer'.

**How can I make a Strategy Event which will keep 'firing' all the time that something is 'true'?**

Normally Strategy Events are edge-driven so that they only fire when a change occurs. Therefore in event that says, for example, 'If Bool1 = On' will only fire once, and will only fire again if the Boolean goes to Off and then back to On.

So if you want something to keep firing all the time, for example, while Bool1=On then do this:

- Add a Value Based Event called 'Every 2 seconds', and watch SpecView.Time, choose 'Changed' & test against 00:00:02. In the Event Control panel check the Enable on Boolean & choose Bool1=True.

This event will then 'fire' every 2 seconds all the time that Bool1=On.

This is useful to, for example, make something blink/flash or repeatedly ring a bell all the time there is an Alarm.

**How can I make something blink/flash on screen?**

- Add a Value Based Event called 'Every second & while Alarm=On', and watch 'SpecView.Time', choose 'Changed' & test against 00:00:00. In the 'Event Control' panel check the 'Enable on Boolean' & choose 'Alarm=True'. (for the Alarm you want, or use SpecView.AnyAlarm for all alarms).

  - Set the Action to do a **Math Function** and subtract a Boolean User Variable from itself and store the answer in itself, for example:
    
    Copy From: Bool1
    Subtract: Bool1
    Copy To: Bool1

    (Subtracting a Boolean value from itself effectively toggles the value).

  - Also add a Value Based Event called 'If Alarm = Off' to check if Alarm equals 'Off'.
  - Set the Action to set Bool1 to 'Off'. So that the Boolean is turned off when the Alarm is.

Then select the item on the screen you want to flash & set the **Color Dynamics** using 'Edit->Color Dynamics'.

- When 'SpecView.Bool1 = On' set it to (maybe) red.
- When 'SpecView.Bool1 = Off' set it to white (if the background is white then it'll disappear)

It is possible to stop the Alarm box appearing automatically by using:

'File->Preferences->Alarm tab' & unsetting 'Popup Enabled'.

**How can I position items on a screen & align them to within a pixel & stop them 'jumping' to the grid?**

This is done using by disabling the grid from the **View Menu**, by setting Grid Size to zero & unchecking Grid Lines.

However, although this allows objects on the screen to be positioned manually to within one pixel, this requires very precise positioning of the mouse & so is not recommended.

**How can I make some text appear on the screen using the Strategy Controller when something happens?**

There are a number of different ways of doing this:

- Make some text on the screen (GDW) appear/disappear using **Color Dynamics** (making the text the same colour as the background color will make it seem to disappear).
- Swap the screen (GDW) to a screen with the text on it. Remember to put a button on the new screen
to swap the screen back.
- Use **Run External Program** to run a program such as Notepad to display a file containing the text. For example:

  ```
  c:\Windows\notepad.exe C:\SV3\Furnace\FurnaceWarning.txt
  (Change paths as appropriate)
  ```

  However, to ensure the Notepad window is seen you will need to set RunExtProgDispMode (default: M, which is minimized) to 'N' (normalized) in the [Settings] section of Settings.ini. See **Preferences**.

- Use **Run External Program** to display a HLP file, for example:

  ```
  C:\windows\winhlp32.exe C:\SV3\Furnace\FurnaceHelp.hlp
  (Change paths as appropriate)
  ```

  Set RunExtProgDispMode to 'N', as described above.

**How can I run a Help (HLP) file from a button on the screen?**
- Use **Run External Program** to display a HLP file, for example:

  ```
  C:\windows\winhlp32.exe C:\SV3\Furnace\FurnaceHelp.hlp
  (Change paths as appropriate)
  ```

  Set RunExtProgDispMode to 'N', as described above.

**How can I use COM ports 10 and above?**
- Firstly to use more than one COM port to connect to instruments the **Multport** option will be required.
- The default number of COM ports is 9, but SpecView supports up 40 ports. To use ports 10 and above change the **MaxPorts** setting.

**Why am I not seeing all the Instrument Parameters I expect to see in the Variables List?**
- Uncheck the **Short List** checkbox on the Variables List to show all the Instrument Variables.
- Or you may need to manually add parts of the instrument which haven't already been defined by Automatically detecting the instrument or defined manually, this is described in **Manually Defining Instruments**.
Index

- 3 -
32bit and 64bit 67, 84

-A-
ActiveX - Method of adding an ActiveX Control 468
ActiveX Control Not Licensed 485
ActiveX Controls and Passwords 482
ActiveX Insert Control 473
ActiveX Licensing 472
ActiveX Manage Control List 484
ActiveX on SpecView Remote 473
ActiveX Preferences 474
ActiveX Register 480
ActiveX Variables Inputs 475
ActiveX Variables Methods 478
ActiveX Variables Outputs 477
ActiveX: Save All GD3s for Version Changes 480
Add a variable to the GDW 517
Add a vertical bar chart 527
Add buttons to switch between GDWs 525
Add/Rename Instruments 102
Adding Instruments 99
Adding Numeric Values to a GDW 208
Adding Trend Chart Pens 232
Administrator privileges 292
Alarm 210, 274
Alarm Acknowledge on Remote 446
Alarm Logging 370
Alarm Scan Rate 237
Alarm Window Position Reset 145
Alarms - Deleting 370
Alarms - Show Alarm List 238
Alarms Menu 145
Alarms On/Off 237
Aligning Text 229
ALM - log file 370
Annunciating Alarms 233
AnyAlarm - SpecView variable 184
Archive 87
Archive and Restore 87
Archive/Restore restrictions 90
Arrange Icons 173
Auto Close Boxes 132
Auto Configuration 93
Automatically detect instruments and display instrument views 514

-B-
Background color of screen (GDW) 166
Backward Compatibility 67
BadComms - SpecView variable 184
Bar Charts 233
Bar Charts - Creating 232
Bar Codes 246
Barcode 106
BarCode Scanner support 106
Batch IDs - Using Batch Tags 380
Batch Numbers - Historical Replay 377
Batch Numbers - Logfile Convert 363
Batch Numbers - Using Batch Tags 380
Batch Tags 380
Batch Tags - Historical Replay 377
Batch Tags - Logfile Convert 363
Bitmap Properties 229
Bitmaps on a GDW 228
Boolean 275
Boolean - changing 133
Boolean "On/Off" Names 190
Bug Fixes 65
Bug Reporting Procedure 69
Buttons on a GDW 232

-C-
C70R 117
Calling other Programs 252
Cascade Control 429
Cascade Windows 173
Changing Instrument Names 102
Changing Screens 239
Changing Values Using Buttons 242, 244
Close SpecView from Button 251
Color Dynamics 54, 213
COM Port 277
COM Port Settings 100
Commandline options 91
CommsErrorCode - SpecView variable 184
Communications ports 277
Configuration Mode 284
Configuration mode shortcut - shift & Go Online Now! 284
Controlling from SpecView 132
Copying Drawing Objects 226
Copying one variable to another 242
Creating a New Instrument 99
CSV files 362

- D -
Data Entry 131
Data Entry - Date and Time 135
Data Entry - Decimal Places 132
Data Entry - Enumeration 133
Data Entry - Numeric 132
Data Entry - Text Strings 134
Data Log Files 359
Data Logging - Alarms 370
Data Logging - Definition 279
Data Logging - Events 373
Data Logging - Variables 357
Data Logging Rate 360
Date - SpecView variable 184
DDE (Dynamic Data Exchange) 349
DDE Application Name 349
DDE Read Example 354
DDE Status Topic 350
DDE Topic Name 350
DDEPoke Examples 352
Decimal Places 279
Decimal Places - Changing 102
Decimal Places - specifying for the Modbus Protocol 104
Decimal Places in Log Reports (CSV files) 369
Decimal point 279
Define a second GDW 524
Deleting old Log Files 359
Description 394
Disk Space for Logging 359
Dongle 19, 281
Dongle - Troubleshooting 281
Draw a trend chart 521
Drawing Irregular Shapes 227
Driver Commands 100
Dynamic Attributes 284

- E -
E12086 269
E12272 269
E12307 480
E12310 269
E12313 269, 485
E12314 269, 485
E12315 269, 485
E12331 487
E17022 269
Edit Links 218
Edit Mode 42
Edit/Review 395
Enable on Boolean - Strategy Controller 421
Entering Values 132
Error Code - 1460 272
Error Codes - Generic errors 272
Error Codes - Protocol Specific 273
Error Codes - Write errors 271
Error message numbers (E numbers) 269
Ethernet and TCP/IP 336
Europe Contact Numbers 499
Event Log 145
Event Logging 373
Event Type 421
Events - Show Event List 238
EVT - log file 373
Example - Automatic Log Report for the duration of a Ramp / Soak profile 408
Examples of Time Based Events 432
Examples of Value Based Events 427
Exit SpecView fro Button 251
Extruder Picture 177

- F -
FastCount - SpecView variable 184
FastCount - SpecView variable in detail 206
File Menu (Runtime) 141
Filling Graphics Objects with color 225
Fonts - Changing 229
For Instruments using the Modbus Protocol 104, 513
Full Screen Mode 268
Full Screen mode - getting out of 259
Future Development 63
Index

- **G** -
  GDW background color 166
  GDW Control - Close when swapping 238
  GDW Control - Closing 239
  GDW Control - Print Screen 239
  GDW Control - Swap to another GDW 239
  GDW Control - Toggle Full Screen Mode 240
  GDW Control - Zoom in 240
  GDW Control - Zoom Out 240
  GDW Setup 436
  GDWs - Graphical Display Windows 176
  Generic Modbus driver 99
  Getting data from SpecView DDE 350
  GoodComms - SpecView variable 184
  Grouping objects 223

- **H** -
  HC900 HCDesigner Modbus Map Import 109
  HC900 Redundant Controller 117
  Help for specific instruments 335
  Help Menu (Runtime) 149
  Historical Replay 375
  Historical Replay - Find Batch Number 377
  Historical Replay and ActiveX Controls 484
  Historical Replay Option 375
  History - Start Replay 240
  History Menu 144
  Honeywell C70R 117
  Honeywell HCDesigner 109

- **I** -
  IDX - log file 359
  Import Project 56
  Importing Graphics from other Programs 228
  Insert New Object 217
  Installation & Wiring 333
  Installing SpecView 75, 506
  Instrument 287
  Instrument Parameter Lists 249
  Instrument Settings 335
  Instrument View 287
  Instrument Views - Automatically 93
  Instrument Views on GDW's 102
  Internet Support 499

- **L** -
  Language Selection 59
  Line Writer 253
  LNM - log file 359
  Loading recipe problems 398
  Local 446
  LOG - log file 359
  Log files 359
  Log Report - Definition 288
  Log Report Format 366
  Log Report Setup 363
  Log Reports 362
  Log Reports - Specifying decimal places 369
  Log Reports from the Remote 365
  Logfile Conversion from the Remote 365
  Logging - access from button 242
  Logging - Alarms 370
  Logging - Convert Specific Log File Format 241
  Logging - Events 373
  Logging - On/Off 241
  Logging - Purge Log Files 242
  Logging Menu 144
  Logging Rate 360
  Logo's on GDW's 228
  LogRate - SpecView variable 184

- **M** -
  Manual Configuration 508
  Manually Defining Instruments 99
  Master Set-Points 242, 246
  Math Functions 246
  Mimos 533
  Minimum Requirements for Multiple Users 456
  Minimum Requirements for running SpecView 16
  Modbus 104, 335, 513
  Modbus PLC support 99
  Modbus TCP/IP 104, 513
  Modem 458
  Most Recent - SpecView variables for recipe 184
  Multiport Option 289
  Multiport Option 289
  Multiport Option 289
  Multiport Option 289
  Multiport Option 289
  Multiport Option 289
Remote Read & Write Access 446
Remote Support 499
Remotes Menu 146
Renaming Instruments 102
Re-Naming Variables 190
Replace (on Edit Menu) 158
Re-Sizing Bitmaps 229
Restore 87
Restore - Overwrite Configuration Warning 90
RS422/EIA422 335
RS485/EIA485 335
Running SpecView 91
Runtime 57
Runtime Functions (on Local) 454
Runtime Functions (on Remote) 453

- S -

Saving graphics objects 223
Scaling Variables 190
Scanning Barcodes 106
Screen background color 166
Screen Print 239
Scroll bars (Full Screen Mode) 268
Scroll bars (removing) 259
Scrollbars (Full Screen Mode) 268
Scrollbars (removing) 259
See how it works in Runtime mode 529
Select Tool 226
Selecting objects 223
Selecting Objects for Access 439
Selecting Variables to be Included in Recipe 389
Setting data into SpecView DDE 351
Setting the recipe download order 402
Setting up an Excel DDE Poke Example 352
Short List 178
Short List - Editing 190
Software Variables 184
Solid Color Objects 225
Source and Target Instruments 399
SpecView - Exit Program 251
SpecView - Maximise screen
   Restore Screen 252
SpecView - OPC Client 340
SpecView - Run External Program 252
SpecView - Write Line to file/printer 253
SpecView Command Line options 91
SpecView DDE Restrictions 350
SpecView Local 446
SpecView Networking 444
SpecView Networking - Setup 446
SpecView Networking via Modem - General 458
SpecView Remote 449
SpecView Variables 184
SpecView Variables - Pre-defined 184
SpecView Variables - User Defined 184
SpecView.FastCount Variable 206
Starting Historical Replay 240
Starting other Programs from SV 252
Startup 59
Strategy Controller - Definition 293
Strategy Controller Actions 427
Support - Internet 499
Supported OPC Servers 343
Switching to another screen 239
Symbol Library 286
SymbolLibrary 286

- T -

TCP/IP Autodetect 96
TCP/IP Modbus address 104
TeamViewer QuickSupport 499
Telnet 455
Test Comms for NEW Configuration 93
Test Comms For Update 59
Text Attributes 229
Text File Log Reports 362
Text Font 229
Text on a GDW 229
Tile Windows 173
Time - SpecView variable 184
Time Based Event Setup 424
Time Based Events
   Examples 432
Toggle 293
Tooltips 294
Touch screen support 16
Trend chart background color 232
Trend Charts 39, 232
Trend Charts - Creating 231
Trend Charts - Exact Values 139
Trend Charts - Runtime 139
Troubleshooting Instrument Communication 490
Troubleshooting the dongle 281

© 1995 - 2015 SpecView
- U -

UK Contact Numbers 499
Update Policies 68
Updating SpecView from a previous version 80
Upgrading SpecView - To add dongle options 25
URL 499
USA Contact Numbers 499
User Control 440
User Defined Variables 184

- V -

Value (Variable) Based Event Setup 421
Value Based Events
   Examples 427
Variable 294
Variable offset 190
Variable Properties 190
Variable Types 294
Variables List 44, 295
Vista 480

- W -

Web Server Option 295
Website 499
Window Menu 149
Windows 7 480
Windows compatibility 16
Windows filenaming rules 296
Windows Vista 480
Windows XP 16
Write error loading recipe 398
Writeable Variable 296
www.specview.com 499

- X -

XXX 490

- Z -

Zoom Menu (Runtime) 148