Using Watlow® Products with the Silver Series EM

Addendum to EZwarePlus Programming Manual

Operator Interface Terminals
# Table of Contents

Chapter 1: Introduction ........................................................................................................... 3
  Additional Resources ............................................................................................................ 3

Chapter 2: Communication Wiring ......................................................................................... 4
  Connecting via Modbus® RTU (232/485) ........................................................................... 4
  Connecting via Modbus® TCP (Ethernet) ........................................................................... 4

Chapter 3: Communication Basics .......................................................................................... 6
  Gateways, Controllers and PLCs .......................................................................................... 6
  Parameter Register Addresses ............................................................................................. 6
  Address Maps ....................................................................................................................... 7
  Choosing a Communication Driver ....................................................................................... 8
  Addressing Parameters in Multiple Controllers ............................................................... 9
  Address Offsets in Multi-Loop Controllers ........................................................................ 9
  Using EZ-ZONE RUI Gateways and RM Access Modules .............................................. 9
  Data Types .......................................................................................................................... 10
  Important Things to Know .................................................................................................. 10

Chapter 4: Programming Tutorials ......................................................................................... 11
  Create a First Project .......................................................................................................... 11
  Create a Popup Window .................................................................................................... 14
  Create a Meter in a Popup Window .................................................................................... 15
  Add a Numeric Display ...................................................................................................... 18
  Add Increment and Decrement Buttons ........................................................................... 20
  Add an Option List for Control Mode ............................................................................... 23
  Add a Button to Close the Popup Window ...................................................................... 25
  Edit the Startup Window ................................................................................................... 26
  Compile and Download the Project .................................................................................. 29
  Log Data .............................................................................................................................. 33
  Create a Graph .................................................................................................................... 38
  Use Recipes ........................................................................................................................ 42

---

WATLOW® and EZ-ZONE® are registered trademarks of Watlow Electric Manufacturing, Incorporated. Modbus® is a registered trademark of Schneider Automation, Incorporated.
Chapter 1: Introduction

Silver Series EM Operator Interface Terminals (OITs) are powerful human machine interfaces for equipment and processes. EZwarePlus is easy-to-use and flexible software for creating the windows, buttons, displays, gauges and other screen items with which operators interact on the OIT. The purpose of this addendum is to quickly get you up and running with the OIT and software when used with Watlow controllers.

Chapter 2: Communication Wiring provides the information needed to physically connect communication between a Silver Series EM OIT and Watlow products.

Chapter 3: Communication Basics provides the necessary information for using an OIT with Watlow controllers. Familiarity with these concepts is assumed in the tutorials that follow.

Chapter 4: Programming Tutorials walks you through establishing communication, creating user interfaces and using powerful features such as trending, data logging and recipes.

Additional Resources

In addition to this addendum the following resources are available for learning about Silver Series EM OITs and EZwarePlus programming software.

At [www.watlow.com](http://www.watlow.com) search for “EZware Software” to find the [EZwarePlus product page](http://www.watlow.com) for:

**EZwarePlus Software Download for Silver Series EM**—look for the “DOWNLOAD NOW” button.

**EZwarePlus Programming Manual**—under Related Documents expand Software and Demos.

**Silver Series Sample Projects**—under Related Documents expand Software and Demos.

**Silver Series Secrets video tutorial series**—under Related Documents expand Training and Education. Many of these were created for to the older EZware-5000, but they are still applicable.

**Silver Series Frequently Asked Questions**—under Related Documents expand Training and Education.

Also available at [www.watlow.com](http://www.watlow.com):

**EZ-ZONE ALL Modbus® register list in Excel**—search for “EZ-ZONE ALL”

**Watlow Silver Series EM Installation Guide**—search for the part number: 0600-0101-0000.
Chapter 2: Communication Wiring

Consult the Watlow Silver Series EM Installation Guide for detailed information on installing and wiring the OITs. This chapter provides important additional information regarding connecting to and communicating with Watlow controllers.

Connecting via Modbus® RTU (232/485)

The tables below indicate to which pins on the Silver Series EM OIT’s DB9 connectors the Watlow EZ-ZONE® screw terminals should connect.

Connecting via 485 2-wire

<table>
<thead>
<tr>
<th>Silver Series EM OIT</th>
<th></th>
<th>Watlow EZ-ZONE</th>
</tr>
</thead>
<tbody>
<tr>
<td>TS00-0043-EM00</td>
<td>TS00-0070-EM00</td>
<td>Watlow Cable¹</td>
</tr>
<tr>
<td>TS00-0043-EM0B</td>
<td>TS00-0070-EM0B</td>
<td>Watlow EZ-ZONE</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Function</th>
<th>COM1</th>
<th>COM3</th>
<th>COM1</th>
<th>COM3</th>
<th>Wire Color</th>
<th>Terminals</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>T-/R-</td>
<td>1</td>
<td>7</td>
<td>1</td>
<td>7</td>
<td>White/Brown</td>
<td>CA</td>
<td>T-/R-</td>
</tr>
<tr>
<td>T+/R+</td>
<td>2</td>
<td>8</td>
<td>2</td>
<td>8</td>
<td>Brown</td>
<td>CB</td>
<td>T+/R+</td>
</tr>
<tr>
<td>Common</td>
<td>5</td>
<td>5</td>
<td>5</td>
<td>9</td>
<td>Blue</td>
<td>CC</td>
<td>Common</td>
</tr>
</tbody>
</table>

¹ Supports COM1 only. Cable part number: 0219-0374-0000 for TS00-0070-EM00, TS00-0070-EM0B and TS00-0100-EM00 or part number 0219-0388-0000 for TS00-0043-EM00 and TS00-0043-EM00B

Connecting via 232

<table>
<thead>
<tr>
<th>Silver Series EM OIT</th>
<th></th>
<th>Watlow EZ-ZONE</th>
</tr>
</thead>
<tbody>
<tr>
<td>TS00-0043-EM00</td>
<td>TS00-0070-EM00</td>
<td>Watlow EZ-ZONE</td>
</tr>
<tr>
<td>TS00-0043-EM0B</td>
<td>TS00-0070-EM0B</td>
<td></td>
</tr>
<tr>
<td>TS00-0100-EM00</td>
<td>TS00-0100-EM00</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Function</th>
<th>COM1</th>
<th>COM1</th>
<th>Terminals</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>TXD</td>
<td>6</td>
<td>3</td>
<td>C2</td>
<td>RD</td>
</tr>
<tr>
<td>RXD</td>
<td>9</td>
<td>2</td>
<td>C3</td>
<td>TX</td>
</tr>
<tr>
<td>Common</td>
<td>5</td>
<td>5</td>
<td>C5</td>
<td>Common</td>
</tr>
</tbody>
</table>

Connecting via Modbus® TCP (Ethernet)

Using standard Ethernet cables connect the controller(s) and the Silver Series EM OIT to an Ethernet switch or connect the controller directly to the OIT.

Determining or Setting the OIT’s IP Address

If you connect the OIT to an Ethernet network in order to download programs or communicate with controllers via Ethernet, you must ensure the OIT has a unique IP address and you will need to know that address in order to communicate from your PC with the OIT.

To read or set the OIT’s IP address:

- Connect a USB mouse to the OIT, if desired.
- Apply power to the OIT.
- Once the OIT is powered up, point with the mouse or tap with your finger at the lower right corner of the OIT screen.
- On the menu bar click the setting button (the one with the gear icon).
• Enter the password. (By default this is 111111.)

• The IP address is listed in the System settings window on the Network tab. If Obtain an IP Address Automatically is selected, the IP Address is not editable. If you want to configure the OIT for a fixed address, select IP address get from below, and enter the IP address.

• Click OK to close the System settings window on the OIT.

Hints for using the Virtual Keyboard to enter the OIT password and IP addresses:

• It can take a few seconds for the Systems settings dialog with the password field to appear.

• If you do not see the Virtual Keyboard it may be minimized; click the keyboard icon on the menu bar.

• Make sure the cursor is in the Password or IP address field on the System Settings dialog.

• You can tell the password key strokes are being entered if you hear the key chirp from the OIT and see stars (******) appearing in the password field.

• If you cannot see the Password field, arrange the Virtual Keyboard and System Settings dialog then make sure the cursor is in the Password field.
Chapter 3: Communication Basics

The Silver Series EM OIT can communicate with Watlow controllers via Modbus® TCP or Modbus® RTU. This section defines terms you will encounter and provides information about Modbus® communication that will help you create a user interface with the Silver Series EM OIT for equipment and machines that include Watlow controllers.

Gateways, Controllers and PLCs

The Silver Series EM OIT can communicate with a variety of devices. Because many of these devices are Programmable Logic Controllers (PLCs), EZwarePlus refers to devices with which it communicates generically as “PLCs”. Don’t let this confuse you. When you are setting up the OIT to communicate with a Watlow product, from the OIT’s point of view the controller is a PLC.

This addendum refers to configuring the Silver Series EM OIT to communicate with “controllers”, but the instructions also apply to Watlow safety limits and gateways such as the EZ-ZONE® RUI Gateway.

Parameter Register Addresses

The Modbus® RTU and Modbus® TCP communication protocols assume that each device’s memory is organized in blocks of like-data. Each data block contains either read-only data or read/write data and either bit-size data or word-size (16-bit) data. For example, the Coils data block contains read/write bits and the Input Registers data block contains read-only words.

Within each of these data blocks there is a range of memory locations. The data blocks are often referred to by the first digit of their address range. For example, the Holding Registers are often referred to as, “the 4x registers”. The Modbus® standard defines both a numbering scheme and an addressing scheme for the memory locations in the data blocks. The table below illustrates this for the four most commonly discussed data blocks.

<table>
<thead>
<tr>
<th>Name</th>
<th>Number</th>
<th>Access</th>
<th>Data Size</th>
<th>Memory Location Numbers (Absolute)</th>
<th>Memory Location Addresses (Relative)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Coils</td>
<td>0x</td>
<td>Read/Write</td>
<td>1 bit</td>
<td>1 to 65,536</td>
<td>0 to 65,535</td>
</tr>
<tr>
<td>Discrete Inputs</td>
<td>1x</td>
<td>Read-Only</td>
<td>1 bit</td>
<td>100,001 to 165,536</td>
<td>0 to 65,535</td>
</tr>
<tr>
<td>Input Registers</td>
<td>3x</td>
<td>Read-Only</td>
<td>Word</td>
<td>300,001 to 365,536</td>
<td>0 to 65,535</td>
</tr>
<tr>
<td>Holding Registers</td>
<td>4x</td>
<td>Read/Write</td>
<td>Word</td>
<td>400,001 to 465,536</td>
<td>0 to 65,535</td>
</tr>
</tbody>
</table>

Because the location numbering scheme includes the data block number, it is helpful to think of it as an absolute address. The absolute address specifies the address completely or absolutely in that it says which data block and which address contains a piece of data. Because the location addresses do not include the data block number, it is helpful to think of them as relative addresses. They specify where to look relative to the starting point of the data block.

Some software and device manufacturers document the use of their products in terms of the numbering scheme while others use the addresses. In either case the manufacturer typically calls the numbers they
supply “the addresses.” So to use any two products together you need to know whether or not you have to convert the specified “address” in order to get the result you want.

EZwarePlus’s Modbus® drivers call the data block, “Device type” and for “Address” expect the memory location’s absolute address without the data block number. For example, to access a value in a holding register with absolute address 401,905, for Device type you select the data block “4x” and enter “1905” in the Address field. The following illustrates setting this address in EZwarePlus.

Watlow controllers use only the 4x registers. Therefore, you will set the Device type to 4x when accessing any parameter in a Watlow controller. Watlow manuals specify relative addresses. Therefore, you must add one (1) to an address found in a Watlow manual (other than this manual) before you enter it in EZwarePlus.

For example, the EZ-ZONE PM Integrated Controller Models User’s Manual lists the relative address for Heat Power as 1904. To monitor the heat power with the Silver Series EM OIT, you will add one (1) to the relative address and enter “1905” in the Address field in EZwarePlus.

In summary, when setting an address for a screen object to read or write from a Watlow controller:

- For the Device type select 4x.
- Set the Address to a value that is one greater than the relative Modbus® address listed in the Watlow controller manual.

**Address Maps**

Some EZ-ZONE products have user-selectable address maps. Select the desired map in the controller’s Setup page, Communication menu with the Data Map parameter. The Data Map affects the parameter addresses at which values are read and written. The Data Map setting applies to all the parameters in the controller. Generally Map 2 provides access to more parameters.
For example, the *EZ-ZONE PM Integrated Controller Models User’s Manual* lists Map1 and Map 2 addresses for Process Value for Analog Inputs 1 and 2. If the Data Map parameter is set to Map 1 then the Process Value for Analog Input 2 is read at address 441 (the listed address plus one), but if Data Map is set to Map 2 then the Process Value for Analog Input 2 is read at address 451. The address for the Process Value for Analog Input 1 is the same for Map 1 and Map 2.

<table>
<thead>
<tr>
<th>Display</th>
<th>Parameter name Description</th>
<th>Range</th>
<th>Default</th>
<th>Modbus Relative Address</th>
</tr>
</thead>
<tbody>
<tr>
<td>R in</td>
<td>Analog Input (1 to 2) Process Value</td>
<td>-1,999.000 to 9,999.000°F or units</td>
<td>-1,128.000 to 5,537.000°C</td>
<td>Instance 1 Map 1 Map 2 360 360 Instance 2 Map 1 Map 2 440 450</td>
</tr>
</tbody>
</table>

### Choosing a Communication Driver

When you create a project using EZwarePlus you select the drivers necessary to communicate with the Watlow controllers and any other devices with which the Silver Series EM OIT must communicate. For Watlow controllers, you select one of these drivers:

- **Modbus RTU Master**—used with Watlow controllers that support Modbus® RTU and communicate via RS-232 or RS-485.
- **Modbus TCP/IP Master**—used with Watlow controllers that support Modbus® TCP and communicate via Ethernet.

#### Using the Modbus® RTU Master Driver to Communicate via 485

When you set up the Silver Series EM OIT to communicate via 485, you add a *Modbus RTU Master* device to the device list in the System Parameter Settings. Only one driver is required for each COM port on the OIT to which controllers are connected. This is true regardless of the number of controllers that are connected to that 485 COM port. Think of the Modbus RTU Master device as a driver for the COM port not as a driver for the controllers themselves. That is why you choose the Modbus RTU *Master* driver rather than the Modbus RTU *Slave* driver. The controllers are slaves; the OIT’s COM port is the master.

#### Using the Modbus RTU Master Driver to Communicate via 232

When you set up the OIT to communicate via a 232 COM port, you add a *Modbus RTU Master* device to the device list in the System Parameter Settings. When using 232 on a COM port, only one controller can be connected to that port.

#### Using the Modbus TCP/IP Master Driver to Communicate via Ethernet

When you set up the OIT to communicate with controllers via Ethernet, you add one *Modbus TCP/IP Master* device to the device list in the System Parameter Settings dialog for *each* controller that has an IP address with which you will communicate. For example, for the OIT to communicate with three EZ-ZONE controllers via Ethernet, add three *Modbus TCP/IP Master* devices to the device list in the System Parameter Settings dialog, and configure each to communicate with one controller.
Addressing Parameters in Multiple Controllers

Normally the Silver Series EM OIT assumes that any register address you enter when communicating via Modbus® RTU is associated with the controller at the network address you set in the **PLC default station no** field in the **Device Properties** under the **System Parameter Settings**.

To read or write data from a register in another controller on a 485 network, enter the network address and register address separated by the number sign or hash mark (#). For example “3#2501” accesses register 2501 in the controller with the Modbus® network address 3.

Address Offsets in Multi-Loop Controllers

In controllers with more than one loop of control, more than one limit etc., there is more than one instance of each parameter for these duplicated functions. The manuals for controllers such as the EZ-ZONE RM, list the Modbus® address and an **offset** for these parameters. Add the offset to the address once to get the address of the second instance of the parameter, add it twice to get the third instance and so on.

For example, the address of the Heat Power for Loop 1 is listed in the EZ-ZONE RM manual as 2244 with an offset of 70. The following table lists the addresses of the Heat Power parameter for each of the four possible loops in the controller. The table also reminds you to add one (1) to the relative addresses from the controller manuals before entering the parameter address in EZwarePlus.

<table>
<thead>
<tr>
<th>Loop</th>
<th>Address + Offset(s)</th>
<th>Convert Relative Address</th>
<th>Enter in EZwarePlus</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>2224</td>
<td>2224 + 1</td>
<td>2225</td>
</tr>
<tr>
<td>2</td>
<td>2224 + 70</td>
<td>2294 + 1</td>
<td>2295</td>
</tr>
<tr>
<td>3</td>
<td>2224 + 70 + 70</td>
<td>2364 + 1</td>
<td>2365</td>
</tr>
<tr>
<td>4</td>
<td>2224 + 70 + 70 + 70</td>
<td>2434 + 1</td>
<td>2435</td>
</tr>
</tbody>
</table>

Using EZ-ZONE RUI Gateways and RM Access Modules

Multiple EZ-ZONE devices can communicate with the Silver Series EM OIT via one or more EZ-ZONE RUI Gateways or EZ-ZONE RM Access modules. When ordered with either the Modbus® TCP or Modbus® RTU communication option, each RUI Gateway or RM Access module allows a Silver Series EM OIT to communicate with up to 16 EZ-ZONE controllers without purchasing communication options for each controller.

In such a system the Silver Series EM OIT is connected to and configured to communicate with the gateway. The gateway presents itself as a single device on the Modbus® network; the OIT does not communicate with the controllers, only with the gateway. The gateway is configured by the user with an address offset for each controller connected to it. That address offset must be added to the parameter addresses for the controller.
For example, consider three EZ-ZONE PM controllers connected to an RUI Gateway configured with an offset of 0 for the first controller, 5000 for the second controller and 10,000 for the third controller. The table below indicates the addresses that must be entered in EZwarePlus to access the set point value in the three PM controllers.

<table>
<thead>
<tr>
<th>PM</th>
<th>Set Point</th>
<th>Plus Gateway Offset</th>
<th>Convert Relative Address</th>
<th>Enter in EZwarePlus</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>2172</td>
<td>2172 + 0</td>
<td>2172 + 1</td>
<td>2173</td>
</tr>
<tr>
<td>2</td>
<td>2172</td>
<td>2172 + 5000</td>
<td>7172 + 1</td>
<td>7173</td>
</tr>
<tr>
<td>3</td>
<td>2172</td>
<td>2172 + 10000</td>
<td>12172 + 1</td>
<td>12173</td>
</tr>
</tbody>
</table>

**Data Types**

The Silver Series EM OIT’s Modbus® drivers support a variety of data types. The Watlow manuals specify the data type of each parameter. However the terminology is not precisely the same. The table below correlates the data types indicated in the Watlow documentation with the data types you should select when configuring a screen object in EZwarePlus.

<table>
<thead>
<tr>
<th>EZ-ZONE User’s Manuals</th>
<th>EZ-ZONE ALL Modbus® List</th>
<th>EZwarePlus</th>
</tr>
</thead>
<tbody>
<tr>
<td>uint</td>
<td>Enumeration, Event, unsigned 8-bit, unsigned 16-bit, Wide Enumeration</td>
<td>16-bit Unsigned</td>
</tr>
<tr>
<td>dint</td>
<td>signed 32-bit</td>
<td>32-bit Signed</td>
</tr>
<tr>
<td>float</td>
<td>IEEE Float</td>
<td>32-bit Float</td>
</tr>
</tbody>
</table>

**Important Things to Know**

**Note:** Make sure the Modbus Word Order is set to *Word Low High* in the controller. That is the setting that works with the Silver Series EM OIT.

**Note:** Examples in this manual use the map 1 addresses. If the controller’s Data Map is set to 2, the examples may not work.

**Caution:** When using a multi-state switch object to set an enumerated parameter in a controller, each time the user clicks the switch, the setting selected by the switch is sent to the controller. When it is desirable to go directly from one setting to another without intermediate settings, use a set word object or an option list to set the parameter instead.
The following sections guide you through creating a first project using EZwarePlus and a Silver Series EM OIT that communicates with a Watlow controller.

### Create a First Project

The following procedure guides you through the process of configuring a Silver Series EM OIT to communicate with a Watlow Controller.

1) To launch EZwarePlus: on the Windows task bar click **Start**, click **All Programs**, click **Watlow**, click **EZwarePlus** and click **EZwarePlus**.

2) With **New** selected, click **OK**.

3) In the **Welcome to EZwarePlus** dialog, for **Model**, choose the OIT model you have.

4) For **Display Mode** choose **Landscape**.

5) Make sure **Use template** is selected.

6) Click **OK**.

---

**Note:** If you have previously created a project, that project will open. In that case from the **File** menu, choose **New** to create a blank project for this tutorial and to see the Welcome dialog.

**Note:** The TS00-0070-EM00, TS00-0070-EM0B and TS00-0100-EM00 are supported by the same driver.
7) In the **System Parameter Settings** dialog, under the **Device List**, click **New…**

8) For **PLC type**, choose the appropriate driver. See the table below.

9) For **PLC I/F**, choose the appropriate hardware interface. See the table below.

10) For **PLC default station no.**, type the controller’s address. Typically this is 1 for the first controller.

11) Click **Settings…**

<table>
<thead>
<tr>
<th>For part numbers like...</th>
<th>with...</th>
<th>For PLC type choose...</th>
<th>For PLC I/F choose...</th>
</tr>
</thead>
<tbody>
<tr>
<td>STxx-xxxx-xxxxx</td>
<td></td>
<td>Modbus® RTU</td>
<td>Modbus RTU Master</td>
</tr>
<tr>
<td>PMxxxxxxxx-1xxxxxxx</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>RMCxxxx-xxxxx1xx</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>RMHx-xxxx-x1xx</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>RMLx-xxxx-x1xx</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>RMSx-xxxx-x1xx</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>For part numbers like...</td>
<td>with...</td>
<td>For PLC type choose...</td>
<td>For PLC I/F choose...</td>
</tr>
<tr>
<td>-------------------------</td>
<td>---------</td>
<td>-----------------------</td>
<td>----------------------</td>
</tr>
<tr>
<td>PMxxxxx-2xxxxx</td>
<td>Modbus® RTU</td>
<td>Modbus RTU Master</td>
<td>RS-232 or RS-485 2W*</td>
</tr>
<tr>
<td>EZKx-2xxx-xxxx</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>RMAX-x2xx-xxxx</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>PMxxxxx-3xxxxx</td>
<td>Modbus® TCP</td>
<td>Modbus TCP/IP Master</td>
<td>Ethernet</td>
</tr>
<tr>
<td>EZKx-3xx-xxxx</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>RMAX-x3xx-xxxx</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Other Watlow Controllers</td>
<td>Modbus® RTU</td>
<td>Modbus RTU Master</td>
<td>RS-232 or RS-485 2W*</td>
</tr>
</tbody>
</table>

*Both 232 and 485 are available; choose the one to which you have connected the OIT.

12) For the Modbus RTU Master...
   - For **COM**, choose the communication port to which you have connected the controller. Typically this is COM 1.
   - For **Baud rate**, choose the rate that is set in the controller.
   - For **Data bits**, choose 8 Bits.
   - For **Parity**, choose None.
   - For **Stop bits**, choose 1 Bit.
   - For multiple controllers on the same port, for **Turn around delay (ms)**, enter 15.
   - Click **OK**.

13) For the Modbus TCP/IP Master...
   - For **IP address**, enter the IP address of the controller.
   - Click **OK**.

14) Click **OK** to close the Device Properties dialog.
15) To set up communication with controllers connected to other COM ports or to configure additional controllers communicating via Ethernet:

- Click New...
- Repeat from step 8 above.

16) Click OK to close the System Parameter Settings dialog.

17) Save the project:
- From the File menu, choose Save.
- In File name type First Project.emtp.
- Click Save.

Create a Popup Window

This example assumes you have created a project that is configured to communicate with a Watlow controller and that project is open in EZwarePlus.

1) From the Window menu, choose Open Window…

2) Click New…

3) Click Base Window.
4) Ensure the **Name** is *Window_011* and the **Window no.** is **11**.

5) Set **Width** to 420.

6) Set **Height** to 300 (272 for the 4.3 in. OIT).

7) To set the background color to white:
   - In the **Background** group, next to **Color** click ![Color](image).
   - Select the white color swatch.

8) In the **Popup window** group, set **Start pos. X** to 120 (0 for the 4.3 in. OIT).

9) In the **Popup window** group, set **Start pos. Y** to 120 (0 for the 4.3 in. OIT).

10) Click **OK**.

11) In the **Open Window** dialog, select Window_11.

12) Click **Open**.

13) From the **File** menu choose **Save**.

**Create a Meter in a Popup Window**

This example assumes you have created a popup window in a project that is configured to communicate with a Watlow Controller and that window is open in EZwarePlus.

1) From the **Objects** menu, choose **Meter Display**.

2) Click the **General** tab.

3) In **Comment** type *Heat Power*.

4) Click **Setting…**
5) For **PLC** choose the *Modbus Master* or *Modbus TCP/IP Master*.

6) For **Device type** choose 4x.

7) For **Address** enter the address of the heat power for your controller. See the table.

8) Select the data type in the field below the **Address** field. See the table.

9) Click **OK**.

<table>
<thead>
<tr>
<th>For this controller…</th>
<th>This parameter…</th>
<th>Enter this Address*…</th>
<th>Choose this Data Type…</th>
</tr>
</thead>
<tbody>
<tr>
<td>RMCxxxx-xxxxxxx</td>
<td>Heat Power</td>
<td>2245</td>
<td>32-bit Float</td>
</tr>
<tr>
<td>RMHx-xxxx-x1xx</td>
<td>Heat Power</td>
<td>4125</td>
<td>32-bit Float</td>
</tr>
<tr>
<td>PMxxxxx-xxxxxxx</td>
<td>Heat Power</td>
<td>1905</td>
<td>32-bit Float</td>
</tr>
<tr>
<td>STxx-xxMx-xxxx</td>
<td>Heat Power</td>
<td>237</td>
<td>32-bit Float</td>
</tr>
<tr>
<td>ST via RUI Gateway</td>
<td>Heat Power</td>
<td>1901</td>
<td>32-bit Float</td>
</tr>
<tr>
<td>Other Controllers</td>
<td>Heat Power</td>
<td>1901</td>
<td>32-bit Float</td>
</tr>
</tbody>
</table>

*These addresses have already been changed to the absolute form required for EZwarePlus by adding 1 to the value listed in the Watlow manual. Enter them as listed.*
10) Click the **Outline** tab.

11) In **Degree** set **Start degree** to 270.

12) In **Degree** set **End degree** to 90.

13) In **Background** uncheck **Full circle**.

14) In **Tick marks** check **Enable**.

15) For **Tick marks** **Color**, select black.

16) In **Tick marks** set **Main scale** to 6.

17) In **Tick marks** set **Sub scale** to 1.

18) In **Tick marks** set **Length** to 6.

19) Click the **Limits** tab.

20) Set **Min.** to 0.

21) Set **Max.** to 100.

22) In **Range limits** select **Enable**.

23) Set **Width** to 3.

24) Click **OK**.

25) Move the cursor with the outline of the meter to position it and click to place the meter in **Window_11**.

26) Resize the meter with the corner handles to make it smaller, if necessary.
27) Double-click the meter to open the **Meter Display Object’s Properties** dialog.

28) Click the **Profile** tab.

29) Set **X** to 140.

30) Set **Y** to 60.

31) Set **Width** to 140.

32) Set **Width (%)** to 100.

33) Click **OK**.

34) From the **File** menu choose **Save**.

---

**Add a Numeric Display**

This example assumes you have created a window in a project that is configured to communicate with a Watlow Controller and that window is open in EZwarePlus.

1) On the **Objects** menu, choose **Numeric**.

2) Click the **General** tab.

3) In **Description** type **Actual Closed Loop Set Point**.

4) For **PLC** choose **Modbus RTU Master** or **Modbus TCP/IP Master**.

5) For **Address** choose **4x** and enter the address of the Closed Loop Working/Active Set Point for your controller. See the table.

<table>
<thead>
<tr>
<th>For this controller…</th>
<th>This parameter…</th>
<th>Enter this Address*…</th>
<th>Choose this Data Type…</th>
</tr>
</thead>
<tbody>
<tr>
<td>RMCxxxx-xxxxxxx</td>
<td>Closed Loop</td>
<td>2513</td>
<td>32-bit Float</td>
</tr>
<tr>
<td>RMHx-xxxx-x1xx</td>
<td>Working/Active</td>
<td>5233</td>
<td>32-bit Float</td>
</tr>
<tr>
<td>PMxxxxx-xxxxxxx</td>
<td>Set Point</td>
<td>2173</td>
<td>32-bit Float</td>
</tr>
<tr>
<td>STxx-xxMx-xxxx</td>
<td>(Read Only)</td>
<td>204</td>
<td>32-bit Float</td>
</tr>
<tr>
<td>ST via RUI Gateway</td>
<td></td>
<td>2173</td>
<td>32-bit Float</td>
</tr>
<tr>
<td>Other Controllers</td>
<td>Consult the controller manual.</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

*These addresses have already been changed to the absolute form required for EZwarePlus by adding 1 to the value listed in the Watlow manual. Enter them as listed.
6) Click the **Format** tab.

7) In **Data format** set the data type. See the table.

8) On the **Font** tab set **Align** to **Right**.

9) Click **OK**.

```
<table>
<thead>
<tr>
<th>For this controller…</th>
<th>This parameter…</th>
<th>Enter this Address*</th>
<th>Choose this Data Type…</th>
</tr>
</thead>
<tbody>
<tr>
<td>RMCxxxx-xxxxxxx</td>
<td>Closed Loop Working/Active Set Point (Read Only)</td>
<td>2513</td>
<td>32-bit Float</td>
</tr>
<tr>
<td>RMHx-xxxx-x1xx</td>
<td></td>
<td>5233</td>
<td>32-bit Float</td>
</tr>
<tr>
<td>PMxxxx-xxxxxxx</td>
<td></td>
<td>2173</td>
<td>32-bit Float</td>
</tr>
<tr>
<td>STxx-xxMx-xxxx</td>
<td></td>
<td>204</td>
<td>32-bit Float</td>
</tr>
<tr>
<td>ST via RUI Gateway</td>
<td></td>
<td>2173</td>
<td>32-bit Float</td>
</tr>
</tbody>
</table>

Other Controllers Consult the controller manual.
```

*These addresses have already been changed to the absolute form required for EZwarePlus by adding 1 to the value listed in the Watlow manual. Enter them as listed.

10) Move the cursor with the outline to position the display field and click to place it.

11) Adjust the size of the field as needed.

12) From the **File** menu choose **Save**.
Add Increment and Decrement Buttons

This example assumes you have created a window in a project that is configured to communicate with a Watlow Controller and that window is open in EZwarePlus.

To add a button that increments the set point:

1) On the Objects menu, click Button then choose Set Word.
2) Click the General tab.
3) In Comment type Increment Set Point.
4) For PLC choose Modbus RTU Master or Modbus TCP/IP Master.
5) Click Settings…
6) For Device type choose 4x.
7) For Address enter the address of the User Set Point for your controller.
8) Select the data type for the parameter in the field below the Address field.
9) Click OK.
10) In Attribute for Set Style choose Press and hold increment (JOG++).
11) Set Inc. value to 1.
12) Set Upper Limit to 100 or a value that is safe for your controller’s set point.
13) Set JOG delay to 0.5 seconds.
14) Click the Shape tab.
15) Check Use shape.
16) Click **Shape Library…**

17) Click the new library icon **Select Lib…**

18) In the EZwarePlus program’s library directory (typically: C:\Watlow\EZPlus\library) select **Arrows 1.plb**.

19) Click **Open**.

20) Locate the button with the triangular arrow pointing up and click it.

21) Click **OK** to close the **Shape Library**.

22) Click **OK** to close the **New Set Word Object** dialog.

23) Click to place the button.

24) Use the handles to adjust the size of the button.

25) Drag the button to place it as desired on the screen.

26) From the **File** menu choose **Save**.
To add a button that decrements the set point:

1) Click the **increment** button to select it.

2) From the Edit menu, choose **Copy**.

3) From the Edit menu, choose **Paste**.

4) Drag the new button to an appropriate position.

5) Double click the new button to edit its properties.

6) On the General tab change:
   - **Comment** to Decrement Set Point
   - **Set Style** to Press and hold decrement (JOG--).

7) Set **Bottom Limit** to 0.

8) On the Shape tab click **Shape Library**…

9) Locate the button with the triangular arrow pointing down and click it.

10) Click **OK** to close the Shape Library.

11) Click **OK** to close the Set Word Object Properties dialog.

12) From the File menu choose **Save**.
Add an Option List for Control Mode

This example assumes you have created a window in a project that communicates with a Watlow Controller and that window is open in EZwarePlus.

1) On the Objects menu, click Button then choose Option List.

2) Click the Option list tab.

3) In Comment type Control Mode.

4) Set Mode to Drop-down list.

5) Set Item No. to 3.

6) In the Monitor address group:
   - For PLC name choose Modbus RTU Master or Modbus TCP/IP Master.
   - Click Settings…
   - For Device type choose 4x.
   - In Address enter the address of the Control Mode. See the table.
   - Select the data type in the field below the Address field.
   - Click OK to close the Address dialog.

<table>
<thead>
<tr>
<th>For this controller…</th>
<th>This parameter…</th>
<th>Enter this Address*…</th>
<th>Choose this Data Type…</th>
</tr>
</thead>
<tbody>
<tr>
<td>RMCxxxx-xxxxxxx</td>
<td>Control Mode</td>
<td>2221</td>
<td>16-bit Unsigned</td>
</tr>
<tr>
<td>RMHx-xxxx-x1xx</td>
<td></td>
<td>4101</td>
<td>16-bit Unsigned</td>
</tr>
<tr>
<td>PMxxxxx-xxxxxxx</td>
<td></td>
<td>1881</td>
<td>16-bit Unsigned</td>
</tr>
<tr>
<td>STxx-xxMx-xxxx</td>
<td></td>
<td>222</td>
<td>16-bit Unsigned</td>
</tr>
<tr>
<td>ST via RUI Gateway</td>
<td></td>
<td>1881</td>
<td>16-bit Unsigned</td>
</tr>
<tr>
<td>Other Controllers</td>
<td>Consult the controller manual.</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

*These addresses have already been changed to the absolute form required for EZwarePlus by adding 1 to the value listed in the Watlow manual. Enter them as listed.
7) Click the **Mapping** tab.

8) In the **Values** column type the numeric values and in the **Item data** the text that corresponds to each option you want to include. See the table.

9) Click **OK** to close the **New Option List Object** dialog.

<table>
<thead>
<tr>
<th>Item</th>
<th>Value</th>
<th>Item Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>10</td>
<td>Auto</td>
</tr>
<tr>
<td>1</td>
<td>54</td>
<td>Manual</td>
</tr>
<tr>
<td>2</td>
<td>62</td>
<td>Off</td>
</tr>
<tr>
<td>3 (error)</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

10) Position the cursor near the bottom center of the window layout and click to place the multi-state switch. (You may have to move the other objects around to fit everything.)

11) From the **File** menu choose **Save**.
Add a Button to Close the Popup Window

This example assumes you have created a window in a project that communicates with a Watlow Controller and that window is open in EZwarePlus.

1) On the **Objects** menu, click **Button** then choose **Function Key**.

2) On the **General** tab, in **Comment** type *Close Window*.

3) Select **Close window**.

4) On the **Shape** tab, uncheck **Use shape**.

5) Check **Use picture**.

6) Click **Picture Library**…

7) Click the **Library** tab.

8) Click the new library icon

9) Select **Computer.flb**.

10) Click **Open**.

11) Locate the round grey button with the white x and click to select it.

12) Click **OK** to close the **Picture Library**.

13) On the **Label** tab, make sure **Use label** is not checked.

14) Click **OK** to close the **New Function Key Object** dialog.

15) Click to place the function key in the upper right.

16) Double-click the function key to open the **Function Key Object’s Properties** dialog.
17) Click the Profile tab
18) Set Position X to 375.
19) Set Position Y to 5.
20) Set Size Width to 32.
21) Set Size Height to 32.
22) Click OK.
23) From the File menu choose Save.

**Edit the Startup Window**

This example assumes you have created a popup window open in EZwarePlus in a project that is configured to communicate with a Watlow Controller.

**To add text to the start up window:**

1) From the Window menu, choose WINDOW_010.

2) From the Draw menu choose Text.

3) Set these text Attributes:
   - Choose a Font.
   - Set Color to white.
   - Set Size to 14.
   - Set Align to Left.

4) Edit Content to read, *This is the Startup Screen.*

5) Click OK.

6) Position the cursor centered in the top third of the window layout and click to place the text.

7) From the File menu choose Save.
Add a Numeric Display to the main window:

1) From the **Objects** menu, choose **Numeric**.

2) Click the **General** tab.

3) In **Description** type **Process Value**.

4) Deselect **Allow input**.

5) For **PLC** choose **Modbus RTU Master** or **Modbus TCP/IP Master**.

6) For **Address** choose 4x and enter the address of the Analog Input 1 Process Value. See the table.

7) Click the **Format** tab.

8) In **Data format** set the data type.

9) Set **Right of decimal Pt.** to 1.

10) On the **Font** tab set **Align** to **Right**.

11) Click **OK**.

12) Move the cursor with the outline to position the display field in the center of the screen and click to place it.

13) From the **File** menu choose **Save**.
To create a function key on Window10:

1) On the **Objects** menu, click **Button** then choose **Function Key**.

2) On the **General** tab, in **Comment** type *Loop 1 Settings*.

3) Select **Display popup window**.

4) For **Style** choose **No title bar**.

5) For **Window no.** select *11. Window_011*.

6) Click the **Shape** tab.

7) Deselect **Use picture**.

8) Select **Use shape**.

9) Click **Shape Library…**

10) In the **Library** list select **button1**.

11) Click one of the buttons to select it.

12) Click **OK** to close the **Shape Library**.

13) Click the **Label** tab.

14) Select **Use label**.

15) Set **Color** to black.

16) Set **Size** to **16**.

17) Set **Align** to **Left**.

18) In **Content** type *Loop 1*.

19) Click **OK**.
20) Position the cursor and click to place the function key.

21) From the **File** menu choose **Save**.

---

**Compile and Download the Project**

This example assumes you have a project that is ready to compile and load into an OIT.

**To compile the project:**

1) From the **Tools** menu, choose **Compile**.

2) Click **Compile**.

3) After the project is compiled, click **Close**.
To download via Ethernet:

1) Determine the OIT’s IP address:
   - If you don’t already know the OIT’s IP address, follow the instructions in *Determining or Setting the OIT’s IP Address* on page 4, note the IP address for use below.

2) In EZwarePlus from the Tools menu, choose Download.

3) In the IP field select or enter the OITs IP address.

4) Check Runtime, if not already checked.

5) Check Reboot HMI after download, if not already checked.

6) Click Download.

7) Once the download is complete, click Exit.
To download the project via a USB drive to an OIT:

1) Connect a USB drive to the PC

2) From the Tools menu choose Build Data for USB Disk or SD Card Download…

3) Click Browse…

4) Locate and select the USB drive. 

   Note: Do not select a sub-directory of the USB drive. Select the root.

5) Click OK to close the Browse For Folder dialog.

6) Click Build.

7) When the files are transferred successfully, click OK.

8) Click Exit to close the USB Disk/CF Card/SD Card Data dialog.

9) Remove the USB drive from the PC.
To download the from the USB drive to the OIT:

1) Connect the USB drive to the OIT.

2) When the Download/Upload screen appears on the OIT click Download.

Note: You only have a few seconds to do this before the screen times out. If you miss it, disconnect the USB drive and connect it again.

3) With the Virtual Keyboard enter the Password. (By default this is 111111.)

4) On the Download Settings dialog make sure Download Project Files is checked.

5) Click OK.

6) In the Pick a Directory dialog expand the usbdisk folder by clicking the plus (+) next to it.

7) Select the disk_a_1 folder.

Note: The OIT represents the USB drive with a folder icon and a name it assigns such as disk_a_1. You can inspect the contents to be sure you pick the right one. The compiled project is in a directory called mt8000ie, but be sure to select the USB drive not a sub folder before proceeding.

8) Click OK.

9) Once the project downloads and runs, you can remove the USB drive from the OIT.
Log Data

This example assumes you have a project with at least one controller.

There are two steps to log data with the OIT:

- Copy data from the controller to contiguous local OIT memory with the Data Transfer (Time-based) object—this is necessary only if you want to log more than one parameter in the same file or show multiple parameters together in a Trend Display (graph) or a History Data Display (table).
- Create a data log with the Data Sampling object.

Note: This example uses specific addresses internal to the OIT. If you have used one or more of these for other purposes you will have to choose appropriate addresses for your project.

To copy data to the OIT’s local memory:

1) From the Objects menu choose Data Transfer.

Note: Do not choose the Data Transfer (Trigger-based) option.

2) For each item to be logged in the file:
   - Click New…

   ![Data Transfer](image)
• In **Comment** type a description of the data to be copied such as “PV 1”.

• For **Address type** choose **Word**.

• For **Interval** choose a value that is the same as or less than the amount of time you want between data samples.

• In **No. of word** type word size of the parameter’s data type. See table.

• For **Source address PLC** choose **Modbus RTU Master** or **Modbus TCP/IP Master**.

• For **Source address device type** choose **4x**.

• In **Source address Address** type the address of the parameter to be logged.

<table>
<thead>
<tr>
<th>Data Type</th>
<th>No. of word</th>
</tr>
</thead>
<tbody>
<tr>
<td>Float</td>
<td>2</td>
</tr>
<tr>
<td>16-bit integer</td>
<td>1</td>
</tr>
<tr>
<td>32-bit integer</td>
<td>2</td>
</tr>
</tbody>
</table>

• **For this controller**

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Enter this Address*</th>
<th>Choose this Data Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>RMCxxxx-xxxxxxx</td>
<td>361</td>
<td>32-bit Float</td>
</tr>
<tr>
<td>RMHx-xxxx-x1xxx</td>
<td>381</td>
<td>32-bit Float</td>
</tr>
<tr>
<td>PMxxxxxx-xxxxxxx</td>
<td>361</td>
<td>32-bit Float</td>
</tr>
<tr>
<td>STxx.xxMx-xxxx</td>
<td>20</td>
<td>32-bit Float</td>
</tr>
<tr>
<td>ST via RUI Gateway</td>
<td>361</td>
<td>32-bit Float</td>
</tr>
<tr>
<td>Other Controllers</td>
<td>Consult the controller manual.</td>
<td></td>
</tr>
</tbody>
</table>

*These addresses have already been changed to the absolute form required for EZwarePlus by adding 1 to the value listed in the Watlow manual. Enter them as listed.

• **For Destination address PLC** choose the OIT (“Local HMI” by default).

• **For Destination address device type** choose **LW**.

• **In Destination address Address** type the local address at which to save the data to be logged.

**Note:** Pick a range of addresses with room to store all the data that must be displayed. For example, use 200 for the first parameter to be logged then for each additional parameter increment the address by the size in words of the previous data. For example, typically you log floats such as process variables and set points which each require two words to store. In that case if the first process variable is copied to 200, set the next parameter to copy to 202 so on. In this example, a process variable, a set point and the heat output power are logged.

• **Click OK.**
3) Click Exit to close the Data Transfer (Time-based) Object window.

To set up data sampling to log the data:

1) On the Objects menu, click Data Logging then choose Data Sampling.

2) Click New…

3) In Comment type a description for the set of data such as “Loop 1”.

4) For Sampling mode choose Time-based.

5) For Sampling time interval choose the time between samples.

6) For Read address PLC name choose the OIT (“Local HMI” by default).

7) For Read address device type choose LW.
8) In **Address** type the first address to which data was copied. In the example, this is 200.

9) In **Max. data records** type the number of records to save in a file.

10) Click **Data Format…**

11) For each item to be logged in the file:

   - Click **New…**

   - For **Data type** choose the data type of the item being logged. Typically 32-bit Float).

   - In **Comment** Enter a description for the item to be logged, for example “PV 1”.

   - Click **OK**.

12) Click **Exit** to close the Data Format window.

13) In the **History Files** group check one or more locations to which to save the data (Save to USB disk or Save to HMI memory).

14) In **Folder name** type a name for the folder in which the data log file should be created such as “datalog”.
15) Click **OK** to close the **Data Sampling Object** setup window.

16) Click **Exit** to close the **Data Sampling Object** window.
Create a Graph
This example assumes you have a project with at least one controller and that you have previously configured a time-based data sampling object.

To create and open a window to use for the trend.
1) From the **Window** menu, choose **Open Window**.
2) Click **New…**
3) Click **Base Window**.
4) In **Name** type **Trend**.
5) Click **OK**.
6) In the Window list select **Trend**.
7) Click **Open**.

To create buttons to open the Trend window and return to the first window:
1) Select window 10.
2) Select the function key on that screen by clicking it once.
3) From the **Edit** menu, choose **Copy**.
4) From the **Edit** menu, choose **Paste**.
5) Place the copy next to the original.
6) Double-click the copy to open the **Function Key Object’s Properties** window.
7) Edit the Comment to read Trend Graph Window.
8) Choose Change full-screen window.
9) For Window no. choose 12. Trend.
10) Click the Label tab.
11) Edit the Content to read Trend.
12) Click OK to close the Function Key Object’s Properties window.
13) If necessary, select the function key by clicking it.
14) From the Edit menu, choose Copy.
15) Select window 12 Trend.
16) From the Edit menu, choose Paste.
17) Position the button centered at the bottom of the screen.
18) Edit the new button’s properties so that it changes to full-screen WINDOW_010 and is labeled “Back”.

To create a trend graph:
1) On the Objects menu point to Data Logging and choose Trend Display.
2) In Comment type a description of the trend such as “Loop 1 PV, SP and Heat vs. Time”.
3) For Data Sampling Object index choose the data sampling object you previously configured.
4) For **Trend type** choose **Real-time**.

5) For **Distance between data samples/X axis time range** choose **Time**.

6) In **Distance** type the number of seconds the width of the trend graph will represent. For example, if you want to see two minutes of data at once, type 120.

7) Click the **Trend** tab.

8) Choose a **Frame** color and a **Background** color.

9) Click the **Channel** tab.

10) For each channel to be graphed:
    - In the Data sampling object group check **Display**.
    - For **Color** choose a color that contrasts with the background color.
    - In **Min** type the value that should be graphed at the bottom of the y-axis.
    - In **Max** type the value that should be graphed at the top of the y-axis.

11) Click **OK**.

**Note:** Keep in mind that while you can choose a different min and max for each pen, you don’t want to confuse users, so it may be best to graph all the channels against the same min and max values.
12) Place and size the trend object.

13) **Optional:** In the Trend Display Object’s Properties dialog Trend tab enable the Grid and set it up to display the time.

14) **Optional:** Use the Scale tool to add a scale and labels with the Text tool. Color coordinate these or add a legend if the trend channels don’t all have the same zero and span.
Use Recipes

This example assumes you have a project with at least one controller in which the recipe memory has not already been used for something else.

In this example we will create a recipe that has five parameters from one controller. For each parameter we will create a data transfer object that saves the parameter’s value in the recipe in the OIT. For these objects the source addresses are the parameters’ Modbus® addresses in the controller and the destination addresses are RW (recipe word) addresses in the OIT. See the table.

Note: This example uses specific addresses internal to the OIT. If you have used one or more of these for other purposes you will have to choose appropriate addresses for your project.

To create a recipe window and link it to the other screens:
1) Create and open a window to use for viewing, saving and loading recipes called “Recipe Manager”.
2) Create a button on WINDOW_010 that opens the Recipe Manager window.
3) Create a button on the Recipe Manager window that opens window 10.

Note: Refer to the Trend example if necessary.

Repeat the following steps to add a data transfer object to the Recipe Manager screen for each parameter you want to save in a recipe. Refer to the table below for addresses etc.:

<table>
<thead>
<tr>
<th>Parameter</th>
<th>“Source” Address in Controller</th>
<th>Size in Words</th>
<th>“Destination” Recipe Address</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>RMC</td>
<td>RMH</td>
<td>PM</td>
</tr>
<tr>
<td>Closed Loop Set Point</td>
<td>2501</td>
<td>5221</td>
<td>2161</td>
</tr>
<tr>
<td>Alarm High Set Point</td>
<td>1741</td>
<td>2661</td>
<td>1481</td>
</tr>
<tr>
<td>Heat Proportional Band</td>
<td>2231</td>
<td>4111</td>
<td>1891</td>
</tr>
<tr>
<td>Integral</td>
<td>2235</td>
<td>4115</td>
<td>1895</td>
</tr>
<tr>
<td>Derivative</td>
<td>2237</td>
<td>4117</td>
<td>1897</td>
</tr>
</tbody>
</table>

*ST via RUI Gateway

1) From the Objects menu choose Data Transfer (Trigger-based).
2) In Comment type “Recipe Save:” and the name of the name of the parameter (such as “Loop 1 Set Point”).
3) In Source address for PLC choose Modbus RTU Master or Modbus TCP/IP Master.
4) In Source address choose 4x and enter the address of the parameter.
5) In Destination address for PLC choose the OIT (Local HMI by default).
6) In Destination address click Settings…
7) For Device type choose RW to store recipes in the battery backed up recipe word memory.
8) In **Address** type 0 for the first item in the recipe (Increment this by the previous item’s *No of words* for each subsequent recipe item. For example, if the first item was a 16-bit integer, the address of the second item is 1. If the second item is a float, the address of the third item is 3.)

9) If you want to store more than one recipe:
   - Check **Index register**.
   - For **Index** choose *INDEX 0 (16-bit)*.

10) Click **OK** to close the **Address** dialog

11) In **No. of words** type word size of the parameter’s data type. See Table

<table>
<thead>
<tr>
<th>Data Type</th>
<th>No. of words</th>
</tr>
</thead>
<tbody>
<tr>
<td>Float</td>
<td>2</td>
</tr>
<tr>
<td>16-bit integer</td>
<td>1</td>
</tr>
<tr>
<td>32-bit integer</td>
<td>2</td>
</tr>
</tbody>
</table>

12) For **Mode** choose **External Trigger**.

13) In **Trigger address** for **PLC** choose the OIT (*Local HMI by default*).

14) In **Trigger address** choose *LB* to use an internal bit to cause the OIT to store values in a recipe.

15) In **Trigger address** for **Address** type 500.

16) Click the **Label** tab.

17) Select **Use label**.

18) Set **State** to 0.

19) In **Content** type the name of the parameter.

20) Click **OK**.

21) Place the Data Transfer (Trigger-based) object on the screen.

**Repeat the following steps to create the data transfer items that will load recipes in to the controller:**

**Note:** For the data transfer objects that load the recipe from the OIT to the controller, the source addresses are RW (recipe words) addresses in the OIT and the destination addresses are the parameters’ Modbus® addresses in the controller.
### Addendum to EZwarePlus Programming Manual

<table>
<thead>
<tr>
<th>Parameter</th>
<th>“Source” Recipe Address</th>
<th>Size in Words</th>
<th>“Destination” Address in Controller</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td>RMC</td>
</tr>
<tr>
<td>Closed Loop Set Point</td>
<td>0</td>
<td>2</td>
<td>2501</td>
</tr>
<tr>
<td>Alarm High Set Point</td>
<td>2</td>
<td>2</td>
<td>1741</td>
</tr>
<tr>
<td>Heat Proportional Band</td>
<td>4</td>
<td>2</td>
<td>2231</td>
</tr>
<tr>
<td>Integral</td>
<td>6</td>
<td>2</td>
<td>2235</td>
</tr>
<tr>
<td>Derivative</td>
<td>8</td>
<td>2</td>
<td>2237</td>
</tr>
</tbody>
</table>

*ST via RUI Gateway

1) From the **Objects** menu choose **Data Transfer (Trigger-based)**.

2) In **Comment** type “Recipe Load:” and the name of the parameter (such as “Loop 1 Set Point”).

3) In **Source address** for **PLC** choose the OIT.

4) In **Source address** choose *RW* and type the recipe address for the item.

5) If you set up the recipe save to use and index register:
   - Click **Source address Settings…**
   - Check **Index register**
   - For **Index** choose **INDEX 0 (16-bit)**.
   - Click **OK** to close the **Address** dialog.

6) In **No. of word** type word size of the parameter’s data type.

7) In **Destination address** for **PLC** choose **Modbus RTU Master** or **Modbus TCP/IP Master**.

8) In **Destination address** for **Address** choose **4x** and enter the controller address of the parameter.

9) For **Mode** choose **External Trigger**.

10) In **Trigger address** for **PLC** choose the OIT (**Local HMI** by default).

11) In **Trigger address** for **Address** choose **LB** to use an internal bit to cause the OIT to load recipe values in to a controller and type 501.
12) Click the **Label** tab.

13) Select **Use label**.

14) Enter the name of the parameter to display.

15) Click **OK**.

16) Place the Data Transfer (Trigger-based) object on the screen.

To create a button to trigger the data transfer objects to copy the values currently in the controller to the corresponding recipe memory in the OIT:

1) On the **Objects** menu, point to **Button** and choose **Set Bit**.

2) In **Comment** type, “Save Recipe”.

3) For **PLC** choose the OIT (**Local HMI** by default).

4) For **Address** choose **LB** and type **500**.

5) For **Set style** choose **Momentary**.

6) Click the **Label** tab.

7) Select **Use label**.

8) In **Content** for state 0 type “Save to OIT”.

9) Click **OK**.

10) Place the button.

To create a button to trigger the data transfer objects to copy the values currently in the OIT’s recipe memory to the controller:

1) On the **Objects** menu, point to **Button** and choose **Set Bit**.

2) In **Comment** type “Load Recipe”.

3) For **PLC** choose the OIT (**Local HMI** by default).

4) For **Address** choose **LB** and type **501**.

5) For **Set style** choose **Momentary**.

6) Click the **Label** tab.

7) Select **Use label**.
8) In **Content** for state 0 type “Load from OIT”.

9) Click **OK**.

10) Place the button.

**Note:** Using pictures for buttons may help operators.

**Optional:** To see what you are copying from the controller to the OIT’s recipe memory, create an object displaying the current value in the controller next to each Data Transfer (Trigger-based) object. Create a label that indicates what the fields are such as “Current Controller Values”.

**Optional:** To see or edit directly what is saved in recipe memory create a data entry object for each recipe item. These objects should display the values of the data in the RW memory at the recipe addresses. Create a label that indicates what the fields are such as “Recipe Values”.

**Optional:** The values in the RW addresses are automatically saved in non-volatile memory every five minutes, but adding a button that momentarily sets LB-9029 forces the values to be saved and can avoid lost data in the event the power is shut off too soon after editing a recipe.

**Optional:** If you want to store more than one recipe in the OIT, set up the data transfer objects to use indexing for the RW addresses.
Address indexing allows a screen object to display and set the value of different memory locations depending on the value in the index. In this example we use LW-9200 as the address index. Whatever value the index is set to is added to the address in the data transfer (and recipe display) objects. When the index value is zero, the first recipe is used. When the index is 10 the second recipe is used. When the index is 20 the third recipe is used. A multi-state switch is used to set the value of the index when the user selects the recipe.

**Data Transfer Objects**
- **Data Transfer Object 1** (Lp 1 Set Point) Address = RW 0 + index
- **Data Transfer Object 2** (Lp 1 Hi Alarm) Address = RW 2 + index
- **Data Transfer Object 3** (Lp 1 Heat PB) Address = RW 4 + index
- **Data Transfer Object 4** (Lp 1 Integral) Address = RW 6 + index
- **Data Transfer Object 5** (Lp 1 Derivative) Address = RW 8 + index

**Recipe Selector**
- Multi-State Switch
  - Address = LW 9200
  - "Recipe 1" = State 0 = 0
  - "Recipe 2" = State 1 = 10
  - "Recipe 3" = State 2 = 20

**Recipe 1** (index = 0)
- RW 0: (Lp 1 Set Point)
- RW 2: (Lp 1 Hi Alarm)
- RW 4: (Lp 1 Heat PB)
- RW 6: (Lp 1 Integral)
- RW 8: (Lp 1 Derivative)

**Recipe 2** (index = 10)
- RW 10: (Lp 1 Set Point)
- RW 12: (Lp 1 Hi Alarm)
- RW 14: (Lp 1 Heat PB)
- RW 16: (Lp 1 Integral)
- RW 18: (Lp 1 Derivative)

**Recipe 3** (index = 20)
- RW 20: (Lp 1 Set Point)
- RW 22: (Lp 1 Hi Alarm)
- RW 24: (Lp 1 Heat PB)
- RW 26: (Lp 1 Integral)
- RW 28: (Lp 1 Derivative)

**Note:** You can also use the address index to create one screen that displays data for one loop at a time with a multi-state switch or option list that allow users to switch from one loop to another.
To select the recipe to save to or load from create a multi-state switch to select the recipe as follows:

1) On the **Objects** menu point to **Buttons** and choose **Multi-State Switch**.

2) In **Comment** type “Recipe Selector”.

3) In **Read address** click **Settings**…

4) For **PLC** choose the OIT (Local HMI by default).

5) Check **System tag**.

6) For **Device type** choose **LW-9200 (16bit) : address index 0**.

7) Click **OK** to close the **Address** dialog.

8) In **Attribute** for **Switch style** choose **JOG+**.

9) For **No. of states** choose the number of recipes you want to store.

10) For **Cyclical** choose **Enable**.

11) Select **User-defined mapping**.
12) In **Attribute** click **Settings**…

13) For each state enter the appropriate offset **Value**. For state 0 enter 0. For state 1 enter a value that will offset the beginning of the second recipe beyond the end of the first in the recipe memory.

14) Click **OK** to close the **Mapping** window.

**Note:** The first recipe is selected with the multi-state switch in its state 0. This recipe stores its values in the memory locations you entered in the data transfer objects with no offset from address indexing, so for state 0 the Value is 0. Calculate the minimum offset for the second recipe by finding the sum of the number of words in memory used to store the items in one recipe. The second recipe (state 1 for the multi-state switch) should set the offset to this sum. The third recipe (state 2) should set the offset to twice the sum. The fourth recipe (state 3) should set the offset to three times the sum. And so on.

15) Click the **Label** tab.

16) Select **Use label**.

17) In **Content** enter a label indicating which recipe is selected. (For state 0 type “Recipe 1”, for state 1 type “Recipe 2” etc.)

18) Click **OK** and place the Multi-State Switch object on the screen.

**To create a button to save the recipes in non-volatile memory:**

1) On the **Objects** menu point to **Buttons** and choose **Set Bit**.

2) In **Comment** type “Save Recipes”.

3) In **Write address** click **Settings**…

4) For **PLC** choose the OIT (Local HMI by default).

5) Check **System tag**.

6) For **Device type** choose **LB-9029 : save all recipe data to machine (set ON)**.

7) Click **OK** to close the **Address** dialog.

8) For **Set style** choose **Momentary**.

9) Click the **Label** tab.

10) Select **Use label**.

11) In **Content** enter, “Save Recipes”.

12) Click **OK** and place the Set Bit object on the screen.
How to Reach Us

Corporate Headquarters
Watlow Electric Manufacturing Company
12001 Lackland Road
St. Louis, MO 63146
Sales: 1-800-WATLOW2
Manufacturing Support: 1-800-4WATLOW
Email: info@watlow.com
Website: www.watlow.com
From outside the USA and Canada:
Tel: +1 (314) 878-4600
Fax: +1 (314) 878-6814

Latin America
Watlow de México S.A. de C.V.
Av. Fundición No. 5
Col. Parques Industriales
Querétaro, Oro. CP-76130
Mexico
Tel: +52 442 217-6235
Fax: +52 442 217-6403

Asia and Pacific
Watlow Singapore Pte Ltd.
16 Ayer Rajah Crescent,
#06-03/04,
Singapore 139965
Tel: +65 6773 9488 Fax: +65 6778 0323
Email: info@watlow.com.sg Website: www.watlow.com.sg

Watlow Australia Pty., Ltd.
4/57 Sharps Road
Tullamarine, VIC 3043
Australia
Tel: +61 3 9335 6449 Fax: +61 3 9330 3566
Website: www.watlow.com

Watlow Electric Manufacturing Company (Shanghai) Co. Ltd.
Room 501, Building 10, KIC Plaza
290 Songhu Road, Yangpu District
Shanghai, China 200433
China
Phone:
Local: 4006 Watlow (4006 928669)
International: +86 21 3381 0188
Fax: +86 21 6106 1423
Email: vlee@watlow.cn
Website: www.watlow.cn

Watlow Japan Co., Ltd.
#2208, Hyundai KIC Building B, 70 Doosan-ro
Geumcheon-gu, Seoul
Republic of Korea
Tel: +82 (2) 2169-2600 Fax: +82 (2) 2169-2601
Website: www.watlow.co.kr

Watlow Korea Co., Ltd.
1F-17, IOI Business Park
No.1, Persiaran Puchong Jaya Selatan
Bandar Puchong Jaya
47100 Puchong, Selangor D.E.
Malaysia
Tel: +60 3 8076 8745 Fax: +60 3 8076 7186
Email: vlee@watlow.com Website: www.watlow.com

Watlow Malaysia Sdn Bhd
80143 高雄市前金區七賢二路189號 10樓之一
電話: 07-2885168 傳真: 07-2885568
Watlow Electric Taiwan Corporation
1F-1 No.189 Chi-Shen 2nd Road Kaohsiung 80143
Taiwan
Tel: +886-7-2885168 Fax: +886-7-2885568

Europe
Watlow France
Tour d’Asnières.
4 Avenue Laurent Cély
92600 Asnières sur Seine
France
Tel: +33 (0) 1 41 32 79 70
Télécopie: +33(0)1 47 33 36 57
Email: info@watlow.fr
Website: www.watlow.fr

Watlow GmbH
Postfach 11 65, Lauchwasenstr. 1
D-76709 Kronau
Germany
Tel: +49 (0) 7253 9400-0
Fax: +49 (0) 7253 9400-900
Email: info@watlow.de
Website: www.watlow.de

Watlow Italy S.r.l.
Viale Italia 52/54
20094 Corsico MI
Italy
Tel: +39 024588954
Fax: +39 0245869954
Email: Italyinfo@watlow.com
Website: www.watlow.it

Watlow Ibérica, S.L.U.
C/Marte 12, Posterior, Local 9
E-28850 Torrejón de Ardoz
Madrid - Spain
T. +34 91 675 12 92
F. +34 91 648 73 80
Email: info@watlow.es
Website: www.watlow.es

Watlow UK Ltd.
Linby Industrial Estate
Linby, Nottingham, NG15 8AA
United Kingdom
Telephone: (0) 115 964 0777
Fax: (0) 115 964 0071
Email: info@watlow.co.uk
Website: www.watlow.co.uk
From outside The United Kingdom:
Tel: +44 115 964 0777
Fax: +44 115 964 0071

Watlow Japan Ltd.
1-14-4 Uchikanda, Chiyoda-Ku
Tokyo 101-0047
Japan
Tel: +81-3-3518-6630 Fax: +81-3-3518-6632
Email: infoj@watlow.com Website: www.watlow.co.jp

Watlow Electric Taiwan Corporation
10F-1 No.189 Chi-Shen 2nd Road Kaohsiung 80143
Taiwan
Tel: +886-7-2885168 Fax: +886-7-2885568

Your Authorized Watlow Distributor

 TOTAL
 CUSTOMER SATISFACTION
 3 Year Warranty